This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1479732 - Horizon won't load with OSP11 - Script timed out before returning headers: django.wsgi
Horizon won't load with OSP11 - Script timed out before returning headers: dj...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-horizon (Show other bugs)
10.0 (Newton)
x86_64 Linux
medium Severity medium
: z4
: 10.0 (Newton)
Assigned To: Radomir Dopieralski
Ido Ovadia
: Triaged, ZStream
Depends On: 1479056 1478042 1478870 1479051 1479055 1479057 1479058 1496173
Blocks: 1485889 1481774 1485890 1485894
  Show dependency treegraph
 
Reported: 2017-08-09 05:54 EDT by Radomir Dopieralski
Modified: 2017-09-27 06:22 EDT (History)
21 users (show)

See Also:
Fixed In Version: puppet-horizon-9.5.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Cause: Some binary python modules used by Horizon were compiled with a flag that makes them use the simplified GIL state API. Consequence: Since mod_wsgi uses sub-interpreters, and the simplified GIL state API is not re-entrant, this results in the mod_wsgi locking up and hanging, making the dashboard unavailable. Fix: Added "WSGIApplicationGroup %{GLOBAL}" to mod_wsgi configuration, which forces it to always use the main interpreter instead of sub-interpreters. Result: With that option, mod_wsgi works correctly no matter what options were used to compile the binary python modules. The slight performance penalty is not noticeable.
Story Points: ---
Clone Of: 1478870
: 1481774 (view as bug list)
Environment:
Last Closed: 2017-09-06 13:11:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1573488 None None None 2017-08-09 05:54 EDT
Launchpad 1708655 None None None 2017-08-09 05:54 EDT
OpenStack gerrit 491459 None None None 2017-08-09 05:54 EDT

  None (edit)
Comment 5 Ido Ovadia 2017-09-05 09:39:55 EDT
Verified
========
puppet-horizon-9.5.0-2.el7ost.noarch
Comment 7 errata-xmlrpc 2017-09-06 13:11:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2654

Note You need to log in before you can comment on or make changes to this bug.