Bug 1479057 - Horizon won't load with OSP11 - Script timed out before returning headers: django.wsgi
Horizon won't load with OSP11 - Script timed out before returning headers: dj...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
x86_64 Linux
medium Severity medium
: zstream
: 7.0 (Kilo)
Assigned To: Radomir Dopieralski
Ido Ovadia
: Triaged, ZStream
Depends On: 1478042 1479051 1479055 1479056 1496173
Blocks: 1478870 1479058 1479732 1481774 1485889 1485890 1485894
  Show dependency treegraph
 
Reported: 2017-08-07 16:51 EDT by Radomir Dopieralski
Modified: 2018-02-08 06:28 EST (History)
16 users (show)

See Also:
Fixed In Version: python-django-horizon-2015.1.4-3.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, mod_wsgi used sub-interpreters, and the simplified GIL state API is not re-entrant. Horizon uses some binary modules compiled with a flag that makes them use the simplified GIL state API. Consequently, mod_wsgi would lock up and hang, making the dashboard unavailable. This update adds "WSGIApplicationGroup %{GLOBAL}" to mod_wsgi configuration, forcing it to always use the main interpreter instead of sub-interpreters. As a result, mod_wsgi works correctly, regardless of the options used to compile the binary python modules. The slight performance penalty is not noticeable.
Story Points: ---
Clone Of: 1479056
: 1479058 (view as bug list)
Environment:
Last Closed: 2017-09-12 13:23:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1573488 None None None 2017-08-07 16:51 EDT
Launchpad 1708655 None None None 2017-08-07 16:51 EDT
OpenStack gerrit 473367 None None None 2017-08-07 16:51 EDT
OpenStack gerrit 491810 None None None 2017-08-08 09:42 EDT
Red Hat Product Errata RHBA-2017:2695 normal SHIPPED_LIVE python-django-horizon bug fix advisory 2017-09-12 17:23:14 EDT

  None (edit)
Comment 5 errata-xmlrpc 2017-09-12 13:23:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2695

Note You need to log in before you can comment on or make changes to this bug.