Bug 14847 - NFS lockd is not stopped properly by init script
Summary: NFS lockd is not stopped properly by init script
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard: Winston rc1
Keywords:
: 12316 14959 14994 16344 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-30 15:09 UTC by Jos Vos
Modified: 2008-05-01 15:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-23 15:27:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos Vos 2000-07-30 15:09:46 UTC
/etc/rc.d/init.d/nfslock stop never stops NFS' lockd properly, so you
always see a red FAILED indication.

Comment 1 Glen Foster 2000-07-30 22:09:26 UTC
This defect is considered MUST-FIX for Winston Release-Candidate #1

Comment 2 Glen Foster 2000-07-30 22:27:27 UTC
*** Bug 12316 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2000-07-31 14:54:57 UTC
This a kernel problem, unfortunately.

Comment 4 Bill Nottingham 2000-08-01 18:27:51 UTC
*** Bug 14994 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2000-08-01 20:27:35 UTC
*** Bug 14959 has been marked as a duplicate of this bug. ***

Comment 6 Jeremy Katz 2000-08-11 20:35:20 UTC
Problem still exists in RC1

Comment 7 Henri Schlereth 2000-08-15 16:28:18 UTC
Additional verification RC1/TUI Upgrade/Install -- Server still fails.

Comment 8 Tim Waugh 2000-08-16 15:15:56 UTC
Getting /etc/rc.d/init.d/functions to wait a little while (udelay 100000) after
sending SIGKILL seems to work around it here.  Should lockd catch SIGTERM
instead though?

Comment 9 Preston Brown 2000-08-16 17:38:57 UTC
*** Bug 16344 has been marked as a duplicate of this bug. ***

Comment 10 Alan Cox 2000-08-16 20:03:15 UTC
Doesnt happen with a standard kernel


Comment 11 Michael K. Johnson 2000-08-20 21:13:29 UTC
Bill, let's implement the workaround Tim found for now, and revert
it if Doug finds the problem in time.

Comment 12 Bill Nottingham 2000-08-21 16:03:28 UTC
Yes, lockd should catch sigterm, I would think.
The 'not waiting after sigkill is actually a real bug, more
or less. Added in initscripts, will be in 5.47 or so.

Comment 13 Doug Ledford 2000-08-22 04:29:29 UTC
Solved by a patch checked into CVS as of 12:30AM, Tue Aug 22, 2000
(Patch29: linux-2.2.16-lockd.patch in the spec file)

Comment 14 Michael K. Johnson 2000-08-22 13:18:35 UTC
Fixed resolution -- "CURRENTRELEASE" would be Red Hat Linux 6.2.

Comment 15 Gene Czarcinski 2000-08-23 15:27:35 UTC
On my dual PII system (only one tested so far), the nfslock shutdown FAILS is
still there.

Comment 16 Doug Ledford 2000-08-23 15:58:41 UTC
Watch the dates in the notes.  I pointed out that the fix was checked into CVS
on 8/22.  That's *after* RC2 so obviously the problem *would* still exist in
RC2, so no reason to reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.