Bug 172130 - RFE: User-based preference for languages
RFE: User-based preference for languages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: FutureFeature
: 136648 167895 171110 172131 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-31 13:48 EST by Need Real Name
Modified: 2015-01-14 18:19 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-09 12:17:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-10-31 13:48:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
It should be trivial and simple for a user to configure their preferred language as a preference for themselves.

Currently a Gnome user can change the *system wide* default language, but not configure a *preference* for their own default language.

Adding this should be a piece of cake, thanks to
 ~/.i18n
(and /etc/sysconfig/i18n)

Please could this be considers a target for FC5. Red Hat has supported utf8 for ages now, this simple addition would make the life of multi-lingual systems a lot easier.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-10-31 13:49:23 EST
*** Bug 171110 has been marked as a duplicate of this bug. ***
Comment 2 Need Real Name 2005-10-31 13:49:29 EST
*** Bug 167895 has been marked as a duplicate of this bug. ***
Comment 3 Need Real Name 2005-10-31 13:49:55 EST
*** Bug 172131 has been marked as a duplicate of this bug. ***
Comment 4 Need Real Name 2005-10-31 13:50:43 EST
*** Bug 136648 has been marked as a duplicate of this bug. ***
Comment 5 Nerijus Baliūnas 2005-10-31 14:19:54 EST
I cannot add new language with  system-config-packages. "Update" button is  
not active when I select a new language.  
 
Comment 6 Nerijus Baliūnas 2005-10-31 14:20:35 EST
In FC3 SUPPORTED line in /etc/sysconfig/i18n includes all languages I selected  
during installation, but in FC4 only en_US. Is it intended? 
Comment 7 Need Real Name 2005-11-25 16:50:14 EST
This is the same in Fedora 5 Test 1.

Please can there be a system-wide administrative default for the language, but a
user-specific preference, like there is for keyboard settings?
Comment 8 Need Real Name 2005-11-30 07:17:38 EST
This feature is offered on the gnome login screen.

This RFE is a request for that to be accessible from within a running Gnome session.
Comment 9 Need Real Name 2006-01-16 09:34:30 EST
2006 - still can't choose a language per user..
Comment 10 Need Real Name 2007-02-28 09:00:23 EST
2007 - still not there..
Comment 11 Bill Nottingham 2007-03-02 12:33:34 EST
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.
Comment 12 Need Real Name 2007-03-25 13:28:48 EDT
This bug has been open, in various forms, since 2004.
You have not replied to any of the comments since 2005.

Please can you update this bug?
Comment 13 Liang Zhang 2007-06-18 02:42:35 EDT
Hi lsof, I am the new maintainer of system-config-language, thank you for your
notice. 
And I will work on it.
:)
Comment 14 Mike A. Harris 2007-11-09 08:21:33 EST
Either X startup scripts, or GNOME startup is completely ignoring
/etc/sysconfig/i18n and $HOME/.i18n settings other than $LANG currently due to
some bug.  I suppose not that many people are likely to manually set LANG, then
set LC_COLLATE or whatever to something different, so the problem only likely
affects a small number of users per se.  The issue goes away in runlevel 3 with
startx though.

See bug #372151 for details.

In order for the feature requested in this RFE to work, the above bug needs to
be fixed.
Comment 15 Jon Stanley 2008-04-23 16:28:58 EDT
Adding FutureFeature keyword to RFE's.
Comment 16 Tony Fu 2008-09-09 23:13:41 EDT
requested by Jens Petersen (#27995)
Comment 17 Mike A. Harris 2009-03-11 05:06:39 EDT
This problem was caused due to hacks in gdm which resulted in ignoring ~/.i18n settings, but under startx ~/.i18n propagated as expected.  I had filed a separate bug report on that problem a few years ago which I just reviewed and it has been closed as fixed in errata for F8 and newer (although I have not yet tested it).

You might want to test Fedora 10 out to see if the problem still occurs.
Comment 18 Jens Petersen 2009-05-08 23:41:26 EDT
With current gdm do we still need this?

Is ~/.i18n working these days with startx?

My personal feeling is that this could probably be closed -
however there may still be need for a locale config
tool that would allow users to customize paper size, currency,
LC_CTYPE, etc - maybe we need a custom locale support
package for gdm or something (a bit like xorg-x11-xinit-session),
together with a simple custom locale tool that would allow
adjust the locale envvar for the desktop.

Moving to gdm, since I would like to hear their take on this.
Comment 19 Matthias Clasen 2009-05-09 12:17:50 EDT
Selecting a paper size in gdm is crazy, of course.

Anyway, the actual complaint is fixed, since users _can_ select their personal language preference on the login screen, even if it is not stored in ~/.i18n

Note You need to log in before you can comment on or make changes to this bug.