Bug 190556 - kdesktop_lock cannot authenticate
kdesktop_lock cannot authenticate
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 190567 190648 190713 190767 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 11:22 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 06:13:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-05-03 11:22:40 EDT
Description of problem:

kdesktop_lock cannot authenticate users and so must be manually killed to unlock
a session.

Version-Release number of selected component (if applicable):
kdebase-3.5.2-0.3.fc5

How reproducible:
everytime
Comment 1 Robert Glover 2006-05-03 15:54:41 EDT
I don't know how helpful this is, but when running kdesktop_lock from the
command-line (with kernel 2.6.16-1.2080_FC5), I get the following:

$ kdesktop_lock --forcelock
WARNING: DCOPReply<>: cast to 'QStringList' error
WARNING: DCOPReply<>: cast to 'QString' error
WARNING: DCOPReply<>: cast to 'QStringList' error
WARNING: DCOPReply<>: cast to 'QString' error
Comment 2 Keunwoo Lee 2006-05-03 21:27:57 EDT
I can reproduce.  I suspect this is related to the removal 
of /usr/bin/kcheckpass from kdebase.  See: 
 
rpm -q --filesbypkg kdebase | grep /usr/bin/kcheckpass 
 
This is a curious absence, because /etc/pam.d/kcheckpass is still there. 
Comment 3 Brian Daniels 2006-05-03 22:52:29 EDT
Also happening here on an x86_64 system.  It gives the following error for good
or bad passwords:

Cannot unlock the session because the authentication system failed to work.  
you must kill kdesktop_lock (pid) manually.

Worked fine before kde update.
Comment 4 Ngo Than 2006-05-04 06:13:49 EDT
it seems a packacking bug in kdebase that kcheckpass was not included in this
version. I will push new kdebase packacge in FC5 update ASAP which resolves this
issue. Thanks for your report.
Comment 5 Ngo Than 2006-05-04 06:17:14 EDT
*** Bug 190567 has been marked as a duplicate of this bug. ***
Comment 6 Ngo Than 2006-05-04 06:18:51 EDT
*** Bug 190648 has been marked as a duplicate of this bug. ***
Comment 7 Ngo Than 2006-05-04 17:18:26 EDT
*** Bug 190713 has been marked as a duplicate of this bug. ***
Comment 8 Ngo Than 2006-05-05 05:03:43 EDT
*** Bug 190767 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.