This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 197219 - nfs-utils from updates-testing can't be installed (missing dependancy)
nfs-utils from updates-testing can't be installed (missing dependancy)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
: 196321 197423 197438 197466 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-29 08:21 EDT by Vedran Miletić
Modified: 2007-11-30 17:11 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-22 08:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vedran Miletić 2006-06-29 08:21:39 EDT
Description of problem:
# yum update
Loading "fastestmirror" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/5]
core                                                                 [2/5]
updates                                                              [3/5]
updates-testing                                                      [4/5]
extras                                                               [5/5]
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package nfs-utils-lib.i386 0:1.0.8-4.FC5 set to be updated
---> Package libgssapi.i386 0:0.9-1.FC5 set to be updated
--> Running transaction check
--> Processing Dependency: librpcsecgss.so.1 for package: nfs-utils
--> Processing Dependency: libgssapi.so.1 for package: nfs-utils
--> Finished Dependency Resolution
Error: Missing Dependency: librpcsecgss.so.1 is needed by package nfs-utils
Error: Missing Dependency: libgssapi.so.1 is needed by package nfs-utils

How reproducible:
Every time.

Steps to Reproduce:
1. Enable updates-testing
2. Do a "yum update"

I have seen a bug filled against FC6, but not against FC5 yet, so I'm filling it
here.
Comment 1 Steve Dickson 2006-06-30 07:44:00 EDT
start with 'rpm -e --nodeps nfs-utils' then 'yum update nfs-utils-lib' 
finally 'yum install nfs-utils' will fix the problem
Comment 2 Marc Wiriadisastra 2006-06-30 19:50:34 EDT
I followed the process and I get this error.

[root@strikeforce ~]# yum install nfs-utils
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Setting up Install Process
Setting up repositories
livna                                                                [1/5]
macromedia                                                           [2/5]
updates                                                              [3/5]
core                                                                 [4/5]
extras                                                               [5/5]
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package nfs-utils.i386 0:1.0.8.rc2-5.FC5 set to be updated
--> Running transaction check
--> Processing Dependency: librpcsecgss.so.1 for package: nfs-utils
--> Processing Dependency: libgssapi.so.1 for package: nfs-utils
--> Finished Dependency Resolution
Error: Missing Dependency: librpcsecgss.so.1 is needed by package nfs-utils
Error: Missing Dependency: libgssapi.so.1 is needed by package nfs-utils
[root@strikeforce ~]#
Comment 3 Mamoru TASAKA 2006-06-30 22:59:46 EDT
See the bug 196359.
Comment 4 David Baron 2006-06-30 23:58:57 EDT
This is now a problem for updates, not just updates-testing.

The workaround in comment 1 does not work, nor does it work with an added
--disablerepo=core, nor with "yum update nfs-utils-1.0.8-1.FC5" (which is the
version described in the email to fedora-package-announce.
Comment 5 Peter Bieringer 2006-07-01 02:39:43 EDT
Short hand solution:

yum update --exclude=libgssapi --exclude=nfs-utils-lib

BTW: this is the second time since a month or so that someone breaks
dependencies in the update repository. That's not good imho, looks like QA is
not working proper, especially because problem was already detected in
updates-testing.
Comment 6 Phil Schaffner 2006-07-01 07:39:11 EDT
Have also seen this problem with the update repo - have not been using testing.
 Using same work-around as Comment #5.
Comment 7 josip 2006-07-01 09:52:25 EDT
Same problem, seen in regular FC5, due to broken version numbering.  After
manually upgrading to libgssapi-0.9-1.FC5, I removed nfs-utils and
nfs-utils-lib, then did "yum install nfs-utils-1.0.8" which seems to have worked:

Installed: nfs-utils.x86_64 0:1.0.8-1.FC5
Dependency Installed: nfs-utils-lib.x86_64 0:1.0.8-4.FC5

Nevertheless, this procedure should not be required.  A fix is needed.
Comment 8 Steve Dickson 2006-07-01 10:19:05 EDT
*** Bug 196321 has been marked as a duplicate of this bug. ***
Comment 9 Steve Dickson 2006-07-01 10:21:57 EDT
*** Bug 197438 has been marked as a duplicate of this bug. ***
Comment 10 Paul Howarth 2006-07-01 10:34:06 EDT
Might I suggest releasing an update to FC5 that is basically just a rebuild of
the current package in FC-5 updates but with a bugus-but-later-than-1.0.8.rc2
version number, such as: 1.0.8.z.RELEASE?

That would fix the immediate problem, would not conflict with upstream's version
numbering (since no further 1.0.8 pre-releases will be made), wouldn't be a
problem when 1.0.9 eventually came out, and wouldn't need an epoch bump.

This is the approach I suggested on fedora-list earlier today:
http://www.redhat.com/archives/fedora-list/2006-July/msg00060.html

Works for me and at least one other person.
Comment 11 Mamoru TASAKA 2006-07-01 10:48:45 EDT
Dear Paul:

Your treatment can be substituted naturally by incrementing Epoch number
as commented in the bug 196359 (, which was originally for FC-devel).

Anyway, a immediate fix is needed now because I can see a lot of people 
annoyed by this issue on fedora mailing list.
Comment 12 Bob Agel 2006-07-01 11:00:44 EDT
I downloaded the libgssapi-0.9-1.FC5.i386.rpm into /home and then did:
rpm --nodeps -Uvh *.rpm
which updated it, followed by 'yum update' which then updated:
nfs-utils-lib.i386 0:1.0.8-4.FC5 without removing and reinstalling nfs-utils. 
Dependency solved.
Comment 13 Michal Jaegermann 2006-07-01 11:40:32 EDT
> Dependency solved.

Not really.  Regardless of which method you used to work around
those dependencies if you will do now 'yum check-update' then you
will likely see, with nfs-utils-1.0.8-1.FC5 installed,

nfs-utils.i386                           1.0.8.rc2-5.FC5        updates

and that means that your next unrelated update will fail with broken
dependencies unless you explicitely excluded, one way or another,
nfs-utils package from updates.
Comment 14 Shad Owen 2006-07-01 21:38:05 EDT
I also tried a number of different methods to install the updated libraries and
it didn't work.  In the end I excluded nfs-utils and I was able to update the
rest of my packages.  
Comment 15 Rahul Sundaram 2006-07-02 01:38:06 EDT
*** Bug 197423 has been marked as a duplicate of this bug. ***
Comment 16 Paul Howarth 2006-07-02 08:45:07 EDT
(In reply to comment #11)
> Dear Paul:
> 
> Your treatment can be substituted naturally by incrementing Epoch number
> as commented in the bug 196359 (, which was originally for FC-devel).

True, and one can argue that this is the sort of case that epochs are designed
for. However, there is a fair bit of resistance to doing epoch bumps these days,
probably because any epoch change now will need to be carried forward forever
more to maintain the upgrade path. The alternative of bodging the version number
as I suggested would avoid this, and once 1.0.9 came along, there would be no
further ongoing impact of this issue.

> Anyway, a immediate fix is needed now because I can see a lot of people 
> annoyed by this issue on fedora mailing list.

Agreed. And of course it prevents *all* updates for people that can't figure out
how to work around it.
Comment 17 John Mellor 2006-07-02 08:49:23 EDT
system-config-nfs also depends upon this incorrect dependency.
Comment 18 John Mellor 2006-07-02 08:54:25 EDT
Request to change the bug summary, to remove -testing from the repository.
This bug is now the result of a defective rollout to the updates-released depot,
and now has much more serious consequences in being defective.
Comment 19 John Mellor 2006-07-02 08:59:44 EDT
Since this change now breaks yum updates, can this be now upgraded from
normal/normal priority to high/urgent?  This rollout now prevents yum from
operating correctly due to inconsistent repository dependencies, and thus
affects every single FC5 site, not just the NFS users.
Comment 20 Rahul Sundaram 2006-07-02 09:28:51 EDT
*** Bug 197466 has been marked as a duplicate of this bug. ***
Comment 21 Mamoru TASAKA 2006-07-02 09:44:30 EDT
Jesse Keating said that the maintainer will fix this when offices open again
July 5th....... (on bug 196359)
Comment 22 Mamoru TASAKA 2006-07-02 12:13:01 EDT
Finally nfs-utils-1.0.8-2.fc5 is now released, on which the EPOCH number
is incremented to 1. 
https://www.redhat.com/archives/fedora-package-announce/2006-July/msg00000.html

This package worked well for me.
Comment 23 drago01 2006-07-02 12:36:15 EDT
(In reply to comment #22)
> Finally nfs-utils-1.0.8-2.fc5 is now released, on which the EPOCH number
> is incremented to 1. 
> https://www.redhat.com/archives/fedora-package-announce/2006-July/msg00000.html
> 
> This package worked well for me.
> 

works fine here too ;)
Comment 24 John Mellor 2006-07-02 14:00:27 EDT
Works for me!  I believe this can now be closed.
Comment 25 Jeff Groves 2006-07-06 16:51:54 EDT
Fell on its face here...

Since I'm not running nfs, I just removed it so I could continue on...

Jeff G.
Comment 26 Steve Dickson 2006-07-22 08:34:05 EDT
I believe this has been resolved, pleaes reopen is that is not the case... 

Note You need to log in before you can comment on or make changes to this bug.