Bug 212781 - (fc6longupgrade) Installer hangs on updating an existing installation
Installer hangs on updating an existing installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
: 213826 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2006-10-28 21:45 EDT by Diego Padula
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 15:43:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diego Padula 2006-10-28 21:45:53 EDT
Description of problem:
I downloaded FC6 set of iso images, sha1sum verified them, burned them, booted
them, media checked them, and during the installation I'm given the option to
update an existing installation of Fedora Core. I choose to do so, and then the
installer never starts/completes the updating process, a progress dialog for
dependency check is displayed, and there it stays for more than 10 minutes.

How reproducible:
Tried twice.

Steps to Reproduce:
1. Download and burn discs.
2. Boot it.
3. Choose update an existing installation.
  
Actual results:
Updating process never completes, the progress bar doesn't show any progress.
CD-ROM drive ceases to read data, though there is some hard disk activity.

Expected results:
The installer should be able to update an existing installation of Fedora Core.
Comment 1 Phil 2006-10-30 05:56:10 EST
Same here, tried to upgrade my notebook's fc5 to fc6.

Reproducible: always

Steps to Reproduce:
1. boot either using boot cd or rescue cd, no matter which boot arguments
2. use nfs or http as installation source
3. select "upgrade an existing FC"

Actual results:
Anaconda starts with a dependency check which takes about 20 minutes. A dialogue
appears "click next to upgrade", then anaconda requests about 800 rpm files from
the webserver and shows "installation process starting". 2 minutes later it
shows "preparing transaction" and anaconda goes to 100% system load and does
nothing. Tried it multiple times. After 120 minutes of melting my notebook with
a 100% system load anaconda I gave up.
Comment 2 Diego Padula 2006-10-30 09:57:40 EST
The installer actually doesn't hang during dependency check, but the progress
bar starts completing several minutes after dependency check has started,
causing the impression that the installer isn't doing anything.

After nearly 15 minutes the progress bar starts filling. The dependency check
completes in about 20 minutes in my computer. So this is not a bug.

Then it begins preparing transaction, but that progress bar is also completed.
Can't reproduce what Phil's describing.

However, when it is updating the first package (at the very begining of the
progress bar) it switches to text mode and initiates a reboot. When the system
is bakc on, you are feced again with the same install screen as if nothing had
been done. If you remove the CD-ROM and boot the existing Fedora Core the system
will fail to start X so previous Fedora Core installation is ruined.
Comment 3 Andrew 2006-10-30 12:30:36 EST
This looks like bug 208717, bug 208725, and bug 212575.  I have the problem on
two different Pentium 3 systems upgrading FC5->FC6 from different sets of
verified boot media.  The dependency check stays at 0% for a long time.  

Then, "Preparing transaction from" takes a long time and eventually fails in
different ways (including a rpmdb panics like bug 211917).  On one system, I
killed it after waiting several hours.  Both my systems became corrupt and the
from-scratch installation hanged on package 6 (glibc-common) with 100% CPU
usage.  I am trying ide=nodma acpi=off apm=off and just got past glibc-common.  :)

I have not had such problems installing earlier versions of Fedora Core.
Comment 4 Joseph Teichman 2006-10-31 01:14:59 EST
I had the same problem I let it run all day and it took about 12 hours for the
upgrade from FC5 to complete. I noticed that the installer was repeatedly
calling ldconfig, and that may have been causing the install to run slow.
Comment 5 Jeremy Katz 2006-11-08 10:30:45 EST
*** Bug 213826 has been marked as a duplicate of this bug. ***
Comment 6 Phil 2006-11-13 08:55:42 EST
After upgrading my notebook's memory from 256 MB to 512 MB the upgrade seems
working fine. Still 30 mins to go %-)
Comment 7 Joseph Teichman 2006-11-16 12:16:18 EST
I also have 512MB ram and still had the problem. Perhaps, since I used a 64 bit
install, I need even more ram?
Comment 8 Paul Brown 2006-12-17 00:30:27 EST
I appear to have the same issue. It has been sitting at "Preparing transaction
from installation source...." for over 10 hours with no signs of moving at all.

I thought to check whether it has perhaps run out of memory, so I ran 'cat
/proc/meminfo' on a VT and it shows LowTotal: 385244 kB, LowFree: 5008 kB,
SwapTotal: 313184 kB, SwapFree: 313184 kB. I'm not entirely sure what I'm
looking at....
Comment 9 Paul Brown 2006-12-17 19:27:59 EST
UPDATE: I ran strace on anaconda, and it appears to be hung giving the following
message for the last 10 or 20 minutes straight:
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigaction(SIGSEGV, {0x8229f0, [], 0}, {0x8229f0, [], 0}, 8) = 0
sigreturn() = ? (mask now [])
Comment 10 Jeremy Katz 2007-05-21 15:43:08 EDT
Things should be better here for Fedora 7.  I've done a few low memory upgrades
at least without problems
Comment 11 Peter Åstrand 2007-09-13 10:21:48 EDT
As bug 253510 indicates, the problem remains. I think this bug should be
REOPENED, but I don't have that access. 

Should we merge these two bugs?

Note You need to log in before you can comment on or make changes to this bug.