Bug 214222 - hidden GtkStatusIcon never reappears under KDE
hidden GtkStatusIcon never reappears under KDE
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
: 214516 380571 (view as bug list)
Depends On:
Blocks: puplet-kde sealert-icon
  Show dependency treegraph
 
Reported: 2006-11-06 12:59 EST by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 14:40:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-11-06 12:59:37 EST
If you have a GtkStatusIcon and set_visible to false and then later set it to
true, it never shows up in the KDE tray.  Simple test case:

#!/usr/bin/python

import gtk, gobject

def show_it(t, *args):
    print "showing it"
    t.set_visible(True)
    return False

t = gtk.status_icon_new_from_file("/usr/share/pirut/pixmaps/puplet-updated.png")
t.set_visible(False)
gobject.timeout_add(5000, show_it, t)
gtk.main()
Comment 1 Matthias Clasen 2007-02-15 13:13:46 EST
Can somebody verify that this is fixed with GTK+ trunk ? If it is,
I would be willing to backport the relevant changes to the stable branch.
Comment 2 Jeremy Katz 2007-09-12 14:40:09 EDT
Definitely fixed with gtk+ 2.11.6
Comment 3 Ngo Than 2007-09-24 12:26:03 EDT
*** Bug 214516 has been marked as a duplicate of this bug. ***
Comment 4 Rex Dieter 2007-11-13 10:02:27 EST
Any chance to see this fixed in F-7's gtk2 too?  We're (still) getting lots of
bugs/complaints there.
Comment 5 Rex Dieter 2007-11-13 10:02:46 EST
*** Bug 380071 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Clasen 2007-11-13 12:03:28 EST
Once I have a working backported fix, sure. So far, no luck
Comment 7 Rex Dieter 2007-11-13 12:12:57 EST
Thanks.
Comment 8 Rex Dieter 2007-11-13 12:51:29 EST
*** Bug 380571 has been marked as a duplicate of this bug. ***
Comment 9 Mary Ellen Foster 2007-11-13 13:32:31 EST
I posted bug 380071 ... the big thing I'm wondering about is, why did
bluetooth-applet etc. suddenly begin getting started as part of log-in after the
KDE upgrade? I never saw this problem before the recent update ...
Comment 10 Kevin Kofler 2007-11-27 11:40:23 EST
Because KDE was patched to honor the XDG autostart directory.

Note You need to log in before you can comment on or make changes to this bug.