Bug 219032 - xpdf-utils conflicts with the current poppler-utils
xpdf-utils conflicts with the current poppler-utils
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 219574 219649 219828 219936 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-09 12:40 EST by Michal Jaegermann
Modified: 2008-02-19 15:00 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-14 16:38:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-12-09 12:40:19 EST
Description of problem:

xpdf-utils-3.01-26.fc6, currently in rawhide, provide 
/usr/bin/pdftoppm and its man page.  These files show up too
in the current poppler-utils-0.5.4-3.fc7 and attempts to update
run into conflicts.

To make things more difficult binary packages for xpdf-3.01-26.fc6
have dependency on xpdf-utils-3.01-26.fc6.  I guess that this means
that an update to 'xpdf' should obsolete 'xpdf-utils' or one has
to use 'rpm --force ...' to avoid failing updates.

Version-Release number of selected component (if applicable):
xpdf-3.01-26.fc6
Comment 1 Matthias Clasen 2006-12-12 14:00:49 EST
Would it be more appropriate if poppler-utils obsoleted xpdf-utils ? 
Thats what we did for RHEL, at least.
Comment 2 Michal Jaegermann 2006-12-12 17:49:32 EST
> Would it be more appropriate if poppler-utils obsoleted xpdf-utils ?

Probably both, although I am not sure.  The catch is that xpdf has
dependency on xpdf-utils so without an update there you will bump
into a missing package unless poppler-utils update will explicitly put
xpdf-utils into "provides".  Is it possible to do that and an obsolete
in one move?  That would likely be the best.
Comment 3 Kevin Kofler 2006-12-13 00:25:05 EST
Yes, use:
Provides: xpdf-utils = 3.01-27%{?dist}
Obsoletes: xpdf-utils <= 3.01-26.fc7
Comment 4 Matthias Clasen 2006-12-13 22:51:44 EST
I don't think using %{?dist} in the provides can be correct.
Comment 5 Michal Jaegermann 2006-12-13 23:16:12 EST
%{?dist} in the provides will get expanded.  No?  Easy enough to try.

Right now yum trips over an update to poppler-utils-0.5.4-3.fc6 and
this is quite unfortunate.
Comment 6 Tom "spot" Callaway 2006-12-14 16:38:34 EST
Yeah, the provides/obsoletes in poppler is the best solution here.

xpdf-utils is no more as of xpdf-3.01-27.
Comment 7 Jeremy Katz 2006-12-15 12:47:23 EST
*** Bug 219828 has been marked as a duplicate of this bug. ***
Comment 8 Alex Lancaster 2006-12-16 03:44:14 EST
This needs to be re-opened, yum install xpdf still fails:

$ sudo yum install xpdf
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Excluding Packages from Fedora Core 6 - i386
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package xpdf.i386 1:3.01-27.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: xpdf-utils for package: xpdf
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xpdf-utils.i386 1:3.01-26.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 xpdf                    i386       1:3.01-27.fc6    extras            1.0 M
Installing for dependencies:
 xpdf-utils              i386       1:3.01-26.fc6    extras            353 k

Transaction Summary
=============================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 1.3 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error:   file /usr/bin/pdftoppm from install of
xpdf-utils-3.01-26.fc6 conflicts with file from package poppler-utils-0.5.4-3.fc6
  file /usr/share/man/man1/pdftoppm.1.gz from install of xpdf-utils-3.01-26.fc6
conflicts with file from package poppler-utils-0.5.4-3.fc6

This is because, according to the current CVS spec:

http://cvs.fedora.redhat.com/viewcvs/rpms/xpdf/FC-6/xpdf.spec?root=extras&rev=1.2&view=auto

It still contains the line:

Requires: xpdf-utils
Comment 9 Alex Lancaster 2006-12-16 03:46:52 EST
*** Bug 219574 has been marked as a duplicate of this bug. ***
Comment 10 Tom "spot" Callaway 2006-12-18 11:45:49 EST
-28 fixes this by Requires: poppler-utils. Thanks for the report.
Comment 11 sascha 2006-12-19 03:38:16 EST
hi!

as a fc6 user who wants to install xpdf -- what do i have to do?
i still get the same error messages as in comment #8.

thanks.

sascha
Comment 12 Alex Lancaster 2006-12-19 03:52:57 EST
Wait for it to appear in the repo.  According to:

http://buildsys.fedoraproject.org/build-status/success.psp

and more specifically:

http://buildsys.fedoraproject.org/build-status/job.psp?uid=24074

it has been built, but not yet signed and "pushed" (i.e it's not actually yum
install-able yet).
Comment 13 Andre Robatino 2006-12-19 08:45:24 EST
  The latest xpdf is now available and doesn't require xpdf-utils, but I already
had xpdf-utils installed and had to manually remove it before being allowed to
update poppler-utils.  Shouldn't xpdf-utils have been removed automatically?
Comment 14 Tom "spot" Callaway 2006-12-19 11:28:11 EST
Only if poppler-utils isn't obsoleting xpdf-utils properly. If so, thats a
poppler bug.
Comment 15 Eric D. Hendrickson 2006-12-19 17:20:00 EST
Here is the current error:

Transaction Check Error:   file /usr/bin/pdftoppm from install of
poppler-utils-0.5.4-3.fc6 conflicts with file from package xpdf-utils-3.01-26.fc6
  file /usr/share/man/man1/pdftoppm.1.gz from install of
poppler-utils-0.5.4-3.fc6 conflicts with file from package xpdf-utils-3.01-26.fc6

This is with the -28 version of xpdf but no change to the existing xpdf-utils.

yum is now backed up with over 80 packages since this problem began.  I can work
around this easily myself, but fyi this is still a problem for all automated yum
jobs.
Comment 16 Tom "spot" Callaway 2006-12-19 17:25:52 EST
File a bug against poppler. xpdf is doing everything properly now.
Comment 17 Michal Jaegermann 2006-12-19 18:04:28 EST
> File a bug against poppler.
See bug 219033 and a discussion there.  If I understand things
correctly a use of epoch somewhere put a spanner in works.
Comment 18 Tom "spot" Callaway 2008-02-19 14:59:04 EST
*** Bug 219649 has been marked as a duplicate of this bug. ***
Comment 19 Tom "spot" Callaway 2008-02-19 15:00:57 EST
*** Bug 219936 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.