Bug 238575 - xorg-x11-server-Xorg segfaults during startup
xorg-x11-server-Xorg segfaults during startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 238559 238585 238645 238868 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-01 11:40 EDT by Peter Jones
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 15:06:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Jones 2007-05-01 11:40:06 EDT
Description of problem: xorg crashes during startup with this traceback:

Backtrace:
0: X(xf86SigHandler+0x81) [0x80d2031]
1: [0x903420]
2: X(RRQueryOutputProperty+0x9) [0x8169dc9]
3: X(RRConfigureOutputProperty+0x2c) [0x816a82c]
4: /usr/lib/xorg/modules/drivers//intel_drv.so [0x5d4934]
5: X(xf86RandR12Init+0x1e3) [0x80f8d53]
6: X(xf86CrtcScreenInit+0x4c) [0x80f3f9c]
7: /usr/lib/xorg/modules/drivers//intel_drv.so [0x5c72a5]
8: X(AddScreen+0x1ee) [0x80706ae]
9: X(InitOutput+0x225) [0x80a27b5]
10: X(main+0x27b) [0x8070e5b]
11: /lib/libc.so.6(__libc_start_main+0xe0) [0x2cef10]
12: X(FontFileCompleteXLFD+0x1e1) [0x8070391]

Version-Release number of selected component (if applicable):

Happens with a fully updated rawhide box running 1.3.0.0-3.fc7 .  If I downgrade
to 1.2.99.905-5.fc7 it starts fine.
Comment 1 Adam Jackson 2007-05-01 14:18:47 EDT
*** Bug 238585 has been marked as a duplicate of this bug. ***
Comment 2 Adam Jackson 2007-05-01 15:06:54 EDT
Fixed in xorg-x11-drv-i810 2.0.0-2.fc7.
Comment 3 Adam Jackson 2007-05-02 10:43:37 EDT
*** Bug 238559 has been marked as a duplicate of this bug. ***
Comment 4 Adam Jackson 2007-05-03 18:19:41 EDT
*** Bug 238645 has been marked as a duplicate of this bug. ***
Comment 5 Adam Jackson 2007-05-03 18:29:09 EDT
*** Bug 238868 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.