This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 241450 - hangs on startup
hangs on startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: codeblocks (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
: 242927 248286 249133 (view as bug list)
Depends On: 241157
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 21:18 EDT by Bill Nottingham
Modified: 2014-03-16 23:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 08:28:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-05-25 21:18:12 EDT
Description of problem:

After accepting the dialog for what compilers codeblocks found, it hangs,
with a blank tip-of-the-day dialog above the main window.

gdb says it's at:
0x0000003c4262b2f3 in g_source_list_add (source=0x41a2b20, context=0xa264d0) at
gmain.c:848
848       while (tmp_source && tmp_source->priority <= source->priority)

#0  0x0000003c4262b2f3 in g_source_list_add (source=0x41a2b20, context=0xa264d0)
at gmain.c:848
#1  0x0000003c4262ee9d in IA__g_source_attach (source=0x41a2b20,
context=0xa264d0) at gmain.c:913
#2  0x0000003c4262efe2 in IA__g_idle_add_full (priority=110,
function=0x3c45aa9690 <gtk_container_idle_sizer>, 
    data=0x0, notify=0) at gmain.c:3986
#3  0x0000003c45aa98ac in _gtk_container_queue_resize (container=<value
optimized out>) at gtkcontainer.c:1154
#4  0x0000003c45b8e95d in queue_resize_on_widget (widget=0x12826d0,
check_siblings=<value optimized out>)
    at gtksizegroup.c:187
#5  0x0000003c4666283b in wxStaticText::DoGetBestSize (this=0x1859bd0) at
src/gtk/stattext.cpp:156
#6  0x0000003c466f41c1 in wxWindowBase::GetEffectiveMinSize (this=0x1859bd0) at
include/wx/window.h:336
#7  0x0000003c466631d9 in gtktoolwidget_size_callback (widget=0x12826d0,
alloc=0x7fff039d5100, win=0x4192c30)
    at src/gtk/tbargtk.cpp:227
#8  0x0000003c4320af19 in IA__g_closure_invoke (closure=0x1854c20,
return_value=0x0, n_param_values=2, 
    param_values=0x7fff039d4d90, invocation_hint=0x7fff039d4c50) at gclosure.c:490
#9  0x0000003c4321aa3a in signal_emit_unlocked_R (node=0xa62e50, detail=0,
instance=0x12826d0, emission_return=0x0, 
    instance_and_params=0x7fff039d4d90) at gsignal.c:2510
#10 0x0000003c4321bbd4 in IA__g_signal_emit_valist (instance=0x12826d0,
signal_id=<value optimized out>, detail=0, 
    var_args=0x7fff039d5010) at gsignal.c:2199
#11 0x0000003c4321bda3 in IA__g_signal_emit (instance=0x41a2b20,
signal_id=10642640, detail=68758576)
    at gsignal.c:2243
#12 0x0000003c45c355bf in IA__gtk_widget_size_allocate (widget=0x12826d0,
allocation=<value optimized out>)
    at gtkwidget.c:3063
#13 0x0000003c45bed928 in gtk_toolbar_size_allocate (widget=0xd56360,
allocation=0x7fff039d5850) at gtktoolbar.c:1781
#14 0x0000003c4320afd0 in IA__g_closure_invoke (closure=0xa53400,
return_value=0x0, n_param_values=2, 
    param_values=0x7fff039d54e0, invocation_hint=0x7fff039d53a0) at gclosure.c:490
#15 0x0000003c4321abce in signal_emit_unlocked_R (node=0xa62e50, detail=0,
instance=0xd56360, emission_return=0x0, 
    instance_and_params=0x7fff039d54e0) at gsignal.c:2370
#16 0x0000003c4321bbd4 in IA__g_signal_emit_valist (instance=0xd56360,
signal_id=<value optimized out>, detail=0, 
    var_args=0x7fff039d5760) at gsignal.c:2199
#17 0x0000003c4321bda3 in IA__g_signal_emit (instance=0x41a2b20,
signal_id=10642640, detail=68758576)
    at gsignal.c:2243
#18 0x0000003c45c355bf in IA__gtk_widget_size_allocate (widget=0xd56360,
allocation=<value optimized out>)
    at gtkwidget.c:3063
#19 0x0000003c45ac83b5 in gtk_event_box_size_allocate (widget=0x17ed300,
allocation=0x7fff039d5ec0)
    at gtkeventbox.c:550
#20 0x0000003c4320afd0 in IA__g_closure_invoke (closure=0xa53400,
return_value=0x0, n_param_values=2, 
    param_values=0x7fff039d5b50, invocation_hint=0x7fff039d5a10) at gclosure.c:490
#21 0x0000003c4321abce in signal_emit_unlocked_R (node=0xa62e50, detail=0,
instance=0x17ed300, emission_return=0x0, 
    instance_and_params=0x7fff039d5b50) at gsignal.c:2370
#22 0x0000003c4321bbd4 in IA__g_signal_emit_valist (instance=0x17ed300,
signal_id=<value optimized out>, detail=0, 
    var_args=0x7fff039d5dd0) at gsignal.c:2199
#23 0x0000003c4321bda3 in IA__g_signal_emit (instance=0x41a2b20,
signal_id=10642640, detail=68758576)
    at gsignal.c:2243
#24 0x0000003c45c355bf in IA__gtk_widget_size_allocate (widget=0x17ed300,
allocation=<value optimized out>)
    at gtkwidget.c:3063
#25 0x0000003c465ec1b4 in gtk_pizza_allocate_child (pizza=0x14a8a00,
child=0x1849b70) at src/gtk/win_gtk.c:691
#26 0x0000003c465ecdcf in gtk_pizza_size_allocate (widget=0x14a8a00,
allocation=<value optimized out>)
    at src/gtk/win_gtk.c:573
#27 0x0000003c4320afd0 in IA__g_closure_invoke (closure=0xa53400,
return_value=0x0, n_param_values=2, 
    param_values=0x7fff039d6210, invocation_hint=0x7fff039d60d0) at gclosure.c:490
#28 0x0000003c4321abce in signal_emit_unlocked_R (node=0xa62e50, detail=0,
instance=0x14a8a00, emission_return=0x0, 
    instance_and_params=0x7fff039d6210) at gsignal.c:2370
#29 0x0000003c4321bbd4 in IA__g_signal_emit_valist (instance=0x14a8a00,
signal_id=<value optimized out>, detail=0, 
    var_args=0x7fff039d6490) at gsignal.c:2199
#30 0x0000003c4321bda3 in IA__g_signal_emit (instance=0x41a2b20,
signal_id=10642640, detail=68758576)
    at gsignal.c:2243
#31 0x0000003c45c355bf in IA__gtk_widget_size_allocate (widget=0x14a8a00,
allocation=<value optimized out>)
    at gtkwidget.c:3063
#32 0x0000003c465ec1b4 in gtk_pizza_allocate_child (pizza=0x14a8970,
child=0x126b870) at src/gtk/win_gtk.c:691
#33 0x0000003c465ecdcf in gtk_pizza_size_allocate (widget=0x14a8970,
allocation=<value optimized out>)
    at src/gtk/win_gtk.c:573
#34 0x0000003c4320afd0 in IA__g_closure_invoke (closure=0xa53400,
return_value=0x0, n_param_values=2, 
    param_values=0x7fff039d68d0, invocation_hint=0x7fff039d6790) at gclosure.c:490
#35 0x0000003c4321abce in signal_emit_unlocked_R (node=0xa62e50, detail=0,
instance=0x14a8970, emission_return=0x0, 
    instance_and_params=0x7fff039d68d0) at gsignal.c:2370
#36 0x0000003c4321bbd4 in IA__g_signal_emit_valist (instance=0x14a8970,
signal_id=<value optimized out>, detail=0, 
    var_args=0x7fff039d6b50) at gsignal.c:2199
#37 0x0000003c4321bda3 in IA__g_signal_emit (instance=0x41a2b20,
signal_id=10642640, detail=68758576)
    at gsignal.c:2243
#38 0x0000003c45c355bf in IA__gtk_widget_size_allocate (widget=0x14a8970,
allocation=<value optimized out>)
    at gtkwidget.c:3063
#39 0x0000003c45c43674 in gtk_window_size_allocate (widget=0xa70410,
allocation=0x7fff039d72b0) at gtkwindow.c:4471
#40 0x0000003c4320af19 in IA__g_closure_invoke (closure=0xa53400,
return_value=0x0, n_param_values=2, 
    param_values=0x7fff039d6f40, invocation_hint=0x7fff039d6e00) at gclosure.c:490
#41 0x0000003c4321abce in signal_emit_unlocked_R (node=0xa62e50, detail=0,
instance=0xa70410, emission_return=0x0, 
    instance_and_params=0x7fff039d6f40) at gsignal.c:2370
#42 0x0000003c4321bbd4 in IA__g_signal_emit_valist (instance=0xa70410,
signal_id=<value optimized out>, detail=0, 
    var_args=0x7fff039d71c0) at gsignal.c:2199
#43 0x0000003c4321bda3 in IA__g_signal_emit (instance=0x41a2b20,
signal_id=10642640, detail=68758576)
    at gsignal.c:2243
#44 0x0000003c45c355bf in IA__gtk_widget_size_allocate (widget=0xa70410,
allocation=<value optimized out>)
    at gtkwidget.c:3063
#45 0x0000003c45c4393e in gtk_window_check_resize (container=0xa70410) at
gtkwindow.c:5838
#46 0x0000003c4320af19 in IA__g_closure_invoke (closure=0xa68ba0,
return_value=0x0, n_param_values=1, 
    param_values=0x7fff039d7680, invocation_hint=0x7fff039d7540) at gclosure.c:490
#47 0x0000003c4321ad98 in signal_emit_unlocked_R (node=0xa68bd0, detail=0,
instance=0xa70410, emission_return=0x0, 
    instance_and_params=0x7fff039d7680) at gsignal.c:2478
#48 0x0000003c4321bbd4 in IA__g_signal_emit_valist (instance=0xa70410,
signal_id=<value optimized out>, detail=0, 
    var_args=0x7fff039d7900) at gsignal.c:2199
#49 0x0000003c4321bda3 in IA__g_signal_emit (instance=0x41a2b20,
signal_id=10642640, detail=68758576)
    at gsignal.c:2243
#50 0x0000003c45aa96c4 in gtk_container_idle_sizer (data=<value optimized out>)
at gtkcontainer.c:1110
#51 0x0000003c4262d1f4 in IA__g_main_context_dispatch (context=0xa264d0) at
gmain.c:2045
#52 0x0000003c4263002d in g_main_context_iterate (context=0xa264d0, block=1,
dispatch=1, self=<value optimized ou
#53 0x0000003c4263033a in IA__g_main_loop_run (loop=0x19f4f40) at gmain.c:2881
#54 0x0000003c45b2d103 in IA__gtk_main () at gtkmain.c:1154
#55 0x0000003c465e0fdd in wxEventLoop::Run (this=0x7fff039d7b90) at
src/gtk/evtloop.cpp:76
#56 0x0000003c46638f61 in wxDialog::ShowModal (this=0x7fff039d7bf0) at
src/gtk/dialog.cpp:140
#57 0x0000003c484ad0e2 in wxShowTip (parent=<value optimized out>,
tipProvider=<value optimized out>, 
    showAtStartup=<value optimized out>) at src/generic/tipdlg.cpp:340
#58 0x0000000000449bb1 in MainFrame::ShowTips (this=0x126ec20, forceShow=<value
optimized out>) at main.cpp:591
#59 0x000000000042a3a9 in CodeBlocksApp::OnInit (this=0xa262f0) at app.cpp:550
#60 0x000000000042afed in wxAppConsole::CallOnInit (this=0x41a2b20) at
/usr/include/wx-2.8/wx/app.h:76
#61 0x0000003c3fa98c02 in wxEntry (argc=<value optimized out>, argv=<value
optimized out>) at src/common/init.cpp:433
#62 0x00000000004262b2 in main (argc=1, argv=0xa264d0) at app.cpp:199
#63 0x00002aaaab386aa4 in __libc_start_main (main=0x4262a0 <main>, argc=1,
ubp_av=0x7fff039d8338, 
    init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value
optimized out>, 
    stack_end=0x7fff039d8328) at libc-start.c:222
#64 0x00000000004260a9 in _start ()

Version-Release number of selected component (if applicable):

codeblocks-1.0-0.24.20070406svn3816.fc7
Comment 1 Dan Horák 2007-05-26 03:48:04 EDT
This is caused by a bug in wxGTK 2.8.3, which is fixed in wxGTK 2.8.4.

Upstream discussion is at http://forums.codeblocks.org/index.php/topic,5805.0.html
Comment 2 Dan Horák 2007-06-06 10:51:46 EDT
*** Bug 242927 has been marked as a duplicate of this bug. ***
Comment 3 Michael Cronenworth 2007-06-12 13:18:15 EDT
I am also seeing this bug. Is there an ETA on a new wxGTK package?

People are unable to use codeblocks at all because of this.
Comment 4 Dan Horák 2007-06-13 04:23:38 EDT
I am aware of this, but we depend on the wxGTK maintainer who must update wxGTK
to 2.8.4 (bug #241157).

When you remove the compiler plugin
(/usr/{lib|lib64}/codeblocks/plugins/compiler.so), you should be able to use CB
as an editor.
Comment 5 Dan Horák 2007-07-13 11:42:53 EDT
I have just done a rebuild in Fedora Development with recently published wxGTK
2.8.4 and everything looks good. After publishing wxGTK 2.8.4 also for Fedora 7
I will rebuild some recent codeblocks nightly build with it.
Comment 6 Dan Horák 2007-07-15 03:37:11 EDT
*** Bug 248286 has been marked as a duplicate of this bug. ***
Comment 7 Aleksey Kontsevich 2007-07-15 05:05:01 EDT
What about to build codeblocks with newest SVN revision - 4265?
Comment 8 Aleksey Kontsevich 2007-07-15 05:58:00 EDT
Sorry, haven't read Comment #5.
Comment 9 Dan Horák 2007-07-16 13:02:08 EDT
Updated wxGTK was just published into updates-testing, so please run
"yum --enablerepo=updates-testing wxGTK"
and then run codeblocks. Versions 2.8.x should be compatible for the client
applications, so it should work. Let me know your results.
Anyway I will soon update codeblock to some newer nightly build.
Comment 10 Christian Nolte 2007-07-16 13:38:02 EDT
It works for me! Thanks!
Comment 11 Dan Horák 2007-07-19 08:28:52 EDT
tested with new wxGTK on F7/i386 and it works, so I am closing this with NOTABUG
(of codebloks) as the problem was in wxGTK
Comment 12 Dan Horák 2007-07-21 05:47:50 EDT
*** Bug 249133 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.