Bug 25992 - Can not create crontab file
Summary: Can not create crontab file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: crontabs
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 26107 26917 27141 27549 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-04 22:46 UTC by Need Real Name
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-04-10 22:03:23 UTC


Attachments (Terms of Use)

Description Need Real Name 2001-02-04 22:46:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i686)


Can not create crontab file using the following command:
crontab -e

Reproducible: Always
Steps to Reproduce:
1.login
2.crontab -e
3.input the cron command
4. :wq
	

Actual Results:  write the crontab file into the /var/spool/cron directory	

Expected Results:  display:
no change to the file

Comment 1 Karsten Hopp 2001-02-05 12:50:41 UTC
fixed in vim-6.0-0.23 (vim removed crontab file and wrote it new instead
of appending)

Comment 2 Bill Nottingham 2001-02-05 16:22:46 UTC
*** Bug 26107 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2001-02-10 05:36:55 UTC
*** Bug 26917 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2001-02-12 17:14:46 UTC
*** Bug 27141 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2001-02-14 17:07:55 UTC
*** Bug 27549 has been marked as a duplicate of this bug. ***

Comment 6 Need Real Name 2001-09-24 17:07:29 UTC
i have here the same bug:
using "crontab -e" and saving it with vi (:wq), i get:
"crontab: no changes made to crontab"

i have installed vim packages like:
vim-enhanced-6.0-0.27
vim-common-6.0-0.27
vim-minimal-6.0-0.27

(they are newer than vim-6.0-0.23)

so i don't know if this is bug of vim or crontabs.
also if i edit user's crontab with other editor (pico), then a new crontab is 
written.



Comment 7 Michael Wardle 2002-05-09 02:06:30 UTC
I am seeing the same thing on a Red Hat 7.2 box with the latest public updates
(as of 2002-04-25) installed.  Vim version is 6.0-7.13.



Note You need to log in before you can comment on or make changes to this bug.