Bug 372931 - Azureus crashes when one tries to view details of a downloading/uploading torrent
Azureus crashes when one tries to view details of a downloading/uploading tor...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
: Reopened
: 377361 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 10:38 EST by Troels Just
Modified: 2008-01-15 18:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 10:02:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Java crash log (45.51 KB, text/plain)
2007-11-09 10:38 EST, Troels Just
no flags Details
log file for my own case (46.59 KB, text/plain)
2007-11-17 14:07 EST, Olivier Kurzweg
no flags Details
New crash log (44.49 KB, text/plain)
2007-12-05 20:55 EST, Troels Just
no flags Details

  None (edit)
Description Troels Just 2007-11-09 10:38:31 EST
Description of problem:
When using Azureus with the IcedTea JRE/JDK the application crashes when you 
try to view the details for a downloading/uploading torrent.

Version-Release number of selected component (if applicable):
Fedora 8

How reproducible:
Easily reproduceable.

Steps to Reproduce:
1. Launch Azureus.
2. Load a torrent and start downloading.
3. Either double click the torrent on the list, or right click and 
select "Show Details".
  
Actual results:
The program crashes.

Expected results:
The details to be shown, and the program continuing to run.

Additional info:
A crash log is attached, however newer versions of Azureus does not have this 
problem, I tested version 3.0.3.4 and it works fine under IcedTea.
Comment 1 Troels Just 2007-11-09 10:38:31 EST
Created attachment 252911 [details]
Java crash log
Comment 2 Anthony Green 2007-11-11 16:16:48 EST
I'm passing the buck to the icedtea team.
Comment 3 Adam Bentitou 2007-11-12 06:05:51 EST
*** Bug 377361 has been marked as a duplicate of this bug. ***
Comment 4 Olivier Kurzweg 2007-11-17 14:07:25 EST
Created attachment 262461 [details]
log file for my own case

Same problem for me with IcedTea (attached log). And I get the same with libgcj
and recompiled Sun JRE 1.6.0U3 (but no log). So it is either a problem in
azureus or some library that is used by all JRE.

BTW, I was previously running fc6 and had no problem (I had a JRE 1.5.0 from
Sun; can't remember which update though...)
Comment 5 Lillian Angel 2007-11-22 11:45:47 EST
I can reproduce this problem with azuerus and IcedTea from rawhide:

azureus-2.5.0.4-4.fc9

java -version
java version "1.7.0"
IcedTea Runtime Environment (build 1.7.0-b23)
IcedTea Server VM (build 1.7.0-b23, mixed mode)
Comment 6 Lillian Angel 2007-11-22 11:54:35 EST
I can also reproduce this problem with Sun's JDK:

java -version
java version "1.6.0_01"
Java(TM) SE Runtime Environment (build 1.6.0_01-b06)
Java HotSpot(TM) Server VM (build 1.6.0_01-b06, mixed mode)
Comment 7 Lillian Angel 2007-11-22 11:55:38 EST
This is a problem with azureus. I am passing this back...
Comment 8 Troels Just 2007-11-25 08:50:36 EST
A friend of mine just sent me a note, saying that Debian has introduced 
Azureus 3.0.3.4 into Debian testing (lenny), in the main "free" repository.
I took a quick look at http://packages.debian.org/lenny/azureus,
and noticed a patch that does a whole bunch of stuff. I don't speak Java, so I 
can't tell what it exactly does, but because of the various new things around 
Azureus, I assume the patch removes all the non-free Vuze stuff, which could 
explain why Debian has it in their main repo, and not their non-free repo.
(http://www.azureuswiki.com/index.php/Azureus_2_/_3_and_Vuze#Can.27t_you_distribute_a_version_of_Azureus_without_Vuze.3F)

I know this crash with "Show Details" is not a problem with Azureus 3.0.3.4, 
so the easiest, and probably the best way to fix this problem would be to 
update the current version of Azureus in Fedora (2.5.0.4) to the latest 
version (With the non-free Vuze stuff removed so that it's fully free 
software).
Comment 9 Lillian Angel 2007-11-30 13:20:40 EST
I, also, tested Azureus 3.0.3.4 and this is fixed.

Anthony, what about an update in rawhide? It would also fix #376111
Comment 10 Lillian Angel 2007-12-03 12:07:37 EST
Updated to azureus-3.0.3.4-1.fc9. 
Should be available tomorrow in rawhide.
Comment 11 Troels Just 2007-12-05 07:14:56 EST
Will an update be pushed out for Fedora 8? Because right now, Azureus is more 
or less broken in Fedora 8. Yes, it runs and can download/seed stuff, but you 
can't view the details of any torrents, and that sort of kills the whole point 
of a "all nuts and bolts exposed"-style of torrent client.
Comment 12 Lillian Angel 2007-12-05 08:42:55 EST
It will be in rawhide. At the moment, we are having a few issues building into rawhide because several 
other packages need to be rebuilt. It should be in within the next couple of days.

You will be able to install it, like so:
yum --enablerepo=development update azureus
Comment 13 Lillian Angel 2007-12-05 08:52:21 EST
Actually, looks like it has already been built:

$ sudo yum --enablerepo=development info azureus
Loading "refresh-updatesd" plugin
development               100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 5.5 MB    00:36     
Installed Packages
Name   : azureus
Arch   : i686
Version: 3.0.3.4
Release: 1.fc9
Size   : 29 M
Repo   : installed
Summary: A BitTorrent Client

Description:
Azureus implements the BitTorrent protocol using java language and
comes bundled with many invaluable features for both beginners and
advanced users.
Comment 14 Troels Just 2007-12-05 20:55:00 EST
I just installed the updated Azureus package, but I still get the exact same 
problem, as I did with the old one. However if I go to azureus.sf.net and 
download Azureus 3.0.3.4 there, the thing works without any problems. New 
crash log attached.
Comment 15 Troels Just 2007-12-05 20:55:54 EST
Created attachment 279001 [details]
New crash log

Crash log from using the updated Azureus package.
Comment 16 Lillian Angel 2007-12-06 09:00:45 EST
What problem are you seeing exactly? 
The "Show Details" issue is definitely fixed in 3.0.3.4.


Comment 17 Lillian Angel 2007-12-06 09:51:20 EST
what version of eclipse do you have installed?

rpm -qa libswt3-gtk2

mine is: libswt3-gtk2-3.3.1.1-10.fc9

Comment 18 Troels Just 2007-12-06 10:03:43 EST
(In reply to comment #16)
> What problem are you seeing exactly? 
> The "Show Details" issue is definitely fixed in 3.0.3.4.
> 
> 
> 
After some more poking at this, this is what I can conclude:

When using the newly updated azureus package from rawhide on Fedora 8, I have 
found that if the user has an old .azureus settings directory (Generated by an 
older version of Azureus) in his home directory, Azureus will crash when 
selecting "Show Details" in the same manner as described in the original bug 
report description. If the user removes his old settings, thereby letting 
Azureus create a new .azureus directory, things work fine.

BUT, here's where the weird things start up! If I go to 
http://azureus.sourceforge.net and download the Azureus tarball for Linux, it 
does not crash when using settings originally created by an older version of 
Azureus.


(In reply to comment #17)
> what version of eclipse do you have installed?
> 
> rpm -qa libswt3-gtk2
> 
> mine is: libswt3-gtk2-3.3.1.1-10.fc9
> 
> 
rpm -qa libswt3-gtk2
libswt3-gtk2-3.3.0-30.fc8
Comment 19 Lillian Angel 2007-12-06 10:09:13 EST
Ok, the version of libswt3-gtk2 you have, should be fine. You can try updating
it to the version in rawhide.

I am looking into why the old .azureus settings cause a crash. Thanks for
finding this.

The reason the azureus downloaded from sourceforge works, might be because it
recreates the .azureus file. We are using the same source as that available from
sourceforge, with a few minor patches to prevent auto-updating.
Comment 20 Troels Just 2007-12-06 10:14:39 EST
(In reply to comment #19)
> Ok, the version of libswt3-gtk2 you have, should be fine. You can try 
updating
> it to the version in rawhide.
> 
> I am looking into why the old .azureus settings cause a crash. Thanks for
> finding this.
> 
> The reason the azureus downloaded from sourceforge works, might be because 
it recreates the .azureus file.
>
What exactly do you mean by recreates? You mean like rewriting the entire 
settings directory?


> We are using the same source as that available from sourceforge, with a few 
minor patches to prevent auto-updating.
>
In the tarball I downloaded from SourceForge, is a file called "TOS.txt" which 
contains a proprietary software license. Do you know what these terms cover, 
and is that stuff removed in Fedora?
Comment 21 Lillian Angel 2007-12-06 10:21:17 EST
I am not sure if it rewrites the entire settings directory, that was just a
guess. I have to do further investigating.

No, we are only incorporating the code which is GPL'd.
Comment 22 Troels Just 2007-12-06 10:28:29 EST
(In reply to comment #21)
> I am not sure if it rewrites the entire settings directory, that was just a
> guess. I have to do further investigating.
> 
Fair enough :)

> No, we are only incorporating the code which is GPL'd.
>
I know, which is why I asked to make sure that that Vuze stuff didn't get in 
by accident, because if I hadn't read the Azureus wiki, I wouldn't have had 
any idea that there was non-free stuff in the latest versions of Azureus.



Also, I just tried updating libswt3-gtk2 on my laptop to the version in 
rawhide, just to make sure it wasn't the problem, and it did not fix the 
problem.
Comment 23 Lillian Angel 2007-12-06 10:33:04 EST
Just to clarify, we are not using the installer version- only the client software.

"Is it still GPL?

Yes, the Azureus3/Vuze source is in the same location as the original Azureus2
source and remains under the same GPL2 license as it always has. See the source
code section above.

    Note: The installer version of Azureus 3 comes with the Vuze Terms of
service, which refers to the use of Vuze Content platform/website, i.e.
www.vuze.com. The client software itself is still governed by the GPL (see
section 6.2). "

Comment 24 E Mair 2007-12-30 22:49:04 EST
(In reply to comment #18)

> When using the newly updated azureus package from rawhide on Fedora 8, I have 
> found that if the user has an old .azureus settings directory (Generated by an 
> older version of Azureus) in his home directory, Azureus will crash when 
> selecting "Show Details" in the same manner as described in the original bug 
> report description. If the user removes his old settings, thereby letting 
> Azureus create a new .azureus directory, things work fine.

This is not the case with azureus-2.5.0.4-3.fc8, at least. Renaming my old
.azureus directory and starting from scratch was the first thing I tried, as it
usually helps whenever Azureus acts up.

I have not been able to update to and try the Rawhide version of Azureus, due to
a conflict:

"file /etc/gre.d/gre.conf from install of xulrunner-1.9-0.beta2.4.fc9.i386
conflicts with file from package firefox-2.0.0.10-3.fc8.i386"

Trying to also update Firefox from Rawhide opens a gate to dependency hell,
which I prefer to leave untouched.

It's been a while now. Is a fixed Fedora 8 version of Azureus about to be
released any time soon?
Comment 25 Troels Just 2007-12-30 22:58:39 EST
(In reply to comment #24)
> This is not the case with azureus-2.5.0.4-3.fc8, at least. Renaming my old
> .azureus directory and starting from scratch was the first thing I tried, as 
it
> usually helps whenever Azureus acts up.
> 
For those of us who are addicted to statistics, deleting the .azureus 
directory is not that great of an option, and especially since it works fine 
if you use the Azureus you can find at azureus.sf.net, which I currently do.
Comment 26 Callum Lerwick 2007-12-31 05:46:31 EST
I ran in to this upon upgrading to Fedora 8. It would crash during start up,
every time I tried to run it. I tried renaming my .azureus directory so it would
create a new one, and this allowed it to start up.

I found I do not have to delete my entire ~/.azureus directory. Just deleting
azureus.config and azureus.config.bak was enough for me, and I was able to start
Azureus and re-enter all my settings. I ran it for a while, but after quitting
and trying to start it again, it crashed again. So I deleted azureus.config*
again, started it up, and this time I tried only modifying a minimal set of
configuration options. After doing this, I can quit and restart Azureus just
fine. So it seems there's some specific configuration option that's screwing it
up, but I have no idea which.

... But that may be a completely different bug. Trying to view details of a
torrent still crashes, deleting ~/.azureus does not seem to help this at all.
Comment 27 Lillian Angel 2008-01-02 09:55:07 EST
(In reply to comment #26)
> ... But that may be a completely different bug. Trying to view details of a
> torrent still crashes, deleting ~/.azureus does not seem to help this at all.

This should not be the case if you are using Azureus from rawhide. You are
probably using an older version still. Do you see the Vuze skins when you start
it up? I suspect you are still using 2.5. rpm -qa azureus ?

Comment 28 Lillian Angel 2008-01-02 09:56:45 EST
(In reply to comment #24)

> I have not been able to update to and try the Rawhide version of Azureus, due to
> a conflict:
> 
> "file /etc/gre.d/gre.conf from install of xulrunner-1.9-0.beta2.4.fc9.i386
> conflicts with file from package firefox-2.0.0.10-3.fc8.i386"
> 
> Trying to also update Firefox from Rawhide opens a gate to dependency hell,
> which I prefer to leave untouched.
> 
> It's been a while now. Is a fixed Fedora 8 version of Azureus about to be
> released any time soon?

The conflict you are seeing is not a problem with Azureus. You will need to
resolve the conflicts with firefox and such on your own machine.
Comment 29 Lillian Angel 2008-01-02 09:57:33 EST
(In reply to comment #25)
> (In reply to comment #24)
> > This is not the case with azureus-2.5.0.4-3.fc8, at least. Renaming my old
> > .azureus directory and starting from scratch was the first thing I tried, as 
> it
> > usually helps whenever Azureus acts up.
> > 
> For those of us who are addicted to statistics, deleting the .azureus 
> directory is not that great of an option, and especially since it works fine 
> if you use the Azureus you can find at azureus.sf.net, which I currently do.

You are right this is definitely a problem. I will open a new report for this,
and close this one sice the summary/comments are irrelevant now.

Comment 30 Lillian Angel 2008-01-02 10:02:33 EST
New bug: https://bugzilla.redhat.com/show_bug.cgi?id=427257

Closing this one. The "viewing details" problem has been fixed in rawhide.
Comment 31 E Mair 2008-01-09 09:13:10 EST
(In reply to comment #28)

> > "file /etc/gre.d/gre.conf from install of xulrunner-1.9-0.beta2.4.fc9.i386
> > conflicts with file from package firefox-2.0.0.10-3.fc8.i386"

> The conflict you are seeing is not a problem with Azureus. You will need to
> resolve the conflicts with firefox and such on your own machine.

I'd say it's a problem with Azureus since this bug is for Fedora 8, not Rawhide.

Why is the bug closed? It's only solved in Rawhide. There's no solution
available yet for Fedora 8, and the Rawhide version of Azureus is only possible
to install together with Rawhide's Firefox version, all of its dependencies, all
of those dependencies' dependencies and so on.

This is the truncated output from "yum --enablerepo=development update azureus",
which I hope was suggested earlier as a temporary workaround:
-----------------------------------------------------------------
[snip]
--> Running transaction check
---> Package azureus.i386 0:3.0.3.4-5.fc9 set to be updated
--> Processing Dependency: xulrunner for package: azureus
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.beta2.6.fc9 set to be updated
--> Processing Dependency: nss >= 3.11.99 for package: xulrunner
--> Processing Dependency: nspr >= 4.6.99 for package: xulrunner
--> Running transaction check
---> Package nss.i386 0:3.11.99.2b-2.fc9 set to be updated
---> Package nspr.i386 0:4.6.99.2-1.fc9 set to be updated
--> Processing Dependency: nspr = 4.6.7-3.fc8 for package: nspr-devel
--> Processing Dependency: nss = 3.11.7-10.fc8 for package: nss-devel
--> Processing Dependency: nss = 3.11.7-10.fc8 for package: nss-tools
--> Running transaction check
---> Package nss-tools.i386 0:3.11.99.2b-2.fc9 set to be updated
---> Package nspr-devel.i386 0:4.6.99.2-1.fc9 set to be updated
---> Package nss-devel.i386 0:3.11.99.2b-2.fc9 set to be updated
--> Finished Dependency Resolution
[snip]
Updating:
 azureus                 i386       3.0.3.4-5.fc9    development        14 M
 nspr                    i386       4.6.99.2-1.fc9   development       118 k
 nss                     i386       3.11.99.2b-2.fc9  development       1.2 M
Installing for dependencies:
 xulrunner               i386       1.9-0.beta2.6.fc9  development       9.8 M
Updating for dependencies:
 nspr-devel              i386       4.6.99.2-1.fc9   development       110 k
 nss-devel               i386       3.11.99.2b-2.fc9  development       221 k
 nss-tools               i386       3.11.99.2b-2.fc9  development       2.1 M
[snip]
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /etc/gre.d/gre.conf from install of xulrunner-1.9-0.beta2.6.fc9.i386
conflicts with file from package firefox-2.0.0.10-3.fc8.i386
-----------------------------------------------------------------

There is no xulrunner for F8, as far as I and yum can tell.

I ask again, is an updated (3.x?) Azureus package for F8 to be released?
Isn't this F8 bug supposed to be open until it's actually fixed for F8?
Comment 32 Lillian Angel 2008-01-09 10:28:34 EST
Working on a release for F-8
Comment 33 Lillian Angel 2008-01-09 12:27:17 EST
azureus-3.0.3.4-2 has been built for i386 and x86_64. this update is not
available for ppc/64. You should be able to update from yum by tomorrow.

To fix your dependency issue- you will need to remove firefox, install xulrunner
from rawhide and re-install firefox from rawhide.
Comment 34 Lillian Angel 2008-01-11 14:55:41 EST
To download the rpms before they hit the updates repo:
http://koji.fedoraproject.org/koji/buildinfo?buildID=30877
Comment 35 E Mair 2008-01-11 17:58:58 EST
Thanks!
Though I have even bigger problems with the GUI in that version: bug #428482
Comment 36 Fedora Update System 2008-01-15 18:04:37 EST
azureus-3.0.3.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.