Bug 398291 - system-config-cluster 1.0.51-2.0 fail to start, gives traceback
system-config-cluster 1.0.51-2.0 fail to start, gives traceback
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
GSSApproved
: ZStream
: 400901 420271 426839 428441 433621 (view as bug list)
Depends On:
Blocks: 426104
  Show dependency treegraph
 
Reported: 2007-11-25 06:01 EST by Anders
Modified: 2010-10-22 16:40 EDT (History)
13 users (show)

See Also:
Fixed In Version: RHBA-2008-0792
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:07:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders 2007-11-25 06:01:38 EST
Description of problem:
Latest system-config-cluster fail to start.

Version-Release number of selected component (if applicable):
system-config-cluster 1.0.51-2.0 in RHEL4 (what you get if you up2date to latest
everything from RHN).

How reproducible:
100%

Steps to Reproduce:
1. install system-config-cluster
2. run system-config-cluster
3. observe traceback
  
Actual results:
[root@dhcp-1-170 ~]# system-config-cluster 
Traceback (most recent call last):
  File "/usr/sbin/system-config-cluster", line 52, in ?
    from ConfigTab import ConfigTab
  File "/usr/share/system-config-cluster/ConfigTab.py", line 27, in ?
    from ConfigTabController import ConfigTabController
  File "/usr/share/system-config-cluster/ConfigTabController.py", line 35, in ?
    from FaildomController import FaildomController
  File "/usr/share/system-config-cluster/FaildomController.py", line 213
    if val == "Yes" or val == "yes" or val="1":
                                          ^
SyntaxError: invalid syntax


Expected results:
gui comes up

Additional info:

This is the patch that fixes it

[root@dhcp-1-170 ~]# diff -u
/usr/share/system-config-cluster/FaildomController.py.bak
/usr/share/system-config-cluster/FaildomController.py
--- /usr/share/system-config-cluster/FaildomController.py.bak   2007-11-25
10:55:26.000000000 +0000
+++ /usr/share/system-config-cluster/FaildomController.py       2007-11-25
10:55:42.000000000 +0000
@@ -210,7 +210,7 @@
       #Set checkboxes for restricted and prioritized
       val = self.current_faildom.getAttribute("restricted")
       if val != None:
-        if val == "Yes" or val == "yes" or val="1":
+        if val == "Yes" or val == "yes" or val == "1":
           self.restricted_cbox.set_active(True)
         else:
           self.restricted_cbox.set_active(False)
Comment 1 Jim Parsons 2007-11-27 10:15:06 EST
*** Bug 400901 has been marked as a duplicate of this bug. ***
Comment 2 Jim Parsons 2007-11-27 10:21:47 EST
Thanks for the patch - that will sure fix it :(
Asking for necessary acks...
Comment 7 Jim Parsons 2007-12-04 08:12:31 EST
ready for z-stream duplo
Comment 12 Jim Parsons 2007-12-10 15:45:22 EST
Absolutely. The patch will do it.
Comment 15 Toure Dunnon 2008-01-11 10:49:40 EST
*** Bug 428441 has been marked as a duplicate of this bug. ***
Comment 16 Jim Parsons 2008-01-30 15:38:19 EST
*** Bug 420271 has been marked as a duplicate of this bug. ***
Comment 17 Jim Parsons 2008-01-30 15:41:54 EST
*** Bug 426839 has been marked as a duplicate of this bug. ***
Comment 21 Johnny Hughes 2008-02-21 07:24:11 EST
is this ever getting fixed :D
Comment 22 Jim Parsons 2008-02-21 11:44:08 EST
It is all set for an asynchronous update. I will check where it is stuck and
give it a kick.
Comment 28 Jim Parsons 2008-04-23 09:34:27 EDT
*** Bug 433621 has been marked as a duplicate of this bug. ***
Comment 33 errata-xmlrpc 2008-07-25 15:07:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0792.html

Note You need to log in before you can comment on or make changes to this bug.