Bug 443117 - packagekit installing updates a few at a time
packagekit installing updates a few at a time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 443214 443501 443598 444250 (view as bug list)
Depends On:
Blocks: F9PKBlocker
  Show dependency treegraph
 
Reported: 2008-04-18 13:59 EDT by Thomas J. Baker
Modified: 2008-04-26 06:52 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-26 04:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gpk-log-two-transactions.txt (20.86 KB, text/plain)
2008-04-21 22:32 EDT, Andrew Farris
no flags Details

  None (edit)
Description Thomas J. Baker 2008-04-18 13:59:08 EDT
Yesterday I had strange dealings with packagekit installing updates a couple at
a time. I'd install some updates and immediately after that, when it automatically
checks again, there are a couple more updates, rinse, repeat.

Happened on three different systems. I have a local mirror and I know it's not
changing every couple of minutes. 

katratzi> rpm -qa | grep -i packagekit

PackageKit-0.1.12-4.20080416git.fc9.i386

gnome-packagekit-0.1.12-5.20080416git.fc9.i386

PackageKit-libs-0.1.12-4.20080416git.fc9.i386

yum-packagekit-0.1.12-4.20080416git.fc9.i386

katratzi>
Comment 1 Brian Pepple 2008-04-18 15:52:52 EDT
Confirmed behavior here also.

[bpepple@localhost ~]$ rpm -qa | grep -i packagekit
PackageKit-libs-0.1.12-4.20080416git.fc9.i386
yum-packagekit-0.1.12-4.20080416git.fc9.i386
PackageKit-0.1.12-4.20080416git.fc9.i386
gnome-packagekit-0.1.12-5.20080416git.fc9.i386
Comment 2 Richard Hughes 2008-04-19 08:25:47 EDT
Yup, this is due the BASENAME filter being too clever. I'll fix this on monday.
Thanks guys.
Comment 3 Richard Hughes 2008-04-20 14:21:06 EDT
*** Bug 443214 has been marked as a duplicate of this bug. ***
Comment 4 Richard Hughes 2008-04-20 17:18:48 EDT
Fixed on stable and master, by turning off basename. We can revisit BASENAME for
updates after the F9 release is out of the door.
Comment 5 Richard Hughes 2008-04-21 21:51:08 EDT
*** Bug 443501 has been marked as a duplicate of this bug. ***
Comment 6 Andrew Farris 2008-04-21 22:32:47 EDT
Created attachment 303240 [details]
gpk-log-two-transactions.txt

In case its useful there is my full gpk-log -v output where this occurred for
the last two transactions at least.  They were done within minutes of each
other and the mirror should not have been changing that time of day (although I
guess its possible).
Comment 7 Richard Hughes 2008-04-22 14:01:17 EDT
*** Bug 443598 has been marked as a duplicate of this bug. ***
Comment 8 Will Woods 2008-04-25 15:14:19 EDT
This appears to be fixed by PackageKit-0.1.12-7.20080425.fc9, available in koji.
Comment 9 Richard Hughes 2008-04-26 06:52:01 EDT
*** Bug 444250 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.