Bug 470728 - apt's and rpm's lua versions conflict
apt's and rpm's lua versions conflict
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
10
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
: 460742 473656 474403 479483 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-09 11:22 EST by Leszek Matok
Modified: 2009-04-27 08:44 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 22:11:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Load required lua packages (1.69 KB, patch)
2008-12-16 12:29 EST, Lubomir Rintel
no flags Details | Diff

  None (edit)
Description Leszek Matok 2008-11-09 11:22:34 EST
I mean it! It doesn't even show syntax or anything:
# apt-get
*** glibc detected *** apt-get: realloc(): invalid pointer: 0x0981bb14 ***
======= Backtrace: =========
/lib/libc.so.6[0x67a454]
/lib/libc.so.6(realloc+0x242)[0x67ee72]
/usr/lib/libapt-pkg.so.3(luaM_realloc+0x35)[0x34b275]
/usr/lib/libapt-pkg.so.3(luaD_reallocstack+0x43)[0x347303]
/usr/lib/libapt-pkg.so.3(luaD_growstack+0x46)[0x3473c6]
/usr/lib/libapt-pkg.so.3(luaD_precall+0x180)[0x347eb0]
/usr/lib/libapt-pkg.so.3(luaD_call+0x42)[0x348282]
/usr/lib/libapt-pkg.so.3(lua_call+0x3b)[0x343d7b]
/usr/lib/liblua-5.1.so(luaL_openlibs+0x65)[0x14b385]
/usr/lib/librpmio-4.6.so(rpmluaNew+0x43)[0x16a893]
/usr/lib/librpmio-4.6.so(rpmluaGetPrintBuffer+0x37)[0x16b2a7]
/usr/lib/librpm-4.6.so(rpmReadConfigFiles+0x25a)[0x1cd3fa]
/usr/lib/libapt-pkg.so.3(_ZN9rpmSystem5ScoreERK13Configuration+0x2b)[0x2e7c2b]
/usr/lib/libapt-pkg.so.3(_Z13pkgInitSystemR13ConfigurationRP9pkgSystem+0x99)[0x30fc29]
apt-get[0x8051036]
/lib/libc.so.6(__libc_start_main+0xe5)[0x6216d5]
apt-get(_ZNSt8ios_base4InitD1Ev+0x41)[0x804cc61]
======= Memory map: ========
00110000-00111000 r-xp 00110000 00:00 0          [vdso]
00111000-00126000 r-xp 00000000 09:7f 398319     /usr/lib/libmagic.so.1.0.0
00126000-00127000 rw-p 00015000 09:7f 398319     /usr/lib/libmagic.so.1.0.0
00129000-00153000 r-xp 00000000 09:7f 398321     /usr/lib/liblua-5.1.so
00153000-00154000 rw-p 0002a000 09:7f 398321     /usr/lib/liblua-5.1.so
00156000-0017d000 r-xp 00000000 09:7f 398322     /usr/lib/librpmio-4.6.so
0017d000-0017f000 rw-p 00027000 09:7f 398322     /usr/lib/librpmio-4.6.so
0017f000-00181000 rw-p 0017f000 00:00 0 
00183000-001eb000 r-xp 00000000 09:7f 381896     /usr/lib/librpm-4.6.so
001eb000-001ef000 rw-p 00067000 09:7f 381896     /usr/lib/librpm-4.6.so
001ef000-001f0000 rw-p 001ef000 00:00 0 
001f0000-00228000 r-xp 00000000 09:7f 880343     /lib/libsoftokn3.so
00228000-00229000 rw-p 00037000 09:7f 880343     /lib/libsoftokn3.so
00229000-00234000 r-xp 00000000 09:7f 880316     /lib/libnss_files-2.8.90.so
00234000-00235000 r--p 0000a000 09:7f 880316     /lib/libnss_files-2.8.90.so
00235000-00236000 rw-p 0000b000 09:7f 880316     /lib/libnss_files-2.8.90.so
0023c000-00256000 r-xp 00000000 09:7f 880252     /lib/libselinux.so.1
00256000-00257000 r--p 00019000 09:7f 880252     /lib/libselinux.so.1
00257000-00258000 rw-p 0001a000 09:7f 880252     /lib/libselinux.so.1
0025a000-00380000 r-xp 00000000 09:7f 1413283    /usr/lib/libapt-pkg.so.3.0.0
00380000-00385000 rw-p 00125000 09:7f 1413283    /usr/lib/libapt-pkg.so.3.0.0
00385000-003c4000 r-xp 00000000 09:7f 880337     /lib/libfreebl3.so
003c4000-003c5000 rw-p 0003e000 09:7f 880337     /lib/libfreebl3.so
0058c000-00594000 r-xp 00000000 09:7f 1721355    /lib/libpopt.so.0.0.0
00594000-00595000 rw-p 00007000 09:7f 1721355    /lib/libpopt.so.0.0.0
005a3000-005a6000 r-xp 00000000 09:7f 1721357    /lib/libplds4.so
005a6000-005a7000 rw-p 00002000 09:7f 1721357    /lib/libplds4.so
005a9000-005ad000 r-xp 00000000 09:7f 1721358    /lib/libplc4.so
005ad000-005ae000 rw-p 00003000 09:7f 1721358    /lib/libplc4.so
005e6000-00606000 r-xp 00000000 09:7f 880152     /lib/ld-2.8.90.so
00607000-00608000 r--p 00020000 09:7f 880152     /lib/ld-2.8.90.so
00608000-00609000 rw-p 00021000 09:7f 880152     /lib/ld-2.8.90.so
0060b000-00779000 r-xp 00000000 09:7f 880176     /lib/libc-2.8.90.so
00779000-0077b000 r--p 0016e000 09:7f 880176     /lib/libc-2.8.90.so
0077b000-0077c000 rw-p 00170000 09:7f 880176     /lib/libc-2.8.90.so
0077c000-0077f000 rw-p 0077c000 00:00 0 
00781000-007a8000 r-xp 00000000 09:7f 880352     /lib/libm-2.8.90.so
007a8000-007a9000 r--p 00026000 09:7f 880352     /lib/libm-2.8.90.so
007a9000-007aa000 rw-p 00027000 09:7f 880352     /lib/libm-2.8.90.so
007ac000-007af000 r-xp 00000000 09:7f 880353     /lib/libdl-2.8.90.so
007af000-007b0000 r--p 00002000 09:7f 880353     /lib/libdl-2.8.90.so
007b0000-007b1000 rw-p 00003000 09:7f 880353     /lib/libdl-2.8.90.so
007b3000-007c9000 r-xp 00000000 09:7f 880349     /lib/libpthread-2.8.90.so
007c9000-007ca000 r--p 00015000 09:7f 880349     /lib/libpthread-2.8.90.so
007ca000-007cb000 rw-p 00016000 09:7f 880349     /lib/libpthread-2.8.90.so
007cb000-007cd000 rw-p 007cb000 00:00 0 
007cf000-007e2000 r-xp 00000000 09:7f 880355     /lib/libz.so.1.2.3
007e2000-007e3000 rw-p 00012000 09:7f 880355     /lib/libz.so.1.2.3
00917000-0091f000 r-xp 00000000 09:7f 880350     /lib/librt-2.8.90.so
0091f000-00920000 r--p 00007000 09:7f 880350     /lib/librt-2.8.90.so
00920000-00921000 rw-p 00008000 09:7f 880350     /lib/librt-2.8.90.so
009b8000-009c8000 r-xp 00000000 09:7f 880257     /lib/libbz2.so.1.0.4
009c8000-009c9000 rw-p 00010000 09:7f 880257     /lib/libbz2.so.1.0.4
009cb000-009e0000 r-xp 00000000 09:7f 398295     /usr/lib/libelf-0.137.so
009e0000-009e1000 r--p 00014000 09:7f 398295     /usr/lib/libelf-0.137.so
009e1000-009e2000 rw-p 00015000 09:7f 398295     /usr/lib/libelf-0.137.so
00a6c000-00b9a000 r-xp 00000000 09:7f 880396     /lib/libdb-4.5.so
00b9a000-00b9d000 rw-p 0012e000 09:7f 880396     /lib/libdb-4.5.so
00bcc000-00bd9000 r-xp 00000000 09:7f 880356     /lib/libgcc_s-4.3.2-20081105.so.1
00bd9000-00bda000 rw-p 0000c000 09:7f 880356     /lib/libgcc_s-4.3.2-20081105.so.1
00c1f000-00c35000 r-xp 00000000 09:7f 1721359    /lib/libnssutil3.so
00c35000-00c38000 rw-p 00015000 09:7f 1721359    /lib/libnssutil3.so
058db000-05a1a000 r-xp 00000000 09:7f 1721360    /lib/libnss3.so
05a1a000-05a20000 rw-p 0013e000 09:7f 1721360    /lib/libnss3.so
05a22000-05a59000 r-xp 00000000 09:7f 1721356    /lib/libnspr4.so
05a59000-05a5a000 rw-p 00037000 09:7f 1721356    /lib/libnspr4.so
05a5a000-05a5c000 rw-p 05a5a000 00:00 0 
05b8d000-05cd8000 r-xp 00000000 09:7f 397942     /usr/lib/libxml2.so.2.7.2
05cd8000-05cdd000 rw-p 0014a000 09:7f 397942     /usr/lib/libxml2.so.2.7.2
05cdd000-05cde000 rw-p 05cdd000 00:00 0 
06356000-063bf000 r-xp 00000000 09:7f 373625     /usr/lib/libsqlite3.so.0.8.6
063bf000-063c1000 rw-p 00068000 09:7f 373625     /usr/lib/libsqlite3.so.0.8.6
07ca3000-07d8a000 r-xp 00000000 09:7f 398007     /usr/lib/libstdc++.so.6.0.10
07d8a000-07d8e000 r--p 000e6000 09:7f 398007     /usr/lib/libstdc++.so.6.0.10
07d8e000-07d90000 rw-p 000ea000 09:7f 398007     /usr/lib/libstdc++.so.6.0.10
07d90000-07d95000 rw-p 07d90000 00:00 0 
08048000-0806f000 r-xp 00000000 09:7f 1101884    /usr/bin/apt-get
0806f000-08072000 rw-p 00027000 09:7f 1101884    /usr/bin/apt-get
097f2000-09828000 rw-p 097f2000 00:00 0          [heap]
b7ea5000-b80a5000 r--p 00000000 09:7f 929795     /usr/lib/locale/locale-archive
b80a5000-b80ad000 rw-p b80a5000 00:00 0 
bfebb000-bfed0000 rw-p bffeb000 00:00 0          [stack]
Abort

Same goes for apt-shell, apt-cache and apt-config.
Comment 1 Panu Matilainen 2008-11-09 13:03:49 EST
Yes, known... this is a clash between apt and rpm internal Lua versions. This and the recent change in repodata format makes apt indeed completely broken for F10. Will fix eventually but maybe we should pull apt+synaptic out until this is resolved, shipping known broken packages does little good to anybody.
Comment 2 Axel Thimm 2008-11-09 15:20:36 EST
*** Bug 460742 has been marked as a duplicate of this bug. ***
Comment 3 Bug Zapper 2008-11-26 00:05:45 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Ignacio Vazquez-Abrams 2008-11-29 14:36:15 EST
*** Bug 473656 has been marked as a duplicate of this bug. ***
Comment 5 Chris Weyl 2008-12-03 13:03:28 EST
*** Bug 474403 has been marked as a duplicate of this bug. ***
Comment 6 Lubomir Rintel 2008-12-16 03:34:56 EST
While searching for Lua 5.1 documentation while attempting to fix this I stumbled upon a patch from that already solves this (which was for some unknown reason sent to rpm-devel@rpm5.org), so I added it to devel CVS in 0.5.15lorg3.94-6 release.

I didn't manage to finish an apt-get update though, failing at CollectFileProvides for flac. I'll eventually try to look at it later today.

(In reply to comment #1)
> This
> and the recent change in repodata format makes apt indeed completely broken for
> F10.

Panu: Are you aware of details of the change in repodata format? Maybe that could help solve my problem.
Comment 7 Panu Matilainen 2008-12-16 10:23:32 EST
(In reply to comment #6)
> While searching for Lua 5.1 documentation while attempting to fix this I
> stumbled upon a patch from that already solves this (which was for some unknown
> reason sent to rpm-devel@rpm5.org), so I added it to devel CVS in
> 0.5.15lorg3.94-6 release.

It's not quite that simple :-/ This discards the local Lua libraries apt (and rpm for that matter) bundles, namely posix and rexlib, shipping without them is a notable functionality regression for apt-lua scripts. Especially the posix library is rather essential for doing much anything useful (without it, gpg checker wont work etc). Hmm... ok, lua-posix appears to be in Fedora as a separate package, that should be enough to preserve most common functionality.

For upstream I'll need a better fix that handles all the myriad of combinations without losing functionality but this is at least a start at getting apt back on track.

> I didn't manage to finish an apt-get update though, failing at
> CollectFileProvides for flac. I'll eventually try to look at it later today.
> 
> (In reply to comment #1)
> > This
> > and the recent change in repodata format makes apt indeed completely broken for
> > F10.
> 
> Panu: Are you aware of details of the change in repodata format? Maybe that
> could help solve my problem.

Well, repodata format didn't really change, it's just that apt was using hardcoded "basenames" for primary/filelist files as a kludge to hide the fact that repomd "index" is actually several files. I've been intending to fix but never got around to it, but it should be fixed upstream now. Thanks for kicking my lazy butt to do something about it :)
Comment 8 Lubomir Rintel 2008-12-16 11:06:21 EST
(In reply to comment #7)
> (In reply to comment #6)
> > While searching for Lua 5.1 documentation while attempting to fix this I
> > stumbled upon a patch from that already solves this (which was for some unknown
> > reason sent to rpm-devel@rpm5.org), so I added it to devel CVS in
> > 0.5.15lorg3.94-6 release.
> 
> It's not quite that simple :-/ This discards the local Lua libraries apt (and
> rpm for that matter) bundles, namely posix and rexlib, shipping without them is
> a notable functionality regression for apt-lua scripts. Especially the posix
> library is rather essential for doing much anything useful (without it, gpg
> checker wont work etc). Hmm... ok, lua-posix appears to be in Fedora as a
> separate package, that should be enough to preserve most common functionality.

Yum, I noticed regex being separate in new lua, added "require 'regex'" in the lua scripts but I forgot to take that into account when commiting. Sorry for that. Not knowing much about LUA I don't even know what does require really do not what's its lua C library counterpart.

> > Panu: Are you aware of details of the change in repodata format? Maybe that
> > could help solve my problem.
> 
> Well, repodata format didn't really change, it's just that apt was using
> hardcoded "basenames" for primary/filelist files as a kludge to hide the fact
> that repomd "index" is actually several files. I've been intending to fix but
> never got around to it, but it should be fixed upstream now. Thanks for kicking
> my lazy butt to do something about it :)

Wow, you're fast. I found out what's the problem with those file names in the morning and had been struggling to fix that sensibly for hours :)
Comment 9 Lubomir Rintel 2008-12-16 11:07:29 EST
(In reply to comment #8)
> Yum, I noticed regex being separate in new lua, added "require 'regex'" in the
  ^^^ This should have been "Yes" :}
Comment 10 Panu Matilainen 2008-12-16 12:19:43 EST
> Wow, you're fast. I found out what's the problem with those file names in the
> morning and had been struggling to fix that sensibly for hours :)

To put things to some perspective, I've been scratching my head for *weeks* how to sensibly fix it :) And the current fix is far from perfect, it's still a bit of a hack but so far I haven't been able to come up with a "fully correct" fix that doesn't require restructuring half of apt's internals...
Comment 11 Lubomir Rintel 2008-12-16 12:29:26 EST
Created attachment 327135 [details]
Load required lua packages

(In reply to comment #7)

> It's not quite that simple :-/ This discards the local Lua libraries apt (and
> rpm for that matter) bundles, namely posix and rexlib, shipping without them is
> a notable functionality regression for apt-lua scripts. Especially the posix
> library is rather essential for doing much anything useful (without it, gpg
> checker wont work etc). Hmm... ok, lua-posix appears to be in Fedora as a
> separate package, that should be enough to preserve most common functionality.

Attaching patch with necessary changes to lua scripts. The lrexlib package is being reviewed here: bug #476712
Comment 12 Panu Matilainen 2008-12-22 17:47:05 EST
Ok upstream whacked to build against external liblua but including bundled Lua-extensions. Support for rpm 4.4.x is horribly broken by that but this'll at least permit moving on with things, apt's been broken for far far too long now.

Kinda amusingly, I apparently don't belong to the "provenpackager" group and the "opening" of ACL's killed my co-maintainer permissions wrt apt... Until I regain the permissions (already requested), here's the src.rpm of upstream snapshot that should make apt reasonably functional again:
http://laiskiainen.org/tmp/apt-0.5.15lorg3.95-0.git416.1.fc11.src.rpm
Comment 13 Panu Matilainen 2008-12-23 03:37:02 EST
Okay, the above snapshot is now built into rawhide:
http://koji.fedoraproject.org/koji/buildinfo?buildID=76168
At least basic smoke-tests pass... F10 is going to need an update soon too of course, but please do test the rawhide package a bit before we go for F10.

Thanks Axel for undoing the mess the ACL mass-opening scripts/whatever caused :)
Comment 14 Fedora Update System 2009-01-07 03:05:17 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/apt-0.5.15lorg3.95-0.git416.3.fc10
Comment 15 Fedora Update System 2009-01-07 16:52:31 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update apt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0304
Comment 16 Panu Matilainen 2009-01-12 05:17:51 EST
*** Bug 479483 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2009-01-14 22:10:52 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 sattam 2009-04-27 08:44:29 EDT
same problem : 

===========
# apt-get update
*** glibc detected *** apt-get: realloc(): invalid pointer: 0x08877024 ***
======= Backtrace: =========
/lib/libc.so.6[0x9a63a4]
/lib/libc.so.6(realloc+0x242)[0x9aadc2]
/usr/lib/libapt-pkg.so.3(luaM_realloc+0x35)[0x1ff195]
/usr/lib/libapt-pkg.so.3(luaD_reallocstack+0x43)[0x1fb223]
/usr/lib/libapt-pkg.so.3(luaD_growstack+0x46)[0x1fb2e6]
/usr/lib/libapt-pkg.so.3(luaD_precall+0x180)[0x1fbdd0]
/usr/lib/libapt-pkg.so.3(luaD_call+0x42)[0x1fc1a2]
/usr/lib/libapt-pkg.so.3(lua_call+0x3b)[0x1f7c9b]
/usr/lib/liblua-5.1.so(luaL_openlibs+0x65)[0xb8b385]
/usr/lib/librpmio-4.6.so(rpmluaNew+0x43)[0x2ba8c3]
/usr/lib/librpmio-4.6.so(rpmluaGetPrintBuffer+0x37)[0x2bb2d7]
/usr/lib/librpm-4.6.so(rpmReadConfigFiles+0x20e)[0x28358e]
/usr/lib/libapt-pkg.so.3(_ZN9rpmSystem5ScoreERK13Configuration+0x2b)[0x19bb4b]
/usr/lib/libapt-pkg.so.3(_Z13pkgInitSystemR13ConfigurationRP9pkgSystem+0x99)[0x1c3b49]
apt-get[0x8051036]
/lib/libc.so.6(__libc_start_main+0xe5)[0x94d6e5]
apt-get(_ZNSt8ios_base4InitD1Ev+0x41)[0x804cc61]
======= Memory map: ========
00110000-00234000 r-xp 00000000 fd:00 1024020    /usr/lib/libapt-pkg.so.3.0.0
00234000-00239000 rw-p 00123000 fd:00 1024020    /usr/lib/libapt-pkg.so.3.0.0
00239000-002a1000 r-xp 00000000 fd:00 1024615    /usr/lib/librpm-4.6.so
002a1000-002a6000 rw-p 00067000 fd:00 1024615    /usr/lib/librpm-4.6.so
002a6000-002cd000 r-xp 00000000 fd:00 1024694    /usr/lib/librpmio-4.6.so
002cd000-002cf000 rw-p 00027000 fd:00 1024694    /usr/lib/librpmio-4.6.so
002cf000-002d1000 rw-p 002cf000 00:00 0 
002d1000-002dc000 r-xp 00000000 fd:00 14726      /lib/libnss_files-2.9.so
002dc000-002dd000 r--p 0000a000 fd:00 14726      /lib/libnss_files-2.9.so
002dd000-002de000 rw-p 0000b000 fd:00 14726      /lib/libnss_files-2.9.so
00312000-0032d000 r-xp 00000000 fd:00 10541      /lib/libselinux.so.1
0032d000-0032e000 r--p 0001a000 fd:00 10541      /lib/libselinux.so.1
0032e000-0032f000 rw-p 0001b000 fd:00 10541      /lib/libselinux.so.1
0032f000-0045d000 r-xp 00000000 fd:00 10702      /lib/libdb-4.5.so
0045d000-00460000 rw-p 0012e000 fd:00 10702      /lib/libdb-4.5.so
00912000-00932000 r-xp 00000000 fd:00 10551      /lib/ld-2.9.so
00933000-00934000 r--p 00020000 fd:00 10551      /lib/ld-2.9.so
00934000-00935000 rw-p 00021000 fd:00 10551      /lib/ld-2.9.so
00937000-00aa5000 r-xp 00000000 fd:00 10552      /lib/libc-2.9.so
00aa5000-00aa7000 r--p 0016e000 fd:00 10552      /lib/libc-2.9.so
00aa7000-00aa8000 rw-p 00170000 fd:00 10552      /lib/libc-2.9.so
00aa8000-00aab000 rw-p 00aa8000 00:00 0 
00aad000-00ab0000 r-xp 00000000 fd:00 10558      /lib/libdl-2.9.so
00ab0000-00ab1000 r--p 00002000 fd:00 10558      /lib/libdl-2.9.so
00ab1000-00ab2000 rw-p 00003000 fd:00 10558      /lib/libdl-2.9.so
00ab4000-00adb000 r-xp 00000000 fd:00 10556      /lib/libm-2.9.so
00adb000-00adc000 r--p 00026000 fd:00 10556      /lib/libm-2.9.so
00adc000-00add000 rw-p 00027000 fd:00 10556      /lib/libm-2.9.so
00adf000-00af5000 r-xp 00000000 fd:00 10565      /lib/libpthread-2.9.so
00af5000-00af6000 r--p 00015000 fd:00 10565      /lib/libpthread-2.9.so
00af6000-00af7000 rw-p 00016000 fd:00 10565      /lib/libpthread-2.9.so
00af7000-00af9000 rw-p 00af7000 00:00 0 
00b51000-00b66000 r-xp 00000000 fd:00 1024186    /usr/lib/libmagic.so.1.0.0
00b66000-00b67000 rw-p 00015000 fd:00 1024186    /usr/lib/libmagic.so.1.0.0
00b69000-00b93000 r-xp 00000000 fd:00 1024190    /usr/lib/liblua-5.1.so
00b93000-00b94000 rw-p 0002a000 fd:00 1024190    /usr/lib/liblua-5.1.so
00bfe000-00c11000 r-xp 00000000 fd:00 10562      /lib/libz.so.1.2.3
00c11000-00c12000 rw-p 00012000 fd:00 10562      /lib/libz.so.1.2.3
00c57000-00c5f000 r-xp 00000000 fd:00 10566      /lib/librt-2.9.so
00c5f000-00c60000 r--p 00007000 fd:00 10566      /lib/librt-2.9.so
00c60000-00c61000 rw-p 00008000 fd:00 10566      /lib/librt-2.9.so
00d36000-00d37000 r-xp 00d36000 00:00 0          [vdso]
02081000-02096000 r-xp 00000000 fd:00 1741       /usr/lib/libelf-0.140.so
02096000-02097000 ---p 00015000 fd:00 1741       /usr/lib/libelf-0.140.so
02097000-02098000 r--p 00015000 fd:00 1741       /usr/lib/libelf-0.140.so
02098000-02099000 rw-p 00016000 fd:00 1741       /usr/lib/libelf-0.140.so
02218000-02281000 r-xp 00000000 fd:00 5063       /usr/lib/libsqlite3.so.0.8.6
02281000-02283000 rw-p 00068000 fd:00 5063       /usr/lib/libsqlite3.so.0.8.6
05708000-0571e000 r-xp 00000000 fd:00 9122       /lib/libnssutil3.so
0571e000-05721000 rw-p 00015000 fd:00 9122       /lib/libnssutil3.so
05963000-05aa2000 r-xp 00000000 fd:00 9644       /lib/libnss3.so
05aa2000-05aa8000 rw-p 0013e000 fd:00 9644       /lib/libnss3.so
06df1000-06f3c000 r-xp 00000000 fd:00 4213       /usr/lib/libxml2.so.2.7.3
06f3c000-06f41000 rw-p 0014b000 fd:00 4213       /usr/lib/libxml2.so.2.7.3
06f41000-06f42000 rw-p 06f41000 00:00 0 
0706b000-07073000 r-xp 00000000 fd:00 9991       /lib/libpopt.so.0.0.0
07073000-07074000 rw-p 00007000 fd:00 9991       /lib/libpopt.so.0.0.0
07311000-0731e000 r-xp 00000000 fd:00 10564      /lib/libgcc_s-4.3.2-20081105.so.1
0731e000-0731f000 rw-p 0000c000 fd:00 10564      /lib/libgcc_s-4.3.2-20081105.so.1
0742c000-07513000 r-xp 00000000 fd:00 4235       /usr/lib/libstdc++.so.6.0.10
07513000-07517000 r--p 000e6000 fd:00 4235       /usr/lib/libstdc++.so.6.0.10
07517000-07519000 rw-p 000ea000 fd:00 4235       /usr/lib/libstdc++.so.6.0.10
07519000-0751e000 rw-p 07519000 00:00 0 
0775a000-0775d000 r-xp 00000000 fd:00 10690      /lib/libplds4.so
0775d000-0775e000 rw-p 00002000 fd:00 10690      /lib/libplds4.so
07760000-07764000 r-xp 00000000 fd:00 10688      /lib/libplc4.so
07764000-07765000 rw-p 00003000 fd:00 10688      /lib/libplc4.so
077c0000-077f7000 r-xp 00000000 fd:00 10686      /lib/libnspr4.so
077f7000-077f8000 rw-p 00037000 fd:00 10686      /lib/libnspr4.so
077f8000-077fa000 rw-p 077f8000 00:00 0 
0797f000-0798f000 r-xp 00000000 fd:00 10708      /lib/libbz2.so.1.0.4
0798f000-07990000 rw-p 00010000 fd:00 10708      /lib/libbz2.so.1.0.4
08048000-0806f000 r-xp 00000000 fd:00 991570     /usr/bin/apt-get
0806f000-08070000 rw-p 00027000 fd:00 991570     /usr/bin/apt-get
0885b000-0889c000 rw-p 0885b000 00:00 0          [heap]
b7ee4000-b80e4000 r--p 00000000 fd:00 1048579    /usr/lib/locale/locale-archive
b80e4000-b80ec000 rw-p b80e4000 00:00 0 
bfcea000-bfcff000 rw-p bffeb000 00:00 0          [stack]
Aborted

============

Note You need to log in before you can comment on or make changes to this bug.