Bug 495231 - dbus service not started in anaconda when using boot.iso
dbus service not started in anaconda when using boot.iso
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 495338 495376 495400 495424 (view as bug list)
Depends On:
Blocks: 494832
  Show dependency treegraph
 
Reported: 2009-04-10 11:34 EDT by Paul W. Frields
Modified: 2009-04-21 13:23 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 13:23:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2009-04-10 11:34:39 EDT
Description of problem:
Rawhide compose 2009-04-10, booting from boot.iso.  The dbus service does not start, causing "System message bus not started" errors before the keymap selection screen.  Afterward, when the "URL" method is selected for installation and Anaconda tries to start the network interface, it fails since there's no message bus.


Version-Release number of selected component (if applicable):
anaconda-11.5.0.42-1
Comment 1 Tom Lane 2009-04-10 15:10:24 EDT
confirmed here; multiple reports of same on fedora-test-list ...
Comment 2 Bruno Wolff III 2009-04-10 15:48:54 EDT
Is it likely that manually starting the network in a shell will work or is anaconda going to be too hosed to continue?
(I want to put F11 on a couple of machines this weekend, and am trying to figure out what the best way to do that without a good boot.iso is going to be. I had tried the beta a couple of days ago but it has issues with the storage layout I wanted to use and I wanted to try a more recent installer.)
Comment 3 Mike Chambers 2009-04-10 17:12:49 EDT
The lil i icon for dbus or whatever (blue shaded color icon) doesn't start/show up as an applet neither.  Guess maybe they are related?
Comment 4 Paul W. Frields 2009-04-11 14:20:19 EDT
Now using the boot.iso from 2009-04-11.  I can see a message shortly after the kernel finishes, saying that the the dbus daemon can't start because it can't open libaudit.so.0.
Comment 5 Hobbes 2009-04-12 13:32:37 EDT
dbus daemon can't start because it can't open libaudit.so.0

I've tested with today's rawhide (04/12) boot.iso and the problem persists.
Comment 6 Jerry Vonau 2009-04-12 15:15:45 EDT
*** Bug 495376 has been marked as a duplicate of this bug. ***
Comment 7 Bruno Wolff III 2009-04-12 15:34:19 EDT
I seem to have a work around that will work in my case. I used a beta install disk in rescue mode to copy over a local mirror of rawhide to one of the disks that I don't need immediately. Then I do an initial boot with the beta install disk and pull it out once the boot (into the kernel) has started. This gives me an option to install from the hard drive (otherwise the image on the beta disk is detected and used) and while I haven't finished the install yet, it seems to be working so far. It allows me to install with encryption over raid, which the beta installer didn't.
Comment 8 Bruno Wolff III 2009-04-12 15:52:55 EDT
That attempt ultimately didn't work. The installer tries to mount an iso image (without giving a path name, it just says image #1) so it looks like I need to play around some more and try to guess where it expects there to be an iso image.
Since I don't want to wait until at least Tuesday to possibly have an easy to install image, I'll be making another attempt with this.
Comment 9 Bruno Wolff III 2009-04-13 01:24:05 EDT
I didn't have any luck today. My last try was using a fresh live base dvd and trying a liveinst, but that failed while trying to do my custom setup (encrypted raid 1).
Tomorrow I'll have better bandwidth and will grab some older install images and
try again tomorrow night.
Comment 10 Chris Lumens 2009-04-13 09:42:14 EDT
*** Bug 495424 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2009-04-13 09:42:22 EDT
*** Bug 495338 has been marked as a duplicate of this bug. ***
Comment 12 Chris Lumens 2009-04-13 09:45:23 EDT
*** Bug 495400 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2009-04-13 10:07:54 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 14 Patrick C. F. Ernzer 2009-04-21 13:14:43 EDT
I can confirm that this bug is fixed in anaconda 11.5.0.46
Thanks Chris.
This bug can be CLOSED RAWHIDE presuming that me testing with kernel and initrd from images/pxeboot/ over PXE is equivalent to using boot.iso
Comment 15 Chris Lumens 2009-04-21 13:23:10 EDT
Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.