Bug 502092 - RuntimeError: Returning partitions to state prior to edit failed
RuntimeError: Returning partitions to state prior to edit failed
Status: CLOSED DUPLICATE of bug 498026
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:69908cde6f8775504...
:
: 504900 518871 573707 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 16:05 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 16:20:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (172.51 KB, text/plain)
2009-05-21 16:05 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (130.20 KB, text/plain)
2009-06-23 20:51 EDT, TP
no flags Details
Attached traceback automatically from anaconda. (62.93 KB, text/plain)
2009-07-06 12:06 EDT, Oliver Henshaw
no flags Details
Attached traceback automatically from anaconda. (63.73 KB, text/plain)
2009-07-06 14:10 EDT, Michael Hagmann
no flags Details
Attached traceback automatically from anaconda. (484.07 KB, text/plain)
2009-07-07 03:35 EDT, iusers
no flags Details
Attached traceback automatically from anaconda. (159.73 KB, text/plain)
2009-07-25 06:23 EDT, Frank Murphy
no flags Details
Attached traceback automatically from anaconda. (374.91 KB, text/plain)
2009-08-06 08:04 EDT, Karel Volný
no flags Details
Attached traceback automatically from anaconda. (262.31 KB, text/plain)
2009-08-10 00:01 EDT, bugchaser
no flags Details
Attached traceback automatically from anaconda. (265.16 KB, text/plain)
2009-09-15 18:55 EDT, Bruno Medeiros
no flags Details
Attached traceback automatically from anaconda. (204.65 KB, text/plain)
2009-09-30 09:53 EDT, Robert Townley
no flags Details
Attached traceback automatically from anaconda. (133.28 KB, text/plain)
2009-09-30 10:01 EDT, Robert Townley
no flags Details
Attached traceback automatically from anaconda. (224.89 KB, text/plain)
2009-10-17 08:27 EDT, Alexander Todorov
no flags Details
Attached traceback automatically from anaconda. (118.18 KB, text/plain)
2009-11-02 08:41 EST, Darr247
no flags Details
Attached traceback automatically from anaconda. (575.80 KB, text/plain)
2010-03-16 08:08 EDT, Igor Katalnikov
no flags Details
Attached traceback automatically from anaconda. (134.48 KB, text/plain)
2010-09-17 22:16 EDT, Isaac
no flags Details
Attached traceback automatically from anaconda. (147.01 KB, text/plain)
2011-04-18 03:10 EDT, igoborkos@mail.ru
no flags Details

  None (edit)
Description James Laska 2009-05-21 16:05:06 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.54 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1134, in editPartition
    raise RuntimeError, ("Returning partitions to state "
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1080, in editCB
    self.editPartition(device)
RuntimeError: Returning partitions to state prior to edit failed
Comment 1 James Laska 2009-05-21 16:05:12 EDT
Created attachment 345020 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-05-21 16:07:21 EDT
Encountered while testing https://fedoraproject.org/wiki/QA:Testcase_Anaconda_autopart_(shrink)_install

1) Perform an @base install with:
   '/' ext3 --grow
   '/boot' ext3
   swap

2) Initiate a new install
3) Choose resize existing partition
4) Check "review partitions"
5) Select previous '/' (ext3) for resize
6) Select previous swap partition, and attempt to format as swap
Comment 3 Chris Lumens 2009-06-08 16:20:13 EDT

*** This bug has been marked as a duplicate of bug 498026 ***
Comment 4 Chris Lumens 2009-06-10 09:45:32 EDT
*** Bug 504900 has been marked as a duplicate of this bug. ***
Comment 5 TP 2009-06-23 20:51:40 EDT
Created attachment 349176 [details]
Attached traceback automatically from anaconda.
Comment 6 Oliver Henshaw 2009-07-06 12:06:43 EDT
Created attachment 350634 [details]
Attached traceback automatically from anaconda.
Comment 7 Oliver Henshaw 2009-07-06 12:18:11 EDT
The above traceback was triggered by an attempt to increase the size of a partition even though anaconda had already allocated all unpartitioned space.

I'm not sure how similar this is to the bug that this bug is duplicated to. I'm completely ignorant of anaconda's workings, but I wonder if bugs/tracebacks are being organised according to their symptoms, rather than their causes.
Comment 8 Michael Hagmann 2009-07-06 14:10:44 EDT
Created attachment 350656 [details]
Attached traceback automatically from anaconda.
Comment 9 iusers 2009-07-07 03:35:40 EDT
Created attachment 350740 [details]
Attached traceback automatically from anaconda.
Comment 10 Frank Murphy 2009-07-25 06:23:02 EDT
Created attachment 355137 [details]
Attached traceback automatically from anaconda.
Comment 11 Karel Volný 2009-08-06 08:04:48 EDT
Created attachment 356493 [details]
Attached traceback automatically from anaconda.
Comment 12 bugchaser 2009-08-10 00:01:12 EDT
Created attachment 356844 [details]
Attached traceback automatically from anaconda.
Comment 13 Chris Lumens 2009-08-24 10:31:20 EDT
*** Bug 518871 has been marked as a duplicate of this bug. ***
Comment 14 Bruno Medeiros 2009-09-15 18:55:07 EDT
Created attachment 361156 [details]
Attached traceback automatically from anaconda.
Comment 15 Robert Townley 2009-09-30 09:53:23 EDT
Created attachment 363187 [details]
Attached traceback automatically from anaconda.
Comment 16 Robert Townley 2009-09-30 10:01:47 EDT
Created attachment 363190 [details]
Attached traceback automatically from anaconda.
Comment 17 Alexander Todorov 2009-10-17 08:27:45 EDT
Created attachment 365119 [details]
Attached traceback automatically from anaconda.
Comment 18 Darr247 2009-11-02 08:41:15 EST
Created attachment 367134 [details]
Attached traceback automatically from anaconda.
Comment 19 Igor Katalnikov 2010-03-16 08:08:47 EDT
Created attachment 400448 [details]
Attached traceback automatically from anaconda.
Comment 20 Igor Katalnikov 2010-03-16 08:15:39 EDT
*** Bug 573707 has been marked as a duplicate of this bug. ***
Comment 21 Isaac 2010-09-17 22:16:47 EDT
Created attachment 448157 [details]
Attached traceback automatically from anaconda.
Comment 22 igoborkos@mail.ru 2011-04-18 03:10:47 EDT
Created attachment 492813 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.