Bug 508434 - (altgr) iso-level-3 / alt-gr broken in rawhide
iso-level-3 / alt-gr broken in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 509163 509578 509717 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-06-27 04:04 EDT by Nicolas Mailhot
Modified: 2009-09-06 13:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 13:31:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xkbcomp output (62.83 KB, text/plain)
2009-07-07 02:07 EDT, Nicolas Mailhot
no flags Details
xkbcomp.err.txt (56.78 KB, text/plain)
2009-07-08 03:56 EDT, birger
no flags Details
xkbcomp.ok.txt (56.68 KB, text/plain)
2009-07-08 03:57 EDT, birger
no flags Details
Output of 'xkbcomp -xkb :0' (56.90 KB, text/plain)
2009-07-10 08:00 EDT, Joachim Frieben
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 19602 None None None Never

  None (edit)
Description Nicolas Mailhot 2009-06-27 04:04:30 EDT
My keyboard layout, as many others, relies heavily on iso-level-3 working

In rawhide it does not work anymore in terminals and other apps (it does seem to work in xev but nowhere else)

KeyPress event, serial 30, synthetic NO, window 0x7800001,
    root 0x114, subw 0x0, time 840925, (97,64), root:(109,162),
    state 0x10, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

$ rpm -qa xorg*
xorg-x11-resutils-00:7.1-7.fc11.x86_64
xorg-x11-fonts-ISO8859-2-100dpi-00:7.2-8.fc11.noarch
xorg-x11-drv-void-00:1.2.0-2.fc12.x86_64
xorg-x11-drv-ati-00:6.12.2-19.fc12.x86_64
xorg-x11-drv-vesa-00:2.2.0-3.fc11.x86_64
xorg-x11-xsm-00:1.0.2-9.fc11.x86_64
xorg-x11-drv-nouveau-1:0.0.12-36.20090514git9656762.fc11.x86_64
xorg-x11-fonts-ISO8859-1-100dpi-00:7.2-8.fc11.noarch
xorg-x11-xinit-00:1.0.9-11.fc12.x86_64
xorg-x11-apps-00:7.3-10.fc12.x86_64
xorg-x11-fonts-100dpi-00:7.2-8.fc11.noarch
xorg-x11-filesystem-00:7.3-4.fc11.noarch
xorg-x11-util-macros-00:1.2.1-3.fc12.noarch
xorg-x11-drv-ivtv-00:1.1.0-1.fc12.x86_64
xorg-x11-drv-v4l-00:0.2.0-2.fc11.x86_64
xorg-x11-xfs-utils-1:1.0.5-5.fc11.x86_64
xorg-x11-xkb-utils-00:7.2-8.fc11.x86_64
xorg-x11-fonts-ISO8859-15-100dpi-00:7.2-8.fc11.noarch
xorg-x11-drv-vmmouse-00:12.6.4-1.fc12.x86_64
xorg-x11-fonts-misc-00:7.2-8.fc11.noarch
xorg-x11-server-common-00:1.6.99-6.20090618.fc12.x86_64
xorg-x11-fonts-ISO8859-14-100dpi-00:7.2-8.fc11.noarch
xorg-x11-proto-devel-00:7.4-17.fc12.noarch
xorg-x11-server-Xorg-00:1.6.99-6.20090618.fc12.x86_64
xorg-x11-fonts-ISO8859-9-100dpi-00:7.2-8.fc11.noarch
xorg-x11-font-utils-1:7.2-7.fc11.x86_64
xorg-x11-xauth-1:1.0.2-6.fc11.x86_64
xorg-x11-drv-fbdev-00:0.4.0-5.fc12.x86_64
xorg-x11-drv-evdev-00:2.2.99-2.20090619.fc12.x86_64
xorg-x11-utils-00:7.4-4.fc11.x86_64
xorg-x11-xdm-1:1.1.6-10.fc12.x86_64
xorg-x11-server-utils-00:7.4-7.fc11.x86_64
xorg-x11-server-devel-00:1.6.99-6.20090618.fc12.x86_64

(unsorted because I can't type pipes anymore)
Comment 1 Christoph Höger 2009-06-27 08:52:42 EDT
I have the very same issue under f11 with those versions:

xorg-x11-drv-mouse-1.4.0-2.fc11.i586
xorg-x11-drv-voodoo-1.2.1-2.fc11.i586
xorg-x11-drv-openchrome-0.2.903-10.fc11.i586
xorg-x11-drv-void-1.2.0-1.fc11.i586
xorg-x11-drv-cirrus-1.2.0-6.fc11.i586
xorg-x11-drv-nouveau-0.0.12-36.20090514git9656762.fc11.i586
xorg-x11-drv-r128-6.8.0-3.fc11.i586
xorg-x11-drv-acecad-1.3.0-1.fc11.i586
xorg-x11-proto-devel-7.4-14.fc11.noarch
xorg-x11-drv-nv-2.1.13-1.fc11.i586
xorg-x11-server-utils-7.4-7.fc11.i586
xorg-x11-twm-1.0.3-4.fc11.i586
xorg-x11-drv-elographics-1.2.3-2.fc11.i586
xorg-x11-drv-intel-2.7.0-7.fc11.i586
xorg-x11-fonts-ISO8859-1-100dpi-7.2-8.fc11.noarch
xorg-x11-drv-sis-0.10.1-2.fc11.i586
xorg-x11-drv-s3virge-1.10.2-2.fc11.i586
xorg-x11-xauth-1.0.2-6.fc11.i586
xorg-x11-drv-ast-0.87.0-2.fc11.i586
xorg-x11-drv-geode-2.11.2-1.fc11.i586
xorg-x11-apps-7.3-8.fc11.i586
xorg-x11-font-utils-7.2-7.fc11.i586
xorg-x11-drv-sisusb-0.9.1-2.fc11.i586
xorg-x11-drv-dummy-0.3.1-2.fc11.i586
xorg-x11-xinit-1.0.9-7.fc11.i586
xorg-x11-fonts-ISO8859-1-75dpi-7.2-8.fc11.noarch
xorg-x11-xinit-session-1.0.9-7.fc11.i586
xorg-x11-filesystem-7.3-4.fc11.noarch
xorg-x11-drv-synaptics-1.1.0-7.fc11.i586
xorg-x11-drv-i128-1.3.0-2.fc11.i586
xorg-x11-drv-fbdev-0.4.0-4.fc11.i586
xorg-x11-xkb-utils-7.2-8.fc11.i586
xorg-x11-drv-glint-1.2.2-2.fc11.i586
xorg-x11-drv-mga-1.4.10-1.fc11.i586
xorg-x11-fonts-ISO8859-9-100dpi-7.2-8.fc11.noarch
xorg-x11-utils-7.4-4.fc11.i586
xorg-x11-drv-vmware-10.16.0-3.fc11.i586
xorg-x11-drv-aiptek-1.2.0-1.fc11.i586
xorg-x11-server-common-1.6.1.901-1.fc11.i586
xorg-x11-drv-keyboard-1.3.2-3.fc11.i586
xorg-x11-drv-trident-1.3.1-2.fc11.i586
xorg-x11-drv-v4l-0.2.0-2.fc11.i586
xorg-x11-drv-vmmouse-12.6.4-1.fc11.i586
xorg-x11-fonts-misc-7.2-8.fc11.noarch
xorg-x11-drv-tdfx-1.4.1-2.fc11.i586
xorg-x11-drv-vesa-2.2.0-3.fc11.i586
xorg-x11-drv-savage-2.2.1-1.fc11.i586
xorg-x11-drv-fpit-1.3.0-2.fc11.i586
xorg-x11-drv-apm-1.2.1-2.fc11.i586
xorg-x11-drv-mach64-6.8.0-3.fc11.i586
xorg-x11-drv-evdev-2.2.1-3.fc11.i586
xorg-x11-drv-siliconmotion-1.7.0-1.fc11.i586
xorg-x11-drv-penmount-1.4.0-2.fc11.i586
xorg-x11-drv-hyperpen-1.3.0-1.fc11.i586
xorg-x11-drivers-7.3-11.fc11.i586
xorg-x11-fonts-100dpi-7.2-8.fc11.noarch
xorg-x11-drv-i740-1.2.0-3.fc11.i586
xorg-x11-drv-ati-6.12.2-14.fc11.i586
xorg-x11-drv-mutouch-1.2.1-2.fc11.i586
xorg-x11-drv-neomagic-1.2.2-2.fc11.i586
xorg-x11-xdm-1.1.6-9.fc11.i586
xorg-x11-drv-rendition-4.2.1-2.fc11.i586
xorg-x11-fonts-Type1-7.2-8.fc11.noarch
xorg-x11-server-Xorg-1.6.1.901-1.fc11.i586

Please note that the key itself is recognized, but stringlookup seems to be messed up:

KeyPress event, serial 27, synthetic NO, window 0x4a00001,
    root 0xfd, subw 0x0, time 134448888, (250,43), root:(259,154),
    state 0x2010, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 30, synthetic NO, window 0x4a00001,
    root 0xfd, subw 0x0, time 134450479, (250,43), root:(259,154),
    state 0x2090, keycode 24 (keysym 0x71, q), same_screen YES,
    XLookupString gives 1 bytes: (71) "q"
    XmbLookupString gives 1 bytes: (71) "q"
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x4a00001,
    root 0xfd, subw 0x0, time 134450590, (250,43), root:(259,154),
    state 0x2090, keycode 24 (keysym 0x71, q), same_screen YES,
    XLookupString gives 1 bytes: (71) "q"
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x4a00001,
    root 0xfd, subw 0x0, time 134450709, (250,43), root:(259,154),
    state 0x2090, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 30, synthetic NO, window 0x4a00001,
    root 0xfd, subw 0x0, time 134451555, (250,43), root:(259,154),
    state 0x2010, keycode 24 (keysym 0x71, q), same_screen YES,
    XLookupString gives 1 bytes: (71) "q"
    XmbLookupString gives 1 bytes: (71) "q"
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x4a00001,
    root 0xfd, subw 0x0, time 134451626, (250,43), root:(259,154),
    state 0x2010, keycode 24 (keysym 0x71, q), same_screen YES,
    XLookupString gives 1 bytes: (71) "q"
    XFilterEvent returns: False



(That was, as expected pressing Alt-Gr+q once and then q)
The problem occured after a while and I guess restarting X will fix it, I'll test that and report back if not.
(Setting priority to high, since this also affects a stable version)
Comment 2 Matěj Cepl 2009-07-01 17:44:55 EDT
*** Bug 509163 has been marked as a duplicate of this bug. ***
Comment 3 Matěj Cepl 2009-07-03 14:10:57 EDT
*** Bug 509578 has been marked as a duplicate of this bug. ***
Comment 4 Matěj Cepl 2009-07-05 21:08:16 EDT
*** Bug 509717 has been marked as a duplicate of this bug. ***
Comment 5 Matěj Cepl 2009-07-06 19:12:01 EDT
Anybody who is able to reproduce this bug, could we get version of your xkeyboard-config package, please?
Comment 6 Matěj Cepl 2009-07-06 19:18:28 EDT
Sorry, and could we get output of

xkbcomp -xkb :0 -

as well, please?
Comment 7 Peter Hutterer 2009-07-06 19:28:29 EDT
does this happen on login or after a while?
does running 'setxkbmap -layout de' fix it? (or the layout you use?)
Comment 8 Nicolas Mailhot 2009-07-07 02:07:00 EDT
1. $ rpm -q xkeyboard-config
xkeyboard-config-0:1.6-1.fc12.noarch

2. it happens on login

3. setxkbmap -layout fr
"fixes" it but it's been a long time I didn't use this layout (I use fr(oss) + ru + several xkb options the latest in date being the iwantzap one)
Comment 9 Nicolas Mailhot 2009-07-07 02:07:56 EDT
Created attachment 350734 [details]
xkbcomp output
Comment 10 Ola Thoresen 2009-07-07 03:15:51 EDT
1) xkeyboard-config-1.6-1.fc12.noarch

2) At login

3) "setxkbmap -layout no" fixes the problem.

Do you want xkbcomp from me as well?
Comment 11 birger 2009-07-08 03:54:27 EDT
xkeyboard-config-1.6-1.fc12.noarch

setxkbmap -layout no
seems to fix it.

Uploading output of xkbcomp before (xkbcomp.err.txt) and after (xkbcomp.ok.txt) running the setxkbmap command.
Comment 12 birger 2009-07-08 03:56:11 EDT
Created attachment 350900 [details]
xkbcomp.err.txt

output of xkbcomp before running setxkbmap
Comment 13 birger 2009-07-08 03:57:06 EDT
Created attachment 350901 [details]
xkbcomp.ok.txt

xkbcomp output after running setxkbmap
Comment 14 Horst H. von Brand 2009-07-08 15:25:12 EDT
(In reply to comment #5)
> Anybody who is able to reproduce this bug, could we get version of your
> xkeyboard-config package, please?  

xkeyboard-config-1.6-1.fc12.noarch here, layout is Spanish. AltGr doesn't work, ever.

"# setxkbmap -layout es" fixes the mess here.
Comment 15 Peter Hutterer 2009-07-09 23:55:28 EDT
Adding reference to freedesktop bug 19602.
Comment 16 Joachim Frieben 2009-07-10 08:00:02 EDT
Created attachment 351250 [details]
Output of 'xkbcomp -xkb :0'

- same issue here: evdev managed keyboard; GDM keyboard setting is German
  w/o dead keys. Upon logging in, key Alt-Gr is disabled.
- xkeyboard-config-1.6-1.fc12
- xorg-x11-drv-evdev-2.2.99-3.20090629.fc12
- 'setxkbmap -layout de ; setxkbmap -variant nodeadkeys' fixes the issue.
Comment 17 Peter Hutterer 2009-07-11 03:42:17 EDT
the patches that cause the issues have been found and reverted, so the next server update will fix it. Unfortunately that update also needs video drivers to be updated first so we didn't push it yet.

Until the update is available, run setxkbmap -layout "<layout>" after login to get the working layout.
Comment 18 birger 2009-07-11 13:58:47 EDT
I actually have to type it in quite often while working. Not sure what triggers the reset, or if it is timed in some way. I just know I often find the layout has reverted, and I have to re-issue the setxkbmap command.
Comment 19 Adam Williamson 2009-07-17 14:48:30 EDT
This bug is in MODIFIED tate; if someone could confirm whether or not it's fixed in current Rawhide, that would be appreciated.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Peter Hutterer 2009-07-17 21:33:38 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=114546

is the latest build that includes the reverted patches.

Note You need to log in before you can comment on or make changes to this bug.