Bug 512090 - Totem and PA volume managers use different volume scales
Summary: Totem and PA volume managers use different volume scales
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: totem
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 514074 516038 523782 524142 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-16 09:55 UTC by Tomasz Chrzczonowicz
Modified: 2009-11-13 02:29 UTC (History)
21 users (show)

Fixed In Version: 0.10.25-2.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 518382 524142 (view as bug list)
Environment:
Last Closed: 2009-11-13 02:29:06 UTC
Type: ---


Attachments (Terms of Use)

Description Tomasz Chrzczonowicz 2009-07-16 09:55:37 UTC
Description of problem:

Totem volume slider has weird behaviour. When sound is adjusted from 0% to 2%, the Totem volume in Pulse Audio mixers is shown (and heard) as over 50%.

Version-Release number of selected component (if applicable):

totem.i586                        2.26.2-1.fc11                        installed

pulseaudio.i586                         0.9.15-14.fc11        installed         
pulseaudio-debuginfo.i586               0.9.15-14.fc11        @updates-debuginfo
pulseaudio-esound-compat.i586           0.9.15-14.fc11        installed         
pulseaudio-libs.i586                    0.9.15-14.fc11        installed         
pulseaudio-libs-glib2.i586              0.9.15-14.fc11        installed         
pulseaudio-libs-zeroconf.i586           0.9.15-14.fc11        @updates          
pulseaudio-module-bluetooth.i586        0.9.15-14.fc11        installed         
pulseaudio-module-gconf.i586            0.9.15-14.fc11        installed         
pulseaudio-module-jack.i586             0.9.15-14.fc11        @updates          
pulseaudio-module-x11.i586              0.9.15-14.fc11        installed         
pulseaudio-utils.i586                   0.9.15-14.fc11        installed         


Expected results:

Volume level inside Totem equal to volume level of Totem in Pulse Audio mixers.

Additional info:

I made a screen recording to better illustrate the problem. Bear in mind it has no sound (that's a different issue), but that shouldn't be relevant in this case.

http://fedorapeople.org/~tch/pa-totem-slider.ogv

Comment 1 Tomasz Chrzczonowicz 2009-07-16 14:52:24 UTC
Rhythmbox seems to have exactly the same problems. Other sound apps (Miro, Exaile), seem unaffected.

Version:

rhythmbox.i586                      0.12.1-3.fc11

screen recording:

http://fedorapeople.org/~tch/pa-rhythmbox-slider.ogv

Since only those two apps seem to have such problems, it might have something to do with http://fedoraproject.org/wiki/Features/VolumeControl#Scope 

#  Media apps (totem, rhythmbox,...) should use the gstreamer playbin2 element to get per-stream volume support for their private volume controls, or use pulsesink directly to modify the stream volume, rather than the internal volume element. DONE (for Rhythmbox and Totem)

Comment 2 Bastien Nocera 2009-07-16 15:02:24 UTC
1) gstreamer-plugins-pulse is obsolete
2) Totem in F11 doesn't use playbin2, but sets the volume itself (which is probably broken)
3) You're 2 versions behind in your Rhythmbox installation, 0.12.3 was pushed to updates-testing last week

Finally, I believe this is a dupe of so many other Totem volume bugs already filed. Reassigning to Totem, file a separate bug for Rhythmbox if this still happens (though I'd wait for the latest gstreamer and gstreamer-plugins-base pre-release to be available before testing).

Comment 3 sawrub 2009-07-22 13:26:58 UTC
Facing similar problem, when trying to change the sound from rhythmbox sound control applet,the sound increases on single mouse click.
Case :
Volume control was at 3%,on the single click it shoots up to 25% and shows the slider,raised to 25%.Which per my thought should have stayed at 3% only,and then provided the option to inc/dec.

Comment 4 sawrub 2009-07-22 13:30:35 UTC
Presently controlling the sound using middle mouse scroll.

Comment 5 Matthias Saou 2009-07-23 18:41:25 UTC
(In reply to comment #2)
> 2) Totem in F11 doesn't use playbin2, but sets the volume itself (which is
> probably broken)

Speaking of playbin2... I can't seem to find it in Fedora, the gstreamer-plugins-base package just doesn't include it. Normal? Weird? Bug?

Comment 6 Matthias Saou 2009-07-23 18:51:09 UTC
Please ignore my previous comment. I was looking for a separate *.so file, but it seems that unlike decodebin/decodebin2, playbin2 isn't in a separate file. What confused me is that on my Fedora 10, a simple "gst-launch -v playbin2 uri=file:///foo/file.mkv" doesn't work, while it works fine with playbin.

Sorry for the noise.

Comment 7 joshua 2009-07-31 04:42:53 UTC
Having the same issues here.  Please fix!

Comment 8 Francois Aucamp 2009-07-31 11:47:14 UTC
(In reply to comment #1)
> Rhythmbox seems to have exactly the same problems.

I also experience this issue with Rhythmbox, with the added effect of the volume dropping by about 10%-15% on each track change (both the "Rhythbox Music Player"-specific volume and the main pulseaudio volume according to the sound preference dialog). It seems somehow randomly re-initialize the volume every time a new track is started?

# rpm -q rhythmbox
rhythmbox-0.12.3-1.fc11.x86_64

Comment 9 Bastien Nocera 2009-08-03 13:45:50 UTC
*** Bug 514074 has been marked as a duplicate of this bug. ***

Comment 10 Bastien Nocera 2009-08-07 09:11:23 UTC
*** Bug 516038 has been marked as a duplicate of this bug. ***

Comment 11 Peter Janakiev 2009-08-13 15:10:32 UTC
Same here with rhythmbox - every time i select next song drops the sound volume until it reaches 0. temporary workaround would be to enable cross fade (works here).

Comment 12 Francois Aucamp 2009-08-13 15:12:47 UTC
(In reply to comment #11)
> Same here with rhythmbox - every time i select next song drops the sound volume
> until it reaches 0. temporary workaround would be to enable cross fade (works
> here).  

Downgrading to rhythmbox-0.12.1-3.fc11.x86_64 also works around it (without enabling crossfading).

Comment 13 Fedora Update System 2009-08-19 11:26:55 UTC
totem-2.26.3-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/totem-2.26.3-3.fc11

Comment 14 Fedora Update System 2009-08-19 23:16:11 UTC
totem-2.26.3-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update totem'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8758

Comment 15 Tomasz Chrzczonowicz 2009-08-20 07:20:46 UTC
(In reply to comment #8)
> with the added effect of the
> volume dropping by about 10%-15% on each track change (both the "Rhythbox Music
> Player"-specific volume and the main pulseaudio volume according to the sound
> preference dialog). It seems somehow randomly re-initialize the volume every
> time a new track is started?
> 
> # rpm -q rhythmbox
> rhythmbox-0.12.3-1.fc11.x86_64  

(In reply to comment #11)
> Same here with rhythmbox - every time i select next song drops the sound volume
> until it reaches 0. temporary workaround would be to enable cross fade (works
> here).  

That's a different issue and I believe that it already has has bugs filed for it. Please don't add to the confusion. This bug is about something entirely different.

Comment 16 Bruce Brackbill 2009-08-20 07:37:04 UTC
"When sound is adjusted from 0% to 2%, the Totem volume in Pulse Audio mixers is shown (and heard) as over 50%."

Does not fix this for me.

Comment 17 Claudio Viano 2009-08-24 08:48:13 UTC
Totem and Rhythmbox volume sliders affect not only their own sliders in the PA mixer, but also the main volume slider, pushing it up exponentially. In my opinion the main volume slider should be unaffected by changing the volume of a single app. On a desktop with powerful speakers, ending up with the general volume at 99% unknowingly is really not desirable.

Every other multimedia app do not affect the main volume slider, only Totem (2.26.3-3 included) and Rhythmbox do.

Comment 18 Tomasz Chrzczonowicz 2009-08-24 11:39:14 UTC
> Totem and Rhythmbox volume sliders affect not only their own sliders in the PA
> mixer, but also the main volume slider

This is intended. It's called flat volumes. I agree that this feature makes this bug much more annoying, but this is out of the scope of this bug report.

Please stay on topic. Most other things you report here have separate bugs reports opened for them already.

I cloned this bug report for Rhythmbox: bug 518382

Comment 19 Fedora Update System 2009-09-04 04:10:37 UTC
totem-2.26.3-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Tomasz Chrzczonowicz 2009-09-04 14:40:23 UTC
This bug is not fixed by the update.

https://bugzilla.redhat.com/show_bug.cgi?id=512090#c0

Comment 21 Michael Cronenworth 2009-09-08 07:34:50 UTC
This bug is the same as 518382 and is with gstreamer. Totem and rhythmbox both use gstreamer for file input and audio output. This bug should be reassigned or closed as 518382 was.

Upstream: http://bugzilla.gnome.org/show_bug.cgi?id=571610

If you wish to turn off flat-volumes (which I recommend, why are we trying to copy Windows 1:1??) you can edit your /etc/pulse/daemon.conf file for "flat-volumes" and restart your session.

Comment 22 Fedora Update System 2009-09-15 13:01:13 UTC
totem-2.26.3-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/totem-2.26.3-5.fc11

Comment 23 Michael Monreal 2009-09-15 16:42:43 UTC
(In reply to comment #22)
> totem-2.26.3-5.fc11 has been submitted as an update for Fedora 11.
> http://admin.fedoraproject.org/updates/totem-2.26.3-5.fc11  

And again, it does not fix this bug.

Comment 24 Bastien Nocera 2009-09-15 17:09:07 UTC
Make sure you have:
- the latest gnome-media
- the latest gnome-settings-daemon
and that your bug isn't the small smidgins of lowering the volume seen in:
https://bugzilla.gnome.org/show_bug.cgi?id=595231

Comment 25 Michael Monreal 2009-09-15 17:21:31 UTC
I have whatever latest gnome-media and gnome-settings-daemon the f11 update channel provides me with.

I have seen the volume lowering thing but that's not the issue here. My issue (which I think is what the original reporter wanted to express):

- turn every volume up to 100
- slowly mouse-wheel down on the totem volume control and look at gnome-volume-control at the same time
- when totem is at 2%, gnome-volume-control shows about 65%
- if you decrease any further (in totem), the volume in gnome-volume-control jumps right to 0

Comment 26 Bastien Nocera 2009-09-15 18:04:36 UTC
That's nothing I can do about for now. See:
https://bugzilla.gnome.org/show_bug.cgi?id=571610
and
https://bugzilla.gnome.org/show_bug.cgi?id=595304

Comment 27 Michael Monreal 2009-09-15 18:22:30 UTC
Just to be clear: totem needs to use new (unreleased) gst api to fix this? Will this be happen in time for F12?

Comment 28 Fedora Update System 2009-09-15 21:00:06 UTC
totem-2.26.3-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update totem'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9636

Comment 29 Bastien Nocera 2009-09-17 08:57:35 UTC
*** Bug 523782 has been marked as a duplicate of this bug. ***

Comment 30 Tomasz Chrzczonowicz 2009-09-18 04:56:05 UTC
I've seen Audio Test Day bug is marked as duplicate of this one. I'll clone this bug and assign it to rawhide.

Comment 31 James 2009-09-18 08:25:57 UTC
(In reply to comment #27)
> Just to be clear: totem needs to use new (unreleased) gst api to fix this? Will
> this be happen in time for F12?  

Moreover, will the fixes show up in F11, or will we just have to put up with the breakage?

Comment 32 Michael Cronenworth 2009-09-18 17:08:10 UTC
(In reply to comment #31)
> 
> Moreover, will the fixes show up in F11, or will we just have to put up with
> the breakage?  

This breakage came from an F11/PulseAudio "feature" called Flat Volumes. You can disable it in the global Pulse config or create a local config. Imitating Vista was a top priority in F11. After it's disabled you should see normality come back to your volume changing. Sure, totem won't adjust global volume any more, but you won't see the logarithmic volume change you see now and who wants global volume changes anyway?

Comment 33 Tomasz Chrzczonowicz 2009-09-18 17:20:20 UTC
Man, please stop ranting offtopic. Not only you're not helping, you're diluting the thread even further than it is already.

This bug is not about flat volumes. It's about mapping Totem volume level/slider in the actual app to the volume level/slider in it's counterpart in Pulse Audio mixers.

Flat volumes make it worse, but they're not what this bug is about. Disabling flat volumes _won't_ fix this bug.

Really, people, please actually _read_ before you comment.

Comment 34 Lennart Poettering 2009-09-18 21:01:51 UTC
(In reply to comment #32)
> (In reply to comment #31)
> > 
> > Moreover, will the fixes show up in F11, or will we just have to put up with
> > the breakage?  
> 
> This breakage came from an F11/PulseAudio "feature" called Flat Volumes. You
> can disable it in the global Pulse config or create a local config. Imitating
> Vista was a top priority in F11. After it's disabled you should see normality
> come back to your volume changing. Sure, totem won't adjust global volume any
> more, but you won't see the logarithmic volume change you see now and who wants
> global volume changes anyway?  

This is utter nonsense. Flat volumes have nothing to do with the mapping used between volume factors and pixels on screen. Please, just go away and troll and fud at some other place, will you?

Comment 35 Fedora Update System 2009-10-03 19:11:37 UTC
totem-2.26.3-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 36 Tomasz Chrzczonowicz 2009-10-04 17:48:51 UTC
This update didn't fix it. If anything, it seems to have made it even worse.

Comment 37 Bastien Nocera 2009-10-05 12:23:40 UTC
*** Bug 524142 has been marked as a duplicate of this bug. ***

Comment 38 Alexey Kuznetsov 2009-10-05 12:43:31 UTC
Flat volumes should be an option, specified for each sound application. For me: i will disable it immediately, after this option will be available.

You can't control sound by several sound streams because each application can be more complex then just one sound line. Firefox can have flash plugin which allow to play different multimedia streams, including radio, different video sites and more. Each source can have self own default volume, optimal for site owner.

Wine, can run huge spectrum wide of application, each with individual steam volume..

In my opinion flat volumes is evil, and at least should be an option in PA configure dialog. (i should abble to choise which appliation controlled by flat volumes, which should have gloval volume control. something like volume groups)

Comment 39 Bastien Nocera 2009-10-05 12:46:06 UTC
(In reply to comment #38)
> Flat volumes should be an option, specified for each sound application. For me:
> i will disable it immediately, after this option will be available.

Can you not read? This has nothing to do with flat-volumes. Comment #33 and #34.

Comment 40 Fedora Update System 2009-10-27 06:39:59 UTC
gstreamer-plugins-good-0.10.16-4.fc11, totem-2.26.4-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer-plugins-good totem'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10747

Comment 41 Fedora Update System 2009-10-29 02:55:24 UTC
gstreamer-plugins-base-0.10.25-2.fc11, gstreamer-plugins-good-0.10.16-4.fc11, totem-2.26.4-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer-plugins-base gstreamer-plugins-good totem'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10747

Comment 42 Michael Monreal 2009-10-29 18:40:38 UTC
I *think* this is still not working correctly on F11, but honestly all the talk has confused me and I don't really know how it is supposed to work...

- on F11, with the latest gstreamer-* packages from koji, the volume control in Totem does *not* match Totem's entry in the volume mixer's "Application" tab

- on current F12, Totem's volume matches the Totem entry in the mixer.

Can someone confirm the F12 behaviour is in fact the correct one?

Comment 43 Bastien Nocera 2009-10-29 19:13:00 UTC
(In reply to comment #42)
> I *think* this is still not working correctly on F11, but honestly all the talk
> has confused me and I don't really know how it is supposed to work...
> 
> - on F11, with the latest gstreamer-* packages from koji, the volume control in
> Totem does *not* match Totem's entry in the volume mixer's "Application" tab

As you're not saying which versions of the packages you're using, I can't tell whether you're seeing a bug or simply the old behaviour. The versions that work are the ones listed in comment 41, and it just won't work correctly if you have any of those missing.

> - on current F12, Totem's volume matches the Totem entry in the mixer.
> 
> Can someone confirm the F12 behaviour is in fact the correct one?

Comment 44 Michael Monreal 2009-10-29 20:46:44 UTC
(In reply to comment #43)
> As you're not saying which versions of the packages you're using, I can't tell
> whether you're seeing a bug or simply the old behaviour. The versions that work
> are the ones listed in comment 41

Sorry my bad, I had not noticed the totem update. I am all up to date now (double checked that I have the versions from comment #41), rebooted, and this is what I get:

- set output volume to 100%
- start a song in totem, set totem's volume to 100% too
- now I lower the global volume by mousewheeling down on the sound tray icon until it says 50%
- from my understanding, with flat volumes, totem's application volume should now also be 50%
=> in gnome-volume-control this is true
=> in totem, volume shows as 18%
=> the sound I hear is certainly more 18% than 50%

Comment 45 Bastien Nocera 2009-10-29 22:46:40 UTC
(In reply to comment #44)
> (In reply to comment #43)
> > As you're not saying which versions of the packages you're using, I can't tell
> > whether you're seeing a bug or simply the old behaviour. The versions that work
> > are the ones listed in comment 41
> 
> Sorry my bad, I had not noticed the totem update. I am all up to date now
> (double checked that I have the versions from comment #41), rebooted, and this
> is what I get:
> 
> - set output volume to 100%
> - start a song in totem, set totem's volume to 100% too
> - now I lower the global volume by mousewheeling down on the sound tray icon
> until it says 50%
> - from my understanding, with flat volumes, totem's application volume should
> now also be 50%
> => in gnome-volume-control this is true
> => in totem, volume shows as 18%
> => the sound I hear is certainly more 18% than 50%  

The question is:
- Does the 18% volume match what's shown in gnome-volume-control's Applications tab, or in pavucontrol?

If it does, I don't really care about any more percentage fiddling, and you should file a bug against PulseAudio about it not matching your expectations of what the volume should be.

Comment 46 Michael Monreal 2009-10-30 08:17:09 UTC
(In reply to comment #45)
> The question is:
> - Does the 18% volume match what's shown in gnome-volume-control's Applications
> tab

No, as I said, gnome-volume-control's application tab shows totem with 50% and that does not match Totem's 18%. Also, if I set the global volume to anything lower than 100%, Totem's entry in the application tab seems to "scale" correctly (but the volume in Totem itself does not).

This is different to how it works in F12, which I assume is the correct bahaviour.

Comment 47 Fedora Update System 2009-11-03 16:26:10 UTC
gstreamer-plugins-base-0.10.25-2.fc11,totem-2.26.4-2.fc11,gstreamer-plugins-good-0.10.16-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gstreamer-plugins-base-0.10.25-2.fc11,totem-2.26.4-2.fc11,gstreamer-plugins-good-0.10.16-4.fc11

Comment 48 Fedora Update System 2009-11-04 12:14:27 UTC
gstreamer-plugins-base-0.10.25-2.fc11, totem-2.26.4-2.fc11, gstreamer-plugins-good-0.10.16-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer-plugins-base totem gstreamer-plugins-good'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10937

Comment 49 Fedora Update System 2009-11-13 02:28:49 UTC
gstreamer-plugins-base-0.10.25-2.fc11, totem-2.26.4-2.fc11, gstreamer-plugins-good-0.10.16-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.