Bug 524142 - Totem and PA volume managers use different volume scales
Totem and PA volume managers use different volume scales
Status: CLOSED DUPLICATE of bug 512090
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-09-18 00:59 EDT by Tomasz Chrzczonowicz
Modified: 2009-10-05 08:23 EDT (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 512090
Environment:
Last Closed: 2009-10-05 08:23:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomasz Chrzczonowicz 2009-09-18 00:59:03 EDT
+++ This bug was initially created as a clone of Bug #512090 +++

Description of problem:

Totem volume slider has weird behaviour. When sound is adjusted from 0% to 2%, the Totem volume in Pulse Audio mixers is shown (and heard) as over 50%.

Version-Release number of selected component (if applicable):

totem.i586                        2.26.2-1.fc11                        installed

pulseaudio.i586                         0.9.15-14.fc11        installed         
pulseaudio-debuginfo.i586               0.9.15-14.fc11        @updates-debuginfo
pulseaudio-esound-compat.i586           0.9.15-14.fc11        installed         
pulseaudio-libs.i586                    0.9.15-14.fc11        installed         
pulseaudio-libs-glib2.i586              0.9.15-14.fc11        installed         
pulseaudio-libs-zeroconf.i586           0.9.15-14.fc11        @updates          
pulseaudio-module-bluetooth.i586        0.9.15-14.fc11        installed         
pulseaudio-module-gconf.i586            0.9.15-14.fc11        installed         
pulseaudio-module-jack.i586             0.9.15-14.fc11        @updates          
pulseaudio-module-x11.i586              0.9.15-14.fc11        installed         
pulseaudio-utils.i586                   0.9.15-14.fc11        installed         


Expected results:

Volume level inside Totem equal to volume level of Totem in Pulse Audio mixers.

Additional info:

I made a screen recording to better illustrate the problem. Bear in mind it has no sound (that's a different issue), but that shouldn't be relevant in this case.

http://fedorapeople.org/~tch/pa-totem-slider.ogv

--- Additional comment from chrzczonowicz@gmail.com on 2009-07-16 10:52:24 EDT ---

Rhythmbox seems to have exactly the same problems. Other sound apps (Miro, Exaile), seem unaffected.

Version:

rhythmbox.i586                      0.12.1-3.fc11

screen recording:

http://fedorapeople.org/~tch/pa-rhythmbox-slider.ogv

Since only those two apps seem to have such problems, it might have something to do with http://fedoraproject.org/wiki/Features/VolumeControl#Scope 

#  Media apps (totem, rhythmbox,...) should use the gstreamer playbin2 element to get per-stream volume support for their private volume controls, or use pulsesink directly to modify the stream volume, rather than the internal volume element. DONE (for Rhythmbox and Totem)

--- Additional comment from bnocera@redhat.com on 2009-07-16 11:02:24 EDT ---

1) gstreamer-plugins-pulse is obsolete
2) Totem in F11 doesn't use playbin2, but sets the volume itself (which is probably broken)
3) You're 2 versions behind in your Rhythmbox installation, 0.12.3 was pushed to updates-testing last week

Finally, I believe this is a dupe of so many other Totem volume bugs already filed. Reassigning to Totem, file a separate bug for Rhythmbox if this still happens (though I'd wait for the latest gstreamer and gstreamer-plugins-base pre-release to be available before testing).

--- Additional comment from sawrub@fedoraproject.org on 2009-07-22 09:26:58 EDT ---

Facing similar problem, when trying to change the sound from rhythmbox sound control applet,the sound increases on single mouse click.
Case :
Volume control was at 3%,on the single click it shoots up to 25% and shows the slider,raised to 25%.Which per my thought should have stayed at 3% only,and then provided the option to inc/dec.

--- Additional comment from sawrub@fedoraproject.org on 2009-07-22 09:30:35 EDT ---

Presently controlling the sound using middle mouse scroll.

--- Additional comment from matthias@rpmforge.net on 2009-07-23 14:41:25 EDT ---

(In reply to comment #2)
> 2) Totem in F11 doesn't use playbin2, but sets the volume itself (which is
> probably broken)

Speaking of playbin2... I can't seem to find it in Fedora, the gstreamer-plugins-base package just doesn't include it. Normal? Weird? Bug?

--- Additional comment from matthias@rpmforge.net on 2009-07-23 14:51:09 EDT ---

Please ignore my previous comment. I was looking for a separate *.so file, but it seems that unlike decodebin/decodebin2, playbin2 isn't in a separate file. What confused me is that on my Fedora 10, a simple "gst-launch -v playbin2 uri=file:///foo/file.mkv" doesn't work, while it works fine with playbin.

Sorry for the noise.

--- Additional comment from joshua@joshuajensen.org on 2009-07-31 00:42:53 EDT ---

Having the same issues here.  Please fix!

--- Additional comment from francois.aucamp@gmail.com on 2009-07-31 07:47:14 EDT ---

(In reply to comment #1)
> Rhythmbox seems to have exactly the same problems.

I also experience this issue with Rhythmbox, with the added effect of the volume dropping by about 10%-15% on each track change (both the "Rhythbox Music Player"-specific volume and the main pulseaudio volume according to the sound preference dialog). It seems somehow randomly re-initialize the volume every time a new track is started?

# rpm -q rhythmbox
rhythmbox-0.12.3-1.fc11.x86_64

--- Additional comment from bnocera@redhat.com on 2009-08-03 09:45:50 EDT ---

*** Bug 514074 has been marked as a duplicate of this bug. ***

--- Additional comment from bnocera@redhat.com on 2009-08-07 05:11:23 EDT ---

*** Bug 516038 has been marked as a duplicate of this bug. ***

--- Additional comment from malwkgad@telecoms.bg on 2009-08-13 11:10:32 EDT ---

Same here with rhythmbox - every time i select next song drops the sound volume until it reaches 0. temporary workaround would be to enable cross fade (works here).

--- Additional comment from francois.aucamp@gmail.com on 2009-08-13 11:12:47 EDT ---

(In reply to comment #11)
> Same here with rhythmbox - every time i select next song drops the sound volume
> until it reaches 0. temporary workaround would be to enable cross fade (works
> here).  

Downgrading to rhythmbox-0.12.1-3.fc11.x86_64 also works around it (without enabling crossfading).

--- Additional comment from updates@fedoraproject.org on 2009-08-19 07:26:55 EDT ---

totem-2.26.3-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/totem-2.26.3-3.fc11

--- Additional comment from updates@fedoraproject.org on 2009-08-19 19:16:11 EDT ---

totem-2.26.3-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update totem'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8758

--- Additional comment from chrzczonowicz@gmail.com on 2009-08-20 03:20:46 EDT ---

(In reply to comment #8)
> with the added effect of the
> volume dropping by about 10%-15% on each track change (both the "Rhythbox Music
> Player"-specific volume and the main pulseaudio volume according to the sound
> preference dialog). It seems somehow randomly re-initialize the volume every
> time a new track is started?
> 
> # rpm -q rhythmbox
> rhythmbox-0.12.3-1.fc11.x86_64  

(In reply to comment #11)
> Same here with rhythmbox - every time i select next song drops the sound volume
> until it reaches 0. temporary workaround would be to enable cross fade (works
> here).  

That's a different issue and I believe that it already has has bugs filed for it. Please don't add to the confusion. This bug is about something entirely different.

--- Additional comment from brackbillbruce@hotmail.com on 2009-08-20 03:37:04 EDT ---

"When sound is adjusted from 0% to 2%, the Totem volume in Pulse Audio mixers is shown (and heard) as over 50%."

Does not fix this for me.

--- Additional comment from claudio.viano@gmail.com on 2009-08-24 04:48:13 EDT ---

Totem and Rhythmbox volume sliders affect not only their own sliders in the PA mixer, but also the main volume slider, pushing it up exponentially. In my opinion the main volume slider should be unaffected by changing the volume of a single app. On a desktop with powerful speakers, ending up with the general volume at 99% unknowingly is really not desirable.

Every other multimedia app do not affect the main volume slider, only Totem (2.26.3-3 included) and Rhythmbox do.

--- Additional comment from chrzczonowicz@gmail.com on 2009-08-24 07:39:14 EDT ---

> Totem and Rhythmbox volume sliders affect not only their own sliders in the PA
> mixer, but also the main volume slider

This is intended. It's called flat volumes. I agree that this feature makes this bug much more annoying, but this is out of the scope of this bug report.

Please stay on topic. Most other things you report here have separate bugs reports opened for them already.

I cloned this bug report for Rhythmbox: bug 518382

--- Additional comment from updates@fedoraproject.org on 2009-09-04 00:10:37 EDT ---

totem-2.26.3-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from chrzczonowicz@gmail.com on 2009-09-04 10:40:23 EDT ---

This bug is not fixed by the update.

https://bugzilla.redhat.com/show_bug.cgi?id=512090#c0

--- Additional comment from mike@cchtml.com on 2009-09-08 03:34:50 EDT ---

This bug is the same as 518382 and is with gstreamer. Totem and rhythmbox both use gstreamer for file input and audio output. This bug should be reassigned or closed as 518382 was.

Upstream: http://bugzilla.gnome.org/show_bug.cgi?id=571610

If you wish to turn off flat-volumes (which I recommend, why are we trying to copy Windows 1:1??) you can edit your /etc/pulse/daemon.conf file for "flat-volumes" and restart your session.

--- Additional comment from updates@fedoraproject.org on 2009-09-15 09:01:13 EDT ---

totem-2.26.3-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/totem-2.26.3-5.fc11

--- Additional comment from michael.monreal@gmail.com on 2009-09-15 12:42:43 EDT ---

(In reply to comment #22)
> totem-2.26.3-5.fc11 has been submitted as an update for Fedora 11.
> http://admin.fedoraproject.org/updates/totem-2.26.3-5.fc11  

And again, it does not fix this bug.

--- Additional comment from bnocera@redhat.com on 2009-09-15 13:09:07 EDT ---

Make sure you have:
- the latest gnome-media
- the latest gnome-settings-daemon
and that your bug isn't the small smidgins of lowering the volume seen in:
https://bugzilla.gnome.org/show_bug.cgi?id=595231

--- Additional comment from michael.monreal@gmail.com on 2009-09-15 13:21:31 EDT ---

I have whatever latest gnome-media and gnome-settings-daemon the f11 update channel provides me with.

I have seen the volume lowering thing but that's not the issue here. My issue (which I think is what the original reporter wanted to express):

- turn every volume up to 100
- slowly mouse-wheel down on the totem volume control and look at gnome-volume-control at the same time
- when totem is at 2%, gnome-volume-control shows about 65%
- if you decrease any further (in totem), the volume in gnome-volume-control jumps right to 0

--- Additional comment from bnocera@redhat.com on 2009-09-15 14:04:36 EDT ---

That's nothing I can do about for now. See:
https://bugzilla.gnome.org/show_bug.cgi?id=571610
and
https://bugzilla.gnome.org/show_bug.cgi?id=595304

--- Additional comment from michael.monreal@gmail.com on 2009-09-15 14:22:30 EDT ---

Just to be clear: totem needs to use new (unreleased) gst api to fix this? Will this be happen in time for F12?

--- Additional comment from updates@fedoraproject.org on 2009-09-15 17:00:06 EDT ---

totem-2.26.3-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update totem'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9636

--- Additional comment from bnocera@redhat.com on 2009-09-17 04:57:35 EDT ---

*** Bug 523782 has been marked as a duplicate of this bug. ***

--- Additional comment from chrzczonowicz@gmail.com on 2009-09-18 00:56:05 EDT ---

I've seen Audio Test Day bug is marked as duplicate of this one. I'll clone this bug and assign it to rawhide.
Comment 1 Bastien Nocera 2009-10-05 08:23:40 EDT

*** This bug has been marked as a duplicate of bug 512090 ***

Note You need to log in before you can comment on or make changes to this bug.