Bug 521277 - kernel BUG at drivers/gpu/drm/ttm/ttm_bo.c:133
kernel BUG at drivers/gpu/drm/ttm/ttm_bo.c:133
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 522066 522178 522366 522902 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-09-04 11:57 EDT by Michal Schmidt
Modified: 2009-09-27 10:52 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-27 10:52:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (40.86 KB, text/plain)
2009-09-04 12:03 EDT, Michal Schmidt
no flags Details
Xorg.0.log (36.30 KB, text/plain)
2009-09-04 12:04 EDT, Michal Schmidt
no flags Details
Another view of the crash message: Xpress 200M RC410 on 32-bits (2.46 KB, text/plain)
2009-09-18 10:30 EDT, Alex Villacís Lasso
no flags Details

  None (edit)
Description Michal Schmidt 2009-09-04 11:57:04 EDT
Description of problem:
Starting compiz hangs my laptop. It responds to ICMP pings, but I am unable to ssh in. The laptop is a Toshiba Satellite Pro A210, its graphics chip is:

01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series] (prog-if 00 [VGA controller])

Using netconsole I got this BUG message:

[drm:radeon_object_list_reserve] *ERROR* radeon: failed to reserve object.
[drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation !
------------[ cut here ]------------
kernel BUG at drivers/gpu/drm/ttm/ttm_bo.c:133!
invalid opcode: 0000 [#1] SMP 
last sysfs file: /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
CPU 1 
Modules linked in: netconsole configfs fuse nfsd lockd nfs_acl auth_rpcgss exportfs sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand powernow_k8 freq_table dm_multipath uinput ata_generic snd_hda_codec_realtek pata_acpi snd_hda_intel sdhci_pci arc4 ecb sdhci snd_hda_codec ath5k amd64_edac_mod snd_hwdep snd_pcm mac80211 firewire_ohci snd_timer video ath r8169 firewire_core snd mmc_core output k8temp edac_core crc_itu_t soundcore pata_atiixp i2c_piix4 hwmon mii cfg80211 shpchp snd_page_alloc rfkill joydev xts gf128mul cryptd aes_x86_64 aes_generic dm_crypt radeon ttm drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
Pid: 1558, comm: Xorg Not tainted 2.6.31-0.199.rc8.git2.fc12.x86_64 #1 Satellite Pro A210
RIP: 0010:[<ffffffffa0047fe3>]  [<ffffffffa0047fe3>] ttm_bo_unreserve+0x47/0x109 [ttm]
RSP: 0018:ffff880063d47b88  EFLAGS: 00010246
RAX: 0000000000000000 RBX: ffff880037ac3ea8 RCX: ffffffffa0047fd2
RDX: ffff880037aca418 RSI: ffffffffa0047fd2 RDI: 0000000000000246
RBP: ffff880063d47bb8 R08: ffff880063cbd1e8 R09: 0000000000000000
R10: ffffffff81e182c0 R11: 0000000000000000 R12: ffff880073ce37a8
R13: ffff880063d47c18 R14: ffff880037aca048 R15: ffff8800652e6b68
FS:  00007f982970a7c0(0000) GS:ffff88000286c000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 0000000001915a08 CR3: 0000000037c33000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process Xorg (pid: 1558, threadinfo ffff880063d46000, task ffff880063cbc940)
Stack:
 ffff880063d47c28 00000000a9b58d22 000000000000004b ffff880053080688
<0> ffff880063d47cd8 ffff880063d47c18 ffff880063d47bd8 ffffffffa0077e65
<0> ffff8800652e6bf8 00000000a9b58d22 ffff880063d47c08 ffffffffa0077eb4
Call Trace:
 [<ffffffffa0077e65>] radeon_object_unreserve+0x21/0x37 [radeon]
 [<ffffffffa0077eb4>] radeon_object_list_unreserve+0x39/0x62 [radeon]
 [<ffffffffa0077f8c>] radeon_object_list_unvalidate+0x78/0x97 [radeon]
 [<ffffffffa00851ad>] radeon_cs_parser_fini+0x31/0xfb [radeon]
 [<ffffffffa00858df>] radeon_cs_ioctl+0x179/0x1a6 [radeon]
 [<ffffffffa0085766>] ? radeon_cs_ioctl+0x0/0x1a6 [radeon]
 [<ffffffffa0015b18>] drm_ioctl+0x23d/0x2fd [drm]
 [<ffffffff811435a0>] ? do_sync_read+0xfa/0x14b
 [<ffffffff81152aac>] vfs_ioctl+0x7e/0xaa
 [<ffffffff81153021>] do_vfs_ioctl+0x4aa/0x506
 [<ffffffff811530e2>] sys_ioctl+0x65/0x9c
 [<ffffffff81012f42>] system_call_fastpath+0x16/0x1b
Code: 89 45 d8 31 c0 48 8b 1f 49 89 fc 48 81 c3 00 01 00 00 48 89 df e8 58 ef 4b e1 41 8b 84 24 58 01 00 00 49 8b 54 24 08 85 c0 75 04 <0f> 0b eb fe 41 f6 84 24 02 01 00 00 20 75 6d 49 8b bc 24 20 01 
RIP  [<ffffffffa0047fe3>] ttm_bo_unreserve+0x47/0x109 [ttm]
 RSP <ffff880063d47b88>
---[ end trace c807ae7874996552 ]---

Version-Release number of selected component (if applicable):
kernel-2.6.31-0.199.rc8.git2.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.2.20090821gitb1b77a4d6.fc12.x86_64
xorg-x11-server-Xorg-1.6.99-45.20090903.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1. Use desktop-effects to enable compiz
2. Wait about 2 seconds
  
Actual results:
Compiz starts, its decorations appear, but in a moment the machine locks hard.

Expected results:
No hangs.
Comment 1 Michal Schmidt 2009-09-04 12:03:55 EDT
Created attachment 359825 [details]
dmesg

dmesg taken before starting compiz
Comment 2 Michal Schmidt 2009-09-04 12:04:34 EDT
Created attachment 359826 [details]
Xorg.0.log

Xorg.0.log taken before starting compiz
Comment 3 Michal Schmidt 2009-09-04 12:12:18 EDT
Correction for Steps to Reproduce:
1. Use desktop-effects to enable compiz
2. When the confirmation message window with the countdown appears, grab it and try to move it.
(i.e. just waiting is not enough)
Comment 4 Michal Schmidt 2009-09-08 15:51:13 EDT
I saw some r600+kms updates in the changelogs, so I retested. Unfortunately, the hang is still there.
kernel-2.6.31-0.212.rc9.git1.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.x86_64
xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64
Comment 5 Dave Airlie 2009-09-09 04:26:17 EDT
can you also upgrade mesa to the latest and retry?
Comment 6 Michal Schmidt 2009-09-09 08:23:16 EDT
Still the same with the latest mesa packages from Koji (7.6-0.11.fc12).
Comment 7 Davide Cescato 2009-09-09 08:35:26 EDT
I think I am hit by the same bug, although I can not verify the error messages.

My smolt profile is at
http://www.smolts.org/client/show/pub_69b4cdb1-7200-4eb7-b885-7b617d7418a0

I am using a testday-20090908-x86_64.iso live image (packages as in comment
#4). When I try updating mesa to mesa-7.6-0.11.fc12 and restarting Xorg, the
bug is still there.
Comment 8 Peter Bloomfield 2009-09-09 11:05:31 EDT
I haven't finished the suite, just got as far as failing to switch to compiz in QA:Testcase radeon glx, step 4: Enable compiz.

Laptop is an aging ThinkPad T43 with:

01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
Comment 9 Miroslav Vadkerti 2009-09-09 11:47:33 EDT
The same bug appears after trying to switch to Compiz on ATI Technologies Inc RV380 [Radeon X600 (PCIE)]. Logs not verified although, but machine freezes.
Comment 10 Mike C 2009-09-09 12:52:42 EDT
Same failure for laptop with smolt 
http://www.smolts.org/client/show/pub_cc800c30-ba60-495b-9362-8f8b9102f97d

ATI Technologies Inc M22 [Radeon Mobility M300]
Comment 11 Martin Decky 2009-09-09 16:42:04 EDT
Also seen on ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01) [1002:5960]
Comment 12 Fraud 2009-09-09 18:11:44 EDT
I am using a testday-20090908-x86_64.iso live with a RV570/X1950 Pro.
Same problem following step on #3
Comment 13 Adam Williamson 2009-09-16 13:29:04 EDT
*** Bug 522066 has been marked as a duplicate of this bug. ***
Comment 14 Adam Williamson 2009-09-16 14:17:41 EDT
*** Bug 522178 has been marked as a duplicate of this bug. ***
Comment 15 Adam Williamson 2009-09-16 20:32:52 EDT
*** Bug 522366 has been marked as a duplicate of this bug. ***
Comment 16 Adam Williamson 2009-09-16 20:55:28 EDT
*** Bug 522902 has been marked as a duplicate of this bug. ***
Comment 17 Alex Villacís Lasso 2009-09-17 12:28:04 EDT
Probably same problem for me with Radeon Xpress 200M (RC410):
http://www.smolts.org/show?uuid=pub_c5cf7e5f-ae21-41eb-aa10-4b919a794807
Comment 18 Alex Villacís Lasso 2009-09-17 12:31:44 EDT
I must add that (at least in my case with RC410) the problem seems to arise when moving the mouse pointer. I can leave the mouse pointer still and tab around the compiz confirmation dialog. However, I have not tried moving the dialog around with the keyboard.
Comment 19 Alex Villacís Lasso 2009-09-18 10:30:20 EDT
Created attachment 361669 [details]
Another view of the crash message: Xpress 200M RC410 on 32-bits

The Live CD from http://torrent.fedoraproject.org/torrents//F12-Snap2-i686-Live.torrent also exhibits the same bug. dmesg log attached.
Comment 20 Stefan Becker 2009-09-27 04:36:46 EDT
Retested with

kernel-2.6.31.1-48.fc12.i686
xorg-x11-drv-ati-6.13.0-0.4.20090908git651fe5a47.fc12.i686
libdrm-2.4.14-1.fc12.i686
mesa-libGL-7.6-0.13.fc12.i686

on

Mobility Radeon X1300 [1002:7149]

compiz works OK now.
Comment 21 Michal Schmidt 2009-09-27 10:52:45 EDT
kernel-2.6.31.1-48.fc12.x86_64 works for me too. Compiz works. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.