Bug 521510 - Wrong stacktrace attached. Was: [abrt] crash detected in nspluginwrapper-1.3.0-8.fc12
Summary: Wrong stacktrace attached. Was: [abrt] crash detected in nspluginwrapper-1.3....
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0b936a1a10ac8bb32d068ff1bbe...
: 522967 522982 523191 523328 524082 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-06 15:46 UTC by Mads Kiilerich
Modified: 2018-04-11 10:04 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-08 15:59:44 UTC


Attachments (Terms of Use)
File: backtrace (11.35 KB, text/plain)
2009-09-06 15:46 UTC, Mads Kiilerich
no flags Details
/var/cache/abrt/ccpp-1252197179-13854/backtrace from nspluginwrapper (4.70 KB, text/plain)
2009-09-09 22:50 UTC, Mads Kiilerich
no flags Details
abrtd -dvvv when filing 524082 (10.34 KB, text/plain)
2009-09-17 19:43 UTC, Mads Kiilerich
no flags Details
/var/log/abrt-logger (108.83 KB, text/plain)
2009-09-17 19:58 UTC, Mads Kiilerich
no flags Details

Description Mads Kiilerich 2009-09-06 15:46:22 UTC
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----
I was surfing a site with flash when abrt popped up with this.

I don't know if it is a nspluginwrapper issue of if nspluginwrapper could do anything to prevent it.

If nspluginwrapper don't care about this flash crash then abrt shouldn't have assigned it to nspluginwrapper.

Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/lib/nspluginwrapper/npviewer.bin --plugin /usr/lib/mozilla/plugins/libflashplayer.so --connection /org/wrapper/NSPlugins/libflashplayer.so/1653-1 


component
-----
nspluginwrapper


executable
-----
/usr/lib/nspluginwrapper/npviewer.bin


kernel
-----
2.6.31-0.199.rc8.git2.fc12.i686.PAE


package
-----
nspluginwrapper-1.3.0-8.fc12


reason
-----
Process was terminated by signal 11

Comment 1 Mads Kiilerich 2009-09-06 15:46:25 UTC
Created attachment 359921 [details]
File: backtrace

Comment 2 Martin Stransky 2009-09-07 13:02:26 UTC
Hm, it looks like a crash somewhere in GTK...not the flash one.

Comment 3 Matthias Clasen 2009-09-09 22:32:36 UTC
Nope. This is a crash in gconf-editor. Since the stacktrace has no relation to the description in the bug, I am going to close this. Or wait. I'll actually move it to abrt, so we can fix the problem of bugs with unrelated stacktraces...

Comment 4 Mads Kiilerich 2009-09-09 22:48:05 UTC
Right. I don't know how that happened. That stacktrace belongs on bug 521507 where it was filed.

nsnpluginwrapper crash was in /var/cache/abrt/ccpp-1252197179-13854
gconf-editor crash was in     /var/cache/abrt/ccpp-1252250554-1742

I think I had abrt-0.0.8.5-1.fc12.i686 installed at that time.

Comment 5 Mads Kiilerich 2009-09-09 22:50:11 UTC
Created attachment 360363 [details]
/var/cache/abrt/ccpp-1252197179-13854/backtrace from nspluginwrapper

This issues has been reassigned and moved around, but just in case anybody cares I have attached the nspluginwrapper stacktrace which should have been attached in the first place.

Comment 6 Jiri Moskovcak 2009-09-10 09:57:38 UTC
Hi, it seems that abrtdb is messed up, could you please send me the whole /var/cache/abrt/ dir?

Thank you,
Jirka

Comment 7 Zdenek Prikryl 2009-09-14 16:33:40 UTC
Ok, please run abrt in the debug mode $ abrtd -dvvv and try to report this bug again. Then copy and paste the output. Thanks.

Comment 8 Mads Kiilerich 2009-09-14 20:29:32 UTC
abrt-gui just tells me that it has been submitted here and does not allow me to report it again. How can I make it forget that report?

Comment 9 Zdenek Prikryl 2009-09-17 07:51:25 UTC
Another question. I suppose that you have also Logger reporter enabled. So take a look into file /var/log/abrt and try to find this report (search for uuid [see whiteboard]). Is it also corrupted? If not, that the bug isn't in abrt itself but in bz plugin.

Thanks.

Comment 10 Zdenek Prikryl 2009-09-17 07:54:08 UTC
(In reply to comment #8)
> abrt-gui just tells me that it has been submitted here and does not allow me to
> report it again. How can I make it forget that report?  

It isn't important. The thing is, that if you run a deamon in a debug mode, then it prints a lot of information even if the crash is already reported. So, stop the daemon $service abrt stop, and run it in the debug mode from command line $abrt -dvvv.

Thanks.

Comment 11 Mads Kiilerich 2009-09-17 19:37:00 UTC
*** Bug 524082 has been marked as a duplicate of this bug. ***

Comment 12 Mads Kiilerich 2009-09-17 19:43:43 UTC
Created attachment 361556 [details]
abrtd -dvvv when filing 524082

abrt-0.0.8.5-1.fc12.i686

Comment 13 Mads Kiilerich 2009-09-17 19:58:07 UTC
Created attachment 361557 [details]
/var/log/abrt-logger

My /var/log/abrt-logger - I don't know if this makes sense to you

Comment 14 Matěj Cepl 2009-09-29 14:55:00 UTC
*** Bug 523191 has been marked as a duplicate of this bug. ***

Comment 15 Denys Vlasenko 2009-10-06 15:37:52 UTC
*** Bug 522967 has been marked as a duplicate of this bug. ***

Comment 16 Denys Vlasenko 2009-10-06 15:38:21 UTC
*** Bug 522982 has been marked as a duplicate of this bug. ***

Comment 17 Denys Vlasenko 2009-10-06 15:38:51 UTC
*** Bug 523328 has been marked as a duplicate of this bug. ***

Comment 18 Bug Zapper 2009-11-16 12:00:19 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 19 Mads Kiilerich 2010-01-13 23:33:29 UTC
I haven't seen this for a while, so I guess this issue has been fixed?

Comment 20 Jiri Moskovcak 2010-02-08 15:59:44 UTC
This has been fixed a while ago.


Note You need to log in before you can comment on or make changes to this bug.