Bug 527319 - Review Request: typepad-motion - A microblogging application for building online communities
Summary: Review Request: typepad-motion - A microblogging application for building onl...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 527316 527317 527428 527431 527433 527445
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-05 23:07 UTC by Sebastian Dziallas
Modified: 2009-10-22 12:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-22 12:16:51 UTC
Type: ---
panemade: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Sebastian Dziallas 2009-10-05 23:07:00 UTC
Spec URL: http://sdz.fedorapeople.org/rpmbuild/typepad-motion.spec
SRPM URL: http://sdz.fedorapeople.org/rpmbuild/typepad-motion-1.0.1-1.fc11.src.rpm
Koji Scratch Build: http://koji.fedoraproject.org/koji/taskinfo?taskID=1729590

[sebastian@localhost SRPMS]$ rpmlint -vi typepad-motion-1.0.1-1.fc11.src.rpm 
typepad-motion.src: I: checking
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
[sebastian@localhost noarch]$ rpmlint -vi typepad-motion-1.0.1-1.fc11.noarch.rpm 
typepad-motion.noarch: I: checking
typepad-motion.noarch: E: explicit-lib-dependency python-httplib2
You must let rpm find the library dependencies by itself. Do not put unneeded
explicit Requires: tags.

1 packages and 0 specfiles checked; 1 errors, 0 warnings.

Does this need to be fixed? I'm asking since it's written in Python...
This package also requires python-oauth and django-flash, which have both been submitted for review.

Comment 1 Sebastian Dziallas 2009-10-06 10:28:58 UTC
Just noticed I was missing a few more dependencies; packaging them now, watch out for updates.

Comment 2 Sebastian Dziallas 2009-10-06 12:23:34 UTC
Here's a new build which should now require all the dependencies. Out of those, all have been packaged and submitted for review, except django-typepad, on which I'm working, too.

Spec URL: http://sdz.fedorapeople.org/rpmbuild/typepad-motion.spec
SRPM URL:
http://sdz.fedorapeople.org/rpmbuild/typepad-motion-1.0.1-2.fc11.src.rpm

Comment 3 Sebastian Dziallas 2009-10-06 12:49:17 UTC
Adding the last requirement, django-typepad, as it has been submitted for review, too.

Comment 4 Sebastian Dziallas 2009-10-07 13:47:26 UTC
And another build, which adds sqlite as a dependency.

Spec URL: http://sdz.fedorapeople.org/rpmbuild/typepad-motion.spec
SRPM URL:
http://sdz.fedorapeople.org/rpmbuild/typepad-motion-1.0.1-3.fc11.src.rpm

Comment 5 Parag AN(पराग) 2009-10-16 05:00:23 UTC
are dependencies built already?

Comment 6 Sebastian Dziallas 2009-10-17 19:57:40 UTC
Yup, I think I built all of them. Should I push them as updates first or wait for this review and push them then altogether?

Comment 7 Sebastian Dziallas 2009-10-17 20:00:23 UTC
Actually, I just noticed I was missing two packages. Going to build them now.

Comment 8 Sebastian Dziallas 2009-10-17 20:28:29 UTC
Everything's built now! :)

Comment 9 Parag AN(पराग) 2009-10-18 10:18:47 UTC
thanks

Comment 10 Parag AN(पराग) 2009-10-21 06:49:17 UTC
Review:
+ package builds in mock (F-13 i686).
koji Build =>http://koji.fedoraproject.org/koji/taskinfo?taskID=1758806
+ rpmlint output for SRPM and for RPM.
typepad-motion.noarch: E: explicit-lib-dependency python-httplib2
==> can be ignored.
+ source files match upstream url(sha1sum)
8330b71b93503f90699c0c4f39519e94456c6534  typepad-motion-1.0.1.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Not a GUI application

APPROVED.

Comment 11 Sebastian Dziallas 2009-10-21 14:24:36 UTC
New Package CVS Request
=======================
Package Name: typepad-motion
Short Description: A microblogging application for building online communities
Owners: sdz
Branches: F-11 F-12 EL-5

Comment 12 Kevin Fenzi 2009-10-22 04:39:58 UTC
cvs done.

Comment 13 Sebastian Dziallas 2009-10-22 12:16:51 UTC
This is all built now, too! Closing.


Note You need to log in before you can comment on or make changes to this bug.