Bug 551500 - Kpackagekit crashes KDE Deamon
Kpackagekit crashes KDE Deamon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
: Triaged
: 550552 555275 555594 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-30 19:28 EST by Martin Kho
Modified: 2015-07-13 13:35 EDT (History)
12 users (show)

See Also:
Fixed In Version: 0.5.4-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 15:04:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Krash report KDED4 crash (3.12 KB, application/octet-stream)
2009-12-30 19:28 EST, Martin Kho
no flags Details
Kcrash report KDED4 crash and packagekit 0.5.6-1 (4.69 KB, application/octet-stream)
2010-01-06 12:16 EST, Martin Kho
no flags Details
KCrash report Kpackagekit 0.5.3-1 crash (4.20 KB, application/octet-stream)
2010-01-16 04:58 EST, Martin Kho
no flags Details
KDED crash on F12 i686 in VirtualBox (3.16 KB, text/plain)
2010-01-16 20:04 EST, Martin Kho
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 219590 None None None Never

  None (edit)
Description Martin Kho 2009-12-30 19:28:34 EST
Created attachment 381033 [details]
Krash report KDED4 crash

Description of problem:
When refreshing the software update listing in System Setting -> Add and Remove software KDED4 crashes. It makes no difference if there are updates available. KDED4 didn't crash immediately.

Version-Release number of selected component (if applicable):
kpackagekit-0.5.2-1.fc12.x86_64 (from updates-testing)
PackageKit-0.5.5-1.fc12.x86_64 (from updates-testing)

How reproducible:

Steps to Reproduce:
1. Open System Setting -> Add and Remove Software
2. Go to Software Updates
3. Press "Refresh" button (maybe wait a while)
  
Actual results:
KDED4 crashes

Expected results:
KDED4 doesn't crash

Additional info:
Comment 1 Martin Kho 2010-01-06 11:09:56 EST
Hi,

PackageKit-0.5.6-1.fc12.x86_64 in updates-testing solves this problem. So this bug report can be closed.

Martin Kho
Comment 2 Martin Kho 2010-01-06 11:20:08 EST
Hi,

Aargh.. My response was somewhat too quick. It took a while before KDED4 crashed. I could update, so everything seemed okay. The Kcrash report was not very informative. I'll try to get a better one.

Martin Kho
Comment 3 Martin Kho 2010-01-06 12:16:07 EST
Created attachment 382029 [details]
Kcrash report KDED4 crash and packagekit 0.5.6-1
Comment 4 Steven M. Parrish 2010-01-12 08:00:28 EST
This bug has been triaged

Steven M. Parrish
KDE & Packagekit Triager 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Kevin Kofler 2010-01-12 16:14:39 EST
*** Bug 550552 has been marked as a duplicate of this bug. ***
Comment 6 Kevin Kofler 2010-01-14 05:29:32 EST
*** Bug 555275 has been marked as a duplicate of this bug. ***
Comment 7 Martin Kho 2010-01-14 07:47:08 EST
Hi,

Not sure if it's interesting, but I saw that kpackagekit 0.5.3 is released.

Changelog:
0.5.3
- Removed some lib dependencies from KdeD module to avoid craches there

Reference:
http://www.kde-apps.org/content/show.php/KPackageKit?content=84745

Martin Kho
Comment 8 Lukáš Tinkl 2010-01-14 08:35:07 EST
Working on it
Comment 9 Jan Simonson 2010-01-14 13:35:46 EST
Today after updating  PackageKit to 0.5.6-1.fc12 kpackagekit started to function again with relevant updates displayed and no chrashes when pressing "refresh".

Seems that the problem was not in kpackagekit but rather in PackageKit.

My system is a fresh install of Fedora12 fully updated with all stable updates, but nos test or dev updates.

Jan Simonson
Comment 10 Rex Dieter 2010-01-14 13:41:44 EST
Looks like a new kpackagekit release happened that includes some workarounds for this problem.  Our quick-n-dirty testing has been good.

Please try it out:
http://koji.fedoraproject.org/koji/buildinfo?buildID=150896

(Also put into the kde-redhat-testing repos for those who use that).
Comment 11 Fedora Update System 2010-01-14 13:55:15 EST
kpackagekit-0.5.3-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kpackagekit-0.5.3-1.fc12
Comment 12 Martin Kho 2010-01-14 16:18:20 EST
Hi,

Tried kpackagekit-0.5.3-1 but got a crash, not KDE Deamon this time. I´ll create a new bug report for this crash.


Martin Kho
Comment 13 Fedora Update System 2010-01-15 17:06:40 EST
kpackagekit-0.5.3-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kpackagekit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0584
Comment 14 Martin Kho 2010-01-16 04:57:42 EST
Updated kpackagekit from updates-testing. It still crashes. After 'Downloading list of changes' in 'Software Updates' kpackagekit crashed. It make no difference if kpackagekit is run from System Settings or stand alone. In de next comment you'll find the crash report.

And after a while...KDE4 Daemon crashed.

Sorry ;-(

Martin Kho

Btw: I created a new bug report [1] for this version of kpackagekit, that can be closed I suppose?

[1] https://bugzilla.redhat.com/show_bug.cgi?id=555594
Comment 15 Martin Kho 2010-01-16 04:58:37 EST
Created attachment 384775 [details]
KCrash report Kpackagekit 0.5.3-1 crash
Comment 16 Kevin Kofler 2010-01-16 10:38:36 EST
*** Bug 555594 has been marked as a duplicate of this bug. ***
Comment 17 Martin Kho 2010-01-16 17:59:55 EST
Hi,

Culprit found! Today libxcb was updated to version 1.5-1 and kpackagekit didn't crash anymore :-) Don't know what fixed the issue:

Changelog says:
* Wed Jan 13 2010 Dave Airlie <airlied@redhat.com> 1.5-1
  - libxcb 1.5

There is a BUT... Now I have the same issue as in F13. Available updates are not visible in Software Updates window. This bug is filed in report [1]

Shall I open a separate report for F12?

[1] https://bugzilla.redhat.com/show_bug.cgi?id=555014

Martin Kho
Comment 18 Kevin Kofler 2010-01-16 18:05:25 EST
I think this is just a red herring, like before with PackageKit 0.5.6, the error will come back. I don't see how a libxcb update can fix this crash.
Comment 19 Jan Simonson 2010-01-16 18:37:26 EST
Since I wrote that comment I have been starting and using the "Update" key in kpackagekit at least 15 times without a single crash. I find it very odd that there are no chrashes for me while they continue for other users. Not that I complain but.. ;-)

Have you tried to erase your config file (/home/jan/.kde/share/config/KPackageKit)?
Also, my system is fully updated, but only with stable.

Jan Simonson
Comment 20 Martin Kho 2010-01-16 19:22:29 EST
@Jan, yes I erased my config file and compared it with the one you send to the mailing list. Thanks for that info :-)

@Kevin, it surely can be a red herring. 'Tux' may need a new pair of glasses :-)

I've set up VirtualBox and installed KDE Live CD x86_64 (1) and i686 (2).

(1) was fully updated with yum update, because kpackagekit reported an unrecoverable error. Then I updated kpackagekit from updates-testing to version 0.5.3-1. Today libxcb was updated, that resulted in what I commented in #17.

(2) Updated to the latest kernel (so I could install VBOX extensions), libxcb and kpackagekit-0.5.2-1 (PackageKit-0.5.6-1) from stable. Then I started kpackagekit. Guess what ... everything runs as expected, no crash, packages are visible in the Software Update window.

I know now I have a very, very bad story :-$. Any ideas? Need to reinstall my stable system?

Martin Kho
Comment 21 Martin Kho 2010-01-16 20:03:05 EST
Hi,

It starts being a farce ;-(

Installed skype on a fully updated Fedora 12 i686 (see 2 in comment #20) in VirtualBox at Jan 17 01:34:02. The KDE Daemon crashed at 01:42. So there is definitely a red herring. I'll add the KCrash report.

Martin Kho
Comment 22 Martin Kho 2010-01-16 20:04:09 EST
Created attachment 384871 [details]
KDED crash on F12 i686 in VirtualBox
Comment 23 Martin Kho 2010-01-19 10:04:28 EST
Hi,

On my fully updated F12 'production system' I downgraded kpackagekit to version 0.5.2-1. Available updates are visible in the Software Updates window. The KDE Daemon doesn't crash. The crashes stopped happening after I got the following updates:

Jan 16 11:26:49 Updated: libxcb-1.5-1.fc12.x86_64
Jan 16 11:26:51 Updated: system-config-printer-libs-1.1.16-8.fc12.x86_64
Jan 16 11:26:53 Updated: libxfcegui4-4.6.2-1.fc12.x86_64
Jan 16 11:26:54 Updated: system-config-printer-udev-1.1.16-8.fc12.x86_64
Jan 16 11:26:56 Updated: gdb-7.0.1-26.fc12.x86_64
Jan 16 11:26:57 Updated: 1:xorg-x11-drv-nouveau-0.0.15-19.20091105gite1c2efd.fc12.x86_64
Jan 16 11:26:58 Updated: libxcb-devel-1.5-1.fc12.x86_64
Jan 16 11:27:00 Updated: system-config-printer-1.1.16-8.fc12.x86_64

Which one is relevant? I don't know.

Hope this info helps.

Martin Kho
Comment 24 Jan Simonson 2010-01-19 11:32:32 EST
Further to the kpackagekit story...

A couple of days ago i upgraded kpackagekit to testing with 
"yum --enablerepo=updates-testing update kpackagekit". That resulted in 
kpackagekit-0.5.3-1.fc12.x86_64 installed on my system.

Since then there has been no upgrades available, at least not in kpackagekit, 
but today i checked with "yum upgrade" in a shell and sure enough there were 22 
upgrades available! After checking once more with kpackagekit (still nothing) I 
downgraded to kpackagekit-0.5.2-1.fc12.x86_64 and all the upgrades were 
available there as well. So I upgraded kpackagekit one more time to check (all 
updates gone) and down again (all updates available).

As I see  it there must be a regression in kpackagekit-0.5.3-1.fc12.x86_64!

BTW, I still have NO chrashes with either version of kpackagekit.

Jan Simonson
Comment 25 Martin Kho 2010-01-23 08:31:17 EST
Hurray, it happens again :-) ... ;-(

Using kpackagekit 0.5.3-1 (0.5.2-1) causes KDE4 Daemon to crash, when updates are available. This starts happening, again, after Jan. 20th updates. There is one difference though, that is that kpackagekit isn't crash any more (removal of kded dependencies in kpackagekit seems to work). KCrash reports always contain the same content. So, to me, this issue still exists.


Martin Kho

Btw. I tried version 0.5.4-1, but it also crashed.
Comment 26 Martin Kho 2010-01-27 17:08:29 EST
Hi,

Well...yesterday I got a really great sensation. 

After installing kpackagekit-0.5.4-2 from Koji, a pop up appeared notifying me that updates were available. I could install them without any problem. I had to reboot so I was not sure if the KDE Daemon would crash.

Today, again, there were some updates available. I installed them from Systemsettings -> Add and Remove Software. Everything went fine and the KDE4 Daemon didn't crash.

Conclusion: The issue stated in the original post is solved for me :-)

Congratulations to anyone who made kpackagekit working again!

Thanks for the excellent work!

Martin Kho

Btw. I'm not sure if the issue from bug report [1] is solved

[1] https://bugzilla.redhat.com/show_bug.cgi?id=546205
Comment 27 Kevin Kofler 2010-01-27 17:16:29 EST
FYI, you don't really have to reboot, just click "Not now", in almost all cases you can continue working just fine (but some security updates, e.g. to the kernel, won't take effect immediately, and in some cases, e.g. if you upgraded KDE from 4.n to 4.n+1, KDE can misbehave quite badly until you restart at least your KDE session).
Comment 28 Lloyd Matthews 2010-02-02 13:39:22 EST
The latest updates that were pushed have fixed this problem for my computers.  Thank you for fixing Kpackagekit.
Comment 29 Jan Simonson 2010-02-02 15:43:01 EST
Hello,

Since late last week I have been running kpackagekit-0.5.4-2.fc12.x86_64 from updates-testing and it functions very well. No chrashes even when Kpackagekit-service is enabled in System-settings. All updates are also available.

However, the notification of new updates in system-tray doesn't function. I have enabled Kpackagekit-service in System-settings  and also marked the "Notify when new updates are available" in Kpackagekit's settings to no avail.

Jan Simonson
Comment 30 peter 2010-02-03 12:56:13 EST
Hello,

I made additional comments to bug nr. 219590 (#96,100) at bugs.kde.org and installed kpackagekit kpackagekit-0.5.4-2.fc12.x86_64 from updates-testing. Updates work with System-settings but today I had a KDE crash again:
Application: KPackageKit (kpackagekitsmarticon), signal: Segmentation fault
[KCrash Handler]
#5  0x000000395a554d54 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#6  0x000000395ca21faf in PackageKit::Transaction::finished(PackageKit::Transaction::ExitStatus, unsigned int) () from /usr/lib64/libpackagekit-qt.so.12
#7  0x000000395ca1de39 in PackageKit::ClientPrivate::serviceOwnerChanged(QString const&, QString const&, QString const&) () from /usr/lib64/libpackagekit-qt.so.12
#8  0x000000395ca1f288 in PackageKit::ClientPrivate::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libpackagekit-qt.so.12
#9  0x000000395a55408c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#10 0x00000039598558cf in QDBusConnectionInterface::serviceOwnerChanged(QString const&, QString const&, QString const&) () from /usr/lib64/libQtDBus.so.4
#11 0x0000003959855b64 in QDBusConnectionInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libQtDBus.so.4
#12 0x000000395a55408c in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#13 0x00000039598557ff in QDBusConnectionInterface::NameOwnerChanged(QString const&, QString const&, QString const&) () from /usr/lib64/libQtDBus.so.4
#14 0x0000003959855bcc in QDBusConnectionInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libQtDBus.so.4
#15 0x0000003959822e84 in ?? () from /usr/lib64/libQtDBus.so.4
#16 0x000000395982a61f in ?? () from /usr/lib64/libQtDBus.so.4
#17 0x000000395a54e401 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#18 0x00000036d7b8f65c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#19 0x00000036d7b968ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#20 0x00000036d6011a66 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#21 0x000000395a53ee6c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#22 0x000000395a53fa42 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#23 0x000000395a567573 in ?? () from /usr/lib64/libQtCore.so.4
#24 0x0000003950c3922e in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#25 0x0000003950c3cc18 in ?? () from /lib64/libglib-2.0.so.0
#26 0x0000003950c3cd3a in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#27 0x000000395a5671e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#28 0x00000036d7c21ffe in ?? () from /usr/lib64/libQtGui.so.4
#29 0x000000395a53d772 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#30 0x000000395a53db44 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#31 0x000000395a53fcd9 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#32 0x000000000040a9eb in _start ()
Comment 31 Martin Kho 2010-02-23 05:03:55 EST
Hi,

I can confirm the previous post. Today after the following updates kpackagekitsmarticon crashed. I had to reboot (because of abrt), but didn do so.

Martin Kho

Feb 23 10:48:22 Updated: abrt-libs-1.0.7-1.fc12.x86_64
Feb 23 10:48:23 Updated: libcom_err-1.41.9-7.fc12.x86_64
Feb 23 10:48:25 Updated: abrt-1.0.7-1.fc12.x86_64
Feb 23 10:48:30 Updated: gtk2-2.18.7-1.fc12.x86_64
Feb 23 10:48:31 Updated: e2fsprogs-libs-1.41.9-7.fc12.x86_64
Feb 23 10:48:31 Updated: libss-1.41.9-7.fc12.x86_64
Feb 23 10:48:34 Updated: gvfs-1.4.3-5.fc12.x86_64
Feb 23 10:48:36 Updated: abrt-gui-1.0.7-1.fc12.x86_64
Feb 23 10:48:37 Updated: abrt-addon-python-1.0.7-1.fc12.x86_64
Feb 23 10:48:37 Updated: abrt-plugin-runapp-1.0.7-1.fc12.x86_64
Feb 23 10:48:38 Updated: abrt-plugin-bugzilla-1.0.7-1.fc12.x86_64
Feb 23 10:48:39 Updated: abrt-plugin-logger-1.0.7-1.fc12.x86_64
Feb 23 10:48:40 Updated: abrt-addon-kerneloops-1.0.7-1.fc12.x86_64
Feb 23 10:48:43 Updated: abrt-addon-ccpp-1.0.7-1.fc12.x86_64
Feb 23 10:48:43 Updated: gvfs-fuse-1.4.3-5.fc12.x86_64
Feb 23 10:48:45 Updated: e2fsprogs-1.41.9-7.fc12.x86_64
Feb 23 10:48:45 Updated: gtk2-immodule-xim-2.18.7-1.fc12.x86_64
Feb 23 10:48:46 Updated: xorg-x11-drv-wacom-0.10.4-2.fc12.x86_64
Feb 23 10:48:47 Updated: crda-1.1.1_2009.11.25-2.fc12.x86_64
Feb 23 10:48:50 Updated: smolt-1.4.2-1.fc12.noarch
Feb 23 10:48:50 Updated: smolt-firstboot-1.4.2-1.fc12.noarch
Feb 23 10:48:51 Updated: abrt-desktop-1.0.7-1.fc12.x86_64
Feb 23 10:48:51 Updated: libcom_err-devel-1.41.9-7.fc12.x86_64
Feb 23 10:48:52 Updated: 1:control-center-filesystem-2.28.1-17.fc12.x86_64
Feb 23 10:48:52 Updated: perl-Git-1.6.6.1-1.fc12.noarch
Feb 23 10:48:59 Updated: git-1.6.6.1-1.fc12.x86_64
Comment 32 Rex Dieter 2010-02-23 15:04:25 EST
This is a different crash, kpackagekitsmarticon (not kded4), please file separately, thanks.

Note You need to log in before you can comment on or make changes to this bug.