Bug 603576 - Cannot type anything into gnome-shell widgets
Summary: Cannot type anything into gnome-shell widgets
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Desktop, i18n, MoveUpstream
: 604019 638828 656474 (view as bug list)
Depends On:
Blocks: 669481
TreeView+ depends on / blocked
 
Reported: 2010-06-13 23:08 UTC by Peng Huang
Modified: 2011-03-26 15:52 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 669481 (view as bug list)
Environment:
Last Closed: 2011-03-26 15:52:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 621659 None None None Never

Description Peng Huang 2010-06-13 23:08:05 UTC
Description of problem:
Can not type anything in gnome-shell

Version-Release number of selected component (if applicable):
gnome-shell-2.31.2-2.fc14.i686
gtk2-2.21.2-1.fc14.i686
gtk3-2.90.2-2.fc14.i686
ibus-1.3.5-1.fc14.i686

How reproducible:

always

Steps to Reproduce:
1. im-chooser to enable ibus
2. move cursor to left top corner
3. type something in the find entry
  
Actual results:
Can not type anything

Expected results:


Additional info:
For some reason, ibus have to processes keypress events in async mode. So gtk_im_context_filter_keypress always returns FALSE. and if ibus need ignore some keyevents, ibus im context will use gdk_event_put to forward the event back to the client window (the window is from gtk_im_context_set_client_window).

Comment 1 Peng Huang 2010-06-13 23:12:50 UTC
BTW, I am thinking if gtk could provide a better way for processing key events in async mode.

Comment 2 A S Alam 2010-06-15 13:44:21 UTC
Fedora i13 update has same problem 
gnome-shell-2.29.1-4.x86_64

Alt+F2 - type in English - Not working
use ibus to switch different language, it is working, but not able to delete

Comment 3 A S Alam 2010-06-15 16:50:08 UTC
ibus-1.3.5-2.fc13.x86_64
ibus-libs-1.3.5-2.fc13.x86_64

Comment 4 Matthias Clasen 2010-06-17 15:45:40 UTC
I can confirm this, I see this too in rawhide. Keyboard input does not work in the overview or alt-f2. Alt-arrow workspace switching still works.

Comment 5 Peng Huang 2010-06-23 02:43:20 UTC
The same bug in gnome bugzilla.
https://bugzilla.gnome.org/show_bug.cgi?id=621659

Comment 6 Peng Huang 2010-06-23 02:50:47 UTC
I read code of gnome-shell and found the client window is from
gdk_window_foreign_new_for_display, and gnome-shell use clutter to handle events.
It seems the clutter does not process events in gdk event queue, and gnome-shell will never get the events sent by gdk_event_put.

Comment 7 Peng Huang 2010-06-24 05:38:45 UTC
*** Bug 604019 has been marked as a duplicate of this bug. ***

Comment 9 Julian Aloofi 2010-06-30 11:23:26 UTC
This occurs on F13 as well.

ibus-1.3.5-2.fc13.i686
gnome-shell-2.29.1-4.i686
gtk2-2.20.1-1.fc13.i686

Comment 10 lionghostshop 2010-07-07 00:21:08 UTC
When will this bug be fixed? It cause great inconvenient to using gnome-shell.

Comment 11 Bug Zapper 2010-07-30 12:07:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 12 Owen Taylor 2010-10-17 15:50:22 UTC
*** Bug 638828 has been marked as a duplicate of this bug. ***

Comment 13 Izhar Firdaus 2010-11-24 03:05:13 UTC
*** Bug 656474 has been marked as a duplicate of this bug. ***

Comment 14 Owen Taylor 2011-03-26 15:52:37 UTC
Upstream bug has been fixed, will be OK in Fedora 15


Note You need to log in before you can comment on or make changes to this bug.