Bug 652504 - [abrt] VbaEventsHelperBase::processVbaEvent
Summary: [abrt] VbaEventsHelperBase::processVbaEvent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e00dcc756d3d91ec0abddb3f57b...
: 654918 655669 656525 658539 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-12 04:32 UTC by BartS
Modified: 2010-12-02 19:07 UTC (History)
4 users (show)

Fixed In Version: openoffice.org-3.3.0-17.2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-02 19:07:35 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (45.79 KB, text/plain)
2010-11-12 04:32 UTC, BartS
no flags Details

Description BartS 2010-11-12 04:32:16 UTC
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/soffice.bin -quickstart -nologo -nodefault
comment: Opening an excel file...
component: openoffice.org
crash_function: raise
executable: /usr/lib/openoffice.org3/program/soffice.bin
kernel: 2.6.35.6-48.fc14.i686
package: openoffice.org-brand-1:3.3.0-13.3.fc14
rating: 4
reason: Process /usr/lib/openoffice.org3/program/soffice.bin was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1289535415
uid: 500

Comment 1 BartS 2010-11-12 04:32:19 UTC
Created attachment 459906 [details]
File: backtrace

Comment 2 David Tardon 2010-11-12 06:25:02 UTC
There is a VBA macro in the file that causes the crash. Could you attach the file here?

Comment 3 David Tardon 2010-11-19 06:32:25 UTC
*** Bug 654918 has been marked as a duplicate of this bug. ***

Comment 4 David Tardon 2010-11-22 05:18:30 UTC
*** Bug 655669 has been marked as a duplicate of this bug. ***

Comment 5 Caolan McNamara 2010-11-22 09:13:33 UTC
Digging into the LibreOffice git log for the afflicted file, I see noelp just ended up adding a try catch around it. So lets just backport that

Comment 6 Caolan McNamara 2010-11-22 09:19:32 UTC
Will be in >= 3.3.0-16.2

Comment 7 David Tardon 2010-11-24 05:53:51 UTC
*** Bug 656525 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2010-11-29 11:47:52 UTC
openoffice.org-3.3.0-17.2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-17.2.fc14

Comment 9 Fedora Update System 2010-11-29 21:35:14 UTC
openoffice.org-3.3.0-17.2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-17.2.fc14

Comment 10 David Tardon 2010-11-30 16:55:07 UTC
*** Bug 658539 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2010-12-02 19:07:13 UTC
openoffice.org-3.3.0-17.2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.