Bug 657560 - anjuta - Update to 2.32.1.1
anjuta - Update to 2.32.1.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anjuta (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
: 657407 660008 662274 662369 (view as bug list)
Depends On: 658471
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-26 08:37 EST by Johannes Schmid
Modified: 2011-01-08 16:28 EST (History)
10 users (show)

See Also:
Fixed In Version: libxfcegui4-4.6.4-4.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-08 16:28:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johannes Schmid 2010-11-26 08:37:40 EST
Spec URL: http://www.jsschmid.de/fedora/anjuta.spec
SRPM URL: http://www.jsschmid.de/fedora/anjuta-2.32.1.0-2.fc14.src.rpm
Description:
(I need a sponsor according to the fedora rules)
Update anjuta to the latest stable upstream version. It just contains bug-fixes according to the GNOME release schedule. Summary of the changes (copied from the NEWS file):

Anjuta 2.32.1 "2.x, we will miss you" (12 Nov 2010) -- Johannes Schmid

This is a bug-fix (and probably the last) release of the Anjuta 2.32.x series.
It fixes several annoying bugs and all users are encouraged to update to this
version.

There have been improvements in the python and C/C++ support so coding should
be a lot more conveninent.

Bugs fixed:
language-support-cpp-java: bgo#621916 - check for brace
libanjuta: bgo#633042 New: Sensitivity off 'ok' button on the project import dialog
language-support-cpp: Don't show duplicated results in autocompletion
build: bgo#633661 - vala support is automagic
language-support-cpp-java: bgo#633112 - Smart Brace Completion Quotation Mark Crash
python-support: Fix bgo#631223 autointention causes anjuta to hang

Thanks to: Carles Ferrando, Daniel Nylander, Giannis Katsampirhs, Jens Georg,
Joan Duran, Jorge González, knight2000,
Pacho Ramos, Sébastien Granjoux, Takayuki KUSANO

Anjuta 2.32.0 "Goodbye Berlin" (27 Sep 2010) -- Johannes Schmid

This is our new stable release. Older releases won't see any bug-fixing, support,
etc and master is now heading for GNOME 3.0 which will rock!

Bugs fixed:
bgo#630460 PackageKit integration is not working on all distros
project-wizard: Update default ui file to use gtk+-2.16

Various translation updates, Anjuta is now fully available in over 20 and more
languages. Thanks for your effort.

Thanks to (again, mostly translators):
Andika Triwidada, Andrea Zagli, Aron Xu, Bruce Cowan, Bruno Brouard,
Chao-Hsiung Liao, Christian Kirbach, Duarte Loreto, Fran Diéguez, Gabor Kelemen,
Jonh Wendell, Jorge González, Kenneth Nielsen, Marek Černocký, Mario Blättermann,
Matej Urbančič, Michael Kotsarinis, Milo Casagrande, Piotr Drąg, Takayuki KUSANO,
Yuri Myasoedov
Comment 1 Jason Tibbitts 2010-11-26 09:14:11 EST
Umm, anjuta is already in the distribution; you cannot submit it again.  You are welcome to file bugs against it, but there is no point at all in submitting another package review ticket for it.
Comment 2 Johannes Schmid 2010-11-26 09:24:28 EST
OK, sorry, maybe I misread the documentation. Changing bug title...
Comment 3 Juan Francisco Cantero Hurtado 2010-12-04 22:50:28 EST
I've compiled anjuta 2.32.1 from sources and everything works fine for me. The version in Fedora (2.31.90) is very outdated (from august). Any problem with the updates of anjuta?

The bug https://bugzilla.redhat.com/show_bug.cgi?id=658471 is important, take a look if you have problems running anjuta.
Comment 4 Johannes Schmid 2010-12-05 06:20:54 EST
Well, my first comments even contains spec file and source rpm and I would even be willing to go to the process of taking over packaging for anjuta but I don't know how to do that, even being the upstream maintainer.

This is really only a stable bug-fix update...
Comment 5 Rakesh Pandit 2010-12-06 00:36:20 EST
Ray seems to be busy. I will have a look into it in couple of days. Thanks Johannes and Juan.

Sorry for inconvenience.
Comment 6 Juan Francisco Cantero Hurtado 2010-12-06 04:24:30 EST
Thanks Rakesh :)
Comment 7 Fedora Update System 2010-12-06 14:10:08 EST
anjuta-2.32.1.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anjuta-2.32.1.0-1.fc14
Comment 8 Bastien Nocera 2010-12-06 14:11:03 EST
Done, update is queued.

FWIW, the patch wasn't against the latest spec, and I don't think you meant "autointentation".
Comment 9 Rakesh Pandit 2010-12-07 00:17:53 EST
Thanks Bastien for taking this up.
Comment 10 Rakesh Pandit 2010-12-07 00:41:50 EST
Seems we have a missing dependency libsqlite3.so . Will test it a bit more and check whether a new build it required.
Comment 11 Rakesh Pandit 2010-12-07 01:36:34 EST
https://bugzilla.redhat.com/show_bug.cgi?id=658471 is related bug. But the update in it does not seem to solve the problem.
Comment 12 Rakesh Pandit 2010-12-07 02:45:28 EST
(In reply to comment #4)
> Well, my first comments even contains spec file and source rpm and I would even
> be willing to go to the process of taking over packaging for anjuta but I don't
> know how to do that, even being the upstream maintainer.
> 
> This is really only a stable bug-fix update...

Hello Johannes Schmid,

Sorry for late response, am looking into it now. As you said you would be interested in package maintenance here in Fedora as well, please make a fas account and see if you can request for co-maintainer ship at this place https://admin.fedoraproject.org/pkgdb/acls/name/anjuta . Thing is you would need to get sponsorship for getting into package maintenance. Please try applying in interface and in between I will check with few folks (sponsors) around in Fedora community to sponsor you quickly as your are upstream maintainer.

Thanks for all your work!
Comment 13 Johannes Schmid 2010-12-07 08:30:34 EST
@Bastien: Thanks for taking care of it. It was a typo of course ;)

@Rakesh: I added myself to the package - I hope that's want you meant. I am not so much in a hurry as the new version is now in but I will happily take care about newer version when they are released.

Thanks!
Comment 14 Fedora Update System 2010-12-07 15:08:27 EST
anjuta-2.32.1.0-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anjuta'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anjuta-2.32.1.0-1.fc14
Comment 15 Johannes Schmid 2010-12-13 11:23:54 EST
*** Bug 657407 has been marked as a duplicate of this bug. ***
Comment 16 Johannes Schmid 2010-12-13 11:24:42 EST
*** Bug 660008 has been marked as a duplicate of this bug. ***
Comment 17 Johannes Schmid 2010-12-13 11:25:20 EST
*** Bug 662274 has been marked as a duplicate of this bug. ***
Comment 18 Johannes Schmid 2010-12-13 11:25:47 EST
*** Bug 662369 has been marked as a duplicate of this bug. ***
Comment 19 Fedora Update System 2011-01-05 02:28:05 EST
libxfcegui4-4.6.4-4.fc14,libxfce4ui-4.7.2-3.fc14,gtkdatabox-0.9.1.1-4.fc14.2,gnome-media-2.32.0-2.fc14,anjuta-2.32.1.1-1.fc14,glade3-3.6.7-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libxfcegui4-4.6.4-4.fc14,libxfce4ui-4.7.2-3.fc14,gtkdatabox-0.9.1.1-4.fc14.2,gnome-media-2.32.0-2.fc14,anjuta-2.32.1.1-1.fc14,glade3-3.6.7-2.fc14
Comment 20 Fedora Update System 2011-01-05 16:22:21 EST
libxfcegui4-4.6.4-4.fc14, libxfce4ui-4.7.2-3.fc14, gtkdatabox-0.9.1.1-4.fc14.2, gnome-media-2.32.0-2.fc14, anjuta-2.32.1.1-1.fc14, glade3-3.6.7-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libxfcegui4 libxfce4ui gtkdatabox gnome-media anjuta glade3'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/libxfcegui4-4.6.4-4.fc14,libxfce4ui-4.7.2-3.fc14,gtkdatabox-0.9.1.1-4.fc14.2,gnome-media-2.32.0-2.fc14,anjuta-2.32.1.1-1.fc14,glade3-3.6.7-2.fc14
Comment 21 Tan Chin Leong 2011-01-05 19:08:56 EST
Package: anjuta-1:2.32.1.0-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start
2. Crash
Comment 22 Johannes Schmid 2011-01-05 20:07:36 EST
@Tan: Do you have latest xulrunner (also from testing) installed? That should fix the issue. It is bug 658471.
Comment 23 Fedora Update System 2011-01-08 16:27:53 EST
libxfcegui4-4.6.4-4.fc14, libxfce4ui-4.7.2-3.fc14, gtkdatabox-0.9.1.1-4.fc14.2, gnome-media-2.32.0-2.fc14, anjuta-2.32.1.1-1.fc14, glade3-3.6.7-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.