Bug 67988 - Limbo install hangs at end of installation
Limbo install hangs at end of installation
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 65805 68003 68033 68108 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-04 22:44 EDT by Todd Booher
Modified: 2007-04-18 12:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 00:16:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Booher 2002-07-04 22:44:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
Installing RH "Limbo" release, installation completes to the
last screen where you click on "Quit" to reboot.  Clicking on Quit
does nothing, the system just sits there.  The system is able to display the
"Release notes" during this time.  Had to do a hard reset, thing the system ran
fine.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Jeremy Katz 2002-07-05 12:57:15 EDT
*** Bug 68003 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2002-07-05 12:57:57 EDT
*** Bug 68033 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2002-07-05 14:51:57 EDT
*** Bug 68043 has been marked as a duplicate of this bug. ***
Comment 4 Thomas M Steenholdt 2002-07-06 03:31:28 EDT
As far as i have been able to look into this - it seems to be related to a
failing grub install... When having pressed Quit a few time with nothing
happening i flipped through tty1-5, and found that on tty5 I had the screen full
of the following line, repeated.

"grub> install --force-lba /boot/grub/stage1 d (hd0) /boot/grub/stage2 p (hd0,4"

notice that the "'s are not there and the missing ')' at the end of the line is
not a typo on my part.

Anyway, this line is repeated over and over again over the screen(no nl or cr in
between) and the bottom of the screen shows an active "grub> " prompt that you
can actually work on.

even though this tells me that the grub installer has not been successfully
installed, it seemed to work fine after pressing ctrl-alt-del to reboot the system.
Comment 5 Peter Toft 2002-07-06 10:56:47 EDT
*** Bug  68108 has been marked as a duplicate of this bug. ***
Comment 6 Need Real Name 2002-07-06 11:40:26 EDT
I had the same problem, but in my case I chose not to install grub.  

So maybe this problem is not realated to grub?
Comment 7 Jeremy Katz 2002-07-06 13:12:01 EDT
No, that's just the way grub's shell output looks when it's redirected to a tty
instead of being used interactively.  Nothing new or different there.
Comment 8 Dan de Haan 2002-07-07 02:46:07 EDT
I had the same problem.

PC is a PIII-800 44BX based board.

Workstation install, selected individual packages.
created LVM group as /

Hit reset to get out.
Comment 9 jbowman 2002-07-07 20:33:57 EDT
Same problem repeatedly happening here on a 1ghz Thunderbird Athlon w/ Abit
KT7A-RAID motherboard. Grub installed fine, and a quick press of the reset
button got me into my new install without a hitch.
Comment 10 Jay Turner 2002-07-08 11:56:21 EDT
*** Bug 65805 has been marked as a duplicate of this bug. ***
Comment 11 Allen A George 2002-07-09 22:08:58 EDT
FWIW I have the same problem...  Here's what I noticed:

Switching through the terminals I found the following message)

(ananconda:76):GnomeCanvas - CRITICAL **:file gnome-canvas-path-def.c: line 1142
(gnome_canvas_path_def_any_closed):assertion 'path !=NULL' failed
<GdkRectangle at 0x8e7df48>

I also noticed on another terminal that the last message was that it was
conntecing on eth0

PS. My network was set up perfectly though...
Comment 12 Allen A George 2002-07-09 22:48:40 EDT
Regarding the above...The Quit button does not work (Enter will not exit the
installer either).  Perhaps those error messages are related to this situation
Comment 13 Jeremy Katz 2002-07-11 00:16:29 EDT
Tracked down and fixed in CVS
Comment 14 Mike McLean 2002-07-18 15:05:01 EDT
Fix confirmed.

Note You need to log in before you can comment on or make changes to this bug.