Bug 734442 - alacarte needs to be ported to new gnome-menus api
alacarte needs to be ported to new gnome-menus api
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: alacarte (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Triaged
: 735194 737086 742713 752238 766444 766492 766843 766927 766973 766975 767491 767586 767587 767626 767782 767999 768280 768345 768565 768591 768633 768697 768985 769345 769736 783766 789082 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-30 08:17 EDT by satellitgo
Modified: 2012-07-24 11:38 EDT (History)
85 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-10 19:56:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 626220 None None None Never

  None (edit)
Description satellitgo 2011-08-30 08:17:39 EDT
Description of problem:
alacarte will not start in gnome3-shell 3.1.5

/usr/lib/python2.7/site-packages/Alacarte/Mainwindow.py line 19 in <module>
Import gtk, gmemu, gio
ImportError No Module named gmenu

Version-Release number of selected component (if applicable):

http://koji.fedoraproject.org/koji/getfile?taskID=3307710&name=Fedora-16-Nightly-20110828.10-i686-Live-desktop.iso (installed to HD)

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
won't start

Expected results:
start Alacarte

Additional info:
I need a way to edit the properties of sugar-emulator to sugar-emulator -f  for full screen. alacarte has done this well in earlier versions of gnome3-shell
Comment 1 Matthias Clasen 2011-09-02 15:43:36 EDT
upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=657512
Comment 2 Matthias Clasen 2011-09-02 20:39:36 EDT
*** Bug 735194 has been marked as a duplicate of this bug. ***
Comment 3 unix63 2011-09-06 22:16:01 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
run alacarte from menu
Comment 4 Andy Lawrence 2011-09-11 14:11:14 EDT
*** Bug 737086 has been marked as a duplicate of this bug. ***
Comment 5 Frederick Grose 2011-09-19 18:48:58 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: 19Sep2011-fgrose-Remix-
Fedora release 16 (Verne)


Comment
-----
Just tried to launch at the gpk-application offer after downloading.
Comment 6 Matteo Settenvini 2011-09-27 16:46:28 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Crashes on start.
Comment 7 kevin.t.bowen 2011-09-29 02:20:48 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
crashed on first startup
Comment 8 Juan Manuel Rodriguez 2011-09-30 10:30:45 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
yum install alacarte. Run alacarte. Get an error related to:
ImportError: No module named gmenu
Comment 9 Greg` 2011-10-01 20:46:30 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Crashes During Launch
Comment 10 Ozgur Gundogan 2011-10-02 07:40:27 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
When I have started the application, ABRT warned error.
Comment 11 Steve 2011-10-03 09:18:47 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Tried to start alacarte..
Comment 12 gabe@codehaus.org 2011-10-05 01:56:51 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Just tried to run alacarte. It crashed.
Comment 13 snejpa 2011-10-05 04:43:43 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
alacarte does not start
Comment 14 Donald Cohen 2011-10-05 13:36:07 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
click applications - sound&video - cheese
This is in fc 16 beta
When I do alacarte from shell I see
$ alacarte
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 22, in <module>
    from Alacarte.MainWindow import MainWindow
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 19, in <module>
    import gtk, gmenu, gobject, gio
ImportError: No module named gmenu
Comment 15 Roberto Orden 2011-10-08 08:51:23 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
He instalado alacarte para gestionar el menu de aplicaciones, y asi poder insertar los enlaces de mis aplicaciones portables, como eclipse.
Comment 16 Laine Stump 2011-10-09 03:36:15 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I installed alacarte-0.13.2-3.fc16 on a F16 beta install, and attempted to run it immediately after installation was complete. Crash was immediate.
Comment 17 Michael 2011-10-12 03:58:30 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
i (will) start Alacarte whit shortcut [Alt]+[F2]
Comment 18 Micknut 2011-10-12 16:26:49 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Unable to launch the software on a new installation. It is in console mode like this : 
$ alacarte
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 22, in <module>
    from Alacarte.MainWindow import MainWindow
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 19, in <module>
    import gtk, gmenu, gobject, gio
ImportError: No module named gmenu
Comment 19 Jesse Hutton 2011-10-12 22:10:58 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Start up program -> crash
Comment 20 Doug Maxey 2011-10-13 16:44:44 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
1) yum download alacarte on x64
2) try to run it.
Comment 21 TSC 2011-10-16 01:37:23 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
add alacarte and execute it.. and error
Comment 22 luke_l 2011-10-16 11:47:24 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
run alacarte
Comment 23 Rick Leir 2011-10-17 19:44:16 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
yum install alacarte
run program

maybe gmenu.py should be a 'prerequisite' for alacarte
Comment 24 Adam Williamson 2011-10-18 14:21:28 EDT
*** Bug 742713 has been marked as a duplicate of this bug. ***
Comment 25 kingtomasmob 2011-10-20 10:10:27 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I want just run the program
Comment 26 kingtomasmob 2011-10-20 10:10:55 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I want just run the program
Comment 27 Tony Themelis 2011-10-21 18:39:22 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
installed alacarte in Fedora 16
Comment 28 dario 2011-10-27 16:02:36 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
just opened alacarte from the installer's window
Comment 29 Billy Crook 2011-10-27 21:40:17 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I right clicked the 'Applications' menu, and chose 'edit menues'.  In the abrt popup I noticed the binary name 'alacarte'.  So I ran it from a terminal, and for this stdout:

Traceback (most recent call last):
  File "/usr/bin/alacarte", line 22, in <module>
    from Alacarte.MainWindow import MainWindow
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 19, in <module>
    import gtk, gmenu, gobject, gio
ImportError: No module named gmenu

On a lark, I tried 'yum whatprovides '*/gmenu*', but it looks like the file containing that module is named something else.  I believe the bug here is that not all of alacart's dependancies are properly declared in its RPM specfile.
Comment 30 Billy Crook 2011-10-27 21:41:04 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I right clicked the 'Applications' menu, and chose 'edit menues'.  In the abrt popup I noticed the binary name 'alacarte'.  So I ran it from a terminal, and for this stdout:

Traceback (most recent call last):
  File "/usr/bin/alacarte", line 22, in <module>
    from Alacarte.MainWindow import MainWindow
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 19, in <module>
    import gtk, gmenu, gobject, gio
ImportError: No module named gmenu

On a lark, I tried 'yum whatprovides '*/gmenu*', but it looks like the file containing that module is named something else.  I believe the bug here is that not all of alacart's dependancies are properly declared in its RPM specfile.
Comment 31 Antonio Trande 2011-10-28 16:30:33 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Running 'alacarte'
Comment 32 Joseph D. Wagner 2011-10-31 03:16:20 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Attempted to run program.
Comment 33 Ryan 2011-10-31 22:35:50 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Installed the Menu editor for the GNOME desktop and when I went to run it I got this error. I'm on a virtualbox image if that helps.
Comment 34 Dan Beard 2011-11-01 00:15:10 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
trying to run alacarte after install
Comment 35 Oleg 2011-11-03 08:56:00 EDT
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
start alacarte
Comment 36 Pavel Roskin 2011-11-05 12:21:23 EDT
gnome-menus provided /usr/lib*/python*/site-packages/gmenu.so in Fedora 15, but not in Fedora 16.  yum cannot find the package providing gmenu.so.  This means alacarte is useless in Fedora 16.
Comment 37 Alex Wajda 2011-11-06 06:43:46 EST
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
just run the application
Comment 38 mutantehq 2011-11-06 09:47:50 EST
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
alacarte does not run on fedora 16.
Comment 39 Oded Arbel 2011-11-07 06:20:05 EST
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
install alacarte in Fedora 16, and when I try to run it - it crashes
Comment 40 Davide Repetto 2011-11-07 23:28:00 EST
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Right click on the (gnome fallback-mode) menu bar and select "Modifica Menu" (in english it should be sometning like "edit menus").
Comment 41 António 2011-11-08 11:44:08 EST
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Installed alacarte with gpk-application and clicked "Run" in the resulting dialog.
Comment 42 Marko 2011-11-08 14:28:59 EST
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Choose app from menu - that's all.
Comment 43 Sean Stangl 2011-11-08 15:06:58 EST
Package: alacarte-0.13.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Start alacarte with F16. Crashes immediately.
Comment 44 emoziko 2011-11-08 16:46:48 EST
Package: alacarte-0.13.2-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
I just tryed to launch alacarte. 
I updated my system from F15 to F16 about 1 hour ago.
Comment 45 Oleg 2011-11-09 00:29:47 EST
Fedora 16

[soz@localhost ~]$ alacarte
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 22, in <module>
    from Alacarte.MainWindow import MainWindow
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 19, in <module>
    import gtk, gmenu, gobject, gio
ImportError: No module named gmenu
[soz@localhost ~]$



???????????????????????
Comment 46 Victor Dolirio Ferreira Barbosa 2011-11-22 09:23:18 EST
Same problem of everyone.
Did someone make a work around for this problem???
Comment 47 Michael McLaughlin 2011-11-24 03:06:26 EST
It appears that the dependency is on:

/usr/lib64/python2.7/site-packages/gmenu.so

which was provided by the following in the last release:

gnome-menus-3.0.1-1.fc15.x86_64

The gmenu.so library isn't found in the package.
Comment 48 Michael McLaughlin 2011-11-24 13:23:00 EST
It's also missing the following symbolic link:

/usr/lib64/libgnome-menu.so.2

which should point to:

/usr/lib64/libgnome-menu.so.2.4.13

If you copy the library files from Fedora 15 to Fedora 16, Menu Editing (alacarte) works fine.
Comment 49 Michael McLaughlin 2011-11-24 13:29:43 EST
Excuse my adding this in a third comment, I should have put it all in one. The problem is that the alacarte-0.13.2-3.fc16.noarch package has a dependency on gnome-menus-3.2.0.1-1.fc16.x86_64 package, which is met but that version of the gnome-menus package requires these omitted libraries:

/usr/lib64/python2.7/site-packages/gmenu.so
/usr/lib64/libgnome-menu.so.2 (link)
/usr/lib64/libgnome-menu.so.2.4.13

They're present in the Fedora 15 package:

gnome-menus-3.0.1-1.fc15.x86_64
Comment 50 David Dreggors 2011-11-25 02:09:38 EST
This sounds like a good workaround but I cannot find 'gnome-menus-3.0.1-1.fc15.x86_64' in the stock repos. Where can I get that package from?

Is there any plan to give an updated package (alacarte or gnome-menus) for F16 that resolves this?
Comment 51 mfohler 2011-11-25 05:38:44 EST
I downloaded gnome-menus-3.0.1-1.fc15.x86_64 from this site:

http://pkgs.org/fedora-15/fedora-x86_64/gnome-menus-3.0.1-1.fc15.x86_64.rpm.html

Then I extracted the .rpm with the the following command (as root!):

rpm2cpio gnome-menus-3.0.1-1.fc15.x86_64.rpm | cpio -ivd

After copying (still as root) the three files mentioned in #49 manually to there locations alacarte starts fine now. Thanks for this workaround!
Comment 52 Victor Dolirio Ferreira Barbosa 2011-11-25 05:48:28 EST
An alternative workaround is to use lxmed. You'll need java installed. Although this excuse, everything works well.
Comment 53 barneyl 2011-11-28 12:57:38 EST
Here is a description of a fix.  http://blog.mclaughlinsoftware.com/2011/11/24/gnome-menu-editing-fix/
Comment 54 Adam Williamson 2011-12-06 19:12:50 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 55 Darr247 2011-12-27 10:30:50 EST
Is there a fix in the works for this yet?

I'd really rather not have to be copying files from different versions around as root, as that tends to snowball and soon you end up having to be root to do ANYthing... which means a new install in 6 months instead of just an upgrade.

Thanks.
Comment 56 Pavel Roskin 2011-12-27 21:31:57 EST
I tried compiling alacarte from git on Fedora 16.  Following is a simplified story.  I got the source by running

git clone git://git.gnome.org/alacarte

I tried applying patches from the GNOME bug 626220

https://bugzilla.gnome.org/show_bug.cgi?id=626220

The first patch appears to be applied already.  The second patch conflicts with the third.  As I understand, the second patch just changes the checks and the messages but doesn't affect the compilation, so I only applied the third patch.  I ensured I had the dependencies for building alacarte by doing:

yumdownloader --source alacarte
rpmbuild --rebuild alacarte*.src.rpm

I configured, compiled and installed alacarte from git by

./autogen.sh --prefix=/usr --libdir=/usr/lib64
make
su
make install

I found that the get_separator function introduced by the patch is missing, so I applied an extra hack to avoid it:

diff --git a/Alacarte/MainWindow.py b/Alacarte/MainWindow.py
index b5fc35b..e85e25f 100644
--- a/Alacarte/MainWindow.py
+++ b/Alacarte/MainWindow.py
@@ -250,7 +250,7 @@ class MainWindow:
 		self.item_store.clear()
 		for item, show in self.editor.getItems(menu):
 			menu_icon = None
-			if isinstance(item, GMenu.TreeSeparator):
+			if item == 'separator':
 				name = '---'
 				icon = None
 			elif isinstance(item, GMenu.TreeEntry):
diff --git a/Alacarte/MenuEditor.py b/Alacarte/MenuEditor.py
index 3ca8a0e..24f9552 100644
--- a/Alacarte/MenuEditor.py
+++ b/Alacarte/MenuEditor.py
@@ -199,7 +199,7 @@ class MenuEditor:
 		item_type = item_iter.next()
 		while item_type != GMenu.TreeItemType.INVALID:
 			if item_type == GMenu.TreeItemType.SEPARATOR:
-				item = item_iter.get_separator()
+				item = 'separator'
 				yield (item, True)
 			else:
 				if item_type == GMenu.TreeItemType.ENTRY:

With this, I got alacarte running.  However, it doesn't do anything useful.  It cannot create new menu items.  Icons are not shown properly.  There were some coredumps.

So that may be a starting point for somebody who wants to make alacarte working.  Don't worry about installing extra stuff.  "make uninstall" appears to be working correctly.

Speaking of Java implementations, they don't allow creating new items in the top-level Application menu, which is the main reason I need alacarte.  I don't want to go into submenus to run xterm or Firefox.

I'm not very enthusiastic about learning Python and GNOME internals, as I have a lot of stuff on my plate.  I did my part, I tested the code.
Comment 57 Darr247 2011-12-27 22:19:26 EST
> With this, I got alacarte running.  However,
> it doesn't do anything useful.  It cannot
> create new menu items. 
> Icons are not shown properly.

I got it running OK using the 'steal 3 files from the fc15 rpm' kludge,
/usr/lib64/libgnome-menu.so.2
/usr/lib64/libgnome-menu.so.2.4.13 and
/usr/lib64/python2.7/site-packages/gmenu.so

from gnome-menus-3.0.1-1.fc15.x86_64.rpm

but after that, my experience with it running so far matches yours. No items I create with it actually show up in the menus, and even just changing the names or tooltip descriptions of an existing shortcut (e.g. so gnome-system-monitor and ksysguard have different shortcut names in the menu) does not show up.
Comment 58 David Batson 2011-12-30 12:03:36 EST
Same problem here with alacarte.

Add me to the list of "holding our breath".
Comment 59 Darr247 2011-12-30 14:51:20 EST
You should join the list at # 752238 too, since it's the same bug. :-)
Comment 60 Chris Pearce 2012-03-11 18:31:06 EDT
I'm sure this will be fixed soon, but in the mean time people who want to change their menu items can work around this bug by editing the *.desktop files in /usr/share/applications/.
Comment 61 Michael Cronenworth 2012-03-14 17:54:56 EDT
*** Bug 789082 has been marked as a duplicate of this bug. ***
Comment 62 Michael Cronenworth 2012-03-14 17:55:06 EDT
*** Bug 783766 has been marked as a duplicate of this bug. ***
Comment 63 Michael Cronenworth 2012-03-14 17:55:10 EDT
*** Bug 769736 has been marked as a duplicate of this bug. ***
Comment 64 Michael Cronenworth 2012-03-14 17:55:15 EDT
*** Bug 769345 has been marked as a duplicate of this bug. ***
Comment 65 Michael Cronenworth 2012-03-14 17:55:41 EDT
*** Bug 768985 has been marked as a duplicate of this bug. ***
Comment 66 Michael Cronenworth 2012-03-14 17:55:48 EDT
*** Bug 768697 has been marked as a duplicate of this bug. ***
Comment 67 Michael Cronenworth 2012-03-14 17:55:54 EDT
*** Bug 768633 has been marked as a duplicate of this bug. ***
Comment 68 Michael Cronenworth 2012-03-14 17:56:12 EDT
*** Bug 768591 has been marked as a duplicate of this bug. ***
Comment 69 Michael Cronenworth 2012-03-14 17:56:18 EDT
*** Bug 768565 has been marked as a duplicate of this bug. ***
Comment 70 Michael Cronenworth 2012-03-14 17:56:26 EDT
*** Bug 768345 has been marked as a duplicate of this bug. ***
Comment 71 Michael Cronenworth 2012-03-14 17:56:58 EDT
*** Bug 768280 has been marked as a duplicate of this bug. ***
Comment 72 Michael Cronenworth 2012-03-14 17:57:10 EDT
*** Bug 767999 has been marked as a duplicate of this bug. ***
Comment 73 Michael Cronenworth 2012-03-14 17:57:20 EDT
*** Bug 767782 has been marked as a duplicate of this bug. ***
Comment 74 Michael Cronenworth 2012-03-14 17:58:14 EDT
*** Bug 767626 has been marked as a duplicate of this bug. ***
Comment 75 Michael Cronenworth 2012-03-14 17:58:31 EDT
*** Bug 767587 has been marked as a duplicate of this bug. ***
Comment 76 Michael Cronenworth 2012-03-14 17:58:37 EDT
*** Bug 767586 has been marked as a duplicate of this bug. ***
Comment 77 Michael Cronenworth 2012-03-14 17:58:42 EDT
*** Bug 767491 has been marked as a duplicate of this bug. ***
Comment 78 Michael Cronenworth 2012-03-14 17:58:48 EDT
*** Bug 766975 has been marked as a duplicate of this bug. ***
Comment 79 Michael Cronenworth 2012-03-14 17:59:29 EDT
*** Bug 766973 has been marked as a duplicate of this bug. ***
Comment 80 Michael Cronenworth 2012-03-14 17:59:42 EDT
*** Bug 766927 has been marked as a duplicate of this bug. ***
Comment 81 Michael Cronenworth 2012-03-14 17:59:54 EDT
*** Bug 766843 has been marked as a duplicate of this bug. ***
Comment 82 Michael Cronenworth 2012-03-14 18:00:05 EDT
*** Bug 766492 has been marked as a duplicate of this bug. ***
Comment 83 Michael Cronenworth 2012-03-14 18:00:13 EDT
*** Bug 766444 has been marked as a duplicate of this bug. ***
Comment 84 Ulrich Hobelmann 2012-03-23 15:12:44 EDT
The problem still occurs on Fedora 17.
Comment 85 Nathan Humphreys 2012-05-30 07:00:42 EDT
I started alacarte on fedora 17 running gnome 3.4 and it crashed immediately
Here is the output from running it from the terminal


*** (process:18725): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:18725): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:18725): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 22, in <module>
    from Alacarte.MainWindow import MainWindow
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 19, in <module>
    import gtk, gmenu, gobject, gio
ImportError: No module named gmenu


Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 86 Gerhard 2012-05-30 07:01:58 EDT
Trying to start Alacarte.

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 87 Pavel Roskin 2012-05-30 07:05:35 EDT
alacarte 0.13.3 was released recently, and it's supposed to address those issues.  I tried it both on Fedora 16 and Fedora 17, but could not get it to work.  Maybe the Fedora packagers could backport the new alacarte to the versions of GNOME shipped by Fedora?
Comment 88 Oleg 2012-05-31 11:50:34 EDT
Start

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 89 M D 2012-05-31 18:20:58 EDT
Opened alacarte

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 90 Yajo 2012-06-01 10:03:56 EDT
Open alacarte. I can't believe this wasn't corrected in the whole F16 release.

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 91 Bob Schultz 2012-06-01 11:47:11 EDT
Attempted to edit Applications menu by right-clicking "Applications" in upper lefthand screen corner (using fallback mode).

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 92 Fedora Update System 2012-06-01 12:26:02 EDT
alacarte-0.13.4-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/alacarte-0.13.4-4.fc16
Comment 93 Fedora Update System 2012-06-01 12:26:05 EDT
alacarte-0.13.4-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/alacarte-0.13.4-4.fc17
Comment 94 Artyom Kunyov 2012-06-01 12:47:45 EDT
Now with alacarte-0.13.4-4.fc17 it launches, but doesn't hide entries from Applications menu.
Comment 95 Pavel Roskin 2012-06-01 13:00:01 EDT
Some thing on Fedora 16. The package builds and runs. However, no items can be created/deleted or enabled/disabled. Only property editing is working. Users will be greatly disappointed. But it's better than a package that doesn't run at all and triggers abrt. At least there would be no automatic reports about a well known problem. There is a lot of development done on alacarte upstream, so I invite everyone who has time and knowledge to work on the upstream code.
Comment 96 Ray Strode [halfline] 2012-06-01 14:10:45 EDT
(note the fedora maintainer and upstream maintainer of alacarte are the same person)
Comment 97 Matthias Clasen 2012-06-01 14:42:42 EDT
Creating items works fine where in F18. I do notice that the new items do not show up in the category I create them in the shell overview though - I created a 'test' item in accessories, launching gnome-terminal, and it showed up next to the gnome-terminal launcher in 'system tools'
Comment 98 Fedora Update System 2012-06-01 23:51:07 EDT
Package alacarte-0.13.4-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing alacarte-0.13.4-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8752/alacarte-0.13.4-4.fc16
then log in and leave karma (feedback).
Comment 99 rvcsaba 2012-06-02 04:28:26 EDT
alacarte 
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 36, in <module>
    main()
  File "/usr/bin/alacarte", line 33, in main
    app.run()
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 64, in run
    self.loadMenus()
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 203, in loadMenus
    self.on_menu_tree_cursor_changed(menu_tree)
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 354, in on_menu_tree_cursor_changed
    self.loadItems(self.menu_store[menu_path][2], menu_path)
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 217, in loadItems
    for item, show in self.editor.getItems(menu):
  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 145, in getItems
    item = item_iter.get_separator()
AttributeError: 'TreeIter' object has no attribute 'get_separator'

I use Fedora 17 and alacarte-0.13.4-4.fc17.noarch.
Comment 100 Mohammad Razeghi 2012-06-02 08:15:32 EDT
just launch it !

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 101 Vilhjálmur Magnússon 2012-06-02 14:14:03 EDT
Trying to run alacarte

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 102 Raphael Groner 2012-06-02 15:02:49 EDT
Please please, let Alacarte die. :)

It's a real mess about reading all that constant howling for a well working menu editor that works for all desktop environments. Xfce tried to adopt the specifications made originally by the Gnome team in times where Gnome2 was the state of the art and it was changed again for Gnome3. I don't know what counts for KDE and those different single window managers only. Okay, Fedora goes with Gnome3 and there are those both serious spins Xfce and KDE - I guess the remaining stuff does not count really here.
Comment 103 Bill Boyd 2012-06-02 19:56:57 EDT
trying to run Gnome menu tweak

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 104 LeRoy Madison JR 2012-06-02 20:11:48 EDT
Error while trying to open main menu

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 105 LeRoy Madison JR 2012-06-02 20:14:09 EDT
Error while trying to open main menu after upgrading Fedora 16 to 17

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 106 rvcsaba 2012-06-02 20:15:55 EDT
(In reply to comment #103)
> trying to run Gnome menu tweak
> 
> Package: alacarte-0.13.2-3.fc16
> OS Release: Fedora release 17 (Beefy Miracle)

I use Xfce 4.10. I clicked right button to applications menu, I use Edit Menu. This button call alacarte, but crash it. (I don't use Gnome.)
Comment 107 Pavel Roskin 2012-06-03 00:29:58 EDT
(In reply to comment #102)
I need alacarte to edit menus on LXDE.  I would prefer to use an utility that doesn't depend on GNOME, but it doesn't exist.  I would prefer to have a desktop-independent menu specification and a desktop-independent menu editor, but it's outside the scope of this issue.  alacarte is needed to edit menus currently used by some of the desktop environments shipped by Fedora.
Comment 108 Raphael Groner 2012-06-03 02:29:14 EDT
(In reply to comment #107)
> (In reply to comment #102)
> I need alacarte to edit menus on LXDE.  I would prefer to use an utility
> that doesn't depend on GNOME, but it doesn't exist. 

There's lxmed. Unfortunately, it is written in Java and therefore needs a JVM.

> I would prefer to have
> a desktop-independent menu specification and a desktop-independent menu
> editor, but it's outside the scope of this issue. 

I know that my comment #102 is fully outside of this bug report. I could not resist with my general comment any more, at least cause of the amount of commitment already here. Sorry about that. Everyone seems to whine about a missing menu editor that fits its special user needs, but nobody starts to code. Why?

> alacarte is needed to
> edit menus currently used by some of the desktop environments shipped by
> Fedora.

+1

Though, there should be something that integrates better into Xfce and LXDE. But outside of this scope. :)
Comment 109 LeRoy Madison JR 2012-06-03 12:49:55 EDT
After Upgrade to Fedora 17 from 16 opening main menu causes error

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 110 Zamir García 2012-06-03 13:55:05 EDT
Open aplication

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 111 Boyd 2012-06-03 13:58:50 EDT
Running Fedora 17 with alacarte-0.13.4-4.fc17.  I am not able to uncheck the 'Show' checkbox for any menu item.  when I click on the box, the check mark momentarily clears for 1 second, then the check mark reappears by itself.

Interestingly, items that are already unchecked, can then be checked, but once this is done, unchecking is not possible.
Comment 112 Filippo Racca 2012-06-03 22:37:32 EDT
launching alacarte

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 113 Basil Mohamed Gohar 2012-06-04 09:45:57 EDT
I just tried to load it immediately after it had finished installing.  I was planning to use it to create a custom application launcher for Aptana.

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 114 Oleg 2012-06-04 12:36:28 EDT
It downloaded and established:

avant-window-navigator-devel-0.4.1-0.4.bzr830.fc16.i686.rpm
python-desktop-agnostic-0.3.92-1.fc16.i686.rpm
libdesktop-agnostic-bin-0.3.92-1.fc16.i686.rpm
libdesktop-agnostic-0.3.92-1.fc16.i686.rpm
awn-extras-applets-0.4.2-0.6.bzr1537.fc16.i686.rpm

Then it established:

avant-window-navigator-0.4.1-0.4.bzr830.fc16.i686.rpm

Thus far it works.
Comment 115 Oleg 2012-06-04 12:40:04 EDT
????????????????????????????????????
Comment 116 Adam Williamson 2012-06-04 13:29:49 EDT
(In reply to comment #102)
> Please please, let Alacarte die. :)
> 
> It's a real mess about reading all that constant howling for a well working
> menu editor that works for all desktop environments. Xfce tried to adopt the
> specifications made originally by the Gnome team in times where Gnome2 was
> the state of the art and it was changed again for Gnome3. I don't know what
> counts for KDE and those different single window managers only. Okay, Fedora
> goes with Gnome3 and there are those both serious spins Xfce and KDE - I
> guess the remaining stuff does not count really here.

The desktop menu spec is a Freedesktop standard:

http://standards.freedesktop.org/menu-spec/latest/

and is well respected by GNOME, KDE, LXDE and Xfce. it has not changed in any significant way between the time of GNOME 2 and that of GNOME 3.

So I'm not really sure what you're talking about...
Comment 117 Aleš Zelený 2012-06-04 14:11:09 EDT
I've tried to run MainMenu application.

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 118 Philippe Troin 2012-06-04 14:44:26 EDT
(In reply to comment #111)
> Running Fedora 17 with alacarte-0.13.4-4.fc17.  I am not able to uncheck the
> 'Show' checkbox for any menu item.  when I click on the box, the check mark
> momentarily clears for 1 second, then the check mark reappears by itself.
> 
> Interestingly, items that are already unchecked, can then be checked, but
> once this is done, unchecking is not possible.

Seeing the same behavior with alacarte-0.13.4-4.fc17.noarch.
Comment 119 Kaspars Mickevics 2012-06-04 18:19:47 EDT
just trying to run  alacarte


PackageKit-gtk3-module-0.7.4-4.fc17.x86_64 is installed

Looks similar to: https://bugzilla.redhat.com/show_bug.cgi?id=643129#c27


Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 120 pcr 2012-06-05 00:51:40 EDT
Import error.  No module named gmenu-abrt-applet.

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 121 Matthieu Pupat 2012-06-05 05:22:27 EDT
$ sudo yum install alacarte
$ alacarte


Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 122 graf.drakul 2012-06-06 03:40:22 EDT
try to start alacarte

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 123 John Sheppard 2012-06-07 02:15:56 EDT
alacarte crashes immediately.

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 124 Gene Snider 2012-06-07 17:52:29 EDT
I tried to run alacarte after installing it from the fedora repo.

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 125 Olivier Penhoat 2012-06-08 02:57:33 EDT
Launch alacarte

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 126 Baleta 2012-06-08 07:52:57 EDT
preupgrade from Fedora16 to Fedora17

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 127 mr.maxime.sauvage 2012-06-08 09:49:19 EDT
lancement de alacarte

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 128 Matthias Dieter Wallnöfer 2012-06-08 11:50:46 EDT
Running "alacarte" on the shell

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 16 (Verne)
Comment 129 Leslie Satenstein 2012-06-09 00:08:32 EDT
Using Gnome tweaks, clicked on the icon and this is the result.

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 130 Mohammad Razeghi 2012-06-09 13:32:55 EDT
just run it!

Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 131 gatlibs 2012-06-09 20:53:44 EDT
Start using Activities' menu. It also didn't start from the terminal; giving the following:
$ alacarte

** (process:28352): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:28352): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:28352): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 22, in <module>
    from Alacarte.MainWindow import MainWindow
  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 19, in <module>
    import gtk, gmenu, gobject, gio
ImportError: No module named gmenu


Package: alacarte-0.13.2-3.fc16
OS Release: Fedora release 17 (Beefy Miracle)
Comment 132 Fedora Update System 2012-06-10 19:56:39 EDT
alacarte-0.13.4-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 133 Boyd 2012-06-11 22:07:22 EDT
Please see comment 111.
https://bugzilla.redhat.com/show_bug.cgi?id=734442#c111

This issue applies to alacarte-0.13.4-4.fc17.

Thanks!

(In reply to comment #132)
> alacarte-0.13.4-4.fc17 has been pushed to the Fedora 17 stable repository. 
> If problems still persist, please make note of it in this bug report.
Comment 134 Ray Strode [halfline] 2012-06-12 09:59:59 EDT
Boyd, would you mind filing that issue upstream at bugzilla.gnome.org ?
Comment 135 Boyd 2012-06-12 15:41:43 EDT
(In reply to comment #134)
> Boyd, would you mind filing that issue upstream at bugzilla.gnome.org ?

Done.

https://bugzilla.gnome.org/show_bug.cgi?id=677972
Comment 136 Fedora Update System 2012-06-13 17:39:19 EDT
alacarte-0.13.4-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 137 Ray Strode [halfline] 2012-07-24 11:38:47 EDT
*** Bug 752238 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.