Bug 74521 - SRPM doesn't compile
SRPM doesn't compile
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Mike McLean
:
: 73624 74755 75277 75336 76844 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-25 18:28 EDT by Kevin Sonney
Modified: 2013-04-02 00:17 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-12 08:12:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Nearly fixed spec (14.80 KB, text/plain)
2002-09-27 15:22 EDT, Kevin Sonney
no flags Details
tarball of new IM patches and spec file (7.45 KB, application/octet-stream)
2002-10-11 16:29 EDT, Eric Bourque
no flags Details

  None (edit)
Description Kevin Sonney 2002-09-25 18:28:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
The shipping ImageMagic Source RPM for psyche fails at package time with
orphened files. Mostly stuff for the -devel rpm

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. get ImageMagick SRPM
2. rpm -ivh same
3. rpmbuild -ba path/to/ImageMagick.spec
	

Actual Results:  RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/X11R6/include/X11/magick/magick/PreRvIcccm.h
   /usr/X11R6/include/X11/magick/magick/api.h
   /usr/X11R6/include/X11/magick/magick/attribute.h
   /usr/X11R6/include/X11/magick/magick/blob.h
   /usr/X11R6/include/X11/magick/magick/cache.h
   /usr/X11R6/include/X11/magick/magick/cache_view.h
   /usr/X11R6/include/X11/magick/magick/classify.h
   /usr/X11R6/include/X11/magick/magick/compress.h
   /usr/X11R6/include/X11/magick/magick/delegate.h
   /usr/X11R6/include/X11/magick/magick/draw.h
   /usr/X11R6/include/X11/magick/magick/error.h
   /usr/X11R6/include/X11/magick/magick/gem.h
   /usr/X11R6/include/X11/magick/magick/image.h
   /usr/X11R6/include/X11/magick/magick/list.h
   /usr/X11R6/include/X11/magick/magick/magic.h
   /usr/X11R6/include/X11/magick/magick/magick.h
   /usr/X11R6/include/X11/magick/magick/magick_config.h
   /usr/X11R6/include/X11/magick/magick/module.h
   /usr/X11R6/include/X11/magick/magick/monitor.h
   /usr/X11R6/include/X11/magick/magick/quantize.h
   /usr/X11R6/include/X11/magick/magick/registry.h
   /usr/X11R6/include/X11/magick/magick/render.h
   /usr/X11R6/include/X11/magick/magick/semaphore.h
   /usr/X11R6/include/X11/magick/magick/timer.h
   /usr/X11R6/include/X11/magick/magick/utility.h
   /usr/X11R6/include/X11/magick/magick/version.h
   /usr/X11R6/include/X11/magick/magick/widget.h
   /usr/X11R6/include/X11/magick/magick/xwindow.h
   /usr/X11R6/lib/ImageMagick/delegates.mgk
   /usr/X11R6/lib/ImageMagick/type-ghostscript.mgk
   /usr/X11R6/lib/ImageMagick/type-solaris.mgk
   /usr/X11R6/lib/ImageMagick/type-windows.mgk
   /usr/X11R6/lib/ImageMagick/type.mgk
   /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/perllocal.pod


Expected Results:  RPMS I can install.

Additional info:

The new maintainer for the package should look into this. It's an easy enough
fix to the spec file, I'm sure. Heck, I'll probably have a patch later today.
Comment 1 Kevin Sonney 2002-09-27 15:22:04 EDT
Created attachment 77524 [details]
Nearly fixed spec
Comment 2 Kevin Sonney 2002-09-27 15:23:55 EDT
OK, attached a specfile that does everything except a post install/uninstall fix
to the system's perllocal.pod files. 

Good luck, and my the new owner (not me!) give it a final fix.
Comment 3 Tom "spot" Callaway 2002-10-01 10:19:30 EDT
*** Bug 74755 has been marked as a duplicate of this bug. ***
Comment 4 Nils Philippsen 2002-10-11 14:15:52 EDT
*** Bug 73624 has been marked as a duplicate of this bug. ***
Comment 5 Nils Philippsen 2002-10-11 14:17:07 EDT
*** Bug 75277 has been marked as a duplicate of this bug. ***
Comment 6 Nils Philippsen 2002-10-11 14:18:23 EDT
*** Bug 75336 has been marked as a duplicate of this bug. ***
Comment 7 Eric Bourque 2002-10-11 16:27:42 EDT
As I mentioned in 75336, I created a patch for the spec file which seemed to work.

Since then, I made some more changes since the magick/image.h file assumed the
inclusion of <stdlib.h> and <stdio.h> (and hence didn't work with gcc-3.2), and
decided to upgrade to the 5.4.9-1 source at the same time which required
updating some of the previous RH patches for IM.

The paths for ImageMagick includes have always bothered me somewhat in the
RedHat packaging - the idea of having a /usr/X11R6/include/X11/magick/magick <-
yes two magicks seems wrong. My patches and new spec file put all the C IM
headers in /usr/X1R6/include/X11/magick, and puts the main C++ header there and
the other C++ headers in /usr/X11R6/include/X11/magick/Magick++. I patched the
Magick-config files to return the appropriate paths: Magick-config --cppflags
returns /usr/X11R6/include/X11 so that #include <magick/api.h> works as in the
examples, and Magick++-config --cppflags returns /usr/X11R6/include/X11/magick
so that #include <Magick++.h> and #include <Magick++/Image.h> work as in the
examples.

I will upload the patches and new spec file here, but if you want to have a look
at the new srpm, you can get it from here:

ftp://ftp.cim.mcgill.ca/pub/people/ericb/rpm/SRPMS/ImageMagick-5.4.9.1-1.src.rpm
Comment 8 Eric Bourque 2002-10-11 16:29:03 EDT
Created attachment 80044 [details]
tarball of new IM patches and spec file
Comment 9 Mike McLean 2002-11-11 11:28:23 EST
*** Bug 76844 has been marked as a duplicate of this bug. ***
Comment 10 Bernie Innocenti 2002-11-12 19:17:30 EST
Also the binary RPM ImageMagick-devel is missing some header files (magick_config.h, api.h 
and possibily others). 

Note You need to log in before you can comment on or make changes to this bug.