Bug 799168 - [abrt] kernel: WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
[abrt] kernel: WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:799...
Status: CLOSED DUPLICATE of bug 873914
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Greene
Fedora Extras Quality Assurance
abrt_hash:717f2250025ab734c50dba7dd1f...
:
: 806450 817241 818432 819561 847749 848077 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 19:56 EST by Bruno Martins
Modified: 2013-02-07 11:36 EST (History)
29 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 11:36:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
brcmsmac: dmesg output of backtrace (2.12 KB, text/plain)
2012-04-26 03:34 EDT, Sebastian Krämer
no flags Details
abrt logger report (77.47 KB, text/x-log)
2012-09-04 20:16 EDT, Ankur Sinha (FranciscoD)
no flags Details

  None (edit)
Description Bruno Martins 2012-03-01 19:56:54 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-0.rc3.git7.2.fc17.x86_64 root=UUID=a1ccafce-671a-4181-9a2c-4d351f00c140 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=pt-latin1 rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.3.0-0.rc3.git7.2.fc17.x86_64
reason:         WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
time:           Fri 02 Mar 2012 12:50:18 AM WET

backtrace:
:WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
:Hardware name: HP G62 Notebook PC              
:Modules linked in: fuse binfmt_misc be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables arc4 brcmsmac snd_hda_codec_hdmi cordic crc8 brcmutil b43 mac80211 snd_hda_codec_realtek uvcvideo cfg80211 ssb hp_wmi sparse_keymap rfkill snd_hda_intel videobuf2_vmalloc videobuf2_memops videobuf2_core videodev v4l2_compat_ioctl32 media mmc_core snd_hda_codec snd_hwdep r8169 iTCO_wdt mii snd_pcm snd_page_alloc iTCO_vendor_support i2c_i801 serio_raw microcode snd_timer bcma snd soundcore uinput wmi usb_storage uas i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 4200, comm: kworker/u:1 Not tainted 3.3.0-0.rc3.git7.2.fc17.x86_64 #1
:Call Trace:
: [<ffffffff81060bef>] warn_slowpath_common+0x7f/0xc0
: [<ffffffffa03e8d64>] ? brcms_msleep+0x34/0x40 [brcmsmac]
: [<ffffffff81060c4a>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa03f53f9>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
: [<ffffffffa03e735b>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
: [<ffffffffa02dd031>] ieee80211_scan_work+0x3a1/0x740 [mac80211]
: [<ffffffff81083c3c>] ? process_one_work+0x17c/0x680
: [<ffffffff81083ca4>] process_one_work+0x1e4/0x680
: [<ffffffff81083c3c>] ? process_one_work+0x17c/0x680
: [<ffffffffa02dcc90>] ? ieee80211_scan_rx+0x1a0/0x1a0 [mac80211]
: [<ffffffff810844b6>] worker_thread+0x126/0x2d0
: [<ffffffff81084390>] ? rescuer_thread+0x210/0x210
: [<ffffffff8108a247>] kthread+0xb7/0xc0
: [<ffffffff810cd7cd>] ? trace_hardirqs_on+0xd/0x10
: [<ffffffff816a8374>] kernel_thread_helper+0x4/0x10
: [<ffffffff8169e230>] ? _raw_spin_unlock_irq+0x30/0x50
: [<ffffffff8169e734>] ? retint_restore_args+0x13/0x13
: [<ffffffff8108a190>] ? kthread_worker_fn+0x1a0/0x1a0
: [<ffffffff816a8370>] ? gs_change+0x13/0x13

smolt_data:
:
:
:General
:=================================
:UUID: 51f8ab96-80a2-4f96-841b-128c2c7deb4f
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4532.94
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i3 CPU       M 350  @ 2.27GHz
:CPU Stepping: 5
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2266
:System Memory: 3728
:System Swap: 5791
:Vendor: Hewlett-Packard
:System: HP G62 Notebook PC 0594110000252710001020100
:Form factor: Notebook
:Kernel: 3.3.0-0.rc3.git7.2.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(5348:18215:4156:5212) pci, bcma-pci-bridge, NETWORK, BCM4313 802.11b/g/n Wireless LAN Controller
:(4332:33078:4156:5177) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:70:4156:5177) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15145:4156:5177) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 4 port SATA AHCI Controller
:(32902:15170:4156:5177) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15113:4156:5177) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:11537:4156:5177) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11536:4156:5177) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11539:4156:5177) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15190:4156:5177) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15174:4156:5177) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 3
:(32902:15152:4156:5177) pci, None, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:9288:4156:5177) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:11538:4156:5177) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15164:4156:5177) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:4156:5177) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:68:4156:5177) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:15204:4156:5177) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:11521:4156:5177) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:11362:4156:5177) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 13092026 11699478 11568428 3276800 3129018 3129018
:/dev/sda2 /boot ext4 1024 1024 508745 456896 431296 128016 127786 127786
:/dev/sda5 /home ext4 4096 4096 63350649 59548339 56377127 15859712 15859165 15859165
:
Comment 1 John W. Linville 2012-03-06 13:43:36 EST
These upstream patches should address the issue.  They will be in the final 3.3 (or 3.3-rc7 if there is one)...

commit 2b0a53d51b5f263bb581bbdb40ebb9f7e09609b1
Author: Arend van Spriel <arend@broadcom.com>
Date:   Thu Feb 23 18:38:23 2012 +0100

    brcm80211: smac: only print block-ack timeout message at trace level
    
    In regular use block-ack timeouts can happen so it does not make
    sense to fill the log with these messages.
    
    Reviewed-by: Pieter-Paul Giesberts <pieterpg@broadcom.com>
    Reviewed-by: Alwin Beukers <alwin@broadcom.com>
    Signed-off-by: Arend van Spriel <arend@broadcom.com>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>

commit 85091fc0a75653e239dc8379658515e577544927
Author: Arend van Spriel <arend@broadcom.com>
Date:   Thu Feb 23 18:38:22 2012 +0100

    brcm80211: smac: fix endless retry of A-MPDU transmissions
    
    The A-MPDU code checked against a retry limit, but it was using
    the wrong variable to do so. This patch fixes this to assure
    proper retry mechanism.
    
    This problem had a side-effect causing the mac80211 flush callback
    to remain waiting forever as well. That side effect has been fixed
    by commit by Stanislaw Gruszka:
    
    commit f96b08a7e6f69c0f0a576554df3df5b1b519c479
    Date:   Tue Jan 17 12:38:50 2012 +0100
    
        brcmsmac: fix tx queue flush infinite loop
    
        Reference:
        https://bugzilla.kernel.org/show_bug.cgi?id=42576
    
    Cc: Stanislaw Gruszka <sgruszka@redhat.com>
    Reviewed-by: Pieter-Paul Giesberts <pieterpg@broadcom.com>
    Reviewed-by: Alwin Beukers <alwin@broadcom.com>
    Signed-off-by: Arend van Spriel <arend@broadcom.com>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>
Comment 2 Dave Jones 2012-03-23 10:44:52 EDT
we're still getting reports of this in 3.3 (See bug 806194)
Comment 3 Dave Jones 2012-03-23 15:16:39 EDT
*** Bug 806450 has been marked as a duplicate of this bug. ***
Comment 4 Dave Johnson 2012-03-25 19:50:40 EDT
I ran a yum provides query and then went back to my xchat session while I waited for that to process.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 John W. Linville 2012-03-26 10:18:28 EDT
Arend and/or Stanislaw, do you have any ideas about why this WARNING still happens?  Did I misdiagnose it in comment 1?
Comment 6 Sebastian Krämer 2012-04-26 03:34:32 EDT
Created attachment 580390 [details]
brcmsmac: dmesg output of backtrace

I see the same warning+crash with the same driver on F17 Beta (kernel 3.3.2-8.fc17.x86_64), also a HP notebook (HP 625, to be exact; I can provide a smolt link).
The problem is related to pairing via bluetooth. Bluetooth and Wifi are hardwired/connected in this device, it appears. The bluetooth connection only holds a few seconds, afterwards I see this dmesg output. Sometimes the bluetooth-applet is in an inconsistens state.
The computer had SUSE Enterprise preinstalled where paring and BT audio worked flawlessly. Unfortunately, I don't know any software+kernel version numbers.

Anything else I can do to help/debug? Would be great to see this fixed in F17 final.
Comment 7 Sebastian Krämer 2012-04-26 04:14:09 EDT
Thinking about it, I'm rather sure now that the SUSE system used the non-free broadcom-wl driver so the results aren't really comparable.
With bluetooth-wl, bluetooth connections are still non-working so my above comment is rather misleading. The warning/crash however did happen in connection with a BT connection attempt.
Comment 8 Arend van Spriel 2012-04-26 07:36:57 EDT
The message can also occur with regulatory domain including channels 12 and 13. Another patch is in upstream kernel:

brcm80211: smac: resume transmit fifo upon receiving frames

There have been reports about not being able to use access-points
on channel 12 and 13 or having connectivity issues when these channels
were part of the selected regulatory domain. Upon switching to these
channels the brcmsmac driver suspends the transmit dma fifos. This
patch resumes them upon handing over the first received beacon to
mac80211.
Comment 9 John W. Linville 2012-04-26 14:03:48 EDT
F17 test kernels w/ the patch mentioned in comment 8 are building here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4026143

When they finish building, please give them a try and post the results here -- thanks!
Comment 10 John W. Linville 2012-04-30 13:29:50 EDT
*** Bug 817241 has been marked as a duplicate of this bug. ***
Comment 11 Jurgen Kramer 2012-05-01 11:33:49 EDT
I am seeing the same call trace as comment #1 on my Macbookair3,1 since installing the latest kernel (3.3.4-1 x86_64). So far it only seems to happen once per boot (happens when enabling?).

kernel mentioned in comment #9 does not seem to be available.


Included some relevant log messages:

[  124.086939] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)
[  180.007662] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  180.007901] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  183.122229] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  183.122802] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  240.008123] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  240.013898] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  245.517120] ------------[ cut here ]------------
[  245.517190] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:8006 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
[  245.517197] Hardware name: MacBookAir3,1
[  245.517201] Modules linked in: fuse lockd sunrpc ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ebtable_nat ebtables ip6table_mangle ip6t_REJECT nf_
conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf
_conntrack rfcomm bnep be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi
_tcp libiscsi_tcp libiscsi scsi_transport_iscsi arc4 snd_hda_codec_hdmi brcmsmac snd_hda_codec_cirrus cordic crc8 brcmutil nls_utf8 mac80211 hfsplus cfg80211 uvcvideo
 videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media btusb bluetooth rfkill microcode applesmc input_polldev bcma bcm5974 shpchp snd_hda_intel snd_hda_co
dec snd_hwdep snd_pcm snd_page_alloc snd_timer snd soundcore apple_bl vhost_net tun macvtap macvlan kvm_intel kvm uinput nouveau mxm_wmi wmi video drm_kms_helper ttm 
drm i2c_core [last unloaded: scsi_wait_scan]
[  245.517375] Pid: 5, comm: kworker/u:0 Not tainted 3.3.4-1.fc17.x86_64 #1
[  245.517381] Call Trace:
[  245.517398]  [<ffffffff810568af>] warn_slowpath_common+0x7f/0xc0
[  245.517408]  [<ffffffff8105690a>] warn_slowpath_null+0x1a/0x20
[  245.517438]  [<ffffffffa0435eb9>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
[  245.517462]  [<ffffffffa042834b>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
[  245.517504]  [<ffffffffa03aaabe>] ieee80211_scan_work+0x34e/0x590 [mac80211]
[  245.517515]  [<ffffffff8101272b>] ? __switch_to+0x12b/0x420
[  245.517526]  [<ffffffff81071b59>] process_one_work+0x129/0x3f0
[  245.517562]  [<ffffffffa03aa770>] ? ieee80211_scan_rx+0x1a0/0x1a0 [mac80211]
[  245.517572]  [<ffffffff81073396>] worker_thread+0x126/0x2d0
[  245.517581]  [<ffffffff81073270>] ? manage_workers.isra.25+0x1f0/0x1f0
[  245.517590]  [<ffffffff81078843>] kthread+0x93/0xa0
[  245.517602]  [<ffffffff815f4fa4>] kernel_thread_helper+0x4/0x10
[  245.517610]  [<ffffffff810787b0>] ? flush_kthread_worker+0x80/0x80
[  245.517617]  [<ffffffff815f4fa0>] ? gs_change+0x13/0x13
[  245.517623] ---[ end trace 2671b7a34bb4ec49 ]---
[  245.526117] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 157
[  245.906085] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 161
[  246.432725] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  246.432842] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  327.175305] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  327.175873] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  420.009485] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  420.010076] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  420.836438] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 3
[  421.464622] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 6
[  421.464689] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 6
[  424.929636] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 153
[  425.304234] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 157
[  425.304234] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 157
[  546.464421] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 157
[  546.464444] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 157
[  660.006167] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  660.006493] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  666.964691] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  784.597399] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 48
[  785.701117] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 165
[  785.886552] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  785.886768] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  903.044414] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 11
[  903.044442] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 11
[  903.044499] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 11
[  904.009498] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 36
[  906.297608] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  906.297888] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[  934.249329] ieee80211 phy0: brcms_c_prec_enq_head: No where to go, prec == 4
[  934.249329] ieee80211 phy0: brcms_c_prec_enq_head: No where to go, prec == 4
[  934.249329] ieee80211 phy0: brcms_c_prec_enq_head: No where to go, prec == 4
[  934.249329] ieee80211 phy0: brcms_c_prec_enq_head: No where to go, prec == 4
[  934.249329] ieee80211 phy0: brcms_c_prec_enq_head: No where to go, prec == 4
[  934.249329] ieee80211 phy0: brcms_c_prec_enq_head: No where to go, prec == 4
[  934.249329] ieee80211 phy0: brcms_c_prec_enq_head: No where to go, prec == 4
[  934.249329] ieee80211 phy0: brcms_c_prec_enq_head: No where to go, prec == 4
[ 1022.189228] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 8
[ 1027.266213] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[ 1027.266484] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[ 1142.149519] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 8
[ 1146.085726] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[ 1146.085989] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[ 1260.008566] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[ 1260.012456] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[ 1264.339372] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 36
[ 1266.559363] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 157
[ 1266.559363] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 157
Comment 12 Josh Boyer 2012-05-03 08:20:39 EDT
*** Bug 818432 has been marked as a duplicate of this bug. ***
Comment 13 Sebastian Krämer 2012-05-04 09:03:57 EDT
Still happening for me with kernel 3.3.4-3.fc17.

Btw, is #787649 a duplicate?
Comment 14 Klaus Lichtenwalder 2012-05-07 03:57:56 EDT
Hi,

I'm seeing the same, on a Acer:
May  7 09:42:58 acer kernel: [ 5074.812095] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:8006 brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]()
May  7 09:42:58 acer kernel: [ 5074.812104] Hardware name: AOD260

F17 beta, 3.3.4-4.fc17.i686

Will provide more information if required.

Thanks
Comment 15 Kedar Patankar 2012-05-12 07:45:27 EDT
I updated the F17-beta install with Kernel-3.3.4-4fc17.i686. Still unable to connect to any access point using the BRCM-4313 interface. It does not matter if I try WEP, WPA or WPA2.

I wish I had bought an intel machine with intel wireless instead.
Comment 16 Klaus Lichtenwalder 2012-05-27 05:50:38 EDT
still in 3.3.7-1.fc17.i686
Comment 17 Kedar Patankar 2012-05-31 05:42:53 EDT
Still in F17 final both x86_64 and 686.

My laptop is Samsung NP305U1A Indian edition.

I can run any specific code or otherwise help in getting this going.
Comment 18 Dave Jones 2012-07-09 16:33:11 EDT
*** Bug 819561 has been marked as a duplicate of this bug. ***
Comment 19 Mikko Tiihonen 2012-07-12 12:02:01 EDT
Still occurs in 3.4.4

wlan0: associated
ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: associated
ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)
wlan0: no IPv6 routers present
WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7990 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
Pid: 4103, comm: kworker/u:20 Not tainted 3.4.4-3.fc17.x86_64 #1
Call Trace:
 [<ffffffff81056ebf>] warn_slowpath_common+0x7f/0xc0
 [<ffffffff81056f1a>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa03bc139>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
 [<ffffffffa03ae69b>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
 [<ffffffffa02af31e>] ieee80211_scan_work+0x34e/0x590 [mac80211]
 [<ffffffff8101258b>] ? __switch_to+0x12b/0x420
 [<ffffffff810732a9>] process_one_work+0x129/0x400
 [<ffffffffa02aefd0>] ? ieee80211_scan_rx+0x1b0/0x1b0 [mac80211]
 [<ffffffff810738d6>] worker_thread+0x126/0x2e0
 [<ffffffff810737b0>] ? rescuer_thread+0x1f0/0x1f0
 [<ffffffff810788b3>] kthread+0x93/0xa0
 [<ffffffff815fdba4>] kernel_thread_helper+0x4/0x10
 [<ffffffff81078820>] ? flush_kthread_worker+0x80/0x80
 [<ffffffff815fdba0>] ? gs_change+0x13/0x13
Comment 20 Klaus Lichtenwalder 2012-08-05 06:40:36 EDT
I'm getting in on 3.5 also, and more frequent. Often I have to remove the module to get on the net again

[ 8783.114080] ------------[ cut here ]------------
[ 8783.114130] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7968 brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]()
[ 8783.114138] Hardware name: AOD260
[ 8783.114145] Modules linked in: brcmsmac cordic brcmutil bcma mac80211 cfg80211 videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media bluetooth cpufreq_stats arc4 fuse ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables iptable_nat nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack acer_wmi sparse_keymap rfkill snd_hda_codec_realtek ecryptfs snd_hda_intel coretemp i2c_i801 snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_timer snd microcode lpc_ich atl1c soundcore sha256_generic encrypted_keys trusted tpm tpm_bios uinput wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: cordic]
[ 8783.114312] Pid: 12054, comm: kworker/u:32 Tainted: G        W    3.5.0-2.fc17.i686 #1
[ 8783.114318] Call Trace:
[ 8783.114337]  [<c0438df2>] warn_slowpath_common+0x72/0xa0
[ 8783.114374]  [<f90cce1a>] ? brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]
[ 8783.114408]  [<f90cce1a>] ? brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]
[ 8783.114421]  [<c0438e42>] warn_slowpath_null+0x22/0x30
[ 8783.114455]  [<f90cce1a>] brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]
[ 8783.114484]  [<f90c05f0>] brcms_ops_flush+0x30/0x50 [brcmsmac]
[ 8783.114551]  [<f8cf1c7d>] ieee80211_mgd_probe_ap_send+0x11d/0x1b0 [mac80211]
[ 8783.114614]  [<f8cf2279>] ieee80211_mgd_probe_ap.part.23+0xe9/0x100 [mac80211]
[ 8783.114677]  [<f8cf23e4>] ieee80211_sta_monitor_work+0x24/0x30 [mac80211]
[ 8783.114690]  [<c0451e68>] process_one_work+0x108/0x370
[ 8783.114752]  [<f8cf23c0>] ? ieee80211_beacon_connection_loss_work+0x130/0x130 [mac80211]
[ 8783.114764]  [<c0453419>] worker_thread+0xf9/0x280
[ 8783.114776]  [<c046348e>] ? complete+0x4e/0x60
[ 8783.114787]  [<c0453320>] ? manage_workers.isra.24+0x1d0/0x1d0
[ 8783.114799]  [<c0457f02>] kthread+0x72/0x80
[ 8783.114811]  [<c0457e90>] ? flush_kthread_worker+0x70/0x70
[ 8783.114824]  [<c094787e>] kernel_thread_helper+0x6/0x10
[ 8783.114831] ---[ end trace ecb8a0aae4c94f2e ]---
[ 8786.988526] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 8797.428861] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 8797.439557] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 8797.441261] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 8876.066349] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9290.286632] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9290.288209] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9290.288922] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9290.289319] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9342.715666] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9395.143739] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9395.144782] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9395.145744] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9793.603879] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9793.607264] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9809.353436] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
[ 9809.378939] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
Comment 21 John W. Linville 2012-08-13 10:51:02 EDT
*** Bug 847749 has been marked as a duplicate of this bug. ***
Comment 22 John W. Linville 2012-08-14 10:24:51 EDT
*** Bug 848077 has been marked as a duplicate of this bug. ***
Comment 23 Klaus Lichtenwalder 2012-08-14 10:26:30 EDT
In 3.5.1-1.fc17.i686
it's extremely frequent and quite disruptive:

Aug 14 16:22:02 acer kernel: [21437.083815] ieee80211 phy2: brcms_c_ampdu_dotxstatus_complete: supr_status 0x18
Aug 14 16:22:02 acer kernel: [21437.484353] ieee80211 phy2: brcms_c_ampdu_dotxstatus_complete: ampdu tx phy error (0x10)
Aug 14 16:22:02 acer kernel: [21437.524648] ieee80211 phy2: brcms_c_ampdu_dotxstatus_complete: ampdu tx phy error (0x10)
Aug 14 16:22:03 acer kernel: [21437.863920] ieee80211 phy2: brcms_c_ampdu_dotxstatus_complete: supr_status 0x18
Aug 14 16:22:03 acer kernel: [21438.525623] ieee80211 phy2: brcms_c_ampdu_dotxstatus_complete: supr_status 0x18
Aug 14 16:22:08 acer kernel: [21442.780651] ieee80211 phy2: brcms_c_ampdu_dotxstatus_complete: ampdu tx phy error (0x8)
Comment 24 Klaus Lichtenwalder 2012-08-19 05:39:02 EDT
Also in 3.5.2-1.fc17.i686
Aug 19 11:19:14 acer kernel: [13002.110193] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7968 brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]()

with lots of
Aug 19 11:37:43 acer kernel: [14111.535973] ieee80211 phy8: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 13
Comment 25 Jurgen Kramer 2012-08-24 13:57:19 EDT
Just got a full hang with 3.5.2-3 caused by the broadcom driver:

Aug 24 19:30:15 mba kernel: [  327.982164] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 44
Aug 24 19:30:15 mba kernel: [  327.983695] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 44
Aug 24 19:30:19 mba kernel: [  331.590044] ------------[ cut here ]------------
Aug 24 19:30:19 mba kernel: [  331.590075] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7968 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
Aug 24 19:30:19 mba kernel: [  331.590077] Hardware name: MacBookAir3,1
Aug 24 19:30:19 mba kernel: [  331.590079] Modules linked in: fuse lockd sunrpc rfcomm bnep ip6t_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables tpm_bios nls_utf8 hfsplus arc4 snd_hda_codec_hdmi snd_hda_codec_cirrus brcmsmac cordic brcmutil mac80211 cfg80211 coretemp kvm_intel uvcvideo btusb bluetooth rfkill bcm5974 kvm videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media applesmc input_polldev microcode snd_hda_intel shpchp snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_timer bcma snd soundcore apple_bl uinput nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
Aug 24 19:30:19 mba kernel: [  331.590136] Pid: 5, comm: kworker/u:0 Not tainted 3.5.1-1.fc17.x86_64 #1
Aug 24 19:30:19 mba kernel: [  331.590138] Call Trace:
Aug 24 19:30:19 mba kernel: [  331.590149]  [<ffffffff810584bf>] warn_slowpath_common+0x7f/0xc0
Aug 24 19:30:19 mba kernel: [  331.590153]  [<ffffffff8105851a>] warn_slowpath_null+0x1a/0x20
Aug 24 19:30:19 mba kernel: [  331.590165]  [<ffffffffa0443129>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
Aug 24 19:30:19 mba kernel: [  331.590173]  [<ffffffffa043569b>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
Aug 24 19:30:19 mba kernel: [  331.590205]  [<ffffffffa03edc0d>] ieee80211_mgd_probe_ap_send+0x12d/0x1f0 [mac80211]
Aug 24 19:30:19 mba kernel: [  331.590219]  [<ffffffffa037fae4>] ? ___cfg80211_scan_done+0x84/0xe0 [cfg80211]
Aug 24 19:30:19 mba kernel: [  331.590236]  [<ffffffffa03ee2cf>] ieee80211_mgd_probe_ap.part.23+0x10f/0x130 [mac80211]
Aug 24 19:30:19 mba kernel: [  331.590254]  [<ffffffffa03ee46e>] ieee80211_sta_monitor_work+0x2e/0x30 [mac80211]
Aug 24 19:30:19 mba kernel: [  331.590259]  [<ffffffff81074409>] process_one_work+0x129/0x400
Aug 24 19:30:19 mba kernel: [  331.590276]  [<ffffffffa03ee440>] ? ieee80211_beacon_connection_loss_work+0x150/0x150 [mac80211]
Aug 24 19:30:19 mba kernel: [  331.590281]  [<ffffffff81075f46>] worker_thread+0x126/0x2e0
Aug 24 19:30:19 mba kernel: [  331.590284]  [<ffffffff81075e20>] ? manage_workers.isra.26+0x1f0/0x1f0
Aug 24 19:30:19 mba kernel: [  331.590289]  [<ffffffff8107b4c3>] kthread+0x93/0xa0
Aug 24 19:30:19 mba kernel: [  331.590295]  [<ffffffff816148e4>] kernel_thread_helper+0x4/0x10
Aug 24 19:30:19 mba kernel: [  331.590299]  [<ffffffff8107b430>] ? flush_kthread_worker+0x80/0x80
Aug 24 19:30:19 mba kernel: [  331.590303]  [<ffffffff816148e0>] ? gs_change+0x13/0x13
Aug 24 19:30:19 mba kernel: [  331.590305] ---[ end trace b72a79fab6ba7da1 ]---
Comment 26 brcm80211 driver developers 2012-08-24 15:11:59 EDT
(In reply to comment #25)
> Just got a full hang with 3.5.2-3 caused by the broadcom driver:
> 

I only see the warning and the stack trace in your comment. What exactly were you observing on your macbook?
Comment 27 Michele Baldessari 2012-08-25 03:07:24 EDT
I get this one as well on my F17 Macbookair 4,1. Will try the current net-next later as well as bunch of mac80211 / brcmsmc fixes just made it in:

Aug 25 09:01:08 fante kernel: [40942.708937] ------------[] cut here ]------------ 
Aug 25 09:01:08 fante kernel: [40942.708957] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7968 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]() 
Aug 25 09:01:08 fante kernel: [40942.708958] Hardware name: MacBookAir4,1 
Aug 25 09:01:08 fante kernel: [40942.708960] Modules linked in: brcmsmac bcma ppp_deflate zlib_deflate bsd_comp ppp_async crc_ccitt ppp_generic slhc qmi_wwan option usb_wwan cdc_wdm usb_storage asix usbnet mii tcp_lp fuse 
tpm_bios ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle rfcomm bnep bridge stp llc ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ib_iser rdma_cm ib_addr iw_cm ib_cm nf_conntrack_ipv4 ip6_tables nf_defrag_ipv4 ib_sa xt_state nf_conntrack ib_mad ib_core iscsi_tcp sha256_generic dm_crypt snd_hda_codec_hdmi snd_hda_codec_cirrus arc4 cordic brcmutil mac80211 cfg80211 joydev uvcvideo videobuf2_vmalloc btusb videobuf2_memops videobuf2_core videodev bcm5974 bluetooth media rfkill applesmc snd_hda_intel coretemp input_polldev snd_hda_codec snd_hwdep snd_pcm microcode snd_page_alloc snd_timer snd i2c_i801 soundcore lpc_ich mfd_core mei binfmt_misc apple_bl nfsd nfs_acl auth_rpcgss lockd vhost_net tun macvtap macvlan kvm_intel kvm uinput crc32c_intel ghas 
Aug 25 09:01:08 fante kernel: h_clmulni_intel i915 video i2c_algo_bit drm_kms_helper drm i2c_core sunrpc be2iscsi bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi libiscsi_tcp qla4xxx iscsi_boot_sysfs libiscsi scsi_transport_iscsi [last unloaded: bcma] 
Aug 25 09:01:08 fante kernel: [40942.709039] Pid: 29728, comm: kworker/u:12 Tainted: G        W    3.5.1-1.fc17.x86_64 #1 
Aug 25 09:01:08 fante kernel: [40942.709040] Call Trace: 
Aug 25 09:01:08 fante kernel: [40942.709046]  [<ffffffff810584bf>] warn_slowpath_common+0x7f/0xc0 
Aug 25 09:01:08 fante kernel: [40942.709048]  [<ffffffff8105851a>] warn_slowpath_null+0x1a/0x20 
Aug 25 09:01:08 fante kernel: [40942.709054]  [<ffffffffa080a129>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac] 
Aug 25 09:01:08 fante kernel: [40942.709058]  [<ffffffffa07fc69b>] brcms_ops_flush+0x3b/0x60 [brcmsmac] 
Aug 25 09:01:08 fante kernel: [40942.709069]  [<ffffffffa055082d>] ieee80211_scan_work+0x34d/0x5e0 [mac80211] 
Aug 25 09:01:08 fante kernel: [40942.709072]  [<ffffffff81074409>] process_one_work+0x129/0x400 
Aug 25 09:01:08 fante kernel: [40942.709080]  [<ffffffffa05504e0>] ? ieee80211_run_deferred_scan+0x80/0x80 [mac80211] 
Aug 25 09:01:08 fante kernel: [40942.709082]  [<ffffffff81075f46>] worker_thread+0x126/0x2e0 
Aug 25 09:01:08 fante kernel: [40942.709084]  [<ffffffff81075e20>] ? manage_workers.isra.26+0x1f0/0x1f0 
Aug 25 09:01:08 fante kernel: [40942.709087]  [<ffffffff8107b4c3>] kthread+0x93/0xa0 
Aug 25 09:01:08 fante kernel: [40942.709091]  [<ffffffff816148e4>] kernel_thread_helper+0x4/0x10 
Aug 25 09:01:08 fante kernel: [40942.709093]  [<ffffffff8107b430>] ? flush_kthread_worker+0x80/0x80 
Aug 25 09:01:08 fante kernel: [40942.709096]  [<ffffffff816148e0>] ? gs_change+0x13/0x13 
Aug 25 09:01:08 fante kernel: [40942.709097] ---[] end trace c27dfd4a0932ddef ]--- 
Aug 25 09:01:09 fante kernel: [40942.714825] ieee80211 phy1: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 36 
Aug 25 09:01:09 fante kernel: [40943.090064] ieee80211 phy1: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 44 
Aug 25 09:01:10 fante kernel: [40943.843124] ieee80211 phy1: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 64 
Aug 25 09:01:12 fante kernel: [40945.825247] ieee80211 phy1: brcmsmac: brcms_ops_bss_info_changed: disassociated 
Aug 25 09:01:12 fante kernel: [40945.825270] ieee80211 phy1: brcms_ops_bss_info_changed: arp filtering: enabled false, count 1 (implement) 
Aug 25 09:01:12 fante kernel: [40945.825278] ieee80211 phy1: brcms_ops_bss_info_changed: qos enabled: false (implement) 
Aug 25 09:01:12 fante NetworkManager[765]: <info> (wlan0): supplicant interface state: completed -> authenticating 
Aug 25 09:01:12 fante kernel: [40946.039945] ieee80211 phy1: brcmsmac: brcms_ops_bss_info_changed: associated 
Aug 25 09:01:12 fante kernel: [40946.039949] ieee80211 phy1: brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement) 
Aug 25 09:01:12 fante kernel: [40946.039950] ieee80211 phy1: brcms_ops_bss_info_changed: qos enabled: true (implement)
Comment 28 Michele Baldessari 2012-08-26 02:41:54 EDT
Tried current net-next (top commit e6acb384807406c1a6ad3ddc91191f7658e63b7a) and I still got one of those warnings (see below), *but* the wireless in general is *a lot* more stable than before:

Aug 25 20:03:17 fante kernel: [   49.658653] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7993 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]() 
Aug 25 20:03:17 fante kernel: [   49.658657] Hardware name: MacBookAir4,1 
Aug 25 20:03:17 fante kernel: [   49.658660] Modules linked in: fuse tpm_bios ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge rfcomm stp bnep llc be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr ip6t_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack_ipv6 nf_defrag_ipv6 iw_cm ib_cm xt_state nf_conntrack ib_sa ip6table_filter ip6_tables ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi sha256_generic dm_crypt snd_hda_codec_hdmi snd_hda_codec_cirrus arc4 brcmsmac btusb bluetooth cordic brcmutil mac80211 joydev bcm5974 coretemp crc32c_intel snd_hda_intel snd_hda_codec snd_hwdep ghash_clmulni_intel cfg80211 rfkill snd_pcm lpc_ich microcode applesmc pcspkr input_polldev mfd_core i2c_i801 snd_page_alloc snd_timer snd bcma mei soundcore apple_bl binfmt_misc nfsd auth_rpcgss nfs_acl lockd sunrpc vhost_net tun macvtap macvlan kvm_intel kvm uinput i915 video i2c_algo_bit drm_kms_helper drm i2c_core 
Aug 25 20:03:17 fante kernel: [   49.658828] Pid: 43, comm: kworker/u:1 Not tainted 3.6.0-rc2+ #1 
Aug 25 20:03:17 fante kernel: [   49.658832] Call Trace: 
Aug 25 20:03:17 fante kernel: [   49.658847]  [<ffffffff8105b50f>] warn_slowpath_common+0x7f/0xc0 
Aug 25 20:03:17 fante kernel: [   49.658854]  [<ffffffff8105b56a>] warn_slowpath_null+0x1a/0x20 
Aug 25 20:03:17 fante kernel: [   49.658881]  [<ffffffffa05aa8c9>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac] 
Aug 25 20:03:17 fante kernel: [   49.658898]  [<ffffffffa059c6cb>] brcms_ops_flush+0x3b/0x60 [brcmsmac] 
Aug 25 20:03:17 fante kernel: [   49.658942]  [<ffffffffa03d47fd>] ieee80211_mgd_probe_ap_send+0x13d/0x200 [mac80211] 
Aug 25 20:03:17 fante kernel: [   49.658969]  [<ffffffffa033341e>] ? cfg80211_cqm_rssi_notify+0x2e/0x40 [cfg80211] 
Aug 25 20:03:17 fante kernel: [   49.659003]  [<ffffffffa03d2ab1>] ? ieee80211_cqm_rssi_notify+0x41/0xa0 [mac80211] 
Aug 25 20:03:17 fante kernel: [   49.659034]  [<ffffffffa03d4e0f>] ieee80211_mgd_probe_ap.part.24+0x11f/0x170 [mac80211] 
Aug 25 20:03:17 fante kernel: [   49.659063]  [<ffffffffa03d4e8e>] ieee80211_sta_monitor_work+0x2e/0x30 [mac80211] 
Aug 25 20:03:17 fante kernel: [   49.659073]  [<ffffffff810775d7>] process_one_work+0x147/0x4a0 
Aug 25 20:03:17 fante kernel: [   49.659101]  [<ffffffffa03d4e60>] ? ieee80211_mgd_probe_ap.part.24+0x170/0x170 [mac80211] 
Aug 25 20:03:17 fante kernel: [   49.659111]  [<ffffffff810792ae>] worker_thread+0x15e/0x460 
Aug 25 20:03:17 fante kernel: [   49.659120]  [<ffffffff81079150>] ? manage_workers.isra.21+0x290/0x290 
Aug 25 20:03:17 fante kernel: [   49.659127]  [<ffffffff8107e703>] kthread+0x93/0xa0 
Aug 25 20:03:17 fante kernel: [   49.659139]  [<ffffffff81616044>] kernel_thread_helper+0x4/0x10 
Aug 25 20:03:17 fante kernel: [   49.659147]  [<ffffffff8107e670>] ? kthread_freezable_should_stop+0x70/0x70 
Aug 25 20:03:17 fante kernel: [   49.659156]  [<ffffffff81616040>] ? gs_change+0x13/0x13 
Aug 25 20:03:17 fante kernel: [   49.659160] ---[] end trace d0df64c40a4ff3cf ]---
Comment 29 Parag Warudkar 2012-09-01 20:32:00 EDT
Also happens routinely with latest 3.5.2-3 kernel.


[10197.885569] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7968 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
[10197.885571] Hardware name: MacBookPro6,1
[10197.885572] Modules linked in: tcp_lp lockd sunrpc rfcomm bnep tpm_bios nls_utf8 hfsplus arc4 brcmsmac cordic brcmutil mac80211 btusb bluetooth cfg80211 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_hda_codec_cirrus coretemp lpc_ich mfd_core snd_hda_intel snd_hda_codec media applesmc snd_hwdep bcma i2c_i801 snd_pcm rfkill intel_ips apple_gmux snd_page_alloc snd_timer snd soundcore tg3 joydev bcm5974 apple_bl kvm_intel kvm microcode input_polldev uinput crc32c_intel ghash_clmulni_intel firewire_ohci firewire_core crc_itu_t i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
[10197.885625] Pid: 1991, comm: kworker/u:2 Not tainted 3.5.2-3mbp.local.fc17.x86_64 #1
[10197.885627] Call Trace:
[10197.885638]  [<ffffffff810584bf>] warn_slowpath_common+0x7f/0xc0
[10197.885642]  [<ffffffff8105851a>] warn_slowpath_null+0x1a/0x20
[10197.885654]  [<ffffffffa0422129>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
[10197.885662]  [<ffffffffa041469b>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
[10197.885687]  [<ffffffffa03ccc0d>] ieee80211_mgd_probe_ap_send+0x12d/0x1f0 [mac80211]
[10197.885705]  [<ffffffffa03cd2cf>] ieee80211_mgd_probe_ap.part.23+0x10f/0x130 [mac80211]
[10197.885722]  [<ffffffffa03cd38d>] ieee80211_beacon_connection_loss_work+0x9d/0x150 [mac80211]
[10197.885727]  [<ffffffff81074429>] process_one_work+0x129/0x400
[10197.885743]  [<ffffffffa03cd2f0>] ? ieee80211_mgd_probe_ap.part.23+0x130/0x130 [mac80211]
[10197.885747]  [<ffffffff81075f66>] worker_thread+0x126/0x2e0
[10197.885751]  [<ffffffff81075e40>] ? manage_workers.isra.26+0x1f0/0x1f0
[10197.885755]  [<ffffffff8107b4e3>] kthread+0x93/0xa0
[10197.885761]  [<ffffffff81615da4>] kernel_thread_helper+0x4/0x10
[10197.885765]  [<ffffffff8107b450>] ? flush_kthread_worker+0x80/0x80
[10197.885768]  [<ffffffff81615da0>] ? gs_change+0x13/0x13
[10197.885771] ---[ end trace 0d22b135ac163c05 ]---
Comment 30 Ankur Sinha (FranciscoD) 2012-09-04 20:16:28 EDT
Created attachment 609815 [details]
abrt logger report

Linux ankur.pc 3.5.3-1.fc17.x86_64 #1 SMP Wed Aug 29 18:46:34 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Comment 31 Stanislaw Gruszka 2012-09-17 04:31:23 EDT
There are upstream patches claiming to fix this problem
http://marc.info/?l=linux-wireless&m=134683858509453&w=2
http://marc.info/?t=134683869300001&r=1&w=2
http://marc.info/?t=134683869300002&r=1&w=2
but according to ubuntu folks tests they do not.
Comment 32 Thiago Coutinho 2012-10-23 15:57:45 EDT
colossus ~ ⚡ uname -a
Linux colossus 3.6.2-1-ARCH #1 SMP PREEMPT Fri Oct 12 23:58:58 CEST 2012 x86_64 GNU/Linux


colossus ~ ⚡ lspci 
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
12:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)
13:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)



[34059.089279] ------------[ cut here ]------------
[34059.089312] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
[34059.089314] Hardware name: Vostro 3300
[34059.089316] Modules linked in: des_generic ecb md4 md5 hmac nls_utf8 cifs fscache fuse btusb bluetooth uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media joydev snd_hda_codec_idt snd_hda_intel acpi_cpufreq mperf arc4 snd_hda_codec microcode kvm_intel serio_raw kvm snd_hwdep snd_pcm snd_page_alloc snd_timer snd soundcore mei dell_wmi psmouse r8169 evdev iTCO_wdt sparse_keymap iTCO_vendor_support mii dell_laptop lpc_ich processor dcdbas intel_ips i2c_i801 coretemp ac thermal battery wmi brcmsmac cordic brcmutil bcma mac80211 cfg80211 rfkill sha256_generic aes_x86_64 ablk_helper cryptd aes_generic cbc hid_generic usbhid hid dm_crypt dm_mod crc32c_intel ums_realtek usb_storage i915 video button i2c_algo_bit intel_agp intel_gtt drm_kms_helper drm i2c_core ext4 crc16 jbd2 mbcache
[34059.089387]  ehci_hcd usbcore sr_mod usb_common cdrom sd_mod ahci libahci libata scsi_mod
[34059.089399] Pid: 13856, comm: kworker/u:2 Not tainted 3.6.2-1-ARCH #1
[34059.089401] Call Trace:
[34059.089411]  [<ffffffff81055c2f>] warn_slowpath_common+0x7f/0xc0
[34059.089417]  [<ffffffff81055c8a>] warn_slowpath_null+0x1a/0x20
[34059.089428]  [<ffffffffa03c0889>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
[34059.089435]  [<ffffffffa03b31bb>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
[34059.089454]  [<ffffffffa0354809>] ieee80211_mgd_probe_ap_send+0xc9/0x230 [mac80211]
[34059.089466]  [<ffffffffa0354fcc>] ieee80211_mgd_probe_ap.part.23+0x12c/0x150 [mac80211]
[34059.089478]  [<ffffffffa035517e>] ieee80211_sta_monitor_work+0x2e/0x30 [mac80211]
[34059.089484]  [<ffffffff810735c9>] process_one_work+0x139/0x500
[34059.089493]  [<ffffffff81485fee>] ? mutex_unlock+0xe/0x10
[34059.089505]  [<ffffffffa0355150>] ? ieee80211_beacon_connection_loss_work+0x160/0x160 [mac80211]
[34059.089509]  [<ffffffff81073d5e>] worker_thread+0x15e/0x460
[34059.089514]  [<ffffffff81073c00>] ? rescuer_thread+0x230/0x230
[34059.089519]  [<ffffffff81079693>] kthread+0x93/0xa0
[34059.089524]  [<ffffffff81490dc4>] kernel_thread_helper+0x4/0x10
[34059.089528]  [<ffffffff81079600>] ? kthread_freezable_should_stop+0x70/0x70
[34059.089531]  [<ffffffff81490dc0>] ? gs_change+0x13/0x13
[34059.089533] ---[ end trace 2888dc3c08dd092f ]---
Comment 33 tod.jackson 2012-11-24 04:16:32 EST
Sorry to chime in with a near identical post to the one just above, but this has gotten even worse and much more frequent in the past few weeks. It's been getting worse with every kernel update.

[tod@Shirokuro ~]$ uname -a
Linux Shirokuro 3.6.7-1-ARCH #1 SMP PREEMPT Sun Nov 18 10:11:22 CET 2012 x86_64 GNU/Linux

It's really strange that I get a message about Bluetooth during the errors, and after my connection drops. I get the connection working again as you can see at the end, by restarting dhcpcd and net-auto-wireless (part of Arch's netcfg).

Also, sorry for the semi-long dmesg:

[  172.407869] wlan0: associated
[  172.407951] cfg80211: Calling CRDA for country: US
[  172.413603] cfg80211: Regulatory domain changed to country: US
[  172.413607] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  172.413610] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[  172.413612] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[  172.413614] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  172.413616] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  172.413618] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  172.413620] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[  179.333210] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)
[ 1653.565113] Bluetooth: Core ver 2.16
[ 1653.565149] NET: Registered protocol family 31
[ 1653.565152] Bluetooth: HCI device and connection manager initialized
[ 1653.565155] Bluetooth: HCI socket layer initialized
[ 1653.565158] Bluetooth: L2CAP socket layer initialized
[ 1653.565178] Bluetooth: SCO socket layer initialized
[ 1653.569464] Netfilter messages via NETLINK v0.30.
[ 1715.140198] ------------[ cut here ]------------
[ 1715.140229] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
[ 1715.140232] Hardware name: M11x R2
[ 1715.140234] Modules linked in: nfnetlink_log nfnetlink bluetooth pci_stub vboxpci(O) vboxvideo(O) acpi_call(O) ipt_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack joydev arc4 iptable_filter ip_tables x_tables coretemp snd_hda_codec_hdmi brcmsmac cordic brcmutil mac80211 cfg80211 firewire_ohci snd_hda_codec_realtek kvm_intel rfkill sdhci_pci kvm snd_hda_intel snd_hda_codec crc32c_intel ghash_clmulni_intel uvcvideo aesni_intel snd_hwdep snd_pcm aes_x86_64 snd_page_alloc snd_timer iTCO_wdt iTCO_vendor_support videobuf2_vmalloc aes_generic videobuf2_memops videobuf2_core dell_wmi sdhci psmouse hid_generic firewire_core acpi_cpufreq mperf nouveau snd ablk_helper jmb38x_ms videodev mxm_wmi cryptd ttm usbhid media hid sparse_keymap intel_ips wmi crc_itu_t i2c_i801 lpc_ich serio_raw pcspkr
[ 1715.140324]  mmc_core evdev processor microcode soundcore memstick atl1c battery ac bcma vboxnetflt(O) vboxnetadp(O) vboxdrv(O) ext4 crc16 jbd2 mbcache sd_mod ahci libahci libata scsi_mod ehci_hcd usbcore usb_common i915 video button i2c_algo_bit intel_agp intel_gtt drm_kms_helper drm i2c_core
[ 1715.140369] Pid: 5460, comm: kworker/u:1 Tainted: G           O 3.6.7-1-ARCH #1
[ 1715.140371] Call Trace:
[ 1715.140384]  [<ffffffff81055c7f>] warn_slowpath_common+0x7f/0xc0
[ 1715.140390]  [<ffffffff81055cda>] warn_slowpath_null+0x1a/0x20
[ 1715.140404]  [<ffffffffa07fc889>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
[ 1715.140412]  [<ffffffffa07ef1bb>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
[ 1715.140434]  [<ffffffffa07a57c9>] ieee80211_mgd_probe_ap_send+0xc9/0x230 [mac80211]
[ 1715.140449]  [<ffffffffa07a5f8c>] ieee80211_mgd_probe_ap.part.23+0x12c/0x150 [mac80211]
[ 1715.140464]  [<ffffffffa07a613e>] ieee80211_sta_monitor_work+0x2e/0x30 [mac80211]
[ 1715.140473]  [<ffffffff81073939>] process_one_work+0x139/0x500
[ 1715.140488]  [<ffffffffa07a6110>] ? ieee80211_beacon_connection_loss_work+0x160/0x160 [mac80211]
[ 1715.140493]  [<ffffffff810740ce>] worker_thread+0x15e/0x460
[ 1715.140498]  [<ffffffff81073f70>] ? rescuer_thread+0x230/0x230
[ 1715.140504]  [<ffffffff81079a03>] kthread+0x93/0xa0
[ 1715.140513]  [<ffffffff8149b204>] kernel_thread_helper+0x4/0x10
[ 1715.140519]  [<ffffffff81079970>] ? kthread_freezable_should_stop+0x70/0x70
[ 1715.140524]  [<ffffffff8149b200>] ? gs_change+0x13/0x13
[ 1715.140528] ---[ end trace 9b7072b361ec7527 ]---
[ 2029.221370] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
[ 2063.986715] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)
[ 2146.706025] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
[ 2146.736177] wlan0: deauthenticating from 00:1d:cf:b3:b0:80 by local choice (reason=3)
[ 2146.748624] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: disassociated
[ 2146.748637] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled false, count 0 (implement)
[ 2146.748641] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
[ 2146.750679] cfg80211: Calling CRDA to update world regulatory domain
[ 2146.757885] cfg80211: World regulatory domain updated:
[ 2146.757893] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2146.757900] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2146.757906] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2146.757911] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2146.757916] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2146.757921] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2146.757960] cfg80211: Calling CRDA for country: US
[ 2146.762674] cfg80211: Regulatory domain changed to country: US
[ 2146.762678] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2146.762681] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 2146.762683] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 2146.762685] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2146.762687] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2146.762689] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2146.762692] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 2147.945466] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
[ 2147.945481] ieee80211 phy0: brcms_ops_config: change power-save mode: false (implement)
[ 2147.946627] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 2151.954388] wlan0: authenticate with 00:1d:cf:b3:b0:80
[ 2151.979194] wlan0: send auth to 00:1d:cf:b3:b0:80 (try 1/3)
[ 2151.980907] wlan0: authenticated
[ 2151.982839] wlan0: associate with 00:1d:cf:b3:b0:80 (try 1/3)
[ 2151.986514] wlan0: RX AssocResp from 00:1d:cf:b3:b0:80 (capab=0xc11 status=0 aid=2)
[ 2151.987076] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: associated
[ 2151.987086] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
[ 2151.987095] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
[ 2151.987122] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 2151.987361] wlan0: associated
[ 2151.987481] cfg80211: Calling CRDA for country: US
[ 2151.991334] cfg80211: Regulatory domain changed to country: US
[ 2151.991337] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2151.991339] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 2151.991341] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 2151.991343] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2151.991345] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2151.991347] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2151.991348] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 2152.911211] IPv6: wlan0: IPv6 duplicate address fe80::c2cb:38ff:fe22:e604 detected!
[ 2158.086407] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)
Comment 34 tod.jackson 2012-11-24 18:37:34 EST
Ah, by the way, I disabled Bluetooth (as well some WWAN feature, Firewire, and 1394) in the BIOS and my issues (the crash above, then disconnection) still persist.
Comment 35 Klaus Lichtenwalder 2012-12-02 06:12:02 EST
Still there on F18 beta:

[ 9895.632217] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x8a/0xa0 [brcmsmac]()
[ 9895.632225] Hardware name: AOD260


3.6.7-5.fc18.i686
Comment 36 Michele Baldessari 2012-12-16 04:44:52 EST
FWIW Still an issue with 3.7.0-1.fc19:
[  129.305248] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7993 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
[  129.305252] Hardware name: MacBookAir4,1
[  129.305255] Modules linked in: fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat_ipv4 nf_nat xt_CHECKSUM iptable_mangle bridge stp llc be2iscsi iscsi_boot_sysfs bnx2i cnic uio rfcomm cxgb4i bnep cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 iw_cm ib_cm ib_sa ib_mad ib_core xt_conntrack nf_conntrack ip6table_filter iscsi_tcp libiscsi_tcp ip6_tables libiscsi scsi_transport_iscsi dm_crypt snd_hda_codec_hdmi snd_hda_codec_cirrus snd_hda_intel snd_hda_codec arc4 brcmsmac snd_hwdep cordic brcmutil iTCO_wdt snd_seq mac80211 cfg80211 iTCO_vendor_support coretemp joydev uvcvideo snd_seq_device videobuf2_vmalloc videobuf2_memops snd_pcm videobuf2_core btusb bcm5974 videodev bluetooth media asix usbnet rfkill
[  129.305357]  mii microcode snd_page_alloc applesmc lpc_ich snd_timer input_polldev snd i2c_i801 mei mfd_core soundcore bcma binfmt_misc apple_bl vhost_net tun macvtap macvlan kvm_intel kvm nfsd auth_rpcgss nfs_acl lockd uinput crc32c_intel i915 ghash_clmulni_intel i2c_algo_bit drm_kms_helper drm i2c_core video sunrpc
[  129.305410] Pid: 84, comm: kworker/u:3 Not tainted 3.7.0-1.fc19.x86_64 #1
[  129.305413] Call Trace:
[  129.305428]  [<ffffffff8105e70f>] warn_slowpath_common+0x7f/0xc0
[  129.305436]  [<ffffffff8105e76a>] warn_slowpath_null+0x1a/0x20
[  129.305458]  [<ffffffffa04d7c99>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
[  129.305474]  [<ffffffffa04ca6bb>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
[  129.305504]  [<ffffffffa044da5d>] ieee80211_scan_work+0x34d/0x5e0 [mac80211]
[  129.305514]  [<ffffffff8101358e>] ? __switch_to+0x13e/0x4a0
[  129.305524]  [<ffffffff8107a557>] process_one_work+0x147/0x490
[  129.305550]  [<ffffffffa044d710>] ? ieee80211_run_deferred_scan+0x90/0x90 [mac80211]
[  129.305559]  [<ffffffff8107cdee>] worker_thread+0x15e/0x450
[  129.305569]  [<ffffffff8107cc90>] ? busy_worker_rebind_fn+0x110/0x110
[  129.305576]  [<ffffffff81081d50>] kthread+0xc0/0xd0
[  129.305585]  [<ffffffff81010000>] ? ftrace_raw_event_xen_mmu_flush_tlb_others+0x50/0xe0
[  129.305593]  [<ffffffff81081c90>] ? kthread_create_on_node+0x120/0x120
[  129.305602]  [<ffffffff8163d72c>] ret_from_fork+0x7c/0xb0
[  129.305609]  [<ffffffff81081c90>] ? kthread_create_on_node+0x120/0x120
Comment 37 librastarnz77 2012-12-31 11:17:34 EST
Not sure how it happened, but i tell you when it happened.
Just loged into picasa web ablum, opened a folder to view files when "error" report occured.
have not looked at 1st photo yet.
hope it helps.


Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)
Comment 38 Dave Jones 2013-02-07 11:36:29 EST

*** This bug has been marked as a duplicate of bug 873914 ***

Note You need to log in before you can comment on or make changes to this bug.