Bug 804543 - Building image from cli with a template without rootpw fails
Building image from cli with a template without rootpw fails
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: rubygem-aeolus-cli (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Maros Zatko
Rehana
: Rebase, Triaged, ZStream
: 830989 (view as bug list)
Depends On:
Blocks: 826233
  Show dependency treegraph
 
Reported: 2012-03-19 04:35 EDT by Shveta
Modified: 2012-12-04 09:59 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously without the rootpw element set in the component outline schema, image builds fail with the error "Service Temporarily Unavailable". This bug fix updates the error message to give users more descriptive feedback.
Story Points: ---
Clone Of:
: 826233 (view as bug list)
Environment:
Last Closed: 2012-12-04 09:59:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shveta 2012-03-19 04:35:24 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.[root@qe-blade-10 ~]# aeolus-image build --target ec2 --template fedora15.tpl -E default

ERROR:  Service Temporarily Unavailable => Please check that Conductor is running.

===========================================================
[root@qe-blade-10 ~]# aeolus-image build --target vsphere --template fedora15.tpl -E default
Image      Build       Target Image   Target      Status     
------------------------------------------------------------ 
fa2e9f2c-719d-11e1-aaee-00215e202f4e     4698a55a-8020-455e-bbfd-711a6c6898a4     a4fbbc04-ef7a-4ae2-8bad-91eb9573f580     vsphere     FAILED     

=================================================================
[root@qe-blade-10 ~]# aeolus-image build --target rhevm --template fedora15.tpl -E default
Image             Build       Target Image       Target     Status     
------------------------------------     -------------------------
034db246-719e-11e1-aaee-00215e202f4e     32aa133f-8bb3-4898-a35b-06656082a155     53d12221-62b4-47bd-84e3-756f4e4ce0b4     rhevm      FAILED     

=========================================================
2. Template used 
<?xml version="1.0"?>
<template>
  <name>Fedora 15</name>
  <description>desc</description>
  <os>
    <name>Fedora</name>
    <arch>x86_64</arch>
    <version>15</version>
    <install type="url">
      <url>http://download.fedoraproject.org/pub/fedora/linux/releases/15/Fedora/x86_64/os/</url>
    </install>
  </os>
  <repositories>
    <repository name="custom">
      <url>http://repos.fedorapeople.org/repos/aeolus/demo/webapp/</url>
      <signed>false</signed>
    </repository>
  </repositories>
</template>

3.
  
Actual results:


Expected results:


Additional info:

 rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.0-14.el6.noarch
aeolus-conductor-doc-0.8.0-43.el6.noarch
aeolus-conductor-0.8.0-43.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
aeolus-conductor-daemons-0.8.0-43.el6.noarch
aeolus-all-0.8.0-43.el6.noarch
Comment 2 Hugh Brock 2012-03-19 14:12:19 EDT
We should fix this, but we are out of time for 1.0. Pushing to 1.0.z.
Comment 3 wes hayutin 2012-04-30 11:24:42 EDT
The error message should be fixed for z stream
Comment 4 Martyn Taylor 2012-05-23 14:23:44 EDT
Conductor

commit 290dde45cfba2254aafd5c59b83f66e5d00f08ca
Author: Maros Zatko <mzatko@redhat.com>
Date:   Tue May 22 21:22:12 2012 +0200

    BZ804543: template relaxng: make rootpw mandatory
    
    rootpw tag is mandatory in imagefactory's xsd file

Aeolus CLI

commit 396a329b43764afa967778c33c71e9cab3843798
Author: Martyn Taylor <mtaylor@redhat.com>
Date:   Wed May 23 19:13:58 2012 +0100

    BZ804543 Removed Optional Element for rootpw in tdl
Comment 6 Maros Zatko 2012-07-24 10:24:15 EDT
*** Bug 830989 has been marked as a duplicate of this bug. ***
Comment 8 pushpesh sharma 2012-09-21 05:36:09 EDT
As suggested in Comment#4,Image build fails with proper error message if rootpwd is not supplied in tdl file and succeed if the rootpasswd is supplied.

[root@dhcp201-113 ~]# aeolus-image build --target ec2 --template fedora15.tpl -E default
ERROR: The given Template does not conform to the TDL Schema, see below for specific details:
- Line: 5 => Expecting an element rootpw, got nothing
- Line: 5 => Invalid sequence in interleave
- Line: 5 => Element os failed to validate content
[root@dhcp201-113 ~]# vim fedora15.tpl
[root@dhcp201-113 ~]# aeolus-image build --target ec2 --template fedora15.tpl -E default
Image                                    Build                                    Target Image                             Target     Status       
------------------------------------     ------------------------------------     ------------------------------------     ------     --------     
5a734cd8-03d0-11e2-a1fa-2c27d73906e5     646cda8e-09c6-41ff-9c6f-81ffcd7b83b1     8d590d50-0d62-42fa-a241-c8bfeb0e8b4b     ec2        BUILDING     


Verified on :-

[root@dhcp201-113 ~]# rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
Comment 10 errata-xmlrpc 2012-12-04 09:59:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.