Bug 81855 - keytable has warnings
keytable has warnings
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
: 82400 82510 91273 91638 98824 100530 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-01-14 13:47 EST by David Balažic
Modified: 2007-04-18 12:49 EDT (History)
13 users (show)

See Also:
Fixed In Version: 1.08-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-31 15:29:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Excerpt from /var/log/messages showing the "xxx ignored" messages (1.16 KB, text/plain)
2003-03-28 03:49 EST, David Balažic
no flags Details
my "/var/log/boot.log" file (4.45 KB, text/plain)
2003-07-31 08:36 EDT, Luke
no flags Details

  None (edit)
Description David Balažic 2003-01-14 13:47:25 EST
[root@localhost root]# service keytable start
Nalagam preslikavo tipk:                                   [  V redu  ]
Nalaga se sistemska pisava: plus before onesuperior ignored
plus before copyright ignored
plus before eth ignored
plus before ETH ignored
plus before egrave ignored
plus before Egrave ignored
plus before ae ignored
plus before AE ignored
plus before threequarters ignored
plus before registered ignored
                                                           [  V redu  ]
=========================
[root@localhost root]# cat /etc/sysconfig/i18n
LANG="sl_SI.UTF-8"
SUPPORTED="hr_HR.UTF-8:hr_HR:hr:en_US.UTF-8:en_US:en:de_AT.UTF-
8:de_AT:de:de_DE.UTF-8:de_DE:de:hu_HU.UTF-8:hu_HU:hu:sr_YU.UTF-
8@cyrillic:sr_YU:sr_YU.UTF-8:sr:sl_SI.UTF-8:sl_SI:sl"
SYSFONT="latarcyrheb-sun16"


[root@localhost root]# cat /etc/sysconfig/keyboard
KEYBOARDTYPE="pc"
KEYTABLE="slovene"

versions :
kbd-1.08-2
Comment 1 Bill Nottingham 2003-01-15 02:18:44 EST
keymap has wrong encoding.
Comment 2 Fred New 2003-01-22 02:01:32 EST
I get similar messages for my Estonian keyboard on Phoebe 2:

Jan 21 23:30:21 phoebe keytable: plus before udiaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before Udiaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before udiaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before Udiaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before otilde ignored
Jan 21 23:30:21 phoebe keytable: plus before Otilde ignored
Jan 21 23:30:21 phoebe keytable: plus before diaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before brokenbar ignored
Jan 21 23:30:21 phoebe keytable: plus before odiaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before Odiaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before odiaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before Odiaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before adiaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before Adiaeresis ignored
Jan 21 23:30:21 phoebe keytable: plus before cedilla ignored
Jan 21 23:30:21 phoebe keytable: plus before acute ignored
Jan 21 23:30:21 phoebe rc: Starting keytable:  succeeded
----------------------------------------------------------------------
# cat /etc/sysconfig/keyboard
KEYBOARDTYPE="pc"
KEYTABLE="et"

Same version of kbd - kbd-1.08-2
Comment 3 David Balažic 2003-01-30 10:11:23 EST
Look like these messages are created by the "dumpkeys | loadkeys -u" line
in the script "unicode_start".
Comment 4 Eido Inoue 2003-02-19 16:33:50 EST
fixed in latest rawhide releases
Comment 5 David Balažic 2003-03-28 03:47:43 EST
Bug still there in RHL 9 ( Shrike )
Comment 6 David Balažic 2003-03-28 03:49:47 EST
Created attachment 90757 [details]
Excerpt from /var/log/messages showing the "xxx ignored" messages
Comment 7 David Balažic 2003-03-28 03:50:55 EST
And here is my i18n file :

# cat /etc/sysconfig/i18n
LANG="en_US.UTF-8"
SUPPORTED="hr_HR.UTF-8:hr_HR:hr:en_GB.UTF-8:en_GB:en:en_US.UTF-
8:en_US:en:de_AT.UTF-8:de_AT:de:de_DE.UTF-8:de_DE:de:hu_HU.UTF-
8:hu_HU:hu:sr_YU.UTF-8@cyrillic:sr_YU:sr_YU.UTF-8:sr:sl_SI.UTF-8:sl_SI:sl"
SYSFONT="latarcyrheb-sun16"
Comment 8 David Balažic 2003-03-31 03:01:55 EST
Which rawhide release has this fixed ?
both rawhide and shrike have kbd-1.08-4.i386.rpm
Comment 9 Thomas M Steenholdt 2003-04-02 12:44:21 EST
*** Bug 82510 has been marked as a duplicate of this bug. ***
Comment 10 Warren S 2003-04-03 12:39:25 EST
I use the dvorak layout and not just for X.  I too noticed the keymap, keytable
and oddly system font fail.  So I have regular en qwerty usage at the console,
but dvorak *is* working in X (KDE).  

A strange case observed in using rdesktop:  I have set my default keyboard
layout on the remote windows box to dvorak in the past but now with RH9, the key
layout seems to be translated to some other I'm not familiar with (not US or
dvorak), possibly dvorak for left or right handed. To fix this I have to change
the windows box to en in order for the local X dvorak to work in the remote
window.  In the past, dvorak did not effect the rdesktop.  This is why I needed
to set windows to use it also.

Changing the default back to en, all is well with no failures at boot time.
Comment 11 Eido Inoue 2003-04-03 12:45:55 EST
I use dvorak (HH kbd with dvorak keycaps) at home on my RHL 9-- works both in
console and X.

Q: are you using dvorak with dead keys? (i.e. are you using dvorak with a
language other than english?) How do you do that?
Comment 12 Warren S 2003-04-03 13:04:06 EST
No I'm not using dvorak with dead keys.  I guess I should add that my RH9
install was an upgrade not a fresh install.
Comment 13 Sepp Rudel 2003-04-09 02:54:32 EDT
Me too! If I use Danish keytable, I also get errors after RH9 installation. But:
if I tweak /etc/sysconfig/i18n to look like:

LANG=C
SYSFONT=lat1-16
SYSFONTACM=8859-1

no errors appear. So it seems that keymaps giving this error are perfectly ok,
loadkeys just reports these things if using Unicode. Personally I find it
strange that the warnings are printed since in /etc/init.d/keytable where
loadkeys is called the line is:

loadkeys $KEYTABLE < /dev/ttyS0 > /dev/null 2>&1

Shouldn't that make these warnings disappear?

Anyway, this bug *does* exists with RH9 and is quite annoying yet totally
harmless. The warnings just means that Caps Lock won't have the normal effect
with the symbols mentioned.
Comment 14 David Balažic 2003-05-22 14:04:55 EDT
I still get this error/warnings with the latest bits.
Comment 15 Noa Resare 2003-06-14 12:15:33 EDT
In an email conversation with the kbd maintainer he said this:

> > does the plus signs mean something
>
> It is not bad if you remove this plus. The idea is that
> if one uses CapsLock then all text IS IN ALL CAPS, but
> for example digits remain as they are. So CapsLock acts
> a bit like ShiftLock, but only for letters. Now what is a letter?
> Letters are A-Z and further those things that have a + in front.
> In Swedish you would regard Aring a letter.
>
> > plus before XXX ignored
> > where XXX is aring, Aring, odiaresis, Odiaresis, adiaresis and Adiaresis
>
> Here all works well, but I do not have redhat modifications.
> The code in ksyms.c says
>
> add_capslock(int code) {
>         if (KTYP(code) == KT_LATIN)
>                 return K(KT_LETTER, KVAL(code));
>         ...
>         fprintf(stderr, _("plus before %s ignored\n"), p);
> }
> 
> so the question is why KTYP(code) == KT_LATIN fails for you.
> Probably because you use unicode.
> 
> For ISO 8859-X character sets there is an easy correspondence
> between lower and upper case versions of a character, but
> Unicode does not have such an easy correspondence, and of
> course for many languages there is no such concept.
> So plus before unicode stuff will not work.
>
> Andries

My conclusion out of this is that the bug should be moved to kernel.

It could also be noted that CapsLock doesn't work as expected in UTF-8 locale
with regards to non-ascii characters. If i type å (aring) in the console with
CapsLock pressed the lowercase version is shown and not the uppercase version.

/noa
Comment 16 Bill Nottingham 2003-07-24 00:34:42 EDT
*** Bug 91273 has been marked as a duplicate of this bug. ***
Comment 17 Bill Nottingham 2003-07-24 01:06:18 EDT
*** Bug 91638 has been marked as a duplicate of this bug. ***
Comment 18 Aleksey Nogin 2003-07-24 01:27:44 EDT
Same deal with Russian keytable (see also bug 79338).
Comment 19 Eido Inoue 2003-07-25 12:58:19 EDT
*** Bug 82400 has been marked as a duplicate of this bug. ***
Comment 20 Eido Inoue 2003-07-25 13:00:44 EDT
*** Bug 98824 has been marked as a duplicate of this bug. ***
Comment 21 Eido Inoue 2003-07-25 14:56:25 EDT
*** Bug 100530 has been marked as a duplicate of this bug. ***
Comment 22 Luke 2003-07-31 08:36:48 EDT
Created attachment 93294 [details]
my "/var/log/boot.log" file
Comment 23 Luke 2003-07-31 08:43:01 EDT
I had changed the default keymap from "us" to Polish ("pl") and got the same 
problem. After I had rebooted the system - during the system startup - my 
screen got flooded with such messages:

plus before ecircumflex ignored
plus before Ecircumflex ignored
plus before oacute ignored
plus before Oacute ignored
(...and many, many more - all in attached /var/log/boot.log file)

# my "/etc/sysconfig/i18n" file:
LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en:pl_PL.UTF-8:pl_PL:pl"
SYSFONT="latarcyrheb-sun16"

Luke

Comment 24 Leonid Kanter 2003-07-31 14:29:56 EDT
All national 8-bit keyboard layouts should be converted to utf-8 in the same way
like we did with Russian layout. See attachment for bug 79338 as an example of
utf-8 layout.
Comment 25 Eido Inoue 2003-07-31 15:29:04 EDT
Warning spewer commented out from ksyms.c in release 9

Note You need to log in before you can comment on or make changes to this bug.