Bug 854904 - Quitting Anaconda in LiveCD reboots machine
Quitting Anaconda in LiveCD reboots machine
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedNTH
:
: 855645 857380 859423 880683 882964 889741 889742 (view as bug list)
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-09-06 05:17 EDT by Daniel Vrátil
Modified: 2015-11-01 20:36 EST (History)
12 users (show)

See Also:
Fixed In Version: anaconda-18.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-12 15:14:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Vrátil 2012-09-06 05:17:00 EDT
Description of problem:
Quitting Anaconda when running liveinst from LiveCD displays a dialog that states "Are you sure you wish to quit the installation process?". Clicking "Quit" does not quit the installation process (Anaconda) but reboots the machine.

The dialog should either state that quitting Anaconda will reboot the machine or Anaconda should just quit without rebooting.

The same situation occurs when Anaconda crashes and you quit the bug-reporting dialog. This prevents users from effectively searching for possible solution for the crash from the liveCD session.


Version-Release number of selected component (if applicable):
anaconda-18.6.5-1.fc18


How reproducible:
Always

Steps to Reproduce:
1. Start liveinst
2. Click QUIT
3. Confirm dialog that "Installation process will quit"
  
Actual results:
Machine reboots

Expected results:
Only Anaconda quits

Additional information:
Fedora 18 Alpha TC6
Comment 1 Chris Lumens 2012-09-06 10:58:21 EDT
Ah, this was a workaround for gnome not providing an easily discoverable quit/reboot button, but there appears to be one now.  I guess this can go.
Comment 2 Chris Lumens 2012-09-09 15:32:36 EDT
*** Bug 855645 has been marked as a duplicate of this bug. ***
Comment 3 Kamil Páral 2012-09-10 04:28:31 EDT
There are two different cases:

1. If user quits anaconda (because he started it by mistake, or it reported an error, etc), it should not restart the whole computer.

2. If anaconda completes installation, the last button should be called Reboot, and it should reboot the whole computer. (But if user closes anaconda using close button, it should not reboot, because he probably wants to work further even though the installation is complete.)

That should be very easy to implement - always close, just in case of Reboot button do reboot.
Comment 4 Chris Lumens 2012-09-14 10:12:37 EDT
*** Bug 857380 has been marked as a duplicate of this bug. ***
Comment 5 Jesse Keating 2012-09-21 14:16:40 EDT
*** Bug 859423 has been marked as a duplicate of this bug. ***
Comment 6 Kamil Páral 2012-10-05 04:23:25 EDT
Quit button now doesn't reboot Live system, which is great. But the Reboot button now doesn't reboot either!

Guys, let's Quit button quit, and Reboot button reboot, sounds good? :)
Comment 7 Chris Lumens 2012-10-05 10:44:40 EDT
In what version of anaconda, in what product?
Comment 8 Kamil Páral 2012-10-08 08:07:52 EDT
Dan says "Fedora 18 Alpha TC6" in the description. My comment 6 talks about F18 Beta TC2, which is anaconda 18.12.
Comment 9 Daniel Vrátil 2012-10-08 10:30:06 EDT
I can confirm that with Fedora 18 Beta TC2 the "Quit" button in Anaconda installer only quits and does not reboot (on both Desktop and KDE Spin).

However, when a crash occurs, the "Quit" button in the "An error occurred" dialog still causes the live system to reboot. This is reproducible only on KDE spin, on Desktop the button works as expected.

I can't confirm whether "Reboot" button works or not, because I'm unable to start/complete installation on both Desktop and KDE spin.
Comment 10 Xavier Hourcade 2012-10-22 14:12:13 EDT
I can confirm that with Fedora 18 Beta TC6 the "Quit" button in Anaconda installer only quits and does not reboot (tested KDE Spin only).

And when a crash occurs, the "Quit" button in the error dialogue did *not* cause the live system to reboot.

As per the "Reboot" button, I still didn't ever try to go as far as installing, so I won't tell either :)
Comment 11 Adam Williamson 2012-11-22 20:33:48 EST
Note that 18.31 is a post-Beta build: don't expect this fixed in Beta. It should be fixed in post-Beta nightlies and Final TC1 onwards.
Comment 12 Chris Lumens 2012-11-27 12:02:15 EST
*** Bug 880683 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2012-12-03 10:17:46 EST
*** Bug 882964 has been marked as a duplicate of this bug. ***
Comment 14 Richard W.M. Jones 2012-12-03 10:33:35 EST
I got this (reboot button does nothing) in Fedora 18 Beta x86-64 Live.

Apart from that, Anaconda works pretty good .. don't know what
everyone was complaining 'bout :-)
Comment 15 Adam Williamson 2012-12-12 14:40:14 EST
Discussed at 2012-12-12 NTH review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-12/f18final-blocker-review-4.2012-12-12-17.01.log.txt . Accepted as NTH, it's a very annoying issue for live installs that cannot be fixed with an update.
Comment 16 Adam Williamson 2012-12-12 14:49:42 EST
In Final TC1, I see only a 'Quit' button at the end of live anaconda, and it quits, it doesn't reboot. Is anything still broken here? kparal seems to think so, but I can't see anything.
Comment 17 Adam Williamson 2012-12-12 14:55:58 EST
setting ON_QA as this was allegedly fixed in 18.31, which is long before the build in TC1 (18.36 has gone stable, so if no-one can point out broken behaviour in TC1, we can close this.)
Comment 18 Kamil Páral 2012-12-12 15:14:37 EST
Reboot has been renamed to Quit in TC1. Quit quits. Fixed in a different way than supposed, but still fixed.
Comment 19 Chris Lumens 2013-01-02 09:49:34 EST
*** Bug 889742 has been marked as a duplicate of this bug. ***
Comment 20 Chris Lumens 2013-01-02 09:49:39 EST
*** Bug 889741 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.