Bug 856456 - Anaconda no longer has option to set hostname in UI
Anaconda no longer has option to set hostname in UI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedNTH
:
: 870921 889740 (view as bug list)
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept 884701
  Show dependency treegraph
 
Reported: 2012-09-12 01:00 EDT by Daniel Belton
Modified: 2013-08-02 17:50 EDT (History)
17 users (show)

See Also:
Fixed In Version: anaconda-18.37.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-03 20:12:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Belton 2012-09-12 01:00:42 EDT
Description of problem:

No way to set hostname in anaconda

Version-Release number of selected component (if applicable):

Fedora 18 Alpha RC2

How reproducible:

Install Fedora 18 from DVD image.

Steps to Reproduce:
1. Install Fedora 18 from DVD image
2. No option to set hostname
3.
  
Actual results:

No option to set hostname

Expected results:

Option as in previous versions to set hostname to something besides localhost.localdomain

Additional info:
Comment 1 Daniel Belton 2012-09-12 01:04:47 EDT
It is possible that this option is in the configuration for the network adapter, but when I tried to click on the configure button, nothing happened. 

While it did set up my network adapter, I just had to accept how anaconda decided to set it up, and couldn't go into the configuration to change it. 

Also, it didn't create the /etc/sysconfig/network file.
Comment 2 Radek Vykydal 2012-09-12 04:01:55 EDT
Setting hostname is not designed/implemented anywhere in UI yet, it should work using kickstart network --hostname option, though not in Alpha (RC2), patches are only in master.

> 
> While it did set up my network adapter, I just had to accept how anaconda
> decided to set it up, and couldn't go into the configuration to change it. 
> 
> Also, it didn't create the /etc/sysconfig/network file.

This is fixed in master with patches mentioned above.
Comment 3 Daniel Belton 2012-10-08 18:14:25 EDT
F18 TC2 still has no option to set the hostname
Comment 4 Reartes Guillermo 2012-10-27 15:44:06 EDT
In forums.fedoraforum.org (F18 Development), someone mentioned this:

http://lists.fedoraproject.org/pipermail/test/2012-October/111230.html

Deprecated files:
/etc/sysconfig/clock
/etc/sysconfig/i18n
/etc/sysconfig/keyboard
/etc/sysconfig/network (Hostname only) <<<< RELEVANT TO THIS BUGREPORT

SystemD v +195 for F18 now has:

# hostnamectl status
   Static hostname: superservercowball
   Pretty hostname: superserver.cowball
         Icon name: n/a
        Machine ID: 5d91ca5f9debf4df91890550bb335d84
           Boot ID: aec5010be8b945149e041ad03324e3b1
    Virtualization: kvm
  Operating System: Fedora 18 (Spherical Cow)
       CPE OS Name: cpe:/o:fedoraproject:fedora:18
            Kernel: Linux 3.6.3-3.fc18.x86_64
      Architecture: x86_64

# hostnamectl set-hostname hyperserver.cowball
      
Installing and updating from F18b TC6 bring such systemd version, so future
test composes will most likely have such systemd version.

The hostname could be set by anaconda or during firstboot. 

If it is decided that the hostname will be set by firstboot, then firstboot 
can simply add a text dialog or similar to enter the hostname and execute a 'hostnamectl set-hostname'. It looks simple for firstboot to be implemented, exept for package groups that do not have xorg.

I would prefer for the hostname to be set by anaconda, so one can boot with the desired hostname. (the setting could be added below 'set root password' during install.
Comment 5 Radek Vykydal 2012-12-04 08:58:34 EST
To Reartes:

We need to set hostname before storage configuration as it is used for default LVM and RAID names.

FYI, the /etc/sysconfig/network -> /etc/hostname patch is being reviewed.
Comment 6 Radek Vykydal 2012-12-07 03:15:19 EST
*** Bug 870921 has been marked as a duplicate of this bug. ***
Comment 7 Richard W.M. Jones 2012-12-07 03:26:22 EST
(In reply to comment #5)
> To Reartes:
> 
> We need to set hostname before storage configuration as it is used for
> default LVM and RAID names.

Indeed this is true .. see: bug 884701 for details about
the current regression in Anaconda.
Comment 8 Radek Vykydal 2012-12-07 04:33:14 EST
Nominating as NTH to bring more eyes to it, although I'd prefer to dedicate proper time to design / discuss the place of the setting in UI post F18.
Comment 9 Reartes Guillermo 2012-12-10 11:01:04 EST
What about a boot parameter, like 'advanced' that will ask the user for a hostname, BEFORE anaconda?

This would be a Q&D route for F18.

~~~~~~~~~~~~~~~~~~~~~~

Advanced parameter specified:

The current hostname is 'fedora', type the desired hostname or just press ENTER to accept the current value.
Hostname: cowball

Setting hostname to Cowball

Launching anaconda...

~~~~~~~~~~~~~~~~~~~~~~
Comment 10 Adam Williamson 2012-12-12 14:47:45 EST
NTH nomination was done wrong by mistake, fixing. I am +1 NTH at least on this, it is a very common complaint about newUI that there is no hostname setting.
Comment 11 Adam Williamson 2012-12-12 14:54:33 EST
Discussed at 2012-12-12 NTH review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-12/f18final-blocker-review-4.2012-12-12-17.01.log.txt . Accepted as NTH, this is a regression from F17 behaviour and a popular request/complaint about newUI, plus it causes https://bugzilla.redhat.com/show_bug.cgi?id=884701 for LV naming.
Comment 12 Aleksandar Kostadinov 2012-12-13 03:41:12 EST
what is the anticipated way to change hostname in fedora 18 at all? I can't figure out.
Comment 13 Adam Williamson 2012-12-13 13:09:37 EST
man hostnamectl
Comment 14 Radek Vykydal 2012-12-14 11:34:46 EST
Here is updates image with a patch adding hostname to network spoke:

http://rvykydal.fedorapeople.org/updates.hostnameui.img

Hostname sanity check is done when leaving spoke.
Comment 15 Radek Vykydal 2012-12-14 11:35:11 EST
(In reply to comment #14)
> Here is updates image with a patch adding hostname to network spoke:
> 
> http://rvykydal.fedorapeople.org/updates.hostnameui.img
> 
> Hostname sanity check is done when leaving spoke.

It is for F18 TC2
Comment 16 Adam Williamson 2012-12-17 21:04:54 EST
Tested (against TC3 - the updates.img seems to work ok). The dialog works. The hostname is properly set on the installed system. The LV name uses the hostname I set (used autopart). Hostname sanity check seems to work - except that the error message is too long and goes off the side of the screen; I think the error message display code lacks line wrapping, I need to file a separate bug for that (seen it with root password errors also). This patch looks good, please apply it for next anaconda build.
Comment 17 Adam Williamson 2012-12-17 21:21:34 EST
Filed https://bugzilla.redhat.com/show_bug.cgi?id=888112 for the error message overflow.
Comment 18 Mukundan Ragavan 2012-12-17 21:28:28 EST
Tested using final TC3 (anaconda version 18.37.3) and performed a minimal install on virtualbox VM.

hostname textbox appears under network spoke and the given hostname is retained for installation and shows up correctly in the installed system.
Comment 19 Adam Williamson 2012-12-18 21:05:10 EST
Radek, can you please commit this so we get it in the next build? It missed 37.4 unfortunately.
Comment 20 Adam Williamson 2012-12-18 21:06:47 EST
I see some nitpicking about the layout on the ML, but seriously, it's getting pretty late, just pick something and go with it guys :)
Comment 21 Richard W.M. Jones 2012-12-24 07:08:03 EST
(In reply to comment #13)
> man hostnamectl

This sucks.  Why isn't just changing the /etc/hostname file
sufficient?  I tried just changing the file and it did nothing.

Note that calling out to arbitrary binaries is unacceptable
when modifying guests (eg. from virt-sysprep).
Comment 22 Richard W.M. Jones 2012-12-24 07:26:15 EST
(In reply to comment #21)
> (In reply to comment #13)
> > man hostnamectl
> 
> This sucks.  Why isn't just changing the /etc/hostname file
> sufficient?  I tried just changing the file and it did nothing.
> 
> Note that calling out to arbitrary binaries is unacceptable
> when modifying guests (eg. from virt-sysprep).

https://bugzilla.redhat.com/show_bug.cgi?id=890027
Comment 23 Paul Franklin (RHlists) 2012-12-24 20:10:42 EST
I'm confused.  It says "Fixed In Version: anaconda-18.37.5-1"
up above yet I don't see the usual automated messages in the
Comment areas reporting the progress of the fix, asking for
karma and so on.  Am I missing something?  Thanks.
Comment 24 Chris Lumens 2013-01-02 09:50:04 EST
*** Bug 889740 has been marked as a duplicate of this bug. ***
Comment 25 Mukundan Ragavan 2013-01-03 15:19:36 EST
Option to set hostname is present under the new TC4 image (anaconda 18.37.8) and it does set the hostname for the installed system as specified during installation.

Works well. This bug report can be closed (I think).
Comment 26 Adam Williamson 2013-01-03 20:12:45 EST
Yes, it can.

Note You need to log in before you can comment on or make changes to this bug.