Bug 875348 - [abrt] python-2.7.3-7.2.fc17: spice_logv: Process /usr/bin/python2.7 was killed by signal 6 (SIGABRT)
[abrt] python-2.7.3-7.2.fc17: spice_logv: Process /usr/bin/python2.7 was kill...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice-gtk (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc-Andre Lureau
Fedora Extras Quality Assurance
abrt_hash:e220b92b2d0ee7dbb7f10bac384...
:
: 882054 894540 902860 905714 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-10 12:57 EST by Antonio Augusto Santos
Modified: 2013-04-03 00:39 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-03 00:39:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.59 KB, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: environ (1.27 KB, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: backtrace (22.46 KB, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: cgroup (129 bytes, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: smolt_data (2.57 KB, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: executable (18 bytes, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: maps (87.94 KB, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: dso_list (18.48 KB, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: proc_pid_status (925 bytes, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: open_fds (1.11 KB, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
File: var_log_messages (306 bytes, text/plain)
2012-11-10 12:57 EST, Antonio Augusto Santos
no flags Details
fix not caching palettes of un-rendered bitmaps. (2.04 KB, patch)
2013-01-31 13:00 EST, Yonit Halperin
no flags Details | Diff

  None (edit)
Description Antonio Augusto Santos 2012-11-10 12:57:27 EST
Description of problem:
I was running virt-maanger when it hang.

Version-Release number of selected component:
python-2.7.3-7.2.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        python /usr/share/virt-manager/virt-manager.py
crash_function: spice_logv
kernel:         3.6.6-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #2 spice_logv at log.c:97
: #3 spice_log at log.c:111
: #4 canvas_get_image_internal at ../spice-common/common/canvas_base.c:1128
: #5 canvas_get_image at ../spice-common/common/canvas_base.c:1264
: #6 canvas_draw_copy at ../spice-common/common/canvas_base.c:2182
: #7 display_handle_draw_copy at channel-display.c:1178
: #8 spice_channel_recv_msg at spice-channel.c:1838
: #9 spice_channel_iterate_read at spice-channel.c:2000
: #11 spice_channel_iterate at spice-channel.c:2058
: #12 spice_channel_coroutine at spice-channel.c:2215
Comment 1 Antonio Augusto Santos 2012-11-10 12:57:30 EST
Created attachment 642278 [details]
File: core_backtrace
Comment 2 Antonio Augusto Santos 2012-11-10 12:57:33 EST
Created attachment 642279 [details]
File: environ
Comment 3 Antonio Augusto Santos 2012-11-10 12:57:36 EST
Created attachment 642280 [details]
File: backtrace
Comment 4 Antonio Augusto Santos 2012-11-10 12:57:38 EST
Created attachment 642281 [details]
File: limits
Comment 5 Antonio Augusto Santos 2012-11-10 12:57:40 EST
Created attachment 642282 [details]
File: cgroup
Comment 6 Antonio Augusto Santos 2012-11-10 12:57:42 EST
Created attachment 642283 [details]
File: smolt_data
Comment 7 Antonio Augusto Santos 2012-11-10 12:57:44 EST
Created attachment 642284 [details]
File: executable
Comment 8 Antonio Augusto Santos 2012-11-10 12:57:48 EST
Created attachment 642285 [details]
File: maps
Comment 9 Antonio Augusto Santos 2012-11-10 12:57:51 EST
Created attachment 642286 [details]
File: dso_list
Comment 10 Antonio Augusto Santos 2012-11-10 12:57:53 EST
Created attachment 642287 [details]
File: proc_pid_status
Comment 11 Antonio Augusto Santos 2012-11-10 12:57:55 EST
Created attachment 642288 [details]
File: open_fds
Comment 12 Antonio Augusto Santos 2012-11-10 12:57:57 EST
Created attachment 642289 [details]
File: var_log_messages
Comment 13 Dave Malcolm 2012-11-12 10:10:09 EST
Thanks for filing this bug report.

Looking at attachment 642280 [details] I see that this is appears to be an assertion failure within spice:
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x0000003896c44d05 in spice_logv (log_domain=0x3896cc2e46 "Spice", log_level=SPICE_LOG_LEVEL_CRITICAL, strloc=0x3896ccc098 "../spice-common/common/canvas_base.c:1128", function=0x3896ccc880 "canvas_get_image_internal", format=0x3896ccc662 "condition `%s' failed", args=args@entry=0x7f7254fff758) at log.c:97
        level = 0x3896ccdcaa "CRITICAL" 

Reassigning from python to virt-manager for now
Comment 14 Christophe Fergeau 2012-12-17 05:03:26 EST
*** Bug 882054 has been marked as a duplicate of this bug. ***
Comment 15 Christophe Fergeau 2013-01-22 12:48:56 EST
*** Bug 894540 has been marked as a duplicate of this bug. ***
Comment 16 Christophe Fergeau 2013-01-22 12:50:36 EST
For the record, this bug has also been hit by people using virt-viewer ( #882054 has simple steps to reproduce which I did not try), and also in boxes.
Comment 17 Christophe Fergeau 2013-01-22 12:52:57 EST
*** Bug 902860 has been marked as a duplicate of this bug. ***
Comment 18 Cole Robinson 2013-01-24 16:06:49 EST
Hans, any idea if the recent spice build will fix this?
Comment 19 Hans de Goede 2013-01-25 03:39:58 EST
(In reply to comment #18)
> Hans, any idea if the recent spice build will fix this?

No, I already noticed this bug and took a look, but nothing we recently fixed comes to mind as being a potential trigger for this. But I'm not the most familiar with this code, you may try pinging yonit or alon on #spice @ gimpnet, and ask them to take a look.
Comment 20 Cole Robinson 2013-01-25 10:26:26 EST
Thanks Hans (and extra thanks for following up and pushing all those builds!). I'll stick with normal bugzilla channels for now.

Alon, Yonit, this bug has hit several spice consumers (virt-viewer, virt-manager, boxes), any thoughts?
Comment 21 Yonit Halperin 2013-01-31 13:00:39 EST
Created attachment 691137 [details]
fix not caching palettes of un-rendered bitmaps.
Comment 22 Yonit Halperin 2013-01-31 13:02:41 EST
This bug is a duplicate of 826036. I've posted the attached patch.
Comment 23 Hans de Goede 2013-01-31 15:07:50 EST
Hi,

(In reply to comment #21)
> Created attachment 691137 [details]
> fix not caching palettes of un-rendered bitmaps.

Thanks for working on this! Ack for the patch, can you please push it too the spice-common master repo?

Then once it is upstream we can update the common submodule of spice-gtk, do a new spice-gtk release and build that for Fedora.

Thanks,

Hans
Comment 24 Yonit Halperin 2013-01-31 16:46:31 EST
(In reply to comment #23)
> Hi,
> 
> (In reply to comment #21)
> > Created attachment 691137 [details]
> > fix not caching palettes of un-rendered bitmaps.
> 
> Thanks for working on this! Ack for the patch, can you please push it too
> the spice-common master repo?
> 
> Then once it is upstream we can update the common submodule of spice-gtk, do
> a new spice-gtk release and build that for Fedora.
> 
> Thanks,
> 
> Hans

Sure, thanks for the ack. I pushed both spice-common and spice-gtk.
Comment 25 Cole Robinson 2013-01-31 20:18:35 EST
*** Bug 905714 has been marked as a duplicate of this bug. ***
Comment 26 Fedora Update System 2013-02-06 14:54:10 EST
spice-gtk-0.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/spice-gtk-0.17-1.fc18
Comment 27 Fedora Update System 2013-02-07 21:28:38 EST
Package spice-gtk-0.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spice-gtk-0.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2081/spice-gtk-0.17-1.fc18
then log in and leave karma (feedback).
Comment 28 Fedora Update System 2013-02-13 13:55:51 EST
spice-gtk-0.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/spice-gtk-0.18-1.fc18
Comment 29 Fedora Update System 2013-04-03 00:39:10 EDT
spice-gtk-0.18-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.