Bug 984152 - Assert in systemd-logind: Assertion 's->user->slice' failed at src/login/logind-session.c:463, function session_start_scope(). Aborting.
Assert in systemd-logind: Assertion 's->user->slice' failed at src/login/logi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
: Reopened
: 984347 986519 986710 989153 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 00:47 EDT by Ben Boeckel
Modified: 2015-11-18 15:36 EST (History)
29 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-19 15:09:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journalctl output containing the error; cut off at unlocking xlock (20.93 KB, text/plain)
2013-07-13 00:47 EDT, Ben Boeckel
no flags Details
File: backtrace (8.75 KB, text/plain)
2013-07-16 16:38 EDT, Jerry James
no flags Details
Hit again. (105.78 KB, application/x-bzip)
2014-02-08 02:19 EST, Christopher Meng
no flags Details

  None (edit)
Description Ben Boeckel 2013-07-13 00:47:17 EDT
Created attachment 772937 [details]
journalctl output containing the error; cut off at unlocking xlock

Description of problem:
After logging in as root in a tmux window, logind crashed. The /run/user/1000 directory disappeared and was emptied. Log attached.

Version-Release number of selected component (if applicable):
systemd-205-1.fc20.x86_64
kernel-3.10.0-0.rc7.git0.3.fc20.x86_64
Comment 1 Zdenek Kabelac 2013-07-13 15:18:04 EDT
I've noticed the same -  also with systemd coredump:

systemd-logind[355]: Assertion 's->user->slice' failed at src/login/logind-session.c:463, function session_start_scope(). Aborting.
linux systemd-cgroups-agent[22324]: Failed to get D-Bus connection: Failed to connect to socket /org/freedesktop/systemd1/private: Connectio

#0  0x00007fa1d8d82b7b in raise (sig=sig@entry=11) at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:37
#1  0x00007fa1da8ca51e in crash (sig=11) at src/core/main.c:144
#2  <signal handler called>
#3  0x00007fa1da91838b in isempty (p=0x6c7463746964 <Address 0x6c7463746964 out of bounds>) at src/shared/util.h:106
#4  join_path (controller=0x7fa1da944fc2 "systemd", path=0x6c7463746964 <Address 0x6c7463746964 out of bounds>, suffix=0x7fa1da979cef "cgroup.procs", 
    fs=0x7fffb7b5fae8) at src/shared/cgroup-util.c:454
#5  0x00007fa1da918b08 in cg_enumerate_processes (controller=controller@entry=0x7fa1da972847 "name=systemd", 
    path=path@entry=0x6c7463746964 <Address 0x6c7463746964 out of bounds>, _f=_f@entry=0x7fffb7b5fb18) at src/shared/cgroup-util.c:50
#6  0x00007fa1da918dfa in cg_is_empty (controller=controller@entry=0x7fa1da972847 "name=systemd", 
    path=path@entry=0x6c7463746964 <Address 0x6c7463746964 out of bounds>, ignore_self=ignore_self@entry=true) at src/shared/cgroup-util.c:801
#7  0x00007fa1da918f6f in cg_is_empty_recursive (controller=controller@entry=0x7fa1da972847 "name=systemd", 
    path=0x6c7463746964 <Address 0x6c7463746964 out of bounds>, ignore_self=ignore_self@entry=true) at src/shared/cgroup-util.c:842
#8  0x00007fa1da90a4b0 in manager_notify_cgroup_empty (m=m@entry=0x7fa1dc0f4470, cgroup=<optimized out>) at src/core/cgroup.c:733
#9  0x00007fa1da8fb91d in private_bus_message_filter (connection=0x7fa1dc12e170, message=0x7fa1dc1b3220, data=0x7fa1dc0f4470) at src/core/dbus.c:491
#10 0x00007fa1d93bec56 in dbus_connection_dispatch (connection=connection@entry=0x7fa1dc12e170) at dbus-connection.c:4631
#11 0x00007fa1da8fc36a in bus_dispatch (m=m@entry=0x7fa1dc0f4470) at src/core/dbus.c:525
#12 0x00007fa1da8d003f in manager_loop (m=0x7fa1dc0f4470) at src/core/manager.c:1739
#13 0x00007fa1da8c7b14 in main (argc=5, argv=0x7fffb7b60608) at src/core/main.c:1731
Comment 2 Lennart Poettering 2013-07-15 15:57:09 EDT
Fixed in git, will upload soon.
Comment 3 Lennart Poettering 2013-07-15 15:59:09 EDT
*** Bug 984347 has been marked as a duplicate of this bug. ***
Comment 4 Jerry James 2013-07-16 16:37:59 EDT
I just made a Rawhide VM on a newly updated Fedora 19 host.  I went away to do some other stuff, and when I returned the VM's screen was locked.  I did the mouse swipe to get back to the login screen.  When I did, it already said "Authentication Error", even though I had not actually entered any text yet.  I typed in my password and hit Enter.  Nothing happened, other than a spinner appearing.  I did this 3 times.  On the 4th try, the words "Authentication Error" did not appear after swiping up the lock screen.  That time, entering my password unlocked the screen immediately, at which point I discovered that this crash apparently happened the first 3 times.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-logind
crash_function: log_assert
executable:     /usr/lib/systemd/systemd-logind
kernel:         3.11.0-0.rc0.git3.1.fc20.x86_64
package:        systemd-205-1.fc20
reason:         Process /usr/lib/systemd/systemd-logind was killed by signal 6 (SIGABRT)
runlevel:       unknown
uid:            0
Comment 5 Jerry James 2013-07-16 16:38:54 EDT
Created attachment 774480 [details]
File: backtrace
Comment 6 Adam Williamson 2013-07-18 17:10:21 EDT
I have multiple occurrences of this crash in my logs; may be related to an NFS mount attempt but I'm not 100% sure. Seems to just happen during running GNOME sessions, nothing in particular to trigger it.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-logind
crash_function: log_assert
executable:     /usr/lib/systemd/systemd-logind
kernel:         3.9.8-300.7.fc19.x86_64
package:        systemd-205-1.fc20
reason:         Process /usr/lib/systemd/systemd-logind was killed by signal 6 (SIGABRT)
runlevel:       N N
uid:            0
Comment 7 Lennart Poettering 2013-07-22 20:32:17 EDT
Fixed in 206-1.
Comment 8 Lennart Poettering 2013-07-25 20:58:13 EDT
*** Bug 986710 has been marked as a duplicate of this bug. ***
Comment 9 Lennart Poettering 2013-07-25 20:58:21 EDT
*** Bug 986519 has been marked as a duplicate of this bug. ***
Comment 10 piio 2013-07-26 15:03:09 EDT
Still happening in 206-1.
In system logs I see often:
systemd[3611]: Failed at step PAM spawning /usr/lib/systemd/systemd: Operation not permitted
Comment 11 Christopher Meng 2013-08-07 02:00:32 EDT
Still happened today when yum updating 4000+ packages.
Comment 12 Christopher Meng 2013-08-13 02:27:12 EDT
Hitting again.

When systemctl status and press tab, failed with:

 Failed to get D-Bus connection: Failed to connect to socket /run/systemd/private: Connection refused
Comment 13 Zbigniew Jędrzejewski-Szmek 2013-10-22 08:07:25 EDT
(In reply to piio from comment #10)
> systemd[3611]: Failed at step PAM spawning /usr/lib/systemd/systemd:
> Operation not permitted
This is a different issue.

(In reply to Christopher Meng from comment #11)
> Still happened today when yum updating 4000+ packages.
What systemd version?
Comment 14 Zbigniew Jędrzejewski-Szmek 2013-10-22 08:07:51 EDT
*** Bug 989153 has been marked as a duplicate of this bug. ***
Comment 15 Christopher Meng 2013-10-22 08:19:27 EDT
(In reply to Zbigniew Jędrzejewski-Szmek from comment #13)
> (In reply to piio from comment #10)
> > systemd[3611]: Failed at step PAM spawning /usr/lib/systemd/systemd:
> > Operation not permitted
> This is a different issue.
> 
> (In reply to Christopher Meng from comment #11)
> > Still happened today when yum updating 4000+ packages.
> What systemd version?

I already forget it, maybe 206 also.... But I remember at that time systemd is not stable. Then things go well.
Comment 16 Zbigniew Jędrzejewski-Szmek 2013-10-24 00:31:44 EDT
Yeah, I'm pretty sure that we've fixed this assert like Lennart said.

piio's message from comment #10 is something different.
Comment 17 Christopher Meng 2014-02-08 02:18:49 EST
Hitting again with rawhide updated to the latest packages.
Comment 18 Christopher Meng 2014-02-08 02:19:29 EST
Created attachment 860843 [details]
Hit again.
Comment 19 Lennart Poettering 2014-06-19 15:09:28 EDT
I m really sure this is fixed with current rawhide versions. If not, please open new bugs with backtraces and stuff. I will ignore comment #10 as that appears unrelated, and should have been filed in a separate bug.
Comment 20 Mikhail Strizhov 2015-11-16 19:12:39 EST
Fedora 22, kernel: 4.1.6-200.fc22.x86_64, systemd-219-25.fc22.x86_64

Problem is still there:

Nov 16 16:58:01 yukon systemd: Received SIGRTMIN+24 from PID 8543 (kill).
Nov 16 16:58:01 yukon systemd: Stopped User Manager for UID 978.
Nov 16 16:58:01 yukon systemd: Removed slice user-978.slice.
Nov 16 16:58:01 yukon systemd: Stopping user-978.slice.
Nov 16 17:07:22 yukon systemd-logind: Failed to start user slice: Connection timed out
Nov 16 17:07:24 yukon systemd-logind: Assertion 's->user->slice' failed at ../src/login/logind-session.c:501, function session_start_scope()
. Aborting.
Nov 16 17:07:24 yukon systemd: Created slice user-0.slice.
Nov 16 17:07:24 yukon systemd: Starting user-0.slice.
Nov 16 17:07:24 yukon systemd: Starting User Manager for UID 0...
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: (EE)
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: Fatal server error:
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: (EE) systemd-logind disappeared (stopped/restarted?)
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: (EE)
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: (EE)
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: Please consult the Fedora Project support
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: at http://wiki.x.org
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: for help.
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: (EE) Please also check the log file at "/var/lib/gdm/.local/share/xorg/Xorg.0.log" for add
itional information.
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: (EE)
Nov 16 17:07:24 yukon /usr/libexec/gdm-x-session: (II) AIGLX: Suspending AIGLX clients for VT switch
Nov 16 17:07:24 yukon systemd: Reached target Sockets.
Nov 16 17:07:24 yukon systemd: Starting Sockets.
Nov 16 17:07:24 yukon systemd: Reached target Paths.
Nov 16 17:07:24 yukon systemd: Starting Paths.
Nov 16 17:07:24 yukon systemd: Reached target Timers.
Nov 16 17:07:24 yukon systemd: Starting Timers.
Nov 16 17:07:24 yukon systemd: Reached target Basic System.
Nov 16 17:07:24 yukon systemd: Starting Basic System.
Nov 16 17:07:24 yukon systemd: Reached target Default.
Nov 16 17:07:24 yukon systemd: Startup finished in 7ms.
Nov 16 17:07:24 yukon systemd: Starting Default.
Nov 16 17:07:24 yukon systemd: Started User Manager for UID 0.
Nov 16 17:07:24 yukon dbus[790]: [system] Activating via systemd: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Nov 16 17:07:24 yukon systemd: systemd-logind.service: main process exited, code=dumped, status=6/ABRT
Nov 16 17:07:24 yukon systemd: Unit systemd-logind.service entered failed state.
Nov 16 17:07:24 yukon systemd: systemd-logind.service failed.
Nov 16 17:07:24 yukon systemd: systemd-logind.service has no holdoff time, scheduling restart.
Nov 16 17:07:24 yukon systemd: Starting Login Service...
Nov 16 17:07:24 yukon dbus[790]: [system] Successfully activated service 'org.freedesktop.login1'
Nov 16 17:07:24 yukon systemd: Started Login Service.
Nov 16 17:07:24 yukon systemd-logind: New seat seat0.
Nov 16 17:07:24 yukon systemd-logind: Watching system buttons on /dev/input/event1 (Power Button)
Nov 16 17:07:24 yukon systemd-logind: Watching system buttons on /dev/input/event0 (Power Button)
Nov 16 17:07:24 yukon systemd: Stopping User Manager for UID 0...
Nov 16 17:07:24 yukon systemd: Reached target Shutdown.
Nov 16 17:07:24 yukon systemd: Starting Shutdown.
Nov 16 17:07:24 yukon systemd-logind: New session c2 of user gdm.
Nov 16 17:07:24 yukon systemd: Starting Exit the Session...
Nov 16 17:07:24 yukon systemd: Stopped target Default.
Nov 16 17:07:24 yukon systemd: Stopping Default.
Nov 16 17:07:24 yukon systemd: Stopped target Basic System.
Nov 16 17:07:24 yukon systemd: Stopping Basic System.
Nov 16 17:07:24 yukon systemd: Stopped target Sockets.
Nov 16 17:07:24 yukon systemd: Stopping Sockets.
Nov 16 17:07:24 yukon systemd: Stopped target Timers.
Nov 16 17:07:24 yukon systemd: Stopping Timers.
Nov 16 17:07:24 yukon systemd: Stopped target Paths.
Nov 16 17:07:24 yukon systemd: Stopping Paths.
Nov 16 17:07:24 yukon systemd-logind: New session c1 of user gdm.
Nov 16 17:07:24 yukon systemd: Received SIGRTMIN+24 from PID 8643 (kill).

Note You need to log in before you can comment on or make changes to this bug.