Bug 2075842 (CVE-2022-21476)

Summary: CVE-2022-21476 OpenJDK: Defective secure validation in Apache Santuario (Libraries, 8278008)
Product: [Other] Security Response Reporter: Mauro Matteo Cascella <mcascell>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: unspecifiedCC: ahughes, chazlett, dfitzmau, jdowland, jhuttana, jochrist, jvanek, nengard, neugens, pjindal, security-response-team, sraghupu
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-04-29 00:15:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2073575, 2073576, 2073577, 2073578, 2073579, 2073587, 2073589, 2073590, 2073591, 2073592, 2073593, 2073594, 2073595, 2073601, 2074639, 2074641, 2074642, 2074643, 2074644, 2074645, 2074646, 2074649, 2074650    
Bug Blocks: 2073424    

Description Mauro Matteo Cascella 2022-04-15 15:55:03 UTC
A flaw was found in Apache Santuario (XML Security for Java) in the way it processed some paths. A remote attacker could use this flaw to circumvent the "secure validation" feature and disclose potentially sensitive information in local XML files.

Comment 7 errata-xmlrpc 2022-04-20 12:38:32 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2022:1443 https://access.redhat.com/errata/RHSA-2022:1443

Comment 8 errata-xmlrpc 2022-04-20 12:50:29 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions

Via RHSA-2022:1444 https://access.redhat.com/errata/RHSA-2022:1444

Comment 9 errata-xmlrpc 2022-04-20 13:08:43 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.4 Extended Update Support

Via RHSA-2022:1441 https://access.redhat.com/errata/RHSA-2022:1441

Comment 10 errata-xmlrpc 2022-04-20 13:28:32 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:1445 https://access.redhat.com/errata/RHSA-2022:1445

Comment 12 errata-xmlrpc 2022-04-20 14:14:40 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:1442 https://access.redhat.com/errata/RHSA-2022:1442

Comment 13 Mauro Matteo Cascella 2022-04-20 15:21:32 UTC
Oracle CPU April 2022:

https://www.oracle.com/security-alerts/cpuapr2022.html#AppendixJAVA

Fixed in Oracle Java SE 7u341, 8u331, 11.0.15, 17.0.3, 18.0.1.

Comment 14 errata-xmlrpc 2022-04-20 15:23:58 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2022:1440 https://access.redhat.com/errata/RHSA-2022:1440

Comment 15 errata-xmlrpc 2022-04-25 13:47:54 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2022:1487 https://access.redhat.com/errata/RHSA-2022:1487

Comment 16 errata-xmlrpc 2022-04-25 14:59:31 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions

Via RHSA-2022:1488 https://access.redhat.com/errata/RHSA-2022:1488

Comment 17 errata-xmlrpc 2022-04-25 15:00:13 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2022:1489 https://access.redhat.com/errata/RHSA-2022:1489

Comment 18 errata-xmlrpc 2022-04-25 15:09:09 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.4 Extended Update Support

Via RHSA-2022:1490 https://access.redhat.com/errata/RHSA-2022:1490

Comment 19 errata-xmlrpc 2022-04-25 15:47:59 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:1491 https://access.redhat.com/errata/RHSA-2022:1491

Comment 20 errata-xmlrpc 2022-04-28 18:58:31 UTC
This issue has been addressed in the following products:

  Red Hat Build of OpenJDK 8u332

Via RHSA-2022:1492 https://access.redhat.com/errata/RHSA-2022:1492

Comment 21 errata-xmlrpc 2022-04-28 18:58:50 UTC
This issue has been addressed in the following products:

  Red Hat Build of OpenJDK 8u332

Via RHSA-2022:1438 https://access.redhat.com/errata/RHSA-2022:1438

Comment 22 errata-xmlrpc 2022-04-28 18:59:37 UTC
This issue has been addressed in the following products:

  Red Hat Build of OpenJDK 11.0.15

Via RHSA-2022:1435 https://access.redhat.com/errata/RHSA-2022:1435

Comment 23 errata-xmlrpc 2022-04-28 18:59:57 UTC
This issue has been addressed in the following products:

  Red Hat Build of OpenJDK 11.0.15

Via RHSA-2022:1439 https://access.redhat.com/errata/RHSA-2022:1439

Comment 24 errata-xmlrpc 2022-04-28 19:04:02 UTC
This issue has been addressed in the following products:

  Red Hat Build of OpenJDK 17.0.3

Via RHSA-2022:1436 https://access.redhat.com/errata/RHSA-2022:1436

Comment 25 errata-xmlrpc 2022-04-28 19:04:30 UTC
This issue has been addressed in the following products:

  Red Hat Build of OpenJDK 17.0.3

Via RHSA-2022:1437 https://access.redhat.com/errata/RHSA-2022:1437

Comment 26 Product Security DevOps Team 2022-04-29 00:15:13 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2022-21476

Comment 27 errata-xmlrpc 2022-05-17 23:39:05 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2022:2137 https://access.redhat.com/errata/RHSA-2022:2137

Comment 28 errata-xmlrpc 2022-05-17 23:39:21 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2022:1729 https://access.redhat.com/errata/RHSA-2022:1729

Comment 29 errata-xmlrpc 2022-05-17 23:39:36 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2022:1728 https://access.redhat.com/errata/RHSA-2022:1728