This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 491754

Summary: DeviceError: cannot commit to disk sda after 5 attempts
Product: [Fedora] Fedora Reporter: PaulB <pbunyan>
Component: anacondaAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: a, atodorov, awilliam, bugger-pihhan, dcantrell, dekacy10, dennisml, drfudgeboy, fedora.090610, jgranado, jlaska, juergen.leising, junzhaoyi, lapointe.xavier, lwang, mbeeraka, mgahagan, mmatsuya, mschmidt, orion, pjones, ricardo.arguello, rmaximo, tao, ujjwol, vanmeeuwen+fedora
Target Milestone: ---Keywords: CommonBugs, Reopened
Target Release: ---Flags: jkeating: fedora_requires_release_note+
Hardware: All   
OS: Linux   
Whiteboard: anaconda_trace_hash:37d7371050a8fb2ee328360d837855e0ec5e57b61418b4980c51e07535b07df9 https://fedoraproject.org/wiki/Common_F11_bugs#491754
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-21 11:48:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 446451    
Attachments:
Description Flags
log saved during install
none
Attached traceback automatically from anaconda.
none
Expection Occured by anaconda
none
bzip2 compressed archive of /tmp/ as it could be found when I failed with installing fc11 because of "Cannot commit to disk...".
none
anaconda-logs.tgz (w/ 491754.img)
none
Patch to disable boot flag modification for upgrade
none
My updates file that helped me to upgrade
none
Storage log with stack trace to problem origin
none
Storage.log with backtrace
none
Contains all the /tmp directory after a failed installation using the patch http://dcantrel.fedorapeople.org/491754.img none

Description PaulB 2009-03-23 16:34:48 EDT
Created attachment 336379 [details]
log saved during install

Description of problem:
anaconda 11.5.0.35 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 800, in commit
    raise DeviceError("cannot commit to disk %s after %d attempts" % (self.name, maxTries,))
  File "/usr/lib/anaconda/storage/devices.py", line 1130, in create
    self.disk.commit()
  File "/usr/lib/anaconda/storage/deviceaction.py", line 206, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 660, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 184, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
DeviceError: cannot commit to disk sda after 5 attempts


Version-Release number of selected component (if applicable):
anaconda 11.5.0.35

How reproducible:
always

Additional info:
see attachment
Comment 1 David Cantrell 2009-03-23 16:44:01 EDT
What partition layout did you define?
Comment 2 Joel Andres Granados 2009-03-24 05:29:26 EDT
dcantrell:
this might be dupe of 491722.
Comment 3 PaulB 2009-03-24 10:45:19 EDT
All,
I carved the drive for an installation of Fedora 11(rawhide) on one LVM and created a second LVM for another Linux installation
The partition scheme was as follows:

Device		MountPoint/RAID/Volume	Type	Format	sizeMB	Start	End ▫LVMVolumeGroups
▫VG_
   swap				        swap		
   root				        ext3		
 ▫VG_Fedora						
   swapFedora				swap		
   rootFedora				ext4		
▫HardDrives
 ▫/dev/sda
   /dev/sda1	/boot			ext3
   /dev/sda2	/bootOther		ext3		
   /dev/sda3    VG_Fedora		LVM PV		
   ▫/dev/sda4				Extended	
    /dev/sda5	VG_		        LVM PV		


-PaulB
Comment 4 Chris Lumens 2009-03-24 11:16:31 EDT
*** Bug 491887 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2009-04-02 09:55:39 EDT
*** Bug 493481 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2009-04-02 09:56:10 EDT
*** Bug 491722 has been marked as a duplicate of this bug. ***
Comment 7 David Cantrell 2009-04-14 22:39:28 EDT
I think this problem has been fixed as of pyparted-2.0.10.  I've tried to recreate the problem locally with two different set ups and it's not happening for me.
Comment 8 DemetrisK 2009-04-20 15:03:12 EDT
Created attachment 340407 [details]
Attached traceback automatically from anaconda.
Comment 9 James Laska 2009-04-23 11:36:09 EDT
I'm still seeing this on an IBM power5 system using anaconda-11.5.0.47
Comment 10 Chris Lumens 2009-05-13 16:22:36 EDT
*** Bug 500723 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2009-05-14 13:54:42 EDT
*** Bug 496660 has been marked as a duplicate of this bug. ***
Comment 12 James Laska 2009-06-09 07:36:29 EDT
This issue has been documented at https://fedoraproject.org/wiki/Common_F11_bugs#491754
Comment 13 Bug Zapper 2009-06-09 08:32:16 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 James Heather 2009-06-10 03:03:56 EDT
I am seeing this on an upgrade from (fully updated) F10 to F11, using preupgrade. I'm not modifying the partition layout at all (unless anaconda has decided to do that without asking).

The 'Common Bugs' page suggests that if I follow exactly the same steps again, it will succeed. But I've now tried it three times, and it's failed every time.

This is on an HP Compaq nx7400 laptop. If more details would be helpful, please let me know what details, and I'll be happy to oblige.
Comment 15 Ujjwol 2009-06-11 00:41:50 EDT
Created attachment 347329 [details]
Expection Occured by anaconda

This what the anaconda said would be helpful for bug reporting
Please fix this error fast..
Comment 16 Ujjwol 2009-06-11 00:44:54 EDT
This is on Dell Inspiron 1420, contact me if more info needed...but please fix this fast...
Comment 17 ovl 2009-06-11 07:47:40 EDT
The same error on Asus M50SV, BUT it does not happen on the same laptop if I choose to install root on external USB drive... May be this information will help to locate problem.
Comment 18 James Heather 2009-06-13 06:17:03 EDT
Rather surprised that this has priority of 'low' when it is stopping people installing!

I suspect that's because of the claim that trying a second time resolves the issue (see Common Bugs page).

Unfortunately that doesn't seem to be true. I suggest that the priority tag be changed to 'high', and that the Common Bugs page be changed to reflect the fact that this isn't (always) resolved by trying again.
Comment 19 juergen leising 2009-06-14 10:39:15 EDT
Hello,

for me this is also a show-stopper. BTW: I got the same
error message, but without any possibility to save
the anaconda exception. However, I saved the complete
/tmp directory manually and added a screenshot of the 
final screen with the notorious "Exit the installer."

The anaconda does not seem to be able to deal with
LVM volumes where the underlying physical devices are
SATA disks.

So, actually, these are 3 bugs:

1. The deeper reason for why the device setup failed.
2. A possibility to save the error output (and some logfiles) is missing.
3. In a situation where no creation of a partition, 
   no formatting and no resizing was needed, the installer
   has no business in committing anything to any disk whatsoever.
   It should have simply left it untouched.  Only /etc/fstab
   must be written. Nothing else.  So a condition where the
   above error message can occur, should be not even be
   theoretically possible.

Bye, bye

Juergen

(now trying to add that attachment...)
Comment 20 juergen leising 2009-06-14 10:44:18 EDT
Created attachment 347824 [details]
bzip2 compressed archive of /tmp/ as it could be found when I failed with installing fc11 because of "Cannot commit to disk...".


Please note, that I did NOT get the usual anaconda exception backtraces.
Comment 21 Adam Williamson 2009-06-16 20:52:51 EDT
(In reply to comment #18)
> Rather surprised that this has priority of 'low' when it is stopping people
> installing!

Priority is mostly a no-op in Fedora Bugzilla at present. Most components do not use it for anything, so it stays at the default value for most bugs (low).

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Orion Poplawski 2009-06-24 14:29:00 EDT
No exception for me, just anaconda window:

An error was encountered while setting up device /dev/sda
cannot commit to disk after 5 attempts

bootloader --location=mbr --driveorder=sda,sda
clearpart --linux --drives=sda
part /boot --size=100
part swap --recommended
part / --size=9000 --grow

Disk is 500GB.  There is a second 250GB /dev/sdb with a single linux partition.

Rebooted and re-attemped with:

bootloader --location=mbr --driveorder=sda

Then get:

Could not allocate requested partitions: not enough free space on disks.

Then cleared out /dev/sda of all partitions and it could install.
Comment 23 Chris Lumens 2009-06-29 09:56:35 EDT
*** Bug 507541 has been marked as a duplicate of this bug. ***
Comment 24 Alexey Bozrikov 2009-07-03 06:12:31 EDT
I had this issue when doing fresh install of Fedora-11-i386 from DVD onto 73GB SCSI disk. First, I made a mistake of specifying ext4 for / filesystem (custom layout). gparted on the installation media does not seem to 'know' what ext4 is, so partitioning fails. I tried to install with everything ext3 and it failed again - now it was because partition sizes were reported as 4GB only (seems to be a python script bug). Finally I created all partitions (/ as ext3 and swap only, no /boot)manually from command line before partitioning in Anaconda GUI and it seemed to work fine.
Comment 25 David Cantrell 2009-07-08 10:23:00 EDT
There is a patch in rawhide for this issue now.  Since there have been so many comments added to this bug, I am asking for anyone seeing this problem in rawhide after anaconda-12.2-1.fc12 is built to please file NEW bugs with details about your specific use case.

Commit regarding this issue:
f765384437f273d3685b8e05abf448c1dc4499e5
Comment 26 Michal Schmidt 2009-07-08 10:53:04 EDT
David,

$ git show f765384437f273d3685b8e05abf448c1dc4499e5
fatal: bad object f765384437f273d3685b8e05abf448c1dc4499e5

And Fedora CVS has only anaconda-12.1-1.fc12 in devel/.

Is the commit only in some private repository so far?

This bug is featured in https://fedoraproject.org/wiki/Common_F11_bugs . Is there going to be an updates.img available for F11?
Comment 27 David Cantrell 2009-07-08 11:23:24 EDT
My mistake, here's the commit:

http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=60ff94ed3fade0716086deeb99892bf1c5103e62

12.2-1.fc12 will be the next build of anaconda for rawhide.  Yes, 12.1 is the latest in the tree.  The next build we do of anaconda will include this fix.
Comment 28 David Cantrell 2009-07-08 11:24:26 EDT
And yes, I can make an updates.img for this fix and update the F-11 common bugs page.
Comment 29 David Cantrell 2009-07-08 17:15:04 EDT
Updated the Fedora 11 common bugs wiki page:

https://fedoraproject.org/wiki/Common_F11_bugs#491754
Comment 30 James Laska 2009-07-09 08:13:02 EDT
Created attachment 351052 [details]
anaconda-logs.tgz (w/ 491754.img)

While testing http://dcantrel.fedorapeople.org/491754.img, I encountered this failure on a power5 ppc64 system that originally exhibited this failure.  I have attached '/tmp/*log*' to this bugzilla.  The system is online now at the time of the failure.  Please let me know if additional information is needed.

Thanks!
Comment 31 James Laska 2009-07-09 08:16:45 EDT
Reopening, based on comment#30
Comment 32 Petr Mensik 2009-07-09 08:40:03 EDT
Created attachment 351055 [details]
Patch to disable boot flag modification for upgrade

I found problem using tracing from commit place to where it is called. I dont much understand in what cases boot flag should be modified or what was meant by it. Maybe it should be negated (if there is no bootable entry for partition, create one), maybe it does apply only for new installations. It worked for me. There is present also some debugging and delay, they are not important.
Comment 33 Petr Mensik 2009-07-09 08:41:22 EDT
Created attachment 351056 [details]
My updates file that helped me to upgrade

My file created with patch above.
Comment 34 Petr Mensik 2009-07-09 08:44:22 EDT
Created attachment 351059 [details]
Storage log with stack trace to problem origin

I used this log to figure out where commit is done. At first i thought i will add some time to drive and it will fix it. Then i realized it is modifying partition table that is beeing used, and cannot handle immediate reload will fail.
Comment 35 Petr Mensik 2009-07-09 08:55:31 EDT
Comment on attachment 351059 [details]
Storage log with stack trace to problem origin

posted wrong file, sorry
Comment 36 Petr Mensik 2009-07-09 08:56:20 EDT
Created attachment 351066 [details]
Storage.log with backtrace
Comment 37 yijunzhao 2009-07-17 07:34:43 EDT
"An updates.img file is available to work around the defect. This image is provided through the Fedora project space of David Cantrell, one of the Anaconda maintainers."

I tested the updates.img for installing with my notebook. Lenevo TSI Y430. It failed still.

Please fix the bug as soon as possible. Thanks.
Comment 38 yijunzhao 2009-07-17 07:37:39 EDT
(In reply to comment #33)
> Created an attachment (id=351056) [details]
> My updates file that helped me to upgrade
> 
> My file created with patch above.  

I used the patch that you provided for us. it also failed. I upgrade from Fedora 10 t0 11 with Fedora 11 DVD disk.
Comment 39 David Cantrell 2009-07-17 16:15:58 EDT
Since no one read comment #25, could people please at least provide details on the installer failing on your system?  I need reproducers in order to actually work the problem for your case.
Comment 40 James Laska 2009-07-21 10:51:09 EDT
(In reply to comment #39)
> Since no one read comment #25, could people please at least provide details on
> the installer failing on your system?  I need reproducers in order to actually
> work the problem for your case.  

I have managed to reproduce the problem on a F-11/ppc system using the update image (http://dcantrel.fedorapeople.org/491754.img).

The steps I used to recreate:

1) Install F-10 using default partition layout

    autopart
    # Partition clearing information
    clearpart --all --initlabel 

2) Install F-11 with updates=http://dcantrel.fedorapeople.org/491754.img on the same system with the same physical disks being used in the transaction

    # Partition clearing information
    clearpart --all --initlabel 
    # Disk partitioning information
    part prepboot --fstype="PPC PReP Boot" --size=8
    part /boot --asprimary --fstype="ext3" --size=200 --label=BOOT
    part swap --fstype="swap" --recommended --label=SWAP
    part /multi-stage --fstype="ext3" --size=100 --label=MULTISTAGE
    part pv.01 --grow --maxsize=3072 --size=1536
    part pv.02 --grow --maxsize=3072 --size=1536
    volgroup SNAKEVG --pesize=32768 pv.01 pv.02
    logvol /  --fstype="ext3" --grow --maxsize=10240 --size=2048 --name=SNAKEROOT --vgname=SNAKEVG
    logvol swap  --fstype="swap" --recommended --name=SNAKE_SWAP --vgname=SNAKEVG
    logvol /SNAKE-LV0  --fstype="ext3" --grow --maxsize=1024 --size=1024 --name=SNAKELV0 --vgname=SNAKEVG

The system is available for remote debugging if needed.
Comment 41 Petr Mensik 2009-07-26 06:13:22 EDT
(In reply to comment #38)
> (In reply to comment #33)
> > Created an attachment (id=351056) [details] [details]
> > My updates file that helped me to upgrade
> > 
> > My file created with patch above.  
> 
> I used the patch that you provided for us. it also failed. I upgrade from
> Fedora 10 t0 11 with Fedora 11 DVD disk.  

If you tried my patch, please post somewhere your /tmp/storage.log. I put backtrace to commit failure, it might help locate where is commit called from. I updated with F11 x64 DVD and worked for me. I do not guarantee it fixed real problem, or there are might be more problems to fix.

I have't got any LVM partitions or logical volumes on my disk, still i got failure at partition change commit. I have read #25 message, but i don't think it would fix anything to me. Also i upgraded successfuly already. I am waiting to some statement about my fix beeing correct, incorrect, or doing nothing.
Comment 42 Xavier Lapointe 2009-08-26 22:32:46 EDT
Created attachment 358801 [details]
Contains all the /tmp directory after a failed installation using the patch http://dcantrel.fedorapeople.org/491754.img

This is a tar file containing all the /tmp/ directory. Hopefully it might help, I can't install Fedora 11 after many attempts. Thanks for your time.
Comment 43 Xavier Lapointe 2009-08-27 13:44:47 EDT
Just a word to say it's still present in Fedora 12 A1. I don't know what have change since the last release ( I'm not really used to Fedora ), but I can't enable network in the install process, so I can't send my log through ftp ..
Comment 44 Chris Lumens 2009-09-03 11:39:27 EDT
This should be fixed in the current build of anaconda/parted/etc.
Comment 45 Ujjwol 2009-09-17 07:19:36 EDT
The update by David Cantrell in https://fedoraproject.org/wiki/Common_F11_bugs#491754 doesnot work.

The error is after the update is retrived, it says running anaconda, the fedors system installer, please wait and then install exited abnornally [1/1] and says you may safely reboot your system.
Comment 46 munipradeep 2009-10-06 04:17:36 EDT
This issue is still occurring in RHEL6 20090930 build. It has anaconda 12.32 version.
Comment 48 Petr Mensik 2009-10-21 02:48:58 EDT
I tested with Fedora 12 beta, and problem seems to be fixed. I have only one CD, so i haven't finish upgrade, but it got over point it failed at before. So this time you seem to be correct, that bug is fixed in upstream. Thanks.
Comment 49 Adam Williamson 2009-10-21 18:43:03 EDT
jesse, I think it may be a little premature to close this on the basis of one report, as it was a very widespread problem and may have had slightly different causes in different cases...I'd quite like to see more than one confirmation that it's better in F12 Beta.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 50 munipradeep 2009-10-22 02:52:49 EDT
Verified with RHEL6-20091015 build. This issue is no more happening.
Comment 51 Joseph Kachuck 2009-10-22 09:40:59 EDT
*** Bug 507541 has been marked as a duplicate of this bug. ***