Bug 510249

Summary: Missing panel applets on gnome login; "Glib-GObject-CRITICAL" messages....
Product: [Fedora] Fedora Reporter: Tom London <selinux>
Component: gtk2Assignee: Matthias Clasen <mclasen>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: awilliam, bnocera, erik-fedora, gczarcinski, libbe, martin.sourada, mattdm, mclasen, nicolas.mailhot, notting, pbrobinson, quentin, rstrode, sangu.fedora, seventhguardian, spoffley, theholyettlz, twaugh, valdis.kletnieks, zaitcev, zkabelac
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-05 19:30:55 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 473303    
Attachments:
Description Flags
yum.log after fix
none
Screenshot of notification area showing missing applets/icons none

Description Tom London 2009-07-08 09:33:07 EDT
Description of problem:
Gnome session starts without most "startup applets" in upper right part of the panel (e.g., sound applet, network applet, etc.).

I see this in ~/.xsession-errors:

(gnome-settings-daemon:1782): GLib-GObject-CRITICAL **: g_param_spec_flags: assertion `G_TYPE_IS_FLAGS (flags_type)' failed

(gnome-settings-daemon:1782): GLib-GObject-CRITICAL **: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed

and this (similar) in /var/log/messages:
Jul  8 06:16:09 tlondon kernel: dp_aux_ch timeout status 0x51450085
Jul  8 06:16:09 tlondon kernel: dp_aux_ch timeout status 0x51450085
Jul  8 06:16:11 tlondon gdm-simple-greeter[1460]: GLib-GObject-CRITICAL: g_param_spec_flags: assertion `G_TYPE_IS_FLAGS (flags_type)' failed
Jul  8 06:16:11 tlondon gdm-simple-greeter[1460]: GLib-GObject-CRITICAL: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed
Jul  8 06:16:14 tlondon auditd[1571]: Started dispatcher: /sbin/audispd pid: 1573
Jul  8 06:16:14 tlondon audispd: af_unix plugin initialized
Jul  8 06:16:14 tlondon audispd: audispd initialized with q_depth=80 and 2 active plugins
Jul  8 06:16:14 tlondon auditd[1571]: Init complete, auditd 1.7.13 listening for events (startup state enable)


Version-Release number of selected component (if applicable):
gnome-settings-daemon-2.27.3-2.fc12.x86_64
gdm-2.26.1-13.fc12.x86_64

How reproducible:
Happened several times yesterday and this morning.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-07-08 09:52:49 EDT
Happened again on very next boot/login.

Here is complete ~/.xsession-errors:

[tbl@tlondon ~]$ cat .xsession-errors
imsettings information
==========================
Is DBus enabled: yes
Is imsettings enabled: yes
Is GTK+ supported: yes
Is Qt supported: no
DESKTOP_SESSION: gnome
DISABLE_IMSETTINGS: 
IMSETTINGS_DISABLE_DESKTOP_CHECK: 
DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-fDxF6SbASR,guid=bc5da65b0772eb40b4c6773b4a54a356
GTK_IM_MODULE: 
QT_IM_MODULE: xim
XMODIFIERS: @im=none
IMSETTINGS_MODULE: none
IMSETTINGS_INTEGRATE_DESKTOP: yes

GNOME_KEYRING_SOCKET=/tmp/keyring-ngTQ4a/socket
SSH_AUTH_SOCK=/tmp/keyring-ngTQ4a/socket.ssh
Initializing nautilus-gdu extension
compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

(gnome-settings-daemon:1761): GLib-GObject-CRITICAL **: g_param_spec_flags: assertion `G_TYPE_IS_FLAGS (flags_type)' failed

(gnome-settings-daemon:1761): GLib-GObject-CRITICAL **: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed

** (nm-applet:1799): WARNING **: Failed to show notification: Message did not receive a reply (timeout by message bus)

** (gnome-screensaver:1998): WARNING **: screensaver already running in this session
[tbl@tlondon ~]$ 

Hmmm... I tried to run "gimp" to crop a screenshot of the entire screen, but it won't start:

[tbl@tlondon ~]$ gimp

(gimp:2279): GLib-GObject-WARNING **: specified class size for type `GimpOperationPointFilter' is smaller than the parent type's `GeglOperationPointFilter' class size

(gimp:2279): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp:2279): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(gimp:2279): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp:2279): GLib-GObject-WARNING **: cannot retrieve class for invalid (unclassed) type `<invalid>'

<<<< HANGS HERE >>>>

This related?
Comment 2 Matthias Clasen 2009-07-08 23:57:14 EDT
Those warnings are unrelated. The problem you are seeing is a redraw issue in GTK+.
Comment 3 Tom London 2009-07-09 18:41:24 EDT
I'm not seeing this today with

gtk2-devel-docs-2.17.3-2.fc12.x86_64
gtk2-devel-2.17.3-2.fc12.x86_64
gtk2-debuginfo-2.17.3-2.fc12.x86_64
gtk2-engines-2.18.1-1.fc11.x86_64
gtk2-2.17.3-2.fc12.x86_64

Fixed? Random?
Comment 4 Matthias Clasen 2009-07-09 20:45:59 EDT
Random. It has not been fixed yet, unfortunately.
Comment 5 Tom London 2009-07-10 11:56:23 EDT
Yeah, still happens sometimes with gtk2-2.17.3-2.fc12.x86_64.

Let me know if there is some debugging/testing I can do....
Comment 6 Matthias Clasen 2009-07-13 10:12:24 EDT
*** Bug 511010 has been marked as a duplicate of this bug. ***
Comment 7 Valdis Kletnieks 2009-07-13 17:06:28 EDT
As of 2.17.3 I'm seeing one application failing to redraw/refresh text boxes - but if you just pass the mouse over each affected line, it refreshes that line.  Same redraw issue?
Comment 8 Matthew Miller 2009-07-14 13:49:14 EDT
Gimp not starting is bug #510209.
Comment 9 Matthias Clasen 2009-07-27 09:31:30 EDT
*** Bug 513108 has been marked as a duplicate of this bug. ***
Comment 10 Matthias Clasen 2009-08-03 21:54:09 EDT
*** Bug 515302 has been marked as a duplicate of this bug. ***
Comment 11 Pete Zaitcev 2009-08-05 15:05:36 EDT
Created attachment 356413 [details]
yum.log after fix

The notification icons are visible now, although gtk2 was not updated.
Attaching a complete yum.log just in case. As far as my bug 513108 is
concerned, the issue is fixed.
Comment 12 Tom London 2009-08-06 09:54:02 EDT
Created attachment 356515 [details]
Screenshot of notification area showing missing applets/icons

I'm still (randomly?) seeing this problem.

Icons appear on some logins; are missing on other logins.

In this case, "gnome-volume-control-applet" is missing, but the process is running:

[tbl@tlondon ~]$ ps agx | grep volume
 1661 ?        S      0:00 gnome-volume-control-applet
 1699 ?        S      0:00 /usr/libexec/gvfs-gdu-volume-monitor
 1707 ?        S      0:00 /usr/libexec/gvfs-gphoto2-volume-monitor
 2910 pts/1    S+     0:00 grep volume
[tbl@tlondon ~]$ 

The volume applet is not just "there but invisible"; clicking on the empty space does not connect to it....

also missing are NetworkManager, battery/power, ...

I think I get the "proper" display/use of the applets/icons about 1 in 3 logins.
Comment 13 Tom London 2009-08-06 09:55:23 EDT
For the record, currently running:

gtk2-engines-2.18.2-4.fc12.x86_64
gtk2-debuginfo-2.17.6-4.fc12.x86_64
gtk2-2.17.6-4.fc12.x86_64
gtk2-devel-2.17.6-4.fc12.x86_64
gtk2-devel-docs-2.17.6-4.fc12.x86_64
Comment 14 Matthias Clasen 2009-08-06 09:57:49 EDT
Thanks, but there i no need to provide detailed version updates here. The bug is known, it is known to not be fixed, and it will be tackled when the relevant developer is back from vacation next week.
Comment 15 Matthias Clasen 2009-08-10 14:14:23 EDT
*** Bug 516544 has been marked as a duplicate of this bug. ***
Comment 16 Adam Williamson 2009-08-13 14:11:32 EDT
This is claimed to be fixed in gtk2-2.17.7-1.fc12, which has been tagged in for the Alpha release. I have just checked and it appears fixed here, and is confirmed fixed by Jesse Keating and Warren Togami on the tag request. Closing bug.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Adam Williamson 2009-08-13 14:17:15 EDT
actually, mclasen says it can still happen but is less easy to hit. Don't know the technical details, but I defer to him, re-opening. Impact should be mitigated for Alpha, though, by the looks of things.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Valdis Kletnieks 2009-08-13 15:46:08 EDT
Was seeing issues with 2.17.6-6, which had a changelog that claimed it was fixed.  Still seeing 100% consistent failures in my one GTK2 app (gyachi) with 2.17.7-1.  Is my 100% issue a different one than this "can still happen", or am I the proud owner of a smoketest app?  Am willing to do low-level debugging if somebody has a hint of what to go look at....
Comment 19 Peter Robinson 2009-08-13 15:54:26 EDT
I'm seeing all the icons back in the notification area without having to randomly kill it off so that's definitely an improvement but I can't see the running applications in the bottom panel. I'm not sure if that's the same issue though.
Comment 20 Matthias Clasen 2009-08-13 17:54:45 EDT
This seems all sorts of confused; I didn't claim that this bug was fixed in 2.17.6-6. That update fixed root window drawing problems in gdm and elsewhere.
2.17.7 makes the problem in this bug (missing status icons) much less frequent.
I know nothing about problems with the taskbar in the bottom panel, and that is entirely unrelated to what this bug is about...
Comment 21 Peter Robinson 2009-08-13 18:06:48 EDT
(In reply to comment #20)
> This seems all sorts of confused; I didn't claim that this bug was fixed in
> 2.17.6-6. That update fixed root window drawing problems in gdm and elsewhere.
> 2.17.7 makes the problem in this bug (missing status icons) much less frequent.
> I know nothing about problems with the taskbar in the bottom panel, and that is
> entirely unrelated to what this bug is about...  

I was seeing the missing status icons. That is fixed with the 2.17.7 release for me on a eeePC 901 netbook. I was wondering whether the missing apps in the taskbar might be related as the issue started the same time AFAICR. I asked if it was possibly related due to the "much less frequent" part of the fix report. If its not that's fine, I'll look for or report another bug, not much point if its the same.
Comment 22 Matthias Clasen 2009-08-13 18:12:57 EDT
Could be that you simply lost the taskbar applet from your panel config somehow ?
Comment 23 Stephen 2009-08-13 18:16:17 EDT
The notification applet on an Acer Aspire 5315 is just a big grey block even with the latest GTK2.  In the past I only had to remove and add the Applet about 3 times to get it to appear, now its around 10 times ! My display hardware is Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03), using the Intel device driver
Comment 24 Peter Robinson 2009-08-13 18:21:23 EDT
(In reply to comment #22)
> Could be that you simply lost the taskbar applet from your panel config somehow

Yes, it appears you are right, and I didn't even know you could remove that bit! Sorry for the fuzz!
Comment 25 Adam Williamson 2009-08-13 18:50:08 EDT
stephen: when you say 'the latest', can you be precise? you need gtk2-2.17.7-1.fc12 or higher, please give your 'rpm -q gtk2' output. you also need to restart X after installing the update.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 26 Valdis Kletnieks 2009-08-14 18:06:39 EDT
Sorry - I read this in the changelog:

* Fri Aug 07 2009 Matthias Clasen <mclasen@redhat.com> - 2.17.6-5
- Fix gdm background drawing

and misinterpreted it as being a fix for the redisplay issue.
Comment 27 Stephen 2009-08-18 06:41:14 EDT
Adam, the output from rpm -q gtk2 is :

gtk2-2.17.7-1.fc12.x86_64
gtk2-2.17.7-1.fc12.i686

Additional information is that when I rebooted yesterday the notification area came up cleanly first time, when I rebooted today I had to remove it and add it again to get it displayed and as I say sometimes I have to add it 9 or 10 times to get it displayed.  This is since I got 2.17.7-1
Comment 28 Adam Williamson 2009-08-18 10:33:26 EDT
stephen: that's the right version...i'm assuming you have both 32-bit and 64-bit versions installed as you have a need to run some GTK+-based software in 32-bit mode?

But thanks for the confirmation.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 29 Matthias Clasen 2009-10-01 21:54:06 EDT
*** Bug 526670 has been marked as a duplicate of this bug. ***
Comment 30 Matthias Clasen 2009-10-05 19:30:55 EDT
Fixed in gtk2-2.18.2-1.fc12
Comment 31 Tim Waugh 2009-10-06 07:30:26 EDT
Works here.  Thanks!
Comment 32 James 2010-05-02 11:42:50 EDT
Hmm, I'm seeing this intermittently with gtk2-2.18.9-3.fc12.x86_64; for example, when I just started XChat, the Seahorse icon took the XChat icon's place (and would not respond). Sometimes the correct icon is drawn in after a while, but not always.