Bug 770484

Summary: [abrt] WARNING: at drivers/net/wireless/iwlwifi/iwl-trans-pcie-tx.c:739 iwl_enqueue_hcmd+0x5c8/0x5f0
Product: [Fedora] Fedora Reporter: eric <eric>
Component: kernelAssignee: Stanislaw Gruszka <sgruszka>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: akurtako, amit.shah, balay, brian, divi, gansalmon, itamar, johannes, jonathan, jwboyer, kernel-maint, madhu.chinakonda, m.vetsch, register, sgruszka, voyager.106
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:23b91682e5f010111d09cfed360d7c581e13ce7e first=3.1.1 tested=3.4.5 wireless iwlwifi
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-14 13:00:01 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
iwlwifi-fix-6000-ch-switch.patch none

Description eric@christensenplace.us 2011-12-26 19:46:43 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.6-1.fc16.x86_64 root=/dev/mapper/vg_ericlaptop-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_ericlaptop/lv_swap KEYTABLE=us quiet rd.luks.uuid=luks-262e7b6b-dd14-436c-9b00-afecd7c07990 rhgb rd.lvm.lv=vg_ericlaptop/lv_root SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8
kernel:         3.1.6-1.fc16.x86_64
reason:         WARNING: at /builddir/build/BUILD/kernel-3.1.fc16/compat-wireless-3.2-rc6-3/drivers/net/wireless/iwlwifi/iwl-trans-pcie-tx.c:739 iwl_enqueue_hcmd+0x5c8/0x5f0 [iwlwifi]()
time:           Sun 25 Dec 2011 06:44:53 PM EST

backtrace:
:WARNING: at /builddir/build/BUILD/kernel-3.1.fc16/compat-wireless-3.2-rc6-3/drivers/net/wireless/iwlwifi/iwl-trans-pcie-tx.c:739 iwl_enqueue_hcmd+0x5c8/0x5f0 [iwlwifi]()
:Hardware name: 4270CTO
:Modules linked in: tcp_lp ppdev parport_pc lp parport fuse lockd rfcomm bnep ipt_LOG nf_conntrack_ipv4 nf_defrag_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables uvcvideo videodev media v4l2_compat_ioctl32 snd_hda_codec_conexant binfmt_misc arc4 microcode joydev btusb bluetooth snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm i2c_i801 iwlwifi iTCO_wdt iTCO_vendor_support mac80211 cfg80211 snd_timer snd_page_alloc thinkpad_acpi rfkill snd e1000e soundcore uinput sunrpc xts gf128mul dm_crypt firewire_ohci firewire_core sdhci_pci crc_itu_t sdhci mmc_core nouveau ttm mxm_wmi wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 4510, comm: kworker/u:65 Tainted: G        W   3.1.6-1.fc16.x86_64 #1
:Call Trace:
: [<ffffffff8106b73f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8106b79a>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa036efc8>] iwl_enqueue_hcmd+0x5c8/0x5f0 [iwlwifi]
: [<ffffffffa036fc40>] iwl_trans_pcie_send_cmd+0x40/0x3a0 [iwlwifi]
: [<ffffffffa0368b1b>] iwl6000_hw_channel_switch+0x12b/0x1a0 [iwlwifi]
: [<ffffffff81061fbb>] ? load_balance+0xcb/0x800
: [<ffffffff810537c8>] ? hrtick_update+0x38/0x40
: [<ffffffff8115d2ab>] ? kfree+0x3b/0x140
: [<ffffffffa02d28f0>] ? is_mesh_bss+0x80/0x80 [cfg80211]
: [<ffffffffa02d292c>] ? bss_release+0x3c/0x70 [cfg80211]
: [<ffffffffa034f3ea>] iwlagn_mac_channel_switch+0x1aa/0x1f0 [iwlwifi]
: [<ffffffff811316bf>] ? __inc_zone_state+0x5f/0x70
: [<ffffffffa0310216>] ieee80211_sta_process_chanswitch+0x106/0x1a0 [mac80211]
: [<ffffffffa031069d>] ieee80211_rx_bss_info+0x13d/0x1a0 [mac80211]
: [<ffffffffa02cea62>] ? ieee802_11_parse_elems_crc+0x472/0x4c0 [cfg80211]
: [<ffffffffa0310f8b>] ieee80211_rx_mgmt_beacon+0x3eb/0x650 [mac80211]
: [<ffffffffa03124c3>] ieee80211_sta_rx_queued_mgmt+0x2b3/0x3f0 [mac80211]
: [<ffffffffa0315b2b>] ieee80211_iface_work+0x25b/0x350 [mac80211]
: [<ffffffffa03158d0>] ? ieee80211_teardown_sdata+0xe0/0xe0 [mac80211]
: [<ffffffffa03158d0>] ? ieee80211_teardown_sdata+0xe0/0xe0 [mac80211]
: [<ffffffff810883dd>] process_one_work+0x11d/0x470
: [<ffffffff810897df>] worker_thread+0x15f/0x350
: [<ffffffff81089680>] ? manage_workers+0x230/0x230
: [<ffffffff8108de0c>] kthread+0x8c/0xa0
: [<ffffffff815dee34>] kernel_thread_helper+0x4/0x10
: [<ffffffff8108dd80>] ? kthread_worker_fn+0x190/0x190
: [<ffffffff815dee30>] ? gs_change+0x13/0x13

smolt_data:
:
:
:General
:=================================
:UUID: be945694-df8f-48cc-990c-1ab7dbfb9473
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4386.43
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 2201
:System Memory: 7870
:System Swap: 9919
:Vendor: LENOVO
:System: 4270CTO ThinkPad W520
:Form factor: Notebook
:Kernel: 3.1.6-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4480:59442:6058:8655) pci, firewire_ohci, FIREWIRE, FireWire Host Controller
:(4480:59427:6058:8655) pci, sdhci-pci, BASE, N/A
:(32902:260:6058:8655) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:257:6058:8655) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:(4147:404:6058:8655) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:7202:6058:8655) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:7171:6058:8655) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7247:6058:8655) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7213:6058:8655) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:6058:8655) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:7226:6058:8655) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:133:32902:4881) pci, iwlwifi, NETWORK, Centrino Advanced-N 6205 AGN
:(32902:294:6058:8657) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7196:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7192:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8655) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7229:6058:8655) pci, serial, 16550_SERIAL, 6 Series/C200 Series Chipset Family KT Controller
:(4318:3578:6058:8657) pci, nouveau, VIDEO, GF108 [Quadro 1000M]
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_ericlaptop-lv_root / ext4 4096 4096 12901535 10827686 10172326 3276800 3019059 3019059
:/dev/sda1 /boot ext4 1024 1024 495844 410308 384708 128016 127788 127788
:/dev/mapper/vg_ericlaptop-lv_home /home ext4 4096 4096 15239693 2524140 1749996 3874816 3577965 3577965
:
Comment 1 Josh Boyer 2012-02-14 11:08:00 EST
*** Bug 790470 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2012-03-22 13:09:13 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 3 Dave Jones 2012-03-22 13:12:05 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 13:21:48 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Dave Jones 2012-03-26 10:55:16 EDT
*** Bug 795182 has been marked as a duplicate of this bug. ***
Comment 6 Dave Jones 2012-03-26 10:55:50 EDT
*** Bug 806639 has been marked as a duplicate of this bug. ***
Comment 7 Dave Jones 2012-07-20 15:00:48 EDT
*** Bug 809658 has been marked as a duplicate of this bug. ***
Comment 8 Josh Boyer 2012-09-18 12:06:28 EDT
*** Bug 852281 has been marked as a duplicate of this bug. ***
Comment 9 Josh Boyer 2012-09-18 12:07:06 EDT
John, we're still seeing this in 3.4.9.  Any ideas on this one?
Comment 10 John W. Linville 2012-09-24 11:56:56 EDT
Not a clue...maybe Johannes has some insight...
Comment 11 Johannes Berg 2012-09-25 10:18:01 EDT
Well, that's embarrassing ... the command is larger than the max inline command size, so it gets aborted. I'll make a fix for this but I'm not sure I can test this particular scenario easily, can you?
Comment 12 Johannes Berg 2012-09-25 10:44:49 EDT
http://p.sipsolutions.net/c3b059565e7f68e3.txt should fix this
Comment 13 eric@christensenplace.us 2012-09-26 07:55:53 EDT
I don't really remember how this issue came to light, now.  I'll happily test anything you have if you let me know where I need to look to see if it is fixed.
Comment 14 Satish Balay 2012-09-26 11:03:34 EDT
I can also try testing - but the last time the issue appeared [per my logs] was 2 months back - with kernel 3.4.5-1.fc16.x86_64 [now I'm at 3.4.11-1.fc16.x86_64]
Comment 15 Stanislaw Gruszka 2012-10-05 09:16:51 EDT
*** Bug 862302 has been marked as a duplicate of this bug. ***
Comment 16 Stanislaw Gruszka 2012-10-05 11:07:40 EDT
Created attachment 622268 [details]
iwlwifi-fix-6000-ch-switch.patch

Patch from comment 12 backported to F-17 kernel.
Kernel build with the patch is here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4563168
Please test it when it finish to compile.
Comment 17 Stanislaw Gruszka 2012-10-17 03:32:41 EDT
We do not have testing feedback for this, so let's apply patch, close this bug, and see if we will get new bug reports on the future.

Josh, please apply patch from comment 16 as fix for this bug. It was currently posted upstream:
http://marc.info/?l=linux-wireless&m=135041140521119&w=2
Comment 18 Josh Boyer 2012-10-18 08:21:02 EDT
Sorry, was trying to recover from international travel yesterday.  I'll get this applied today.
Comment 19 Josh Boyer 2012-10-18 08:31:16 EDT
F17 (and all releases really) have moved to the 3.6 kernel at this point.  I used Johannes' original patch in comment #12.  Applied across F16-F18.
Comment 20 Dave Jones 2012-10-23 11:32:54 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 21 Fedora Update System 2012-10-23 17:58:30 EDT
kernel-3.6.3-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.3-3.fc18
Comment 22 Fedora Update System 2012-10-24 12:16:16 EDT
Package kernel-3.6.3-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.3-3.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16787/kernel-3.6.3-3.fc18
then log in and leave karma (feedback).
Comment 23 Brian J. Murrell 2012-10-27 15:58:31 EDT
what about fc17 though?  I just got this with 3.6.2-4.fc17.x86_64.
Comment 24 Stanislaw Gruszka 2012-10-28 16:18:29 EDT
F17 has this fix since kernel-3.6.3-1.fc17
http://koji.fedoraproject.org/koji/buildinfo?buildID=361634