This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 849211

Summary: display for "Software Selection" lacks margin and is scrunched into upper left quarter
Product: [Fedora] Fedora Reporter: John Reiser <jreiser>
Component: anacondaAssignee: Chris Lumens <clumens>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dvratil, g.kaviyarasu, joachim.backes, jonathan, jsedlak, ljozsa, mbanas, rtguille, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-20 11:04:49 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
screenshot of Software Selection
none
/tmp/X.log
none
/tmp/X.log before going to Software Selection
none
/tmp/X.log after going to Software Selection
none
/tmp/X.log (1280x1024) before going to Software Selection
none
/tmp/X.log (1280x1024) after going to Software Selection
none
/tmp/anaconda.log
none
/tmp/syslog none

Description John Reiser 2012-08-17 13:32:55 EDT
Created attachment 605233 [details]
screenshot of Software Selection

Description of problem: On the spoke displayed for Software Selection, the Desktop box is flush against the left side of the screen, and only the upper left 1/4 (or so) of the screen is used.  The lack of margin makes the Desktop box hard to read (particularly the left side of the letter 'D' of Desktop has zero pixels to the left; but also the text inside the box still is hard to read because there is no margin, although there is 1/2 char of white space to the left).  Using only 1/4 of the available space  makes the layout cramped.


Version-Release number of selected component (if applicable):
anconda-18.6

How reproducible: every time (4 of 4 so far)


Steps to Reproduce:
1. Boot DVD Fedora 18-Alpha-TC3-netinst.iso (x86_64) on bare hardware with 1280x1024 screen, nVidia 8400 GS card (PCI 10de:0404)
2. Select default boot option (Test this media & install/upgrade Fedora)
3. Accept default language (US English) and pre-release Fate.
4. Wait for download of repo info, initialization of Softare Selection, and initialization of Storage.
5. Click on Software Selection spoke.
  
Actual results: Desktop box is flush left on screen (no margin).  'D' of Desktop has 0 pixels to the left, therefore blends with black hardware border, and is hard to read.  Text in Desktop box is also hard to read because no left margin to the whole box.

Titles, buttons, and both boxes (Desktop and Addons) are in upper left quarter only, leaving 3/4 of screen blank.  Titles of individual Addons often span two rows because of narrow column.


Expected results: Desktop box has at least 4 pixels of margin (away from edge of screen) on all sides.  Better use of screen realestate: say, at least 800 pixels wide by 600 pixels tall (SVGA).


Additional info:
Comment 1 Chris Lumens 2012-08-17 13:56:39 EDT
*** Bug 849218 has been marked as a duplicate of this bug. ***
Comment 2 John Reiser 2012-08-17 16:47:43 EDT
Created attachment 605262 [details]
/tmp/X.log

Here is the X11 server log.
Comment 3 Chris Lumens 2012-08-20 15:00:50 EDT
Is that X log from before or after you click on the spoke?
Comment 4 John Reiser 2012-08-20 16:48:30 EDT
I don't remember, but it should have been after clicking to get to the spoke, because that's when I saw the layout with no margin.

Just now I re-ran to get both:

X-before.log: wait until first new-UI hub is quiescent, C-A-F2, copy /tmp/X.log to X-before.log, C-A-F6 go get back to new-UI hub.

X-after.log: click on Software Selection, C-A-F2, copy /tmp/X.log to X-after.log.

This time the layout had a proper margin.
Comment 5 John Reiser 2012-08-20 16:49:37 EDT
Created attachment 605779 [details]
/tmp/X.log before going to Software Selection
Comment 6 John Reiser 2012-08-20 16:50:07 EDT
Created attachment 605780 [details]
/tmp/X.log after going to Software Selection
Comment 7 John Reiser 2012-08-20 21:56:39 EDT
Created attachment 605813 [details]
/tmp/X.log (1280x1024) before going to Software Selection

This is X.log before going to Software Selection, on a 1280x1024 monitor.  The display of Software Selection will have the defects.
Comment 8 John Reiser 2012-08-20 21:59:30 EDT
Created attachment 605814 [details]
/tmp/X.log (1280x1024) after going to Software Selection

This is X.log after going to Software Selection, on a 1280x1024 monitor.

There is an additional wrinkle: the first time that I click on Software Selection, then the two boxes are blank, as if no XFlush().  (The left box still lacks margin, and both boxes are in upper left 1/4 of screen._  So I click Back, then Software Selection again; the result is as given in screen shots.
Comment 9 Chris Lumens 2012-08-21 13:28:27 EDT
When you hit this problem, can you please grab /tmp/anaconda.log and /tmp/syslog and attach them to this bug report?  I am only intermittently able to reproduce this bug, and other people I've had check are not having a lot of luck with it either.  Thanks.
Comment 10 John Reiser 2012-08-21 13:45:04 EDT
Created attachment 605996 [details]
/tmp/anaconda.log

anaconda.log when Software Selection layout is scrunched into upper left 1/4 of screen. Monitor is 1280x1024 (and used that way by xorg), nVidia 8400 GS, both DESKTOP and ADDONS boxes are completely white (as if text drawn without XFlush()).
Comment 11 John Reiser 2012-08-21 13:45:48 EDT
Created attachment 605997 [details]
/tmp/syslog

syslog when Software Selection is scrunched into upper left 1/4 of screen.
Comment 12 John Reiser 2012-08-21 17:27:23 EDT
Another complication.  I moved the 1280x1024 monitor to the box with the GeForce GT 430 card (pci 10de:0de1).  Going back and forth from the initial hub to the Software Selection spoke, for the first 1/2 second or so the display for Sofware Selection is scrunched into the upper left 1/4 of the screen, as in the screen shot 605223 of the initial Description, but then changes to a centered with ample margins and wider columns.  The text is re-flowed, too: there are more words per line in the centered display, and fewer words per line in the scrunched display.  This correct centered display persists without changes until I click on the Back button.

I double-checked the sha256sum on the download (result: OK), and did:
   $ cmp  /dev/sr0  $HOME/Download/Fedora-18-Alpha-TC3-x86_64-netinst.iso
which showed no differences for the length of the disk .iso file.  (The DVD had not yet reached end-of-file; this is normal.)
Comment 13 John Reiser 2012-08-21 22:03:28 EDT
At 1680x1050 on the GeForce GT 430, the first display at Software Selection was correct.  Times 2 through 6 (moving back and forth between hub and Software Selection spoke) saw 2 cases OK, 3 cases with scrunched into upper left at first, shifting in about 1/2 second to correct display.  Times 7 through 15 were all scrunched at first, then shifting to correct.
Comment 14 John Reiser 2012-08-22 12:01:10 EDT
I see similar behavior at 1280x1024 using ATI Technologies Inc Redwood PRO [Radeon HD 5500 Series] (pci 1002:68da).  The scrunched-into-upper-left layout appears first for a fraction of a second, then changes to the correct centered layout.
Comment 15 Chris Lumens 2012-08-24 09:50:40 EDT
*** Bug 849733 has been marked as a duplicate of this bug. ***
Comment 16 Chris Lumens 2012-08-24 09:50:48 EDT
*** Bug 849563 has been marked as a duplicate of this bug. ***
Comment 17 Chris Lumens 2012-08-31 10:00:29 EDT
Are you still seeing this behavior?  I was able to reproduce for a while, but not with any of the recent official TC images.  There's a similar issue where pressing windows key+up/down causes the window to shrink, but I don't think that's what was going on here.
Comment 18 John Reiser 2012-08-31 12:16:04 EDT
With -TC4 using anaconda-18.6.4, I see the behavior of comment 12 through comment 14.  The first time I click on the Software Selection spoke, before any choice has been made, then I see the correct centered display with wide margins and amply-wide columns.  I choose one of the Desktops in the left column.  Then going back and forth between the hub and the spoke, at first the display for the spoke is scrunched into the upper left, and the box for the left column is flush against the left margin.  Then about 1/2 second later, the display changes to the correct centered display with wide margins and amply-wide columns.  The text is re-flowed into the wider columns, too: there is a change in distribution of words on each line.  (The re-display is more than just a pixel-blt "pan" which centers.)
Comment 19 Chris Lumens 2012-09-19 11:39:21 EDT
*** Bug 857420 has been marked as a duplicate of this bug. ***
Comment 20 Chris Lumens 2012-10-04 20:28:54 EDT
*** Bug 863280 has been marked as a duplicate of this bug. ***
Comment 21 Chris Lumens 2012-10-10 08:54:23 EDT
*** Bug 864940 has been marked as a duplicate of this bug. ***
Comment 22 Chris Lumens 2012-10-10 16:24:07 EDT
I've pushed a patch that will be in anaconda-18.15-1 that I hope will fix the initial squished problem.  I'm less optimistic it'll do anything about the flickering.  I think that's a more general problem that will need a different fix.
Comment 23 Fedora Update System 2012-10-10 21:05:05 EDT
anaconda-18.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.15-1.fc18
Comment 24 Fedora Update System 2012-10-10 22:58:40 EDT
Package anaconda-18.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.15-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15903/anaconda-18.15-1.fc18
then log in and leave karma (feedback).
Comment 25 John Reiser 2012-10-11 18:19:55 EDT
Using anaconda-18.15-1.fc18 on a self-built full install DVD, the problem is no longer present on a box with nVidia 8400GS card.  I get the correct display every time, with ample margins and with two wide columns centered on the display.

However, on a box with nVidia GT430 card (several years newer and faster than 8400GS; the CPU is also about 2X as fast), I still see the behavior of comment 12 through comment 14: the wrong display (scrunched into upper left with no margin) now for about 0.2 second (1/5 second), then re-drawn correctly with no intervention required.  This happens each time I go back and forth between the main hub and Software Selection.
Comment 26 Fedora Update System 2012-10-11 21:06:54 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18
Comment 27 Chris Lumens 2012-10-12 10:03:46 EDT
Okay, this is progress then.

I've also got bug 858684 for that flickering/redrawing thing.  I have a plan, hopefully for F18, but perhaps not.
Comment 28 Fedora Update System 2012-10-16 23:09:55 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 29 Fedora Update System 2012-10-17 22:38:44 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 30 Fedora Update System 2012-10-19 21:34:34 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 31 Fedora Update System 2012-12-20 11:04:51 EST
anaconda-18.17-1.fc18 has been pushed to the Fedora 18 obsolete repository.  If problems still persist, please make note of it in this bug report.