Bug 861753

Summary: [abrt]: WARNING: at drivers/net/wireless/iwlwifi/iwl-trans.h:565 iwlagn_mac_flush+0x1a3/0x1b0 [iwlwifi](): TAINTED G C
Product: [Fedora] Fedora Reporter: Devon Janitz <devonjspace-bugzilla>
Component: kernelAssignee: Stanislaw Gruszka <sgruszka>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: arthurxiao97, bikehead, brian, byhisdeeds, emmanuel.grumbach, gansalmon, haitzer, itamar, johannes, jonathan, kernel-maint, klement.sekera, kvolny, madhu.chinakonda, mikhail.v.gavrilov, quannum, roshan_ail, steevithak, tophdogg, willicat
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:4b017b10fa004792bf8cfa78d69e1979d188d4e2
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-22 04:57:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Devon Janitz 2012-09-30 09:26:49 EDT
Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.5.4-1.fc17.x86_64 root=/dev/mapper/vg_fisc--dcj--fedora-lv_root ro rd.md=0 rd.dm=0 SYSFONT=True rd.lvm.lv=vg_fisc-dcj-fedora/lv_root KEYTABLE=us rd.luks=0 rd.lvm.lv=vg_fisc-dcj-fedora/lv_swap LANG=en_US.UTF-8 rhgb quiet
kernel:         3.5.4-1.fc17.x86_64

kernel_tainted_long:
:Proprietary module has not been loaded.
:Modules from drivers/staging are loaded.

backtrace:
:WARNING: at drivers/net/wireless/iwlwifi/iwl-trans.h:565 iwlagn_mac_flush+0x1a3/0x1b0 [iwlwifi]()
:Hardware name: Dell System XPS L702X
:iwl_trans_wait_tx_queue_empty bad state = 0
:Modules linked in: hidp fuse lockd sunrpc rfcomm bnep vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media btusb snd_hda_codec_hdmi bluetooth arc4 iwlwifi snd_hda_codec_realtek mac80211 snd_hda_intel snd_hda_codec cfg80211 snd_hwdep coretemp kvm_intel snd_seq snd_seq_device snd_pcm dell_laptop lpc_ich rfkill r8169 mii kvm dell_wmi sparse_keymap mei mfd_core snd_page_alloc snd_timer snd i2c_i801 dcdbas soundcore microcode uinput crc32c_intel ghash_clmulni_intel nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 11149, comm: kworker/u:0 Tainted: G         C O 3.5.4-1.fc17.x86_64 #1
:Call Trace:
: [<ffffffff8105867f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81058776>] warn_slowpath_fmt+0x46/0x50
: [<ffffffffa0406c03>] iwlagn_mac_flush+0x1a3/0x1b0 [iwlwifi]
: [<ffffffffa03b6c0d>] ieee80211_mgd_probe_ap_send+0x12d/0x1f0 [mac80211]
: [<ffffffff8107432f>] ? cwq_activate_first_delayed+0x4f/0xc0
: [<ffffffffa03b72cf>] ieee80211_mgd_probe_ap.part.23+0x10f/0x130 [mac80211]
: [<ffffffffa03b746e>] ieee80211_sta_monitor_work+0x2e/0x30 [mac80211]
: [<ffffffff810745e9>] process_one_work+0x129/0x400
: [<ffffffffa03b7440>] ? ieee80211_beacon_connection_loss_work+0x150/0x150 [mac80211]
: [<ffffffff81076126>] worker_thread+0x126/0x2e0
: [<ffffffff81076000>] ? manage_workers.isra.26+0x1f0/0x1f0
: [<ffffffff8107b6a3>] kthread+0x93/0xa0
: [<ffffffff81616124>] kernel_thread_helper+0x4/0x10
: [<ffffffff8107b610>] ? flush_kthread_worker+0x80/0x80
: [<ffffffff81616120>] ? gs_change+0x13/0x13
Comment 1 Devon Janitz 2012-09-30 09:28:27 EDT
These seem to be more random and come days or weeks apart?
Comment 2 Devon Janitz 2012-09-30 18:21:39 EDT
Did this twice today.  Has not done it for quite a while, maybe weeks?

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Josh Boyer 2012-10-04 10:58:06 EDT
*** Bug 861626 has been marked as a duplicate of this bug. ***
Comment 4 Josh Boyer 2012-10-04 10:58:43 EDT
Can you recreate this without the vbox modules loaded?
Comment 5 Devon Janitz 2012-10-04 18:14:28 EDT
I will try to remember to unload them most of the time.  Only use Virtual box for testing mostly.  Will report back if it occurs then.  Should I report this to the Virtual Box people?
Comment 6 Stanislaw Gruszka 2012-10-05 07:59:31 EDT
*** Bug 861767 has been marked as a duplicate of this bug. ***
Comment 7 Stanislaw Gruszka 2012-10-05 08:07:02 EDT
*** Bug 861647 has been marked as a duplicate of this bug. ***
Comment 8 Christopher Dello Russo 2012-10-06 14:20:10 EDT
Came back to my computer, put my password in at the lock screen. After it returned back from the locked screen log in my desktop was frozen.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 Karel Volný 2012-10-07 06:02:53 EDT
after moving to a new flat, I'm experiencing a lot of issues with WiFi - connections freezing for tenths of seconds and so ... at first I thought that there is a lot of steel in the walls so there's problem with signal level, but increasing AP power did not help, now I have the signal strenght indicated at about 50% at worst, and just a few moments ago I've been working just about two metres from the AP and it was the same - so it looks more like a time coincidence with some kernel update that broke the wifi

btw, I don't know why abrt hasn't put the report here, there are some lines different from the original report, so here it goes:

WARNING: at drivers/net/wireless/iwlwifi/iwl-trans.h:565 iwlagn_mac_flush+0x1a3/0x1b0 [iwlwifi]()
Hardware name: 4384BR2
iwl_trans_wait_tx_queue_empty bad state = 0
Modules linked in: ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack rfcomm bnep be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi snd_hda_codec_hdmi snd_hda_codec_conexant uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core snd_hda_intel snd_hda_codec videodev arc4 snd_hwdep media snd_seq snd_seq_device btusb snd_pcm coretemp i2c_i801 iwlwifi mac80211 e1000e thinkpad_acpi snd_page_alloc cfg80211 bluetooth lpc_ich mfd_core snd_timer mei snd intel_ips microcode soundcore rfkill vhost_net tun macvtap macvlan kvm_intel kvm nfsd nfs_acl auth_rpcgss lockd sunrpc binfmt_misc uinput xts gf128mul dm_crypt crc32c_intel ghash_clmulni_intel firewire_ohci firewire_core crc_itu_t sdhci_pci sdhci mmc_core mxm_wmi wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
Pid: 3545, comm: kworker/u:3 Not tainted 3.5.4-2.fc17.x86_64 #1
Call Trace:
 [<ffffffff8105864f>] warn_slowpath_common+0x7f/0xc0
 [<ffffffff81058746>] warn_slowpath_fmt+0x46/0x50
 [<ffffffff810696dd>] ? mod_timer+0x15d/0x2a0
 [<ffffffffa04d6c03>] iwlagn_mac_flush+0x1a3/0x1b0 [iwlwifi]
 [<ffffffffa0433bed>] ieee80211_mgd_probe_ap_send+0x12d/0x1f0 [mac80211]
 [<ffffffff81075d8f>] ? cwq_activate_first_delayed+0x4f/0xc0
 [<ffffffffa04342af>] ieee80211_mgd_probe_ap.part.23+0x10f/0x130 [mac80211]
 [<ffffffffa043444e>] ieee80211_sta_monitor_work+0x2e/0x30 [mac80211]
 [<ffffffff81075fc9>] process_one_work+0x129/0x400
 [<ffffffffa0434420>] ? ieee80211_beacon_connection_loss_work+0x150/0x150 [mac80211]
 [<ffffffff810765f6>] worker_thread+0x126/0x2e0
 [<ffffffff810764d0>] ? rescuer_thread+0x1f0/0x1f0
 [<ffffffff8107b633>] kthread+0x93/0xa0
 [<ffffffff816161e4>] kernel_thread_helper+0x4/0x10
 [<ffffffff8107b5a0>] ? flush_kthread_worker+0x80/0x80
 [<ffffffff816161e0>] ? gs_change+0x13/0x13
Comment 10 Stanislaw Gruszka 2012-10-08 04:36:39 EDT
Johannes, perhaps you have some clue here?
Comment 11 Stanislaw Gruszka 2012-10-08 08:30:52 EDT
*** Bug 863640 has been marked as a duplicate of this bug. ***
Comment 12 Stanislaw Gruszka 2012-10-15 07:29:42 EDT
*** Bug 865854 has been marked as a duplicate of this bug. ***
Comment 13 Stanislaw Gruszka 2012-10-15 10:27:09 EDT
*** Bug 860891 has been marked as a duplicate of this bug. ***
Comment 14 Stanislaw Gruszka 2012-10-16 06:38:11 EDT
Please add this iwlwifi module debug option:

echo "options iwlwifi debug=0x0803" > /etc/modprobe.d/iwlwifi.conf

and install this kernel, with additional patch:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4591540

Then try to reproduce the problem and provide output of dmesg:

dmesg > dmesg.txt

(attach dmesg.txt file here).
Comment 15 Stanislaw Gruszka 2012-10-18 07:42:28 EDT
Please test this kernel (with proposed fix for the problem) and report back:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4602595
Comment 16 Mikhail 2012-10-18 22:44:50 EDT
(In reply to comment #15)
> Please test this kernel (with proposed fix for the problem) and report back:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=4602595

Yep, it's works! with attached kernel!!

I am write this message from the netbook which connected to internet through WiFi with the Intel 5150 card.
Comment 17 Stanislaw Gruszka 2012-10-22 04:57:39 EDT

*** This bug has been marked as a duplicate of bug 866013 ***