This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 873845

Summary: [abrt] qemu-system-x86-1.2.2-1.fc18 (and earlier): crash via qemu_spice_create_update
Product: [Fedora] Fedora Reporter: Gerard Ryan <gerard>
Component: qemuAssignee: Hans de Goede <hdegoede>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: alevy, amit.shah, berrange, bnocera, cfergeau, crobinso, dwmw2, fweimer, hdegoede, itamar, kibokin, knoel, kraxel, mcatanzaro, mikhail.v.gavrilov, pbonzini, rjones, scottt.tw, virt-maint, zali, znmeb
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:f17b2faa0951ef84657fedec83c9eac4eb42d69c
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-01 11:53:02 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: core_backtrace
none
File: environ
none
File: backtrace
none
File: limits
none
File: cgroup
none
File: executable
none
File: maps
none
File: dso_list
none
File: build_ids
none
File: proc_pid_status
none
File: open_fds
none
File: var_log_messages none

Description Gerard Ryan 2012-11-06 14:51:00 EST
Description of problem:
1. Open gnome-boxes
2. Create a new box with a live iso file.
3. Try to maximize the window.

I don't know if step 3 is relevant. The 'box' started booting from the live iso, then this happened.


Version-Release number of selected component:
qemu-system-x86-1.2.0-19.fc18

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/bin/qemu-kvm -name Fedora-Java-x86_64-LiveDVD.iso -S -M pc-1.2 -cpu Penryn,+pdcm,+xtpr,+tm2,+est,+vmx,+ds_cpl,+monitor,+dtes64,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -enable-kvm -m 2035 -smp 2,sockets=1,cores=2,threads=1 -uuid 8cbeb4d5-6223-4d34-84e7-cfdb4f1516c8 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/home/grdryn/.config/libvirt/qemu/lib/Fedora-Java-x86_64-LiveDVD.iso.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -no-kvm-pit-reinjection -no-reboot -no-shutdown -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/home/grdryn/.local/share/gnome-boxes/images/Fedora-Java-x86_64-LiveDVD.iso,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=2 -drive file=/home/grdryn/Downloads/Fedora-Java-x86_64-LiveDVD.iso,if=none,id=drive-ide0-1-0,readonly=on,format=raw -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=1 -netdev user,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:c0:86:f6,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5900,addr=127.0.0.1,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -device AC97,id=sound0,bus=pci.0,addr=0x4 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7
crash_function: malloc_and_trace
kernel:         3.6.5-2.fc18.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #2 malloc_and_trace at /usr/src/debug/qemu-kvm-1.2.0/vl.c:2322
: #3 fallback_calloc at gmem.c:525
: #4 g_malloc0 at gmem.c:189
: #5 qemu_spice_create_one_update at ui/spice-display.c:161
: #6 qemu_spice_create_update at ui/spice-display.c:285
: #7 qemu_spice_display_refresh at ui/spice-display.c:425
: #8 dpy_refresh at /usr/src/debug/qemu-kvm-1.2.0/console.h:267
: #9 gui_update at /usr/src/debug/qemu-kvm-1.2.0/vl.c:1281
: #10 qemu_run_timers at qemu-timer.c:393
: #12 qemu_run_all_timers at qemu-timer.c:450
Comment 1 Gerard Ryan 2012-11-06 14:51:05 EST
Created attachment 639582 [details]
File: core_backtrace
Comment 2 Gerard Ryan 2012-11-06 14:51:07 EST
Created attachment 639583 [details]
File: environ
Comment 3 Gerard Ryan 2012-11-06 14:51:10 EST
Created attachment 639584 [details]
File: backtrace
Comment 4 Gerard Ryan 2012-11-06 14:51:12 EST
Created attachment 639585 [details]
File: limits
Comment 5 Gerard Ryan 2012-11-06 14:51:14 EST
Created attachment 639586 [details]
File: cgroup
Comment 6 Gerard Ryan 2012-11-06 14:51:16 EST
Created attachment 639587 [details]
File: executable
Comment 7 Gerard Ryan 2012-11-06 14:51:18 EST
Created attachment 639588 [details]
File: maps
Comment 8 Gerard Ryan 2012-11-06 14:51:21 EST
Created attachment 639589 [details]
File: dso_list
Comment 9 Gerard Ryan 2012-11-06 14:51:23 EST
Created attachment 639590 [details]
File: build_ids
Comment 10 Gerard Ryan 2012-11-06 14:51:25 EST
Created attachment 639591 [details]
File: proc_pid_status
Comment 11 Gerard Ryan 2012-11-06 14:51:27 EST
Created attachment 639592 [details]
File: open_fds
Comment 12 Gerard Ryan 2012-11-06 14:51:29 EST
Created attachment 639593 [details]
File: var_log_messages
Comment 13 Cole Robinson 2012-12-14 17:36:55 EST
*** Bug 871963 has been marked as a duplicate of this bug. ***
Comment 14 Cole Robinson 2012-12-14 17:37:09 EST
*** Bug 872889 has been marked as a duplicate of this bug. ***
Comment 15 Cole Robinson 2012-12-14 17:37:13 EST
*** Bug 872892 has been marked as a duplicate of this bug. ***
Comment 16 Cole Robinson 2012-12-14 17:40:32 EST
Alon or spice guys, any idea what's going on here?
Comment 17 Cole Robinson 2012-12-14 17:47:27 EST
*** Bug 878445 has been marked as a duplicate of this bug. ***
Comment 18 Cole Robinson 2012-12-20 13:38:20 EST
*** Bug 888628 has been marked as a duplicate of this bug. ***
Comment 19 Michael Catanzaro 2013-01-19 13:03:49 EST
Occurred using GNOME Boxes 3.6.2 during the installation of openSUSE 12.2 GNOME Live CD. (For some reason Boxes thinks it was 12.1; it is wrong.) 

No idea what caused this; in fact installation, proceeded completely normally so I wouldn't have noticed if not for abrt.


backtrace_rating: 4
Package: qemu-system-x86-1.2.2-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 20 Cole Robinson 2013-01-19 14:31:57 EST
*** Bug 901530 has been marked as a duplicate of this bug. ***
Comment 21 Cole Robinson 2013-01-19 14:34:16 EST
Hans, we've had quite a few abrt reports about this one, any thoughts?
Comment 22 Michael Catanzaro 2013-01-19 14:36:28 EST
It happened again when I was running openSUSE 12.2 in Boxes, normal use. Again, there weren't any symptoms at all - nothing graphical stopped working, and I wouldn't have noticed if not for abrt.
Comment 23 Hans de Goede 2013-01-21 10:33:27 EST
Hi all,

It took me a bit of digging. but this seems to be the same issue as bug 865767, which is fixed by:
http://cgit.freedesktop.org/spice/qemu/commit/?h=spice.v63&id=e32c25b5f2452c7fed4dbe8962f4a9f4831fbe24

I've started a new build including this fix + a few other cherry picked qxl fixes. You can expect updated packages fixing this soon :)

Regards,

Hans
Comment 24 Michael Catanzaro 2013-01-21 11:38:30 EST
I had an instance of Boxes open running openSUSE 12.1.  Then I clicked "New Window" on the Boxes icon on the GNOME 3 dock. Boxes didn't like that.

backtrace_rating: 4
Package: qemu-system-x86-1.2.2-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 25 Fedora Update System 2013-01-21 13:55:52 EST
spice-0.12.2-3.fc18,qemu-1.2.2-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/spice-0.12.2-3.fc18,qemu-1.2.2-4.fc18
Comment 26 Zeeshan Ali 2013-01-21 15:47:30 EST
(In reply to comment #19)
> Occurred using GNOME Boxes 3.6.2 during the installation of openSUSE 12.2
> GNOME Live CD. (For some reason Boxes thinks it was 12.1; it is wrong.) 

Apparently, openSUSE doesn't put versions in volume IDs of live medias and thats what we use to detect OS/info from media. I filed a bug report about this:
https://bugzilla.novell.com/show_bug.cgi?id=799712
Comment 27 Fedora Update System 2013-01-22 20:34:09 EST
Package spice-0.12.2-3.fc18, qemu-1.2.2-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spice-0.12.2-3.fc18 qemu-1.2.2-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1202/spice-0.12.2-3.fc18,qemu-1.2.2-4.fc18
then log in and leave karma (feedback).
Comment 28 Cole Robinson 2013-01-24 17:25:44 EST
*** Bug 902138 has been marked as a duplicate of this bug. ***
Comment 29 Fedora Update System 2013-02-01 11:53:06 EST
spice-0.12.2-3.fc18, qemu-1.2.2-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 30 Florian Weimer 2013-06-10 11:46:06 EDT
abrt thinks I just saw this crash with qemu-kvm-1.2.2-11.fc18.x86_64.  Is this really fixed?
Comment 31 Hans de Goede 2013-06-11 06:07:24 EDT
(In reply to Florian Weimer from comment #30)
> abrt thinks I just saw this crash with qemu-kvm-1.2.2-11.fc18.x86_64.  Is
> this really fixed?

Given that we were gotten a lot of reports about it before we fixed it, and yours is the first in months, I do believe we've fixed it. So maybe you've hit some obscure variant, or maybe this somewhat invasive fix:
https://bugzilla.redhat.com/attachment.cgi?id=736836

Added to the -11 build, reintroduces it in some form ?

I'm afraid it is too soon to tell. But if you hit this again please do report it, either here or file a new bug.