This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 893892

Summary: liveinst does not [continue] after welcome screen in dd USB of RC4 Soas-live using "liveinst" command in root (GSM/UMTS device)
Product: [Fedora] Fedora Reporter: satellitgo
Component: anacondaAssignee: Radek Vykydal <rvykydal>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 18CC: andreasfleig, any0n3, dcbw, g.kaviyarasu, jantho, jonathan, karl, kuko, marcus.moeller, martin_, mswal2846, ondra.pelech, satellitgo, sbueno, spital, stephent98, valent.turkovic, vanmeeuwen+fedora, vpodzime
Target Milestone: ---Keywords: CommonBugs, Patch, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: https://fedoraproject.org/wiki/Common_F18_bugs#livecd-with-wwan-card
Fixed In Version: anaconda-19.3-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-14 10:39:17 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
output of root terminal when liveinst started and failed to [continue]
none
output of root terminal when liveinst started and failed to [continue]
none
terminal screen in VirtualBox of "liveinst" Soas RC4 where [continue] worked
none
Soas-errors when installing with liveinst command
none
liveinst -errors screenshot
none
anaconda-tb-file from /tmp as requested
none
patched network.py
none
anaconda-tb file for failing install after applying proposed fix
none
anaconda.log for failing install after applying proposed fix
none
Fedora-18-x86_64-Live-SoaS.iso sugar-terminal root# RuntimeError: Gtk couldn't be initialized
none
Soas-liveinst-errors after update of anaconda in VirtualBox-(It started)
none
updated for error in updates url
none
errors from liveinst in Soas after d/l fix none

Description satellitgo 2013-01-10 01:46:15 EST
Description of problem:
liveinst does not [continue] after welcome screen in dd USB of RC4 Soas-live using  "liveinst" command in root sugar terminal

Version-Release number of selected component (if applicable):
RC4 Soas-live both <arch>

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
proceed past welcome screen (Language selection) when [continue] is clicked

Additional info:
Comment 1 satellitgo 2013-01-10 01:59:43 EST
Created attachment 676118 [details]
output of root terminal when liveinst started and failed to [continue]

output of root terminal when liveinst started and failed to [continue] from welcome screen anaconda 18.37.11 RC4 Soas-live dd to USB
Comment 2 satellitgo 2013-01-10 02:01:02 EST
Created attachment 676119 [details]
output of root terminal when liveinst started and failed to [continue]

output of root terminal when liveinst started and failed to [continue] from welcome screen anaconda 18.37.11 RC4 Soas-live dd to USB
Comment 3 satellitgo 2013-01-10 02:44:35 EST
Created attachment 676127 [details]
terminal screen in VirtualBox of "liveinst" Soas RC4 where [continue] worked

terminal screen in VirtualBox of "liveinst" Soas RC4 where [continue] worked
Comment 4 Chris Lumens 2013-01-10 11:01:26 EST
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 77, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 287, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 73, in _on_continue_clicked
    cb()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 234, in _on_continue_clicked
    nextAction = self._instantiateAction(self._actions[1])
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 77, in _instantiateAction
    obj = actionClass(self.data, self.storage, self.payload, self.instclass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1091, in __init__
    self.network_control_box.hostname = self.data.network.hostname
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 960, in hostname
    self.entry_hostname.set_text(value)
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
TypeError: Argument 1 does not allow None as a value
Comment 5 Chris Lumens 2013-01-10 11:09:09 EST
Can you see if there's a /tmp/anaconda-tb-* file and if so, attach it to this bug report?  Thanks.
Comment 6 satellitgo 2013-01-14 11:31:48 EST
Created attachment 678293 [details]
Soas-errors when installing with liveinst command
Comment 7 satellitgo 2013-01-14 11:35:06 EST
Created attachment 678294 [details]
liveinst -errors screenshot
Comment 8 Andreas Fleig 2013-01-15 05:15:21 EST
Created attachment 678701 [details]
anaconda-tb-file from /tmp as requested

The continue button also doesn't work on my netbook. I started anaconda using the "Install to Hard Drive" shortcut.
Comment 9 Vratislav Podzimek 2013-01-15 06:00:26 EST
anaconda 18.37.11 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 476, in createMissingDefaultIfcfgs
    hwaddr = device_props_iface.Get(isys.NM_DEVICE_WIRED_IFACE, "HwAddress")
  File "/usr/lib/python2.7/site-packages/pyanaconda/network.py", line 1054, in networkInitialize
    if createMissingDefaultIfcfgs():
  File "/usr/lib/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
DBusException: org.freedesktop.DBus.Error.AccessDenied: Interface "org.freedesktop.NetworkManager.Device.Wired" isn't exported (or may not exist), can't access property "HwAddress"
Comment 10 Radek Vykydal 2013-01-15 07:59:31 EST
Created attachment 678767 [details]
patched network.py

Sending patch to anaconda-patches.

You can check the patch by copying attached network.py in live environment before installing to hard drive:

su -c "cp network.py /usr/lib/python2.7/site-packages/pyanaconda/network.py"
Comment 11 Miguel Armas 2013-01-16 06:34:38 EST
The previous fix didn't work for me. I'm trying with a Latitude E6230 with an internal wwan card

I'll attach the /tmp/anaconda*
Comment 12 Miguel Armas 2013-01-16 06:37:32 EST
Created attachment 679472 [details]
anaconda-tb file for failing install after applying proposed fix
Comment 13 Miguel Armas 2013-01-16 06:38:26 EST
Created attachment 679473 [details]
anaconda.log for failing install after applying proposed fix
Comment 14 Radek Vykydal 2013-01-16 06:41:19 EST
(In reply to comment #10)
> Created attachment 678767 [details]
> patched network.py
> 
> Sending patch to anaconda-patches.
> 
> You can check the patch by copying attached network.py in live environment
> before installing to hard drive:
> 
> su -c "cp network.py /usr/lib/python2.7/site-packages/pyanaconda/network.py"

The fix was incomplete (and for i686 systems only), I've created updates image with updated fix. To check it, run installation using liveinst command as root with these options:

liveinst --updates=http://rvykydal.fedorapeople.org/updates.wwan.img
Comment 15 Miguel Armas 2013-01-16 06:57:26 EST
Now it works for me. Thanks!
Comment 16 Radek Vykydal 2013-01-16 07:04:00 EST
Recap for CommonBugs:

scope:
Installations on machines with wwan (GSM, UTFS, ...) network devices present.
We have only reports for LiveCD installs so far but I think DVD and netinst is hit too.

problem:
Installation freezes after [Continue] on welcome screen.

workaround:
Using updates image http://rvykydal.fedorapeople.org/updates.wwan.img. For live installs this means running installation from terminal using liveinst command as root:

liveinst --updates=http://rvykydal.fedorapeople.org/updates.wwan.img
Comment 17 satellitgo 2013-01-16 07:18:42 EST
Created attachment 679506 [details]
Fedora-18-x86_64-Live-SoaS.iso sugar-terminal root# RuntimeError: Gtk couldn't be initialized
Comment 18 satellitgo 2013-01-16 07:21:01 EST
soas is using gtk3 in sugar?
Comment 19 Radek Vykydal 2013-01-16 07:42:16 EST
(In reply to comment #17)
> Created attachment 679506 [details]
> Fedora-18-x86_64-Live-SoaS.iso sugar-terminal root# RuntimeError: Gtk
> couldn't be initialized

Most probably it is not related to the new Gtk traceback you are seeing (deserves a new bug report), but you have a typo in updates url.
Comment 20 satellitgo 2013-01-16 07:45:20 EST
Created attachment 679522 [details]
Soas-liveinst-errors  after update of anaconda in VirtualBox-(It started)
Comment 21 satellitgo 2013-01-16 08:02:42 EST
Created attachment 679527 [details]
updated for error in updates url
Comment 22 Radek Vykydal 2013-01-16 08:57:27 EST
*** Bug 895752 has been marked as a duplicate of this bug. ***
Comment 23 Jann 2013-01-16 09:30:50 EST
(In reply to comment #16)
> Recap for CommonBugs:
> 
> scope:
> Installations on machines with wwan (GSM, UTFS, ...) network devices present.
> We have only reports for LiveCD installs so far but I think DVD and netinst
> is hit too.

I 've actually used a netinst iso to circumvent the problem, in other words, the livecd hit the problem, the netinst did not.
Comment 24 satellitgo 2013-01-16 12:57:33 EST
I just tested the Fedora-18-Multi-Desktop.iso

 dd if=Fedora-18-Multi-Desktop.iso of=/dev/sdb bs=2M

It boots each f18 DE's and installs gnome and KDE with anaconda.
Soas fails with the same errors shown above using liveinst
Comment 25 Andreas Fleig 2013-01-16 15:23:20 EST
(In reply to comment #16)
> liveinst --updates=http://rvykydal.fedorapeople.org/updates.wwan.img

Doing that, the installer proceeds up to "writing network configuration", where the following error occurs:

Traceback (most recent call first):
  File "/tmp/updates/pyanaconda/simpleconfig.py", line 77, in read
    with open(filename) as f:
  File "/tmp/updates/pyanaconda/simpleconfig.py", line 187, in read
    SimpleConfigFile.read(self, self.path)
  File "/tmp/updates/pyanaconda/network.py", line 311, in loadIfcfgFile
    IfcfgFile.read(self)
  File "/tmp/updates/pyanaconda/network.py", line 840, in write_sysconfig_network
    dev.loadIfcfgFile()
  File "/tmp/updates/pyanaconda/network.py", line 929, in write_network_config
    write_sysconfig_network(rootpath, ksdata, overwrite=flags.livecdInstall)
  File "/tmp/updates/pyanaconda/kickstart.py", line 759, in execute
    network.write_network_config(storage, ksdata, instClass, ROOT_PATH)
  File "/tmp/updates/pyanaconda/install.py", line 72, in doConfiguration
    ksdata.network.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/tmp/updates/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
IOError: [Errno 2] No such file or directory: '/etc/sysconfig/network-scripts/ifcfg-wwan0'
Comment 26 Miguel Armas 2013-01-16 15:33:59 EST
> IOError: [Errno 2] No such file or directory:
> '/etc/sysconfig/network-scripts/ifcfg-wwan0'

I had the same problem, but my missing file was /etc/sysconfig/network-scripts/ifcfg-ttyUSB1

An ugly workaround is to just create that file (touch will work) and the installation will complete.
Comment 27 Radek Vykydal 2013-01-17 06:52:05 EST
I've updated the
http://rvykydal.fedorapeople.org/updates.wwan.img
to fix tracebacks from comment #25.
Comment 28 Radek Vykydal 2013-01-17 07:33:05 EST
Adding to F18 CommonBugs
Comment 29 Miguel Armas 2013-01-17 08:07:14 EST
I can confirm that this update fixed both of my problems
Comment 30 Radek Vykydal 2013-01-18 04:20:46 EST
To satellit: your traceback from comment #17 will be tracked in bug #896687.
Comment 31 Chris Lumens 2013-01-22 11:14:29 EST
*** Bug 902847 has been marked as a duplicate of this bug. ***
Comment 33 satellitgo 2013-01-23 13:36:09 EST
Created attachment 686143 [details]
errors from liveinst in Soas after d/l fix
Comment 34 Dan Williams 2013-01-23 16:47:02 EST
Random question; why is Anaconda writing any ifcfg file at all for WWAN devices?
Comment 35 Dan Williams 2013-01-23 16:48:25 EST
(In reply to comment #34)
> Random question; why is Anaconda writing any ifcfg file at all for WWAN
> devices?

Or was it just something in the code that was attempting to access an ifcfg file for *any* NMDevice object no matter what the name?
Comment 36 Radek Vykydal 2013-01-24 03:53:19 EST
(In reply to comment #35)
> (In reply to comment #34)
> > Random question; why is Anaconda writing any ifcfg file at all for WWAN
> > devices?
> 
> Or was it just something in the code that was attempting to access an ifcfg
> file for *any* NMDevice object no matter what the name?

Yes, sort of this. The fix will be not to write ifcfg files for WWAN devices and not to fail on missing ifcfg files later. Generally I want to move from reading/writing ifcfg files to reading/updating NM settings objects. Still there are some cases where we need to r/w ifcfg file:

1) (write) setting NM_CONTROLLED for root on network storage (maybe not needed anymore, I'm going to test it, bug #607921)

2) (write) setting ONBOOT value in ifcfg files in root of installed system (/mnt/sysroot/etc/sysconfig/network-scripts) - the reason is that setting the value in installation root (which would be possible via NM - "autoconnect") activates the device (in some cases?) which I'm a bit afraid of doing.

3) (read) BOOTPROTO=ibft value which is handled by ifcfg-rh (reads the values with iscaiadm) so the information ("use ibft") we need to pass to dracut is not accessible in NM settings.
Comment 37 Chris Lumens 2013-01-29 09:41:33 EST
*** Bug 905206 has been marked as a duplicate of this bug. ***
Comment 38 Radek Vykydal 2013-03-11 04:06:36 EDT
*** Bug 919709 has been marked as a duplicate of this bug. ***
Comment 39 spital 2013-03-17 13:47:19 EDT
Lenovo X200 with the same problem - switch the wifi off helped ( Bug 882615#19 ).
Comment 40 Michael Spahn 2013-04-19 06:29:49 EDT
I can confirm this bug too on a Lenovo T420.

Makes installation without patch not possible.

Neither with cli nor mit text mode.

 - Fedora 18 XFCE 86_64.
Comment 41 Michael Spahn 2013-04-19 07:10:24 EDT
Maybe a rebuild of the spins / iso should be discussed with the release engineering team.

@Radek what is your statement?
Comment 42 Radek Vykydal 2013-04-19 07:27:45 EDT
Sorry, we don't rebuild spins / isos post release. This bug will be fixed in the next release. The fix should be included in F19 Alpha which will be publicly available on Tuesday, April 23, 2013.
Comment 43 mswal28462 2013-04-19 07:41:41 EDT
mmm.  Meanwhile, it's virtually impossible to install F18 on these Lenovo machines, even with the work around, it's hit and miss on whether it will work.

I had to reinstall F18 on my x230 and it took me about 10 attempts before I could get it to work ... there's some sort of timing issue with the patch.
Comment 44 Michael Spahn 2013-04-19 07:45:56 EDT
Thank you.

But I still think we should think about this and maybe should think about rebulding ISOs in case of rly critical bugs.

Policies are great if they are discussed.

We have a broken anaconda for almost every pc with installed GSM/UMTS device.

And this one will scare linux starters - or is this just my oppinion?

I think this have to be fixed, Fedora 18 will be supported and used by a lot of people in the future.

The comments in this bug proves this statement.

@mswal28462: Whats your anaconda version? Have you used the image provided? Or have you applied the patch by yourself?
Comment 45 Radek Vykydal 2013-05-13 10:42:45 EDT
*** Bug 957819 has been marked as a duplicate of this bug. ***
Comment 46 Michael Spahn 2013-05-14 10:39:17 EDT
Close due to fix in next release.

Solution for F18 in this ticket available.