Bug 1026284 - [ja_JP] Source string "%(action)s %(data_type)s" is causing grammatically incorrect translations
[ja_JP] Source string "%(action)s %(data_type)s" is causing grammatically inc...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity unspecified
: z1
: 4.0
Assigned To: Julie Pichon
Lijun Li
: i18n, Translation, Triaged, ZStream
: 1026160 1026592 1026594 1026597 1026621 1026759 1026767 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-04 05:45 EST by Yuko Katabami
Modified: 2015-02-15 17:02 EST (History)
9 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2.1-1.el6ost
Doc Type: Bug Fix
Doc Text:
The same string concatenation system was used to display messages about present and past actions in the UI. As a result, in some languages, such as Japanese, this caused one of the strings to be grammatically incorrect. A context marker has been added so that 2 different translated strings can be proposed, depending on whether the string is in the past or present tense. Now, the Japanese strings for these messages are now grammatically correct.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 09:24:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Deleted router message in ja-JP (163.62 KB, image/png)
2013-11-04 05:45 EST, Yuko Katabami
no flags Details
Deleted role message in ja-JP (288.21 KB, image/png)
2013-11-05 00:36 EST, Yuko Katabami
no flags Details
Deleted group message in ja-JP (108.44 KB, image/png)
2013-11-05 01:02 EST, Yuko Katabami
no flags Details
Deleted project message in ja-JP (139.73 KB, image/png)
2013-11-05 02:01 EST, Yuko Katabami
no flags Details
Deleted network message in ja-JP (125.56 KB, image/png)
2013-11-05 19:28 EST, Yuko Katabami
no flags Details
Deleted subnet message in ja-JP (173.32 KB, image/png)
2013-11-05 20:52 EST, Yuko Katabami
no flags Details
Deleted port message in ja-JP (181.48 KB, image/png)
2013-11-05 20:58 EST, Yuko Katabami
no flags Details
"Released Floaping IP" message in Japanese (126.60 KB, image/png)
2013-11-11 02:20 EST, Yuko Katabami
no flags Details
Instance Paused in ja-JP (147.28 KB, image/png)
2013-11-11 02:25 EST, Yuko Katabami
no flags Details
Instance Suspended in ja-JP (162.87 KB, image/png)
2013-11-11 02:36 EST, Yuko Katabami
no flags Details
Instance Resumed in ja-JP (161.71 KB, image/png)
2013-11-11 02:39 EST, Yuko Katabami
no flags Details
Disabled User message in ja-JP (161.15 KB, image/png)
2013-11-11 02:45 EST, Yuko Katabami
no flags Details
Delete ExtraSpec in ja-JP (8.54 KB, image/png)
2013-11-11 02:58 EST, Yuko Katabami
no flags Details
Deleted Flavor in ja-JP (175.12 KB, image/png)
2013-11-11 03:01 EST, Yuko Katabami
no flags Details
Grammatical error in ja-JP message generated by %(action)s %(data_type)s is now fixed - example 1 (146.53 KB, image/png)
2014-01-15 19:19 EST, Yuko Katabami
no flags Details
Grammatical error in ja-JP message generated by %(action)s %(data_type)s is now fixed - example 2 (126.62 KB, image/png)
2014-01-15 19:20 EST, Yuko Katabami
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1252082 None None None Never
OpenStack gerrit 58139 None None None Never
OpenStack gerrit 60713 None None None Never

  None (edit)
Description Yuko Katabami 2013-11-04 05:45:56 EST
Created attachment 819050 [details]
Deleted router message in ja-JP

Description of problem:
Japanese translation for "Deleted Router" message is grammatically incorrect.

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Dashboard with Admin account.
2. Click "Settings" menu and change the language to Japanese.
3. On the left panel, select Project => Manage Network => Router
4. Select a router and click "Delete Routers" button.
5. Confirm your action.
6. "Success: Deleted router: <ROUTER NAME>" is displayed.

Actual results:
Translation is grammatically incorrect.
"ルーターの削除しました"

Expected results:
It should be:
"ルーターを削除しました"

Additional info:
Screenshot attached
Comment 1 Yuko Katabami 2013-11-04 05:48:04 EST
This will be discussed with the upstream ja-JP user group.
I will report the progress here.
Comment 2 Yuko Katabami 2013-11-04 05:53:20 EST
Similar to BZ#1026160, this string might be formed by combining separate parts using variables, resulting grammatical error.

Confirmed that full sentence is not in the upstream file.
Comment 4 Yuko Katabami 2013-11-05 00:36:24 EST
Created attachment 819520 [details]
Deleted role message in ja-JP

The same bug is also applicable to "Role".

ロールの削除しました should be ロールを削除しました
Comment 5 Yuko Katabami 2013-11-05 01:02:13 EST
Created attachment 819526 [details]
Deleted group message in ja-JP

The same bug is also applicable to "Group".

グループの削除しました should be グループを削除しました
Comment 6 Yuko Katabami 2013-11-05 02:01:04 EST
Created attachment 819541 [details]
Deleted project message in ja-JP

The same bug is also applicable to "Project".

プロジェクトの削除しました should be プロジェクトを削除しました
Comment 7 Yuko Katabami 2013-11-05 18:54:38 EST
This is also applicable to the message "Deleted router" displayed when a router is deleted on Admin => Routers.
Comment 8 Yuko Katabami 2013-11-05 19:28:57 EST
Created attachment 820093 [details]
Deleted network message in ja-JP

The same bug is also applicable to "Network".

ネットワークの削除しました should be ネットワークを削除しました
Comment 9 Yuko Katabami 2013-11-05 20:52:25 EST
Created attachment 820108 [details]
Deleted subnet message in ja-JP

The same bug is also applicable to "Subnet".

サブネットの削除しました should be サブネットを削除しました
Comment 10 Yuko Katabami 2013-11-05 20:58:58 EST
Created attachment 820109 [details]
Deleted port message in ja-JP

The same bug is also applicable to "Port".

ポートの削除しました should be ポートを削除しました
Comment 11 Yuko Katabami 2013-11-10 16:01:58 EST
Reported to the upstream ja-JP user group on 8 Nov and is currently under discussion.
Comment 12 Yuko Katabami 2013-11-11 02:02:21 EST
These are all cased by the following string:

#: tables/actions.py:560
#, python-format
msgid "%(action)s %(data_type)s"
msgstr "%(data_type)sの%(action)s"

According to the upstream ja-JP user group, this needs to be separated for each use case combination, because the current form is is causing a problem to some combination, but it works with some particular combinations of action and data_type.
Comment 13 Yuko Katabami 2013-11-11 02:04:45 EST
*** Bug 1026160 has been marked as a duplicate of this bug. ***
Comment 14 Yuko Katabami 2013-11-11 02:20:19 EST
Created attachment 822304 [details]
"Released Floaping IP" message in Japanese

Merging BZ#1026160.

Description of problem:
Japanese translation for "Released Floaping IP" message is grammatically incorrect.

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Dashboard with Admin account.
2. Click "Settings" menu and change the language to Japanese.
3. Select Project => Access & Security => Floating IPs
4. Select one IP address from the list. If there is no IP addresses listed, you need to allocate one first.
5. Click "More" button on the right and click "Release Floating IP".
6. Confirm your action.
7. Check the message start with "Success".

Actual results:
Floating IP の解放しました

Expected results:
Floating IP を解除しました

Additional info:
Screenshot attached
Comment 15 Yuko Katabami 2013-11-11 02:21:38 EST
*** Bug 1026592 has been marked as a duplicate of this bug. ***
Comment 16 Yuko Katabami 2013-11-11 02:25:49 EST
Created attachment 822307 [details]
Instance Paused in ja-JP

Merging BZ#1026592.

Description of problem:
Translation of Paused Instance is grammatically incorrect

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Dashboard with Admin account.
2. Click "Settings" menu and change the language to Japanese.
3.Click on Admin-System Panel-Instances tab from the left side panel, click & check the drop-down list "Pause Instance"

Actual results:
インスタンスの一時停止しました。

Expected results:
インスタンスを一時停止しました。

Additional info:
similar bugs
1026160
1026284
Comment 17 Yuko Katabami 2013-11-11 02:27:52 EST
*** Bug 1026594 has been marked as a duplicate of this bug. ***
Comment 18 Yuko Katabami 2013-11-11 02:36:07 EST
Created attachment 822308 [details]
Instance Suspended in ja-JP

Merging BZ#1026594.

Description of problem:
Translation of suspended Instance is grammatically incorrect

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Dashboard with Admin account.
2. Click "Settings" menu and change the language to Japanese.
3. Click on Admin-System Panel-Instances tab from the left side panel.
4. Click drop-down list and select "Suspend Instance".
5. Check the message shown on the right-top corner.

Actual results:
インスタンスの休止しました。

Expected results:
インスタンスを休止しました。

Additional info:
similar bugs
1026160
1026284
1026592
Comment 19 Yuko Katabami 2013-11-11 02:37:08 EST
*** Bug 1026597 has been marked as a duplicate of this bug. ***
Comment 20 Yuko Katabami 2013-11-11 02:39:25 EST
Created attachment 822310 [details]
Instance Resumed in ja-JP

Merging BZ#1026597.

Description of problem:
Translation of suspended Instance is grammatically incorrect

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Dashboard with Admin account.
2. Click "Settings" menu and change the language to Japanese.
3.Click on Admin-System Panel-Instances tab from the left side panel, click & check the drop-down list "Suspend Instance" or "Pause Instance"
4 Wait until the instance is suspended or paused
5 Click on the drop down list "Resume Instance"
The pop up message is grammatically incorrect.

Actual results:
インスタンスの再開しました。

Expected results:
インスタンスを再開しました。

Additional info:
similar bugs
1026160
1026284
1026592
1026594
Comment 21 Yuko Katabami 2013-11-11 02:40:28 EST
*** Bug 1026621 has been marked as a duplicate of this bug. ***
Comment 22 Yuko Katabami 2013-11-11 02:45:39 EST
Created attachment 822311 [details]
Disabled User message in ja-JP

Merging with BZ#1026621.

Description of problem:
Japanese translation of message "Disabled user" is grammatically incorrect.

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Dashboard with Admin account.
2. Click "Settings" menu and change the language to Japanese.
3. On the left side panel, click "Users".
4. Select an active user from the list and disable it by clicking "Disable User" under "More" dropdown menu.

Actual results:
The current translation for "Disabled user" is:
ユーザーの無効化しました

Expected results:
ユーザーを無効化しました

Additional info:
Screenshot attached.
Similar bugs:
1026597
1026594
1026592
1026284
1026160
[reply] [−]  Private Comment 1
Comment 23 Yuko Katabami 2013-11-11 02:46:58 EST
*** Bug 1026759 has been marked as a duplicate of this bug. ***
Comment 24 Yuko Katabami 2013-11-11 02:58:56 EST
Created attachment 822313 [details]
Delete ExtraSpec in ja-JP

Merging BZ#1026759.

Description of problem:
translation of DeletedExtraspec: is grammatically in correct

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Log in to Dashboard with Admin account.
2. Click "Settings" menu and change the language to Japanese.
3. Click on Admin-System Panel-Flavors tab from the left side panel
4. Click on More pulldown menu and Select View Extra Specs.
5. In the Flavor Extra Spec window, click "Create" to create an Extra Spec.
6. In Actions column, click More and select "Delete ExtraSpec".
7. Check the message shown on the right-top corner.


Actual results:
追加スペックの削除しました

Expected results:
追加スペックを削除しました

Additional info:
Comment 25 Yuko Katabami 2013-11-11 02:59:51 EST
*** Bug 1026767 has been marked as a duplicate of this bug. ***
Comment 26 Yuko Katabami 2013-11-11 03:01:49 EST
Created attachment 822314 [details]
Deleted Flavor in ja-JP

Merging BZ#1026767.

Description of problem:
Translation of Deleted Flavor is grammatically incorrect

Version-Release number of selected component (if applicable): 4.0


How reproducible:100%


Steps to Reproduce:
1. Log in to Dashboard with Admin account.
2. Click "Settings" menu and change the language to Japanese.
3. Click on Admin-System Panel-Flavors tab from the left side panel
4. Click on More pulldown menu and select Delete flavor.

Actual results:
フレーバーの削除しました


Expected results:

フレーバーを削除しました
Additional info:
Comment 27 Julie Pichon 2013-11-12 11:31:35 EST
We're going to need to find a new mechanism to generate these messages, that is more friendly to other languages.
Comment 28 Yuko Katabami 2013-11-12 17:09:04 EST
(In reply to Julie Pichon from comment #27)
> We're going to need to find a new mechanism to generate these messages, that
> is more friendly to other languages.

Hi Julie,

Thank you for your comment.
That is exactly what Motoki-san in upstream was saying.

My understanding of his solution is to separate this string for different use cases (every action + type combination).
He said he was aware of this issue, but has not been able to take action yet due to other high priority bugs.

I have asked him if this is causing a problem in other languages (still waiting for his reply) - I have dealt with a similar case with other product in which multiple languages were affected.

I will update when I get his reply. If it is affecting multiple languages, I will change this bug from Translation to i18n.
Comment 29 Julie Pichon 2013-11-13 12:04:17 EST
I think the i18n tag will be appropriate. To be honest, there are times where IMO it's causing problems in English as well and we end choosing somewhat awkward phrasing. It would be helpful if Motoki-san describes his solution idea in a bug or blueprint upstream so we can track the solution's implementation :) I will ask him.
Comment 30 Yuko Katabami 2013-11-13 20:51:47 EST
Got Motoki-san's reply yesterday. He explained to me briefly his solutions:

1) He has also recognized that this is an i18n issue (not ja-JP or any locale specific) but fix is beyond the scope of Havana release, therefore the fundamental changes will be done for Icehouse.

2) As adhoc solution, he is thinking of adding context to the source string to distinguish two different patterns of Japanese translation which needs to be done at POT level. 

Hope my description makes sense, but Motoki-san can describe further details.

We might have to clone this bug so that we would have one for Translation (Havana) and the other one for i18n (Icehouse).
Comment 31 Julie Pichon 2013-11-14 06:21:56 EST
Are you suggesting option #2 can be done only in the pot file, without requiring changing the code? If so then I agree it would make sense to clone the bug, as unlike #1 this should be doable within the Havana / 4.0 context.
Comment 32 Yuko Katabami 2013-11-14 06:34:53 EST
(In reply to Julie Pichon from comment #31)
> Are you suggesting option #2 can be done only in the pot file, without
> requiring changing the code? If so then I agree it would make sense to clone
> the bug, as unlike #1 this should be doable within the Havana / 4.0 context.

@Julie
Yes, that's what my understanding of his solution is, but when you ask him more details, please confirm it with him.

I can track the progress of #2 from the upstream user group and report it here.
Comment 33 Julie Pichon 2013-11-14 06:41:53 EST
Thanks, moving to 5.0 for tracking the messages overhaul work.
Comment 34 Yuko Katabami 2013-12-11 18:21:39 EST
Ad hoc solution has been completed and the translation fix has been merged into the upstream Havana Stable Update.

For Icehouse, Motoki-san is planning to separate this string so that we can translate each combination of action and data_type separately.

@Julie
Since the target release is set to 5.0, should I wait to move the status to POST until the string is properly fixed and separated and all strings are translated upstream?
Comment 35 Julie Pichon 2013-12-12 04:53:25 EST
@Yuko: If the workaround merged in Havana stable is enough to resolve the initial issue reported in this bug, we can move the target to 4.0 async and close it during the 4.0 cycle. It seems to me the を vs. の issue that was reported is now resolved, though let me know your thoughts.
Comment 36 Yuko Katabami 2013-12-12 04:55:18 EST
(In reply to Julie Pichon from comment #35)
> @Yuko: If the workaround merged in Havana stable is enough to resolve the
> initial issue reported in this bug, we can move the target to 4.0 async and
> close it during the 4.0 cycle. It seems to me the を vs. の issue that was
> reported is now resolved, though let me know your thoughts.

@Julie
I agree with you.
I am moving the status to POST now.
Thank you!
Comment 38 Yuko Katabami 2014-01-15 19:19:35 EST
Created attachment 850746 [details]
Grammatical error in ja-JP message generated by %(action)s %(data_type)s is now fixed - example 1
Comment 39 Yuko Katabami 2014-01-15 19:20:11 EST
Created attachment 850747 [details]
Grammatical error in ja-JP message generated by %(action)s %(data_type)s is now fixed - example 2
Comment 40 Yuko Katabami 2014-01-15 19:20:35 EST
Verified on the latest RHOS 4.0.z puddle. Screenshot attached. Moving the status to VERIFIED.
Comment 43 Lon Hohberger 2014-02-04 12:20:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-0046.html

Note You need to log in before you can comment on or make changes to this bug.