Bug 102955 - (TB4a5c5e6f) maindialog.py:198:__init__:NameError: global name 'timeout_add' is not defined
maindialog.py:198:__init__:NameError: global name 'timeout_add' is not defined
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 106080 106439 106510 109461 112714 113164 120650 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-23 04:29 EDT by Michael Kory Woods
Modified: 2007-04-18 12:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-08 12:08:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Kory Woods 2003-08-23 04:29:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Won't work

Version-Release number of selected component (if applicable):
1.2.15

How reproducible:
Always

Steps to Reproduce:
1. downloaded updates via up2date
2. went to configure modem...
    

Actual Results:  Component: redhat-config-network
Version: 1.2.15
Summary: TB4a5c5e6f maindialog.py:198:__init__:NameError: global name
'timeout_add' is not defined
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 163, in main
    window = mainDialog()
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 198, in __init__
NameError: global name 'timeout_add' is not defined

Local variables in innermost frame:
widget: <gtk.VBox object (GtkVBox) at 0x861a6a4>
notebook: <gtk.Notebook object (GtkNotebook) at 0x8610a8c>
page: 0
glade_file: /usr/share/redhat-config-network/netconfpkg/gui/maindialog.glade
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x83fcec4>


Additional info:
Comment 1 Harald Hoyer 2003-09-01 10:58:26 EDT
this is not version 1.2.15!!!
the line no. is wrong and maindialog.py uses gtk.timeout! 
strange...
could you please 
# rm -f /usr/share/redhat-config-network/netconfpkg/*/*.pyc
# rm -f /usr/share/redhat-config-network/netconfpkg/*.pyc
and retry?
Comment 2 Harald Hoyer 2003-10-06 02:49:37 EDT
*** Bug 106080 has been marked as a duplicate of this bug. ***
Comment 3 Harald Hoyer 2003-10-08 05:28:28 EDT
*** Bug 106510 has been marked as a duplicate of this bug. ***
Comment 4 Harald Hoyer 2003-11-24 05:07:44 EST
*** Bug 109461 has been marked as a duplicate of this bug. ***
Comment 5 Harald Hoyer 2003-12-02 04:36:59 EST
$ md5sum /usr/share/redhat-config-network/netconfpkg/gui/maindialog.py*
a829c5dbf0b6305c47502f02e7aa0517 
/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py
45f5e10e62c49ddf6c311e01e9986fc6 
/usr/share/redhat-config-network/netconfpkg/gui/maindialog.pyc
20854dbbfcae4b90c24363ce0de3c2c7 
/usr/share/redhat-config-network/netconfpkg/gui/maindialog.pyo
Comment 6 Harald Hoyer 2004-01-12 06:24:29 EST
*** Bug 112714 has been marked as a duplicate of this bug. ***
Comment 7 Harald Hoyer 2004-01-12 06:46:34 EST
*** Bug 113164 has been marked as a duplicate of this bug. ***
Comment 8 Harald Hoyer 2004-04-13 08:00:06 EDT
*** Bug 120650 has been marked as a duplicate of this bug. ***
Comment 9 Harald Hoyer 2004-06-04 06:08:27 EDT
maybe you pressed configure in r-control-network, this started
r-c-network and then you closed the r-control-network window...
Comment 10 Harald Hoyer 2004-09-21 08:10:44 EDT
*** Bug 106439 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.