Bug 106693 - up2date window size larger than screen resolution
up2date window size larger than screen resolution
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Beth Nackashi
:
: 91576 103911 109955 112586 (view as bug list)
Depends On:
Blocks: 168424 169775
  Show dependency treegraph
 
Reported: 2003-10-09 13:28 EDT by Alex Thomsen Leth
Modified: 2007-11-30 17:06 EST (History)
14 users (show)

See Also:
Fixed In Version: RHBA-2006-0105
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 10:31:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the issue (329.98 KB, image/png)
2003-10-16 16:03 EDT, Sindre Pedersen Bjørdal
no flags Details
big window (95.75 KB, image/png)
2003-11-08 04:32 EST, Alex Thomsen Leth
no flags Details
up2date-4.1.16-newlines-da-po.patch (851 bytes, patch)
2004-02-05 15:43 EST, Bart Martens
no flags Details | Diff
up2date-4.1.16-newlines-no-po.patch (5.02 KB, patch)
2004-02-05 15:44 EST, Bart Martens
no flags Details | Diff
up2date rpm for now (876.76 KB, application/x-rpm)
2004-02-11 14:46 EST, Alex Thomsen Leth
no flags Details
up2date-gnome rpm for now (135.25 KB, application/x-rpm)
2004-02-11 14:48 EST, Alex Thomsen Leth
no flags Details
english/danish up2date (115.53 KB, image/png)
2004-11-13 18:00 EST, Alex Thomsen Leth
no flags Details

  None (edit)
Description Alex Thomsen Leth 2003-10-09 13:28:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031003

Description of problem:
in the dansih version of fedora core, the up2date program is to big.. i cant
resize it.

Version-Release number of selected component (if applicable):
up2date-4.0.1-2

How reproducible:
Always

Steps to Reproduce:
1.start the program    

Actual Results:  there appere a big windows. it could fit to screens

Expected Results:  a normal windows :-)

Additional info:
Comment 1 Sindre Pedersen Bjørdal 2003-10-16 16:03:17 EDT
Created attachment 95235 [details]
Screenshot of the issue

Screenshot of the issue
Comment 2 Sindre Pedersen Bjørdal 2003-10-16 16:06:35 EDT
Comment on attachment 95235 [details]
Screenshot of the issue

The same problem is in the Norwegian translation of up2date-4.1.7-1

This really needs to be fixed!
Comment 3 Kjartan Maraas 2003-10-18 18:09:56 EDT
Is this caused by the translation somehow? I'd like to fix it but I can't really
see where the translation is causing this.
Comment 4 Alex Thomsen Leth 2003-10-19 07:29:58 EDT
someone says it is a translation problem... but i dont know
Comment 5 JP Matos 2003-10-19 09:33:43 EDT
This suspiciously looks like
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=31707
Also happens with portuguese translation and the version of
up2date/up2date-gnome from rawhide-release-20031018-1. At the time of bug 31707
it seems that only the french translation was fixed. A systematic check should
be in order...
Comment 6 Chan Min Wai 2003-11-08 04:15:08 EST
At lease make it viewable on 800x600. Not to have it move Left and
right :(

Thank You
Comment 7 Alex Thomsen Leth 2003-11-08 04:32:34 EST
Created attachment 95818 [details]
big window

the screen is not so big
Comment 8 Alex Thomsen Leth 2003-11-08 04:34:54 EST
it is not good with this error, the first thing a noob sees when linux
is up and running is a bug.
Comment 9 Bjorn Ryborg 2004-01-25 10:09:12 EST
The problem was there in RedHat 8 and 9 and Core 1. 
When are somone going to fix it???
Comment 10 Bart Martens 2004-02-05 15:43:28 EST
Created attachment 97499 [details]
up2date-4.1.16-newlines-da-po.patch

This patch should solve the problem for Danish.
Comment 11 Bart Martens 2004-02-05 15:44:48 EST
Created attachment 97500 [details]
up2date-4.1.16-newlines-no-po.patch

This patch should solve the problem for Norwegian.
Comment 12 Alex Thomsen Leth 2004-02-05 16:08:44 EST
the danish up2date problem is solved. thx alot Bart
Comment 13 Alex Thomsen Leth 2004-02-05 16:11:00 EST
norweigan also working
Comment 14 Jef Spaleta 2004-02-05 16:16:25 EST
i just want to say.....kickass!
setting the patch keyword

Comment 15 Miloslav Trmac 2004-02-07 12:14:31 EST
*** Bug 91576 has been marked as a duplicate of this bug. ***
Comment 16 Miloslav Trmac 2004-02-07 12:15:04 EST
*** Bug 103911 has been marked as a duplicate of this bug. ***
Comment 17 Miloslav Trmac 2004-02-07 12:17:15 EST
*** Bug 112586 has been marked as a duplicate of this bug. ***
Comment 18 Bart Martens 2004-02-10 15:04:08 EST
Any plans to get the patch packaged and released as an update? Can I
help to speed things up?
Comment 19 Alex Thomsen Leth 2004-02-11 14:46:30 EST
Created attachment 97589 [details]
up2date rpm for now
Comment 20 Alex Thomsen Leth 2004-02-11 14:48:18 EST
Created attachment 97590 [details]
up2date-gnome rpm for now
Comment 21 Bart Martens 2004-03-12 17:49:18 EST
Setting severity to "translation".
Comment 22 Sergio Monteiro Basto 2004-03-25 20:50:20 EST
well the problem persist on Portuguese, up2date, up2date-gnome-4.1.21-3
a very big size of up2date window.
neither up2date-gnome-4.1.16-1.0041.bartm.i386.rpm and
up2date-4.1.16-1.0041.bartm.i386.rpm resolve Portuguese problem 
thanks 
Comment 23 Sindre Pedersen Bjørdal 2004-04-14 16:12:51 EDT
This problem is still there in the norwegian translation of
up2date-4.3.15-2, the one in Fedora Core 2 test2, please fix this problem.
Comment 24 Kjartan Maraas 2004-04-14 16:16:20 EDT
I tried fixing this according to the changes shown above, but if it's
a matter of placing the newlines at some magic position to make it
work I think the app is broken beyond repair. This is the only place
I've seen such behaviour in any app I've translated so far.
Comment 25 Sindre Pedersen Bjørdal 2004-04-15 11:05:05 EDT
If you can't make the norwegian translation work, I don't thing you
should include it at all. Its much better to have a working, usable
up2date in english than an unusable one in norwegian. up2date is one
of the first things a new users see after installing Fedora and it has
to work. 
Comment 26 Kyrre Ness Sjøbæk 2004-04-15 11:41:20 EDT
Maybee a little off-topic:

Another localisation thing that should be changed is the use of
mirrors. Many universities and such provide these, and I think fedora
should default to those nearest the selected place (during timezone
setup). The default setting is really awfully slow...

I have also seen som crashes of up2date, looks like it occurs if you
try to minimize the window and it then begins downloading the next
package.

Yet another thing i (and many others) certainly would like, is an
option to use a synaptic-like interface.
Comment 27 Kjartan Maraas 2004-04-15 12:24:22 EDT
I checked again and this problem was fixed in the norwegian
localisation in mid march, but there's been no updated release with
new translations it seems. Please do another release and include
updated translations from CVS.
Comment 28 Sindre Pedersen Bjørdal 2004-04-26 14:07:43 EDT
Norwegian is fixed in development (rawhide) now (26 april), thanks. 
Comment 29 Alex Thomsen Leth 2004-04-28 16:56:51 EDT
why isnt the danish translation fixed in development. when the
norwegian is
Comment 30 Kjartan Maraas 2004-04-28 18:39:40 EDT
Because the danish translator is lazy? :-)

Seriously, it seems as if the danish translation was last updated in
march, but the pot file it was merged with was from september 2003.
Maybe it needs remerging and updating?
Comment 31 Alex Thomsen Leth 2004-05-12 12:02:11 EDT
i cant understand why this not is fixed. in bartm's rpms it works
great in danish.
Comment 32 Warren Togami 2004-06-17 20:27:06 EDT
*** Bug 109955 has been marked as a duplicate of this bug. ***
Comment 33 Warren Togami 2004-06-17 20:33:43 EDT
RHEL3 U2 up2date-4.2.16-1 window size is larger than 800x600 screen
resolution in multiple specific languages.  Screenshots:

English and Japanese are fine
=============================
http://togami.com/~warren/archive/2004/rhel3u2_up2date_en_US.UTF-8.png
http://togami.com/~warren/archive/2004/rhel3u2_up2date_ja_JP.eucJP.png

Simplified Chinese, Traditional Chinese and Korean are broken
=============================================================
http://togami.com/~warren/archive/2004/rhel3u2_up2date_zh_TW.Big5.png
http://togami.com/~warren/archive/2004/rhel3u2_up2date_ko_KR.eucKR.png
Comment 34 Alex Thomsen Leth 2004-07-18 17:55:36 EDT
if the  bug not will be fixed. please turn off the danish laungauge
and make it default english. 
Comment 35 Sergio Monteiro Basto 2004-07-29 09:57:48 EDT
this also happens on fedora core 1 
up2date-4.1.21-3.i386.rpm
up2date-gnome-4.1.21-3.i386.rpm

huge windows size larger than screen resolution on LANG=pt_PT

the workarround is :
export LANG=en_US; up2date
Comment 36 Henrik Juul Hansen 2004-10-14 17:13:30 EDT
The problem still remains in the FC3T3 release.

The size of the up2date window is still too wide/big to fit the
screen. Not possible to resize the window. I use Danish language on a
i386 system.
Comment 37 Bjorn Ryborg 2004-10-23 09:28:51 EDT
The patch is allready submitted. Its in the end of this tread. Why
issent it getting in mainstream?
Comment 38 Bjorn Ryborg 2004-11-11 13:52:33 EST
Same problem in FC3 :(
Comment 39 Alex Thomsen Leth 2004-11-13 17:55:51 EST
damn. what is happening. you guys made it english, but now the english
version has the same problem
Comment 40 Alex Thomsen Leth 2004-11-13 18:00:20 EST
Created attachment 106653 [details]
english/danish up2date
Comment 41 Sergio Monteiro Basto 2004-11-17 10:01:25 EST
the workarround is :

export LANG=en_US; up2date
Comment 42 Jens Petersen 2005-03-17 20:46:06 EST
Any progress on this?
Comment 43 Bjorn Ryborg 2005-03-18 00:35:24 EST
Same problem in RHEL4
Comment 44 Jens Petersen 2005-05-16 01:27:46 EDT
(This is RHEL4 bug 148913 for RHEL3.)
Comment 45 Bjorn Ryborg 2005-05-16 08:32:30 EDT
Up2date to wide, has been fixed for the Danish version in FC4T3
Comment 48 Bjorn Ryborg 2005-06-29 12:49:26 EDT
Fixed in FC4.
Comment 50 Jason Connor 2005-09-29 18:40:00 EDT
This is a translation bug and not a bug with up2date itself. Adrian (and I) work
on the up2date code. As this bug has been kicked around for a long long time,
I'm assuming that the translations cannot be fixed and I'm closing this bug.

Jason Connor
Comment 52 Jens Petersen 2005-09-29 21:37:29 EDT
One could argue of course that up2date should restrict itself
to not exceed the available screen size but I don't know of that
is feasible for rhel3? :)
Comment 54 Sarah Wang 2005-09-30 09:10:59 EDT
I'd like to add some comments from translation point of view, and I'm
reassigning this bug to the package maintainer because I don't believe it's a
translation bug.

All internal translators have worked on this bug in RHEL3 and tried their best
to shorten the translation text to fit into the screen widgets. For some
languages, it is simply impossible to construct anything meaningful with this
size restriction.

Is it possible to redesign/rewrite the code to cater for the natural restrains
of different languages? I expect this problem would effect more users when RHEL
starts support more and more locales/languages.

(In reply to comment #50)
> This is a translation bug and not a bug with up2date itself. Adrian (and I) work
> on the up2date code. As this bug has been kicked around for a long long time,
> I'm assuming that the translations cannot be fixed and I'm closing this bug.
> 
> Jason Connor

Comment 56 Adrian Likins 2005-10-17 13:28:57 EDT
re comment #54, it may be possible to change the app, but I'm not sure what
those changes would need to be. What do the translators etc have in mind?
If there are any strings left that aren't properly wrapping, that could
probably be fixed. 
Comment 57 Bjorn Ryborg 2005-12-14 22:11:18 EST
The problem is fixed in RHEL4 after latest update...
Comment 58 Adrian Likins 2006-01-06 13:53:36 EST
translations updated, and all code changes that I'm aware of that can make
this work better applied, and verification it seems better, moving to modified
Comment 59 Beth Nackashi 2006-01-23 13:28:10 EST
I need to know what resolution this customer was using, or if that even matters
at this point.  What was the fix here?
Comment 60 Bjorn Ryborg 2006-01-23 13:51:48 EST
New and updted translation.
Comment 61 Beth Nackashi 2006-01-24 12:49:28 EST
up2date-4.4.64-3 still has the problem.  Please try it out using People's
Republic Chinese.
Comment 62 Beth Nackashi 2006-01-24 14:49:11 EST
test plan:

1- Configure a proper kickstart profile for rhel 3 AS.  In the profile:
   o  packages are @ Base and @ Everything
   o  options -> advanced options.  Set langsupport= --default en_US en_US da nl
no af fr af pt af ja zh zh_CN zh_TW ko.

2- Kickstart a client.

3- Log in to the client using ssh -Y root@<host>

4- Run redhat-config-language.  There should be a list of suported language codes. 

5- Set the system language to a non-English, such as zh_TW.  Log out.

6- On the local machine (assuming the test box is a remote client), change the
resolution to 800x600 using xrandr.  You should not have to log out of X for the
change to take effect. 

7- Log back in to the client using ssh -Y.

8- Run up2date.

Comment 63 Adrian Likins 2006-01-27 15:15:54 EST
updated translations again, it's as close as it's going to get without 
requireing major string changes, or a significant change to the look of
the gui, neither of which I can do at this stage. 
Comment 64 Adrian Likins 2006-01-27 16:54:28 EST
up2date-4.4.66-5 has the latest translations I have available. 

The original bug reported here is long since fixed, so I consider
this closed.
Comment 65 Beth Nackashi 2006-01-27 18:40:43 EST
for 800x600 resolution, up2date-4.4.66-3:

Chinese (P.R. of China) -- NOT FIXED
Chinese (Taiwan) -- NOT FIXED
English (Australia) -- FIXED
English (USA) -- FIXED
French (Canada) -- FIXED
German (Switzerland) -- FIXED
Italian (Switzerland) -- FIXED
Japanese -- FIXED
Korean (Republic of Korea) -- NOT FIXED
Portuguese (Brasil) -- FIXED
Spanish (Nicaragua) -- NOT FIXED


-opened 179194 to track the remaining languages for rhel 3 u8
-cloned for rhnupr4u4
Comment 67 Red Hat Bugzilla 2006-03-15 10:31:59 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0105.html

Note You need to log in before you can comment on or make changes to this bug.