Bug 1222413 - During installation, shell is not available on tty2 (sometimes it appears after a long wait, sometimes it never does)
Summary: During installation, shell is not available on tty2 (sometimes it appears aft...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
: 1222881 1222998 1232587 1233855 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-18 07:40 UTC by lnie
Modified: 2015-08-10 06:59 UTC (History)
13 users (show)

Fixed In Version: anaconda-23.17-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-03 14:06:28 UTC
Type: Bug


Attachments (Terms of Use)
screenshot (27.12 KB, image/png)
2015-05-18 07:40 UTC, lnie
no flags Details
program.log (28.18 KB, text/plain)
2015-05-18 07:41 UTC, lnie
no flags Details
anaconda.log (21.63 KB, text/plain)
2015-05-18 07:42 UTC, lnie
no flags Details
dnf.log (48.38 KB, text/plain)
2015-05-18 07:42 UTC, lnie
no flags Details
syslog (60.53 KB, text/plain)
2015-05-18 07:43 UTC, lnie
no flags Details
X.log (15.07 KB, text/plain)
2015-05-18 07:43 UTC, lnie
no flags Details

Description lnie 2015-05-18 07:40:11 UTC
Created attachment 1026612 [details]
screenshot

Description of problem:
I'm trying to cp the logs to my host machine by switch to tty2,but I have to wait for a long time,as there is no shell shows up 

Version-Release number of selected component (if applicable):
f22-Final-TC4

How reproducible:
always

Steps to Reproduce:
1.Do a default installation
2.Switch to tty2 using"Ctrl+alt+F2"
3.

Actual results:
As shown in the screenshot,shell dosen't show up until a long time later

Expected results:


Additional info:

Comment 1 lnie 2015-05-18 07:41:32 UTC
Created attachment 1026613 [details]
program.log

Comment 2 lnie 2015-05-18 07:42:05 UTC
Created attachment 1026614 [details]
anaconda.log

Comment 3 lnie 2015-05-18 07:42:32 UTC
Created attachment 1026615 [details]
dnf.log

Comment 4 lnie 2015-05-18 07:43:18 UTC
Created attachment 1026616 [details]
syslog

Comment 5 lnie 2015-05-18 07:43:48 UTC
Created attachment 1026617 [details]
X.log

Comment 6 David Shea 2015-05-19 12:32:08 UTC
*** Bug 1222881 has been marked as a duplicate of this bug. ***

Comment 7 Kamil Páral 2015-05-19 12:54:42 UTC
What is a "long time"? I've waited 2 minutes and the shell didn't appear.

Comment 8 David Shea 2015-05-19 13:11:39 UTC
Sometimes a long time is forever. I'm not sure what exactly changed, but systemd isn't always starting logind, or sometimes isn't starting it as soon. bug 1194015 mentioned that systemd-logind.service should be added as a Wants to anaconda's systemd service.

Comment 9 Martin Kolman 2015-05-19 14:57:58 UTC
*** Bug 1222998 has been marked as a duplicate of this bug. ***

Comment 10 lnie 2015-05-20 02:31:40 UTC
(In reply to Kamil Páral from comment #7)
> What is a "long time"? I've waited 2 minutes and the shell didn't appear.

I'm not sure,sometimes 2 minutes is long enough for it to show up,but sometimes I didn't see it even after 10 minutes.It is likely that
>Sometimes a long time is forever

Comment 11 Adam Williamson 2015-06-10 22:22:23 UTC
Clearing F22 accepted / nominated freeze exception status as F22 has shipped, per https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Trackers . You may nominate as an Alpha, Beta or Final freeze exception for F23 if desired using the web application - https://qa.fedoraproject.org/blockerbugs/propose_bug (though it is not currently set up for F23) - or by marking the bug as blocking AlphaFreezeException, BetaFreezeException, or FinalFreezeException.

Personal note: this seems pretty bad, did we ship this way?! It also breaks openQA tests that expect to be able to use tty2...I think I'll nominate this for 23 Alpha myself.

Comment 12 hypatia 2015-06-14 13:33:16 UTC
As temporary fix for F22 put the following commands at the end of your own kickstart config file

%pre --interpreter /bin/bash --log=/tmp/preInstall.log
systemctl start systemd-logind.service
%end

Comment 13 Adam Pribyl 2015-06-17 06:24:28 UTC
*** Bug 1232587 has been marked as a duplicate of this bug. ***

Comment 14 David Shea 2015-06-19 15:28:41 UTC
*** Bug 1233855 has been marked as a duplicate of this bug. ***

Comment 15 Kamil Páral 2015-06-22 16:41:46 UTC
Discussed at today's blocker review meeting [1].

This bug was rejected as blocker: This bug doesn't violate any criteria and there are means around this issue. Please document in F22/F23 Common Bugs pages.

[1] http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-06-22/

Comment 16 Adam Williamson 2015-07-21 02:53:36 UTC
This is still valid, and as the systemd devs said on 1194015, I think the issue is simply that nothing in the anaconda startup path requires systemd-logind.service (which is what starts autovt@.service). In F21 it got started for some reason (even with systemd debug logging I can't tell why, but it doesn't really seem that important), but that was just serendipity, really. On regular boots it's pulled in by multi-user.target , but because anaconda uses its own custom target, it's really anaconda's responsibility to add the service to that target.

I'll send a patch to add it to anaconda.target.

Comment 17 Adam Williamson 2015-07-21 02:56:06 UTC
https://github.com/rhinstaller/anaconda/pull/228

Comment 18 Adam Williamson 2015-07-22 18:47:02 UTC
This got committed, will be in next anaconda build.


Note You need to log in before you can comment on or make changes to this bug.